Autor Thema: Ubuntu 100% CPU und FHEM ohne Reaktion  (Gelesen 1842 mal)

Offline stebar_

  • Full Member
  • ***
  • Beiträge: 152
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #30 am: 11 April 2018, 21:56:52 »
Home Connect habe ich ebenfalls im Einsatz

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #31 am: 12 April 2018, 07:38:49 »
Tue mir bitte den gefallen und erkläre beim nächstenmal dieses. Zerbreche mir schon länger den Kopf, wieso bei Dir so viele Prozesse mit der gleichen PID ....

Sorry. Habe gedacht du siehst es an Hand der Prozess Laufzeit die immer wieder hoch geht.
Das nächste mal schreib ich was dazu

Ich wollte schauen ob der Speicher Verbrauch hoch geht.

Heute Nacht war wieder Schluss.
Letzter log Eintrag war gehen 00:16
Erzeugt von freezmon.
Ich hab nun homeconnect und die dazu gehörigen devices gelöscht.

Mich wundert der Zeitpunkt.
Scheint ja schon System zu haben.
Um die Uhrzeit hab ich allerdings nicht wirklich was am laufen.

Der nuc ist auch exklusiv für FHEM usw.

Gruß Robert


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 4248
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #32 am: 12 April 2018, 08:38:57 »
Freezmon ... hast Du den schon länger im Einsatz? Bei PIs gibt es, glaube ich, aktuell Probleme damit. Da musten einige Ihn löschen ...
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #33 am: 12 April 2018, 10:32:56 »
Ja Freezmon läuft.
Allerdings hatte ich freezmon auch schon deaktiviert und FHEM crashed trotzdem.

Ist halt echt schwer bei so vielen Modulen den Schuldigen zu finden.


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.

Offline frank

  • Hero Member
  • *****
  • Beiträge: 6700
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #34 am: 12 April 2018, 10:38:33 »
hast du auch mal in die system logs geschaut, was da zum crashzeitpunkt steht?
FHEM: 5.8(SVN) => Pi3(jessie)
IO: CUL433_V3.3(1.00.01B53)|CUL868_V3.3(1.58)|HMLAN(0.965)|HMUSB2(0.967)|HMUART(1.4.1)
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #35 am: 12 April 2018, 11:34:06 »
Ja aber auch nichts wirklich gefunden.
Ich hab jetzt erst mal homeconnect gelöscht.

Sollte das auch nicht helfen werd ich morgen noch na alles durch Schauen.


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.

Offline hilde

  • New Member
  • *
  • Beiträge: 15
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #36 am: 12 April 2018, 20:49:54 »
Hallo zusammen,

ich habe mit erstaunlich großer Übereinstimmung exakt das gleiche Fehlerbild:

  • fhem reagiert nicht mehr im Webinterface und hängt bei 100% CPU auf einen Kern fest.
  • Das OS ist noch wunderbar per ssh erreichbar (Ubuntu 16.04 mit neuestem HWE, Intel NUC 2820).
  • Laut Statistik ist das keine allmähliche Entwicklung sondern steigt innerhalb von 5 Min. von Normalauslastung (~10%) auf 100% (enger als 5 min messe ich nicht).
  • Die Störung ist bis jetzt vermehrt auch gegen 00:16 aufgetreten und trat mindestens einmal am Tag auf. Wobei das System auch gerne mal ein paar Stunden bei 100% festhing, bevor ich gemerkt habe, dass es mal wieder "kaputt" ist.
  • freezemon hat mir nichts gebracht; hat nur dazu geführt, dass sich das OS wegen out-of-memory aufhängt. Innerhalb eines 5 Min. Messintervalls werden dabei zusätzlich ca. 7GB RAM und SWAP belegt. Ein ssh Login ist dann nicht mehr möglich (das System ist headless) -> harter Reset; freezemon Logs gibt es vom fraglichen Zeitpunkt trotzdem nicht
  • Der bei 100% CPU hängende fhem Prozess lässt sich nicht per "service fhem stop" stoppen. Killen geht nur per kill -9, allerdings bleiben dabei noch einige andere fhem prozesse übrig, sodass ich das System trotzdem für einen sauberen Ausgangszustand reboote.

Ich hatte auch schon einige Module in Verdacht, aber noch nichts gefunden. Werde jetzt auch mal die homeconnect Devices löschen und dann berichten.

Bin aber trotzdem schon etwas beruhig, dass es kein Einzelfall ist - Danke, no_Legend, dass Du mich auf den Thread hier aufmerksam gemacht hast  ;)

Offline Wernieman

  • Hero Member
  • *****
  • Beiträge: 4248
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #37 am: 12 April 2018, 21:56:58 »
Zitat
sodass ich das System trotzdem für einen sauberen Ausgangszustand reboote.
Das ist nicht nötig, Unix (Linux) <> Windows.

Einfach alle anderen fhem-Prozesse auch per "kill" oder "kill -9" abschießen.

Das FHEM nur auf einen Prozessor werkelt ist normal. FHEM selber ist schließlich singlethreaded, nur die "nonblocking" mOdule werden auf andere Kerne ausgelagert.

-> Es dürfte dann auch genau ein Modul sein, welche FHEM solche Probleme macht.
- Bitte um Input für Output
- When there is a Shell, there is a Way
- Wann war Dein letztes Backup?

Wie man Fragen stellt: https://tty1.net/smart-questions_de.html

Offline hilde

  • New Member
  • *
  • Beiträge: 15
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #38 am: 12 April 2018, 22:55:16 »
Das ist nicht nötig, Unix (Linux) <> Windows.

Einfach alle anderen fhem-Prozesse auch per "kill" oder "kill -9" abschießen.

Das FHEM nur auf einen Prozessor werkelt ist normal. FHEM selber ist schließlich singlethreaded, nur die "nonblocking" mOdule werden auf andere Kerne ausgelagert.

Klar soweit, ich mache das auch aus Faulheit. Der Reboot geht schnell und schadet auch nicht.

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #39 am: 13 April 2018, 08:37:49 »
So heute Nacht ist FHEM ohne Absturz durch gelaufen.
Es sieht wohl nach homeconnect aus.
Netatmo hatte ich gestern Abend wieder aktiviert.

Gruß Robert


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.

Offline hilde

  • New Member
  • *
  • Beiträge: 15
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #40 am: 13 April 2018, 09:33:54 »
Ohne homeconnect lief es jetzt auch hier ohne Störung durch!  :)
Netatmo, Withings, Calendar sind zwar aktuell auch raus bei mir, aber die hatte ich vorher schon als Ursache ausgeschlossen.

Werde es trotzdem noch einen weiteren Tag beobachten, nach den Erfahrungen der letzten Tage will ich mich nicht zu früh freuen ;-)

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #41 am: 13 April 2018, 10:14:10 »
Withings und netatmo haben keine Probleme.
Hab ich heute Nacht laufen gehabt.


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3543
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #42 am: 13 April 2018, 11:52:03 »
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline no_Legend

  • Sr. Member
  • ****
  • Beiträge: 898
Antw:Ubuntu 100% CPU und FHEM ohne Reaktion
« Antwort #43 am: 13 April 2018, 13:32:06 »
@Beta-User

Danke homeconnect bleibt nun erst mal gelöscht.
Bis es eine bugfix gibt


Gesendet von iPhone mit Tapatalk Pro
IntelNUC mit Ubuntu mit FHEM immer aktuell,2x HMLAN, CUL443, CUL868 -homekit/siri -tablet ui -homebridge
Device, diverse:
HM-SEC-KEY,HM-LC-BL1-FM,HM-SEC-SD,HM-Sen-DB-PCB,HM-Sec-RHS,HM-Sec-SC-2,HM-WDS10-TH-O,Harmony,Netamo, 433MHz Steckdosen uvm.