Autor Thema: KNX-Anbindung über TPUART-Modul von Busware: fhem.pl hängt sich auf  (Gelesen 110 mal)

Offline jw9

  • New Member
  • *
  • Beiträge: 16
Hallo allerseits,

ich versuche, eine KNX-Anbindung nach dieser Anleitung zu verwirklichen.

Das Flaschen des Moduls funktioniert, und beim nächsten Start erscheint es auch brav unter /dev/ttyACM0

Als nächstes trage ich das Gerät ein und definiere einen KNX-Datenpunkt:
define KNXIF TUL tul:/dev/ttyACM0 1.1.249
attr KNXIF room KNX
define Roll_EZ KNX 3/1/14:dpt1.008:Roll_EZ KNXIF
attr Roll_EZ webCmd on:off
attr Roll_EZ room KNX

Das wird mir im Logfile soweit auch bestätigt:
2021.01.17 11:11:24 1: FHEMWEB SSL/HTTPS error:  SSL accept attempt failed (peer: 192.168.1.101)
2021.01.17 11:13:12 3: TUL opening KNXIF device tul:/dev/ttyACM0
2021.01.17 11:13:12 3: TUL setting KNXIF baudrate to 19200
2021.01.17 11:13:12 3: TUL device opened

Allerdings sehe ich keine KNX-Telegramme wenn ich den zugehörigen Taster drücke.

Wenn ich versuche, einen Wert an KNX zu senden:
set Roll_EZ on
[/quote]

dann  hängt sich fehm.pl auf. Fhem.pl geht auf 100% CPU und ist nicht mehr ansprechbar. Nur noch "kill -KILL <fhem-pid>" hilft. Kein Eintrag im Logfile.

Wer hat eine Idee was da schiefläuft?

Offline erwin

  • Full Member
  • ***
  • Beiträge: 414
Hi,
schau dir mal diesen Beitrag an: https://forum.fhem.de/index.php/topic,111225.0.html
ohne knxd gabs in der Vergangenheit immer wieder Probleme...die dringende empfehlung ist: TUL-Modul ->knxd ->USB-Schnittstelle
l.g. erwin
FHEM 5.7 auf RaspberryPI mit Busware ROT
CUNO2 V 1.44 CUNO868 SLOWRF - HMS100xx, FS20, FHT
1-Wire über ROT - 2401(iButton), 18x20, 2406, 2413 (AVR), 2450,...
MQTT-DEVICES, KNX - EIBD