Autor Thema: IT Fernbedienung auswerten mit nanoCUL V 1.26.03 a-culfw Build: 300 klappt nicht  (Gelesen 692 mal)

Offline FlatTV

  • New Member
  • *
  • Beiträge: 10
Hallo zusammen,
mein nanoCUL bedient alle IT Steckdosen (V3) aus FHEM heraus genau wie es sein soll.
Ich möchte auch mit der IT Fernbedienung Events in FHEM auslösen, habe mich aber vergeblich daran versucht.

Folgendes habe ich schon gemacht:
- der nanoCUL defmod nanoCUL CUL /dev/serial/by-id/usb-1a86_USB2.0-Serial-if00-port0@38400 1357
attr nanoCUL room 99_Geräte

setstate nanoCUL 2018-05-01 15:48:45 ccconf freq:441.943MHz bWidth:325KHz rAmpl:42dB sens:4dB
setstate nanoCUL 2018-05-01 23:59:29 cmds  A B C e F f G i K L l M N R T t U V W X x
setstate nanoCUL 2018-05-01 21:23:48 raw is01010110110010000100110110000010
setstate nanoCUL 2018-05-01 23:59:29 state Initialized
setstate nanoCUL 2018-05-01 15:57:49 version V 1.26.03 a-culfw Build: 300 (2018-04-15_20-15-39) nanoCUL433 (F-Band: 433MHz)
- per Debug den Code der FB herausgefunden und kontrolliert 01010110110010000100110110 0 0010- ein Device mit diesem Code angelegt defmod itSwitch IT 01010110110010000100110110 0 0010
attr itSwitch IODev nanoCUL
attr itSwitch model itremote

Beim Tastendruck auf die FB kommt nur das hier
2018-05-01 23:48:21 CUL nanoCUL DISCONNECTED
2018-05-01 23:48:21 CUL nanoCUL cmds:  A B C e F f G i K L l M N R T t U V W X x
2018-05-01 23:48:21 CUL nanoCUL Initialized
2018-05-01 23:48:21 CUL nanoCUL CONNECTED

Also einmal X25 an und nachgeschaut
2018-05-01 23:54:43 CUL nanoCUL raw X25
2018-05-01 23:54:51 CUL nanoCUL DISCONNECTED
2018-05-01 23:54:51 readingsGroup rgIT itSwitch.state:
2018-05-01 23:54:51 IT itSwitch on
2018-05-01 23:54:51 CUL nanoCUL UNKNOWNCODE p 9  256 2832  240  304  240 1392  65  1  8 1   240 10752     0 FC B334D2CAB2D34B2C80
2018-05-01 23:54:51 CUL nanoCUL UNKNOWNCODE p 9  224 2832  240  320  224 1392  65  1  8 1   224 10784     0 FD B334D2CAB2D34B2C80
2018-05-01 23:54:51 CUL nanoCUL UNKNOWNCODE p 9  256 2832  224  320  240 1376  65  1  8 1   240 10768     0 FD B334D2CAB2D34B2C80
2018-05-01 23:54:51 CUL nanoCUL cmds:  A B C e F f G i K L l M N R T t U V W X x
2018-05-01 23:54:51 CUL nanoCUL Initialized
2018-05-01 23:54:51 CUL nanoCUL CONNECTED
Tatsächlich wird jetzt das Device gefunden und auf „on“ gesetzt. Danach ist aber nichts mehr möglich, es wird nichts mehr erkannt.
2018-05-01 23:58:13 CUL nanoCUL DISCONNECTED
2018-05-01 23:58:13 CUL nanoCUL cmds:  A B C e F f G i K L l M N R T t U V W X x
2018-05-01 23:58:13 CUL nanoCUL Initialized
2018-05-01 23:58:13 CUL nanoCUL CONNECTED

Erst mit X25 klappt das wieder ein einziges mal.
2018-05-01 23:59:24 CUL nanoCUL raw X25
2018-05-01 23:59:29 CUL nanoCUL DISCONNECTED
2018-05-01 23:59:29 readingsGroup rgIT itSwitch.state:
2018-05-01 23:59:29 IT itSwitch off
2018-05-01 23:59:29 CUL nanoCUL UNKNOWNCODE p 9  240 2832  208  352  208 1408  65  1  8 1   240 10752     0 FC B334D2CAB2D34AAC80
2018-05-01 23:59:29 CUL nanoCUL UNKNOWNCODE p 9  256 2832  224  320  240 1392  65  1  8 1   208 10784     0 FC B334D2CAB2D34AAC80
2018-05-01 23:59:29 CUL nanoCUL UNKNOWNCODE p 9  240 2848  240  336  224 1376  65  1  8 1   224 10784     0 FC B334D2CAB2D34AAC80
2018-05-01 23:59:29 CUL nanoCUL cmds:  A B C e F f G i K L l M N R T t U V W X x
2018-05-01 23:59:29 CUL nanoCUL Initialized
2018-05-01 23:59:29 CUL nanoCUL CONNECTED

Kann da jemand helfen?

Offline KölnSolar

  • Hero Member
  • *****
  • Beiträge: 2674
Zitat
freq:441.943MHz
War das eine Ausnahme ? Oder woher kommt diese völlig falsche Frequenz ? 433.92 ist der Standard.

Du zeigst uns ständige connects/disconnects des nanoCUL. Ist das so ? Dann stimmt was nicht mit dem nanoCUL. Ich tippe auf schlechte Spannungsversorgung.  :-\ Mal mit nem USB-Hub, stärkerem Netzteil.... probieren.
Grüße Markus
RPi3/2 Stretch-RFXTRX-IT-RSL-NC5462-Oregon-CUL433-CUL868-FS20A4-EMGZ-1W(GPIO)-DS18B20-CO2-USBRS232-USBRS422-Betty-Boop-EchoDot

Offline FlatTV

  • New Member
  • *
  • Beiträge: 10
Die connect/disconnects kommen immer beim Empfang der Ferbedienung. Beim Senden über FHEH ist alles sauber.
Die Frequenz war so, da hab ich nicht verstellt. Ich setze das mal auf deinen Wert.

Offline hsepm

  • Full Member
  • ***
  • Beiträge: 128
Ich habe bisher alle meine IT V3-Geräte (ca. 10) direkt (FB, Sensor) oder indirekt (Aktor über FB) über autocreate angelernt.
Nach dem Autocreate einfach die Geräte nach eigenem Gusto umbenennen bzw. den Typ setzen.

Ich benutze gegenwärtig einen nanocul mit aculfw (Software Stand ca. Dezember 2017).

Gruß,
Holger


Raspi V3 mit fhem + CUL433, CUL868
IT-1500, IT-CMR500, ITM-100, FS20-ST-2, FS20-AS1-2, FS20-AS4-2
Arduino + bsb_lan + ABS700
Echo Dot, Echo Plus
ha-bridge

Offline FlatTV

  • New Member
  • *
  • Beiträge: 10
Also der Hinweis auf die verbogene Frequenz hat mir doch geholfen. Ich habe jetzt sooft raw e an den nanoCUL gesendet, bis die LED auf dem Arduino flackerte. Danach einen Raspi Neustart und den Arduino kurz stromlos gemacht. Plötzlich steht die richtige Frequenz drin und autocreate geht auch wie von Geisterhand  :o

Danke für den Schups in die richtige Richtung.

 

decade-submarginal