Autor Thema: [98_feels_like.pm] Gefühlte Temperatur, Berechnung der Bewölkung  (Gelesen 1051 mal)

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Hallo,

Update 17:07

folgenden Fehler habe ich gefunden und möchte ihn nicht behalten:

in Zeile 144:
            next if $hash->{$dk} ne $dev_name;

kommt es zu folgenden Fehler im Log:

2018.06.27 16:56:19 1: PERL WARNING: Use of uninitialized value in string ne at ./FHEM/98_feels_like.pm line 144.


Kann du bitte mal ein list des feels_like device und sein define posten?

Online JoWiemann

  • Tester
  • Hero Member
  • ****
  • Beiträge: 2396
Hier das List:

Internals:
   DEF        Wetterstation temperature humidity wind
   DEVNAME    Wetterstation
   H_DEV      Wetterstation
   H_READING  humidity
   NAME       Feel_KS300
   NOTIFYDEV  Wetterstation
   NR         449
   NTFY_ORDER 48-Feel_KS300
   STATE      active
   TYPE       feels_like
   T_DEV      Wetterstation
   T_READING  temperature
   W_DEV      Wetterstation
   W_READING  wind
Attributes:
   room       Wetter

Grüße Jörg
Jörg Wiemann

Slave: RPi B+ mit 512 MB, COC (868 MHz), CUL V3 (433.92MHz SlowRF); FHEMduino, Aktuelles FHEM

Master: CubieTruck; Debian; Aktuelles FHEM

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Moin,

hat schon mal jemand das Modul mit der HM-WDS100-C2-O-2 Wetterstation benutzt?
Bis auf den Wert für die Sonneneinstrahlung sind die Messwerte direkt verfügbar. Die Sonneneinstrahlung [W/m²] ließe sich aus dem Helligkeitswert ermitteln (Helligkeitswert -> Lux -> Sonneneinstrahlung]. Den Lux - Wert errechne ich bereits.
Macht das Sinn?
Ein Versuch wäre es Wert.
Das Modul ist zZ auf den WH2601 Sonnensensor getuned, der eine Art Kuppel ist und morgens im Schatten des Regensensors liegt. Die WH2601 zeigt daher morgens Faktor 2 zu wenig und nachmittags Faktor 2 zuviel an. Das wird zZ mit ziemlich viel Aufwand korrigiert.
Für diese Korrektur kann ich natürlich einfach ein Attribut zum ausschalten einbauen.

Wenn dein Helligkeitssensor waagerecht ohne Abschattungen liegt, müsste das dann bei abgeschalteter Korrektur funktionieren.

Offline alru

  • New Member
  • *
  • Beiträge: 45
...
Wenn dein Helligkeitssensor waagerecht ohne Abschattungen liegt, müsste das dann bei abgeschalteter Korrektur funktionieren.

Ja, das tut er.
Gruß,

Stefan
(Raspi/Cul/HM/MySensors)

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Habe soeben eine neue Version hochgeladen:
- Fix der gemeldeten Fehler/Typos
- verbesserte Algorithmen und Parameter (verbesserte Erkennung schwacher Bewölkung)
- neues Attribut sensorType

Wie üblich ab morgen per UPDATE verfügbar.

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Ja, das tut er.

Setze mal das Attribut sensorType auf generic.
Im feels_like device gibt es das Reading nr_current, nr_* = normalized radiation = gemessen / "berechnet gemäß Sonnenstand".
Bei klarem Himmel und richtiger Parametrisierung sollte das immer zwischen so zwischen 0.9 und 1.1 liegen. Wenn das bei Dir der Fall ist, steht einer korrekten Funktion nichts entgegen.

Offline alru

  • New Member
  • *
  • Beiträge: 45
.... Wenn das bei Dir der Fall ist, steht einer korrekten Funktion nichts entgegen.
Probiere ich aus, komme aber erst nächste Woche dazu und melde mich dann noch mal. Danke erst mal!
Gruß,

Stefan
(Raspi/Cul/HM/MySensors)

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1366
Hallo.
Mein Windsensor ist defekt! Deshalb habe ich aus dem DEF den Windsensor entfernt.
Dennoch kommt regelmäßig diese Fehlermeldung:
feels_like: reading wetter:wind is too old, sorry!
Kann es sein, dass das geänderte DEF nicht (ohne Neustart) übernommen wird?

sG
Joe
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Ja, werde ich heute abend fixen.

Gesendet von meinem Nexus 5X mit Tapatalk


Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Hallo.
Mein Windsensor ist defekt! Deshalb habe ich aus dem DEF den Windsensor entfernt.
Dennoch kommt regelmäßig diese Fehlermeldung:
feels_like: reading wetter:wind is too old, sorry!
Kann es sein, dass das geänderte DEF nicht (ohne Neustart) übernommen wird?

sG
Joe

Im Repository, ab morgen per UPDATE.

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1366
Hann es sein, dass das Modul keine Hygro-Werte mit Nachkommastellen mag? Mein neuer KNX Sensor liefert diese Werte auf 2 Nachkommastellen,
aber das Modul "berechnet" damit nichts....
Mit dem alten Sensor ohne Nachkommastellen hat es funktioniert.

Edit: oder ist es doch die Häufigkeit, die der Sensor neue Werte sendet?
Er sendet nämlich von sich aus NUR bei Veränderung, also manchmal auch für 2 Stunden nichts. Im Log erscheint dies natürlich....

SG Joe.
« Letzte Änderung: 15 Juli 2018, 08:43:50 von JoeALLb »
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
Edit: oder ist es doch die Häufigkeit, die der Sensor neue Werte sendet?
Er sendet nämlich von sich aus NUR bei Veränderung, also manchmal auch für 2 Stunden nichts. Im Log erscheint dies natürlich....

Steht denn das Attribut maxTimediff entsprechend? Also auch auf 2 Stunden = 7200 ?
Sonst mach mal beim feels_like device verbose auf 5 und poste ein Stück vom log.

-h

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1366
Steht denn das Attribut maxTimediff entsprechend? Also auch auf 2 Stunden = 7200 ?

DANKE! So ein Attribut habe ich schon gesucht, jedoch in der Vielzahl der Attribute (die durch andere Module hinzugefügt werden),
habe ich maxTimediff übersehen! In der Commandref hatte ich nachgesehen, dort wird das aber noch nicht erwähnt!

Ich werde es damit testen!

sG Joe
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline hotbso

  • Developer
  • Jr. Member
  • ****
  • Beiträge: 97
In der Commandref hatte ich nachgesehen, dort wird das aber noch nicht erwähnt!

Jetzt wird es erwähnt!
Gefällt mir Gefällt mir x 1 Liste anzeigen