Autor Thema: ( vorerst glöst ) Raspberry P 3 jessy mit ENOcean 310 Module kein erfolg  (Gelesen 506 mal)

Offline nfm-depot

  • New Member
  • *
  • Beiträge: 11
Wie schon oben kurz erwähnt
Ein Raspberry P 3 mit auf gesteckten ENocean 310 Modul kein zugriff auf den Modul
Hier mal die Log vom FHEM

2018.05.21 17:17:21 0: Server started with 9 defined entities (fhem.pl:16744/2018-05-15 perl:5.024001 os:linux user:fhem pid:475)
2018.05.21 17:17:14 1: Including fhem.cfg
2018.05.21 17:17:14 3: telnetPort: port 7072 opened
2018.05.21 17:17:14 3: WEB: port 8083 opened
2018.05.21 17:17:14 3: WEBphone: port 8084 opened
2018.05.21 17:17:14 3: WEBtablet: port 8085 opened
2018.05.21 17:17:14 2: eventTypes: loaded 1 events from ./log/eventTypes.txt
2018.05.21 17:17:14 1: Including ./log/fhem.save
2018.05.21 17:17:14 1: usb create starting
2018.05.21 17:17:15 3: Probing CUL device /dev/ttyAMA0
2018.05.21 17:17:15 3: Probing TCM_ESP3 device /dev/ttyAMA0
2018.05.21 17:17:15 3: Probing ZWDongle device /dev/ttyAMA0
2018.05.21 17:17:16 3: Probing FRM device /dev/ttyAMA0
2018.05.21 17:17:21 3: Probing CUL device /dev/ttyS0
2018.05.21 17:17:21 1: PERL WARNING: can't getattr: Input/output error at ./FHEM/DevIo.pm line 419.
2018.05.21 17:17:21 1: CUL: Can't open /dev/ttyS0: Input/output error
2018.05.21 17:17:21 1: usb create end
2018.05.21 17:17:21 0: Featurelevel: 5.8
2018.05.21 17:17:21 0: Server started with 9 defined entities (fhem.pl:16744/2018-05-15 perl:5.024001 os:linux user:fhem pid:468)

ls -l /dev/
crw-rw---- 1 root dialout 204,  64 Mai 21 17:17 ttyAMA0
crw------- 1 root root      5,   3 Mai 21 17:17 ttyprintk
crw-rw---- 1 root dialout   4,  64 Mai 21 17:17 ttyS0
in der
cmdline.txt
 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait splash plymouth.ignore-serial-consoles

und boot config
hdmi_force_hotplug=1
dtoverlay=pi3-disable-bt
core_freq=250
enable_uart=1

habe die ganze sache nach wiki abgearbeitet
bin etwas  ratlos was fehlt denn ???
der Treiber für das Aufsteckmodul 310 ?
währe schön wenn einer helfen kann

guss Juergen


« Letzte Änderung: 23 Mai 2018, 10:31:27 von nfm-depot »

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15987
  • s/fhem\.cfg/configDB/g
Antw:Raspberry P 3 jessy mit ENOcean 310 Module kein erfolg
« Antwort #1 am: 22 Mai 2018, 13:44:57 »
  • deaktiviere das usbautocreate in Deinem FHEM
  • definiere das device manuell

Bei mir steht in der config.txt anstatt "core_freq=250" immer "force_turbo=1"

Mach mal ein "ps -A" aus der Systemkonsole und schau nach, ob irgendein Prozess noch /dev/ttyS0 belegt.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.

Offline nfm-depot

  • New Member
  • *
  • Beiträge: 11
Antw:Raspberry P 3 jessy mit ENOcean 310 Module kein erfolg
« Antwort #2 am: 22 Mai 2018, 16:36:15 »
Hallo betateilchen
ok
 den usb habe ich in der Fhem.cfg  so abgeschaltet :
#define initialUsbCheck notify global:INITIALIZED usb create

jetzt haben wir diesen log
2018.05.22 15:17:21 0: Server started with 9 defined entities (fhem.pl:16744/2018-05-15 perl:5.024001 os:linux user:fhem pid:472)
2018.05.22 16:10:32 0: Server shutdown
2018.05.22 16:10:39 1: Including fhem.cfg
2018.05.22 16:10:39 3: telnetPort: port 7072 opened
2018.05.22 16:10:39 3: WEB: port 8083 opened
2018.05.22 16:10:39 3: WEBphone: port 8084 opened
2018.05.22 16:10:39 3: WEBtablet: port 8085 opened
2018.05.22 16:10:40 2: eventTypes: loaded 1 events from ./log/eventTypes.txt
2018.05.22 16:10:40 1: Including ./log/fhem.save
2018.05.22 16:10:40 1: ./log/fhem.save: Please define initialUsbCheck first
Please define initialUsbCheck first

der ps  -A ergab keine belegung der  dev/ttyS0

wenn ich richtig liege hat der Fhem über USB die Schnittstellen abgefragt ...AMA0 und  device /dev/ttyS0

Ihr schrieb ich soll das definiere das device manuell ok  da ich in FHem anfänger bin
wo mache ich das und was soll darein ???

gruss Juergen

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15987
  • s/fhem\.cfg/configDB/g
Antw:Raspberry P 3 jessy mit ENOcean 310 Module kein erfolg
« Antwort #3 am: 22 Mai 2018, 17:14:32 »
Jetzt haben wir diesen log
2018.05.22 16:10:40 1: Including ./log/fhem.save
2018.05.22 16:10:40 1: ./log/fhem.save: Please define initialUsbCheck first
Please define initialUsbCheck first

kannst Du ignorieren. Nach einem save und dem nächsten Neustart tritt die Meldung nicht mehr auf.

wo mache ich das und was soll darein ???

http://commandref.fhem.de/#TCM

dort unter "Define" stehen Beispiele.
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.

Offline nfm-depot

  • New Member
  • *
  • Beiträge: 11
Antw:Raspberry P 3 jessy mit ENOcean 310 Module kein erfolg
« Antwort #4 am: 23 Mai 2018, 10:29:49 »
Hallo betateilchen
Danke für die Hinweise
 jetzt  schein  es richtig zu sein:
BaseID
00000000
DEF   
ESP3 /dev/ttyAMA0@57600
DeviceName
/dev/ttyAMA0@57600
FD
11
LastID
00000000
MODEL
ESP3
NAME
TCM_310_0
NOTIFYDEV
global
NR
21
NTFY_ORDER
50-TCM_310_0
PARTIAL
STATE
initialized
TYPE
TCM

ich bin  da von aus gegangen das FHem sich selber die Pasende Schnittstelle sucht was
ja nicht so ist.
Wenn er in USB nach AMA0  finder er die AMA0 auf Seriell nicht ist ja logisch.

Also danke noch mal
jetzt mussen nur noch die Verbindungen hergestellt werden