Autor Thema: [Gelöst]Busmaster disconnected durch SIGNALduino  (Gelesen 484 mal)

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
[Gelöst]Busmaster disconnected durch SIGNALduino
« am: 09 Juni 2018, 14:06:18 »
Hallo,

bin so langsam am Ende meiner Fehlersuche und bitte Euch um Unterstützung.
Habe den 433 CUL von Busware gegen einen SIGNALduino am selben Port getauscht und damit fingen die Probleme
an.
Alle IT Fensterkontakte und Thermo/Feuchte Sender liefen anstandslos weiter .
Bis auf die leidige Funkklingel Intertechno MLT-7100 Funk-Taster .

Nach der Inbetriebnahme des SIGNALduino ging entweder der SIGNALduino oder der 1 Wire Busmaster.
Zeitweise lief beides Stundenlang zusammen bis sich der Busmaster verabschiedete.
Komisch auch der Funktaster muss mal mehrmals oder sehr lange gedrückt werden um meinen Signalgeber auszulösen, war vorher nicht so.

Eben Batterie am Funktaster erneuert und mal beim SIGNALduino attr addvaltrigger gesetzt Taster gedrückt und Busmaster(LinkUSBi) geht in disconnected.

Im Log habe ich folgendes
2018.06.09 11:11:11 0: Server started with 224 defined entities (fhem.pl:16813/2018-06-03 perl:5.018002 os:linux user:fhem pid:2162)
2018.06.09 11:11:59 1: OWX_Init called for bus OWio1 with interface state opened, now going for detect
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $rise2 in numeric gt (>) at ./FHEM/95_Astro.pm line 826.
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $rise1 in numeric gt (>) at ./FHEM/95_Astro.pm line 826.
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $set2 in numeric gt (>) at ./FHEM/95_Astro.pm line 828.
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $set1 in numeric gt (>) at ./FHEM/95_Astro.pm line 828.
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $rise1 in numeric lt (<) at ./FHEM/95_Astro.pm line 841.
2018.06.09 11:12:03 1: PERL WARNING: Use of uninitialized value $set1 in numeric lt (<) at ./FHEM/95_Astro.pm line 845.
2018.06.09 12:19:50 1: PERL WARNING: Use of uninitialized value $\ in concatenation (.) or string at ./FHEM/99_myUtils_Astro.pm line 51.
2018.06.09 13:27:53 1: PERL WARNING: Use of uninitialized value within %ttsAPIKey in numeric gt (>) at ./FHEM/98_Text2Speech.pm line 439.
2018.06.09 13:27:53 1: PERL WARNING: Use of uninitialized value within %ttsUser in numeric gt (>) at ./FHEM/98_Text2Speech.pm line 440.
2018.06.09 13:29:21 1: /dev/ttyUSB0 disconnected, waiting to reappear (OWio1)
2018.06.09 13:29:21 1: OWX_SER::Query OWio1:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2018.06.09 13:29:21 1: OWX_Complex called while interface OWio1 disconnected
2018.06.09 13:29:22 1: OWX_Complex called while interface OWio1 disconnected
2018.06.09 13:29:39 1: OWX_Complex called while interface OWio1 disconnected
2018.06.09 13:29:39 1: OWX_Complex called while interface OWio1 disconnected
2018.06.09 13:29:40 1: OWX_Complex called while interface OWio1 disconnected
2018.06.09 13:31:27 1: OWX_Complex called while interface OWio1 disconnected

hier noch ein List vom SIGNALduino falls es nützlich sein sollte



Internals:
   Clients    :IT:CUL_TCM97001:SD_RSL:OREGON:CUL_TX:SD_AS:Hideki:SD_WS07:SD_WS09: :SD_WS:RFXX10REC:Dooya:SOMFY:SD_UT:SD_WS_Maverick:FLAMINGO:CUL_WS:Revolt: :FS10:CUL_FHTTK:Siro:FHT:FS20:SIGNALduino_un:
   DEF        /dev/serial/by-id/usb-Unknown_radino_CC1101-if00@57600
   DMSG       s4CA1464000
   DevState   initialized
   DeviceName /dev/serial/by-id/usb-Unknown_radino_CC1101-if00@57600
   FD         24
   LASTDMSG   s4CA1464000
   MSGCNT     714
   NAME       SIGNALduino_Stick
   NR         310
   PARTIAL   
   RAWMSG     MS;P2=-2011;P3=437;P4=-4570;P5=-9586;D=3532343232343432323432343232323234323432323234343232343232;CP=3;SP=5;R=251;O;
   RSSI       -76.5
   STATE      opened
   TIME       1528545185.66699
   TYPE       SIGNALduino
   sendworking 0
   unknownmessages
   version    V 3.3.1-dev SIGNALduino cc1101 (433Mhz )- compiled at Mar 10 2017 23:27:29
   DoubleMsgIDs:
   MatchList:
     10:SD_WS07 ^P7#[A-Fa-f0-9]{6}F[A-Fa-f0-9]{2}(#R[A-F0-9][A-F0-9]){0,1}$
     11:SD_WS09 ^P9#F[A-Fa-f0-9]+
     12:SD_WS   ^W\d+x{0,1}#.*
     13:RFXX10REC ^(20|29)[A-Fa-f0-9]+
     14:Dooya   ^P16#[A-Fa-f0-9]+
     15:SOMFY   ^Ys[0-9A-F]+
     16:SD_WS_Maverick ^P47#[A-Fa-f0-9]+
     17:SD_UT   ^u30#.*
     18:FLAMINGO ^P13#[A-Fa-f0-9]+
     19:CUL_WS  ^K[A-Fa-f0-9]{5,}
     1:IT       ^i......
     20:Revolt  ^r[A-Fa-f0-9]{22}
     21:FS10    ^P61#[A-F0-9]+
     22:Siro    ^P72#[A-Fa-f0-9]+
     23:FHT     ^81..(04|09|0d)..(0909a001|83098301|c409c401)..
     24:FS20    ^81..(04|0c)..0101a001
     2:CUL_TCM97001 ^s[A-Fa-f0-9]+
     3:SD_RSL   ^P1#[A-Fa-f0-9]{8}
     4:OREGON   ^(3[8-9A-F]|[4-6][0-9A-F]|7[0-8]).*
     5:CUL_TX   ^TX..........
     6:SD_AS    ^P2#[A-Fa-f0-9]{7,8}
     7:Hideki   ^P12#75[A-F0-9]+
     9:CUL_FHTTK ^T[A-F0-9]{8}
     X:SIGNALduino_un ^[u]\d+#.*
   QUEUE:
   READINGS:
     2018-06-06 23:06:37   ccconf          freq:433.920MHz bWidth:325KHz rAmpl:42dB sens:4dB  (DataRate:5603.79Baud)
     2018-06-07 01:19:38   config          MS=1;MU=1;MC=1
     2018-06-09 12:18:33   state           opened
     2018-06-09 12:18:33   version         V 3.3.1-dev SIGNALduino cc1101 (433Mhz )- compiled at Mar 10 2017 23:27:29
   keepalive:
     ok         1
     retry      0
   mcIdList:
     10
     11
     12
     18
     43
     47
     52
     57
     58
   msIdList:
     0
     1
     13
     14
     15
     17
     2
     22
     23
     25
     3
     3.1
     32
     33
     35
     38
     4
     41
     51
     55
     6
     68
     7
     72.1
   muIdList:
     13.1
     16
     20
     21
     24
     26
     27
     28
     29
     30
     31
     36
     37
     39
     40
     44
     44.1
     45
     46
     48
     49
     5
     50
     56
     59
     60
     61
     62
     64
     65
     66
     67
     69
     70
     71
     72
     75
     8
     9
Attributes:
   DbLogExclude .*
   addvaltrigger 1
   flashCommand avrdude -c arduino -b [BAUDRATE] -P [PORT] -p atmega328p -vv -U flash:w:[HEXFILE] 2>[LOGFILE]
   hardware   nanoCC1101
   room       Server
   verbose    0


meine leider kaum vorhandenen Linux Kenntnisse gehen in Richtung(Vermutung) USB Schnittstelle beide /dev/ttyUSB0 ??
Funk Beeinflussung wohl eher Quatsch oder ?

Vielleicht hat von Euch jemand noch eine Idee mein System in dem Punkt Ordnung zu bringen.
SIGNALduino wollte ich als nächstes FHEM Projekt zur Innenfensterrollo Beschattung benutzen, Aussenfenster Rollo macht sich leider an diesem Fenster schlecht.

Gruß und Danke vorweg sagt schon mal

Hans-Jürgen




« Letzte Änderung: 14 Juni 2018, 10:56:42 von Deckoffizier »
FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3543
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #1 am: 09 Juni 2018, 18:10:39 »
Pi!
Vermutlich liefert der nicht genug Strom.  Aktiven Hub testen, NT tauschen usw.

Kurz, da mobil
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #2 am: 09 Juni 2018, 21:21:48 »
Hallo Beta-User,

kein PI, Industrieserver mit 4 mal USB3.0 und 2 mal USB2.0. OS Linux.

Sehe gerade, vor 10 min ist der Busmaster wieder ausgestiegen.
Meine beiden Sundtek SatTV USBSticks sind auch nicht am Rennen.

Soll der SIGNALduino jetzt soviel an der USB Geschichte bewirkt haben ?

Gehört hier vielleicht nicht mehr her aber wie ist  es am besten bei mehreren USB Geräten ?
Jeden freien USB Port einzeln benutzen ? Welchen CUL an USB3 ?
Ja und wie bei der DEF der Geräte vernünftig zuordnen.
Oder immer Aktiven Hub benutzen und welchen Port(USB2/3) trotz potenter Hardware.

Bin da leider überfragt zu diesem Thema.
Ja hast Recht, nächster Versuch wäre bei mir aktiver Hub.

Gruß
Hans-Jürgen


FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #3 am: 09 Juni 2018, 22:50:04 »
Hallo,

habe mehrmals den Funktaster betätigt und es mal geklappt den Signalgeber auszulösen und diese Info im
Eventmonitor gefunden

2018-06-09 22:43:04 IT IT_Funkgong1 on
2018-06-09 22:43:04 IT IT_Funkgong1 DMSG: i105455
2018-06-09 22:43:04 IT IT_Funkgong1 RSSI: -49
2018-06-09 22:43:04 IT IT_Funkgong1 RAWMSG: MS;P1=284;P2=-1123;P4=984;P5=-431;P6=-10928;D=16121212451212121212451245124512121245124512451245;CP=1;SP=6;R=50;O;

Mal sehen wie lange der Busmaster durchhält ohne disconnecten.

Gruß
Hans-Jürgen
FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3543
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #4 am: 10 Juni 2018, 04:20:53 »
...deine Signatur legte Pi nahe ;) :
Zitat
FHEM 5.8 auf RasPI B+ mit CUL 868MHz, CUL 433 MHZ,1 Wire USB Busmaster, diverse 1 Wire Sensoren
Vielleicht bei Gelegenheit updaten?

Was das USB-Thema angeht:
An sich sollte es möglich sein, dass jeder Port auch ein Gerät verträgt.
Irgendwo in den Untiefen meiner Erinnerung war es aber so, dass USB3 in Verbindung mit manchen Arduinos Probleme macht. Leider weiß ich nicht mehr, was da die Ursache und wie die Lösung war (betraf evtl. nur FTDI-Chips und man mußte den Modus umstellen; irgend sowas ??? ).
Vielleicht suchst du im Linux-Server-Bereich mal nach USB3. Da das Problem auch mit den anderen Geräten besteht: liefere doch mal ein ls -l /dev/serial/by-id, nähere Angaben zum Motherboard/Rechner und verschiebe den (umbenannten) Thread in den genannten Bereich. Scheint mir kein spezielles 1wire-Problem zu sein.
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #5 am: 10 Juni 2018, 09:02:52 »
Hallo Beta-User,

eigentlich soll man auf die erfahrenen hören.....
aber irgendwie total komisch im log kurz nach 0 Uhr  SQL Datenbank geleert sollte auch so sein ok.

Aber dann
2018.06.10 03:18:34 1: PERL WARNING: Hexadecimal number > 0xffffffff non-portable at ./FHEM/10_IT.pm line 953.
2018.06.10 03:18:34 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/10_IT.pm line 986.
2018.06.10 03:50:22 1: /dev/ttyUSB0 disconnected, waiting to reappear (OWio1)
2018.06.10 03:50:22 1: OWX_SER::Query OWio1:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2018.06.10 03:50:22 1: OWX_Complex called while interface OWio1 disconnected
2018.06.10 03:50:25 1: OWX_Complex called while interface OWio1 disconnected
2018.06.10 03:50:28 1: OWX_Complex called while interface OWio1 disconnected
2018.06.10 03:50:28 1: OWX_Complex called while interface OWio1 disconnected

dieses OWX_Complex läuft bis morgens durch.

wundersam um kurz nach 7 Uhr ist der Busmaster wieder lebendig ?

2018.06.10 07:03:12 1: OWX_Init called for bus OWio1 with interface state opened, now going for detect
2018.06.10 07:03:15 1: OWID:     Device OWX_01_9117A6180000 defined.
2018.06.10 07:03:15 1: OWX_Discover: 1-Wire devices found on bus OWio1 (Wettersensor,Puffer_Sensor3_unten,Puffer_Sensor1_oben,Puffer_Sensor2_mitte,HZ_Vorlauf,WW_Speicher,Abgassensor,HZ_Ruecklauf,Kellersensor,Abgassensor_part2,Heizraum_Klima,OWX_01_9117A6180000)
2018.06.10 07:03:15 1: /dev/ttyUSB0 reappeared (OWio1)

Erstaunlich auch OWID des Busmaster(LinkUSBi) zeigt den Status present an war vorher nicht so und 1 Wire (OWX) lief trotzdem.
Irgendwo ist es mir schon 2 Nummern zu hoch.

SIGNALduino hing bisher am USB2.0 Port.

Hier noch
lrwxrwxrwx 1 root root 13 Jun  9 21:44 usb-busware.de_CUL868-if00 -> ../../ttyACM1
lrwxrwxrwx 1 root root 13 Jun 10 07:02 usb-FTDI_FT232R_USB_UART_AI03X1WP-if00-port0 -> ../../ttyUSB0
lrwxrwxrwx 1 root root 13 Jun  9 21:44 usb-Unknown_radino_CC1101-if00 -> ../../ttyACM0

packe noch mal lsusb dazu
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 011: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC
Bus 001 Device 010: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 017: ID 2659:1502 Sundtek
Bus 001 Device 018: ID 2659:1502 Sundtek
Bus 001 Device 003: ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project
Bus 001 Device 002: ID 1da9:002c 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Sundtek sind die SatTV Sticks.

Mainboard ASRock J3160B-ITX
yakkaroo Emu A1FL.1

Gruß
Hans-Jürgen










FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #6 am: 10 Juni 2018, 09:43:27 »
Hallo,

kurzer Nachtrag

eben mehrmals den Funktaster  betätigt um den Signalgeber auszulösen.
Busmaster geht auf disconnected

2018.06.10 09:34:25 1: OWX_SER::Query OWio1:  0 of 1 bytes in last attempt and state opened, this is an unrecoverable error
2018.06.10 09:34:25 1: OWX_Complex called while interface OWio1 disconnected
2018.06.10 09:34:25 1: OWX_Complex called while interface OWio1 disconnecte

Irgendwo scheint hier doch ein Zusammenhang möglich zu sein.

Gruß
Hans-Jürgen
FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3543
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #7 am: 10 Juni 2018, 10:57:36 »
Passiert da auch was auf OS-Ebene (dmesg)?
Und grundsätzlich würde ich empfehlen, alle (drei) USB-Geräte mit "by-id"-Definition einzubinden. Nicht, dass da irgend was durcheinander geht (ACM0 und ACM1). Und wo sind da die TV-Sticks?...
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline Deckoffizier

  • Full Member
  • ***
  • Beiträge: 276
Antw:Busmaster disconnected durch SIGNALduino
« Antwort #8 am: 14 Juni 2018, 10:56:19 »
Hallo Beta-User,

habe Deinen Rat soweit befolgt und den LinkUSBi auch mit by-id neu definiertund an einer Stelle die USB Geräteports(SIGNALduino, 868CUL) getauscht.

Gab zwar  komische Huddeleien zwischendurch wie Wettersensor gab keine Werte mehr rein obwohl mit get die Werte geliefert werden.

Nun ja im Moment lief es mit allem schon mal 1 Tag durch.
Knackpunkt wird eventuell ein Stromausfall oder Neustart ob dann die Zuordnung noch so steht.
Lass erst mal die Finger davon muss noch mit anderen Sachen weiterkommen hoffentlich holt mich dies nicht später ein.
Ansonsten wäre noch die Thematik udev udev-rules zum rein knien hatte da noch was in der Richtung für 1Wire und den TV Sticks gefunden.

Gruß und DANKE für die Mithilfe

Hans-Jürgen
FHEM 5.8 auf "yakkaroo Emu A1FL.1" mit CUL 868MHz, SIGNALduino,1 Wire USB Busmaster, diverse 1 Wire Sensoren,Landroid

Offline Beta-User

  • Hero Member
  • *****
  • Beiträge: 3543
Antw:[Gelöst]Busmaster disconnected durch SIGNALduino
« Antwort #9 am: 14 Juni 2018, 11:07:37 »
Hallo Deckoffizier,

schön, dass es was gebracht hat.

Vielleicht zur Ergänzung noch eine Anmerkung. Die "by-id"-Geschichte macht im Prinzip genau dasselbe wie die udev-rules: Aus den Angaben, die das USB-Gerät beim Anmelden an den Rechner schickt, wird eine eindeutige Zuordnung abgeleitet. M.E. ist der einfachere (direkte) Weg, die Definition in FHEM "by-id" zu machen, dann funktioniert das nämlich nicht nur auch noch, wenn du umstöpselst - auch wenn ein aktiver Hub dazwischenkommt, sondern sogar dann, wenn du ganz andere Server-Hardware nimmst, das OS wechselst (jedenfalls von Debian-Derivat zu Debian) usw...

Melde dich, wenn weitere Infos benötigt werden :) .

Gruß, Beta-User
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

 

decade-submarginal