Autor Thema: WeMos neue FW, danach keine Textübertragung auf OLED  (Gelesen 282 mal)

Offline M_I_B

  • Sr. Member
  • ****
  • Beiträge: 920
  • ... Biker essen keinen Honig; die kauen Bienen!
Moin...

... habe hier einen WeMos mit diesem LowCost OLED- Display. Der WeMos läuft mit ESPeasy. Vorletzte, verwendete Version war "ESP_Easy_mega-20180316_normal_ESP8266_4096".
Heute Abend habe ich dann ein neues OS geflasht, die Version "ESP_Easy_mega-20180614_normal_ESP8266_4096", da nunmehr auch meine geliebten BMx- Chips unterstützt werden.

Nach dem Flashen scheint alles ok. Die im ESPeasy gesetzen Zeilen 1 und 2 (Datum, Zeit, IP, RSSI) werden wie bisher angezeigt. Auch doe Übertragung von Soundereignissen via rtttl funktioniert weiterhin wie gewohnt, aber ich kann keinerlei Texte mehr auf dem Display aus FHEM senden. Es taucht weder eine Fehlermeldung auf, noch andere Dinge, die auf einen Fehler schließen ließen; es passiert einfach nix...

Den Sound sende ich z.B. mit ...
set WM_08 rtttl 16:d=10 o=6 b=180 e g... einen entsprechenden Text entsprechend mit ...
set WM_08 oled 4 1 BR: Normal-Betrieb
Das Ganze sieht dann als Ausschnitt aus einem DOIF- Konstrukt so aus:
define set_oled DOIF ([HWBR] eq "on" and [HWi1] ne "on" and [HWi2] ne "on" and [HWi3] ne "on") (set WM_08 oled 4 1 BR: . Vorwaermen)(set WM_08 rtttl 16:d=10 o=6 b=180 c) \
DOELSEIF ([HWBR] eq "on" and [HWi1] eq "on" and [HWi2] ne "on" and [HWi3] ne "on") (set WM_08 oled 4 1 BR: Normal-Betrieb)(set WM_08 rtttl 16:d=10 o=6 b=180 e g) \
DOELSEIF ([HWi2] eq "on") (set WM_08 oled 4 1 BR: ! STOERUNG !)(set WM_08 rtttl 16:d=10 o=6 b=180 c e g e c e g e c e g e c e g e c e g e c e g e c) \
DOELSEIF ([HWi3] eq "on") (set WM_08 oled 4 1 BR: ! OVERTEMP !)(set WM_08 rtttl 16:d=10 o=6 b=180 c e g e c e g e c e g e c e g e c e g e c e g e c) \
DOELSEIF ([HWBR] ne "on") (set WM_08 oled 4 1 BR: . STAND BY . )(set WM_08 rtttl 16:d=10 o=6 b=180 g c) \
 ... blablub ...
Wie gesagt hat das mit der Vorversion funktioniert, mit der aktuellen Version geht nur rtttl, nicht aber das Senden von Text...

Frage ist also: Hat sich da irgend etwas geändert, was ich übersehen habe?


EDIT:
Version 20180522 funktioniert noch, Version 20180524 und alle Nachfolgenden nicht mehr. Also entweder hat sich da ein BUG eingeschlichen, oder aber die haben was an der Parametrierung geändert, was ich noch nicht gefunden habe ...

Fred dazu: https://www.letscontrolit.com/forum/viewtopic.php?f=6&t=5472&p=28925#p28925
« Letzte Änderung: 14 Juni 2018, 22:53:03 von M_I_B »
DLzG
Micha

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3404
    • _.:|:._
Antw:WeMos neue FW, danach keine Textübertragung auf OLED
« Antwort #1 am: 15 Juni 2018, 10:27:30 »
Gut, dass Du Dich direkt ans Letscontrolit Team gewendet hast:
Zitat
There were several bug reports related to it and I applied already a quick fix for it, but apparently there is some other that's still not working.

Offline M_I_B

  • Sr. Member
  • ****
  • Beiträge: 920
  • ... Biker essen keinen Honig; die kauen Bienen!
Antw:WeMos neue FW, danach keine Textübertragung auf OLED
« Antwort #2 am: 15 Juni 2018, 10:43:41 »
... japp ... Scheint doch ein FW- Problem zu sein. Aber da ich ob der Masse der hier laufenden Threads nicht alles mitbekommen kann, hätte es ja sein können, das ich etwas nicht mitbekommen habe. Zudem ist mein Englisch ziemlich gruselig  ::)
DLzG
Micha

Offline M_I_B

  • Sr. Member
  • ****
  • Beiträge: 920
  • ... Biker essen keinen Honig; die kauen Bienen!
Antw:WeMos neue FW, danach keine Textübertragung auf OLED
« Antwort #3 am: 19 Juni 2018, 08:59:59 »
Nachtrag:
Offensichtlich doch nicht so einfach wie gedacht. Mal davon abgesehen, das sich ab FW 0524 diverse Fehler nach einer massiven Umstellung eingeschlichen haben, hat sich auch das Format geändert, wie aus FHEM und MQTT heraus Daten an das Display zu senden sind. Kann also so nicht funktionieren. Wenn ich das richtig verstanden habe, ist nunmehr u.a. auch ein Dimmer- Befehl implementiert, der die Lebensdauer der Displays verlängert (mit voller Helligkeit ist nach 4-5 Monaten 50% von der Helligkeit weg). Somit kommen die Daten vermutlich an, werden aber mit 0%, also dunkel dargestellt... Wie sie sehen, sehen sie nix ...
Leider sind diese Änderungen wohl auch nirgends dokumentiert (schon schräg...), so das erst mal herausgefunden werden muss, wie das neue Format ausschaut... Zumindest habe ich es so verstanden...
DLzG
Micha

Offline dev0

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3404
    • _.:|:._
Antw:WeMos neue FW, danach keine Textübertragung auf OLED
« Antwort #4 am: 21 Juni 2018, 07:26:16 »
Wenn Du herausfindest, wie die neue Syntax lautet, dann würde ich das (zusätzlich?) ins Modul integrieren.