Autor Thema: Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00  (Gelesen 958 mal)

Offline steffus

  • New Member
  • *
  • Beiträge: 17
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #15 am: 16 Juni 2018, 21:31:27 »
Ja, da steht 433MHz und 915 MHz. OK, ich könnte da etwas einlöten, welche Vorteile hätte ich dadurch? Würde der CUL dann auch anders erkannt werden, wenn ich ls -l /dev/serial/by-id eingebe? Der Stick hat mich jetzt 25 Euro gekostet, weiss nicht ob ich den jetzt zurück schicken sollte.

Offline Omega-5

  • Full Member
  • ***
  • Beiträge: 373
  • climbing is cool
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #16 am: 16 Juni 2018, 23:45:11 »
Würde der CUL dann auch anders erkannt werden, wenn ich ls -l /dev/serial/by-id eingebe?

Ja, er meldet sich dann mit usb-busware.de_CUL433-if00. Das kann man im Quellcode der Original CUL-Software sehen.

Gruß Frieder
RaspberryPi2, nanoCUL, 3x DS18B20, FS20: 4x Funk-Schalter ST-4, LaCrosseGW,
HomeMatic: HMLAN, HM-WDS10-TH-O, HM_MYS_RelaisBoard,
I2C: HYT221 über modifiziertes Modul I2_I2C_SHT21.pm (Q&D),
eHZ-IW8E2 mit USB-IR-Schreib-Lesekopf

Online Beta-User

  • Hero Member
  • *****
  • Beiträge: 3808
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #17 am: 17 Juni 2018, 07:45:26 »
Denselben Effekt hat man, wenn man dem CUL vor dem Flashen eine andere USB-Kennung unterschiebet. Dazu
Oder eben die firmware nochmal bauen und den "433-er" umbenennen (board.h im CUL-Zweig der firmware, dort die beiden 868-er-Angaben ändern und dann wie im Selbstbau-CUL-Artikel beschreiben flashen. (Ändert aber nichts an der vermutlich "falschen" Hardware).)
Bei deiner Version sollte eine universelle Antennenanpassung vorhanden sein.
Es mag ein universell bestückbares Board sein, aber daran, dass der eigentliche Antennenschaltkreis "universell" sein soll, glaube ich nicht. Zu den diversen Antennenproblemen könnt ihr euch ja mal ein Video von Andreass Spiess reinziehen (#191 ist auch nett ;) ). Ist zwar nicht Schwingkreisorientiert, macht aber deutlich, wie kleine Unterschiede riesige Auswirkungen haben...
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline Omega-5

  • Full Member
  • ***
  • Beiträge: 373
  • climbing is cool
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #18 am: 17 Juni 2018, 15:08:05 »
Denselben Effekt hat man, wenn man dem CUL vor dem Flashen eine andere USB-Kennung unterschiebet.

Nein, es wird nicht nur die Kennung geändert, sondern bei der Initialisierung auch die Frequenz 433,35MHz im CC1101 eingestellt. Wie schon gesagt, ruhig mal in den Quellcode gucken:
CC1100.c
#ifdef MULTI_FREQ_DEVICE
  // check 433MHz version marker and patch default frequency
  if (!bit_is_set(MARK433_PIN, MARK433_BIT)) {
    t = EE_CC1100_CFG + 0x0d;
    ewb(t++, 0x10);
    ewb(t++, 0xb0);
    ewb(t++, 0x71);
...
#endif   
  cc_set_pa(8); 

Dazu Es mag ein universell bestückbares Board sein, aber daran, dass der eigentliche Antennenschaltkreis "universell" sein soll, glaube ich nicht.

Bei dieser Version des Original-CUL ist die Anpassung nicht über eine induktiv/kapazitive Schaltung, die natürlich stark Frequenz abhängig wäre, sondern über einen BALUN gelöst. Das ist zwar auch nicht für beide Frequenzbereiche optimal, aber besser als die Lösung mit L und C. Die Design Note DN025 von TI zeigt auf Seite 14 einen Schaltungsvorschlag  "3.3.2 JTI Matched Filter Balun for 433 MHz or 868 MHz or 915 MHz". Vielleicht kann ja mal jemand aus der Köln/Leverkusener Runde einen der Funkamateure, bei denen sie zu Gast waren, um eine Erklärung bitten.

LG Friedrich
RaspberryPi2, nanoCUL, 3x DS18B20, FS20: 4x Funk-Schalter ST-4, LaCrosseGW,
HomeMatic: HMLAN, HM-WDS10-TH-O, HM_MYS_RelaisBoard,
I2C: HYT221 über modifiziertes Modul I2_I2C_SHT21.pm (Q&D),
eHZ-IW8E2 mit USB-IR-Schreib-Lesekopf

Online Beta-User

  • Hero Member
  • *****
  • Beiträge: 3808
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #19 am: 17 Juni 2018, 15:46:53 »
Danke, wieder was gelernt :D .
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline steffus

  • New Member
  • *
  • Beiträge: 17
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #20 am: 17 Juni 2018, 20:40:39 »
Verstehe gerade so gar nichts. Neu kompilieren und flashen? Oder einen Widerstand einlöten? Ich tendiere zum Widerstand, keine Ahnung wie ich das neu kompilieren soll mit Umbau auf 433MHz.

Online Beta-User

  • Hero Member
  • *****
  • Beiträge: 3808
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #21 am: 17 Juni 2018, 20:42:26 »
Widerstand ist besser, da geht mehr automatisch....
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

Offline steffus

  • New Member
  • *
  • Beiträge: 17
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #22 am: 20 Juni 2018, 20:02:33 »
OK, bekomme das aber leider nicht hin mit dem Widerstand. Das kann ich knicken. Alternative wäre das flashen auf 433. Gibt es da eine Anleitung im Netz?

Online Beta-User

  • Hero Member
  • *****
  • Beiträge: 3808
Antw:Zwei CUL an FHEM betreiben? usb-busware.de_CUL868-if00
« Antwort #23 am: 21 Juni 2018, 07:33:10 »
Es gibt nicht nur die Alternative, die beiden Angaben für die Identifizierung des USB-Devices vor dem Compilieren in der board.h zu ändern (für 868-er dasselbe oder was ähnliches reinschreiben wie für 433-er), du kannst auch - wie bereits mehrfach hier geschrieben und auch im verlinkten Wiki-Artikel erläutert - "by-path" verwenden.

Letzteres ist einfacher.
Wenn du das dann hast, bitte thread auf "gelöst" setzen nicht vergessen und bei Reichweitenproblemen ggf. den CUL tauschen oder jemanden der's kann bitten, den Widerstand einzulöten.
Server: HP-T5740 mit Debian stretch (i386) + aktuellem FHEM | ConfigDB | VCCU mit einiger HM-Hardware | MySensors seriell (2.3.0-alpha@RS485, div. konkrete Hardware, u.a. einige DS18B20) | Milight@ESP-GW | SIGNALduino | MapleCUN

 

decade-submarginal