Autor Thema: configDB  (Gelesen 468 mal)

Offline Firefield

  • New Member
  • *
  • Beiträge: 25
configDB
« am: 01 Juli 2018, 20:43:21 »
Hi,
nach meinem RPi crash hab fhem auch gleich auf configDB umgestellt und bin dazu dem Workshop gefolgt (https://forum.fhem.de/index.php/topic,54055.0.html).
Migriert hat sich das auch, Datenbank ist angelegt und hat sich befüllt. Den Restart hab ich auch ausgeführt.
Wenn ich in fhem allerdings configDB info eingeb kommt:  error: configDB not used!. Beim Suchen hab ich dann bemerkt, dass sich fhem nach perl fhem stop auf der Stelle wieder selbst startet, und zwar mit fhem.cfg. Bei /etc/init.d/fhem hab ich auch die Zeile auf den configDB Start geändert.
Weiß jemand, von wo aus fhem noch automatisch wieder gestartet werden könnte? Finde das irgendwie seltsam.

Im Logfile sieht das so aus:
2018.07.01 20:34:38 0: Server shutdown
2018.07.01 20:34:39 1: Including fhem.cfg
2018.07.01 20:34:39 3: telnetPort: port 7072 opened
2018.07.01 20:34:39 3: WEB: port 8083 opened
2018.07.01 20:34:39 3: WEBphone: port 8084 opened
2018.07.01 20:34:39 3: WEBtablet: port 8085 opened
2018.07.01 20:34:39 2: eventTypes: loaded 0 events from ./opt/fhem/log/eventTypes.txt
2018.07.01 20:34:39 3: Opening SCLX85 device 192.168.178.25:23
2018.07.01 20:34:39 1: HMLAN_Parse: HM new condition disconnected
2018.07.01 20:34:39 3: Opening HM device 192.168.178.37:1000
2018.07.01 20:34:40 1: HMLAN_Parse: HM new condition init
2018.07.01 20:34:40 3: HM device opened
2018.07.01 20:34:41 3: [HC_thWz] device <Wzth> in fhem not defined, but accepted
2018.07.01 20:34:41 1: PERL WARNING: given is experimental at ./FHEM/98_PID20.pm line 305, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 307, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: given is experimental at ./FHEM/98_PID20.pm line 339, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 341, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 345, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 356, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 363, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 370, <$fh> line 1105.
2018.07.01 20:34:41 1: PERL WARNING: when is experimental at ./FHEM/98_PID20.pm line 385, <$fh> line 1105.
2018.07.01 20:34:41 3: Gz_1: I/O device is Lamp
2018.07.01 20:34:41 3: Gz_2: I/O device is Lamp
2018.07.01 20:34:41 3: WZ_Couch: I/O device is Lamp
2018.07.01 20:34:41 3: HUEGroup0: I/O device is Lamp
2018.07.01 20:34:41 3: Bad: I/O device is Lamp
2018.07.01 20:34:41 3: TelegramBot_Define Bot: called
2018.07.01 20:34:41 3: Opening ZWAVE1 device /dev/ttyACM0
2018.07.01 20:34:41 3: Setting ZWAVE1 serial parameters to 115200,8,N,1
2018.07.01 20:34:41 1: ZWAVE1: wrong checksum: received 00, computed 03 for 1a0004001112011a00040011123202a16c000000000000000000
2018.07.01 20:34:44 3: ZWAVE1 device opened
2018.07.01 20:34:44 3: Opening myJeeLink device /dev/ttyUSB0
2018.07.01 20:34:44 3: Setting myJeeLink serial parameters to 57600,8,N,1
2018.07.01 20:34:45 3: myJeeLink device opened
2018.07.01 20:34:45 3: TKS: I/O device is myJeeLink
2018.07.01 20:34:45 3: TFSz: I/O device is myJeeLink
2018.07.01 20:34:45 3: TGem: I/O device is myJeeLink
2018.07.01 20:34:45 1: Including ./log/fhem.save
2018.07.01 20:34:45 3: No I/O device found for Nacht
2018.07.01 20:34:45 3: Device BoFe added to ActionDetector with 000:10 time
2018.07.01 20:34:45 3: Device TFGast added to ActionDetector with 000:10 time
2018.07.01 20:34:45 3: Device TFout added to ActionDetector with 000:10 time
2018.07.01 20:34:45 0: HMLAN_Send:  HM I:Y01,00,
2018.07.01 20:34:45 0: HMLAN_Send:  HM I:Y02,00,
2018.07.01 20:34:45 0: HMLAN_Send:  HM I:Y03,00,
2018.07.01 20:34:46 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/32_withings.pm line 460.
2018.07.01 20:34:46 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/32_withings.pm line 461.
2018.07.01 20:34:46 1: PERL WARNING: Use of uninitialized value in string eq at ./FHEM/32_withings.pm line 462.
2018.07.01 20:34:46 1: usb create starting
2018.07.01 20:34:46 3: Probing CUL device /dev/ttyS0
2018.07.01 20:34:46 1: PERL WARNING: can't getattr: Input/output error at FHEM/DevIo.pm line 419.
2018.07.01 20:34:46 1: CUL: Can't open /dev/ttyS0: Input/output error
2018.07.01 20:34:46 3: Probing CUL device /dev/ttyS1
2018.07.01 20:34:47 3: Probing CUL device /dev/ttyS2
2018.07.01 20:34:47 1: CUL: Can't open /dev/ttyS2: Input/output error
2018.07.01 20:34:47 3: Probing CUL device /dev/ttyS3
2018.07.01 20:34:47 1: CUL: Can't open /dev/ttyS3: Input/output error
2018.07.01 20:34:47 1: usb create end
2018.07.01 20:34:47 0: Featurelevel: 5.8
2018.07.01 20:34:47 0: Server started with 149 defined entities (fhem.pl:16866/2018-06-14 perl:5.024001 os:linux user:fhem pid:8776)
2018.07.01 20:34:47 0: HMLAN_Send:  HM I:+339BD8,00,00,00
2018.07.01 20:34:47 0: HMLAN_Send:  HM I:+30E30B,00,00,00
2018.07.01 20:34:47 0: HMLAN_Send:  HM I:+323EE0,00,00,00
2018.07.01 20:34:47 0: HMLAN_Send:  HM I:+2CBA68,00,00,00
2018.07.01 20:34:47 2: ZWDongle_ProcessSendStack: no ACK, resending message 0107000301020100f9
2018.07.01 20:34:47 3: CUL_HM set Terrasse_S statusRequest
2018.07.01 20:34:47 1: SCLX85: Can't connect to 192.168.178.25:23: 192.168.178.25: No route to host
2018.07.01 20:34:47 0: HMLAN_Parse: HM V:03C4 sNo:LEQ0640775 d:2CD8E8 O:ABCDEF t:33F95757 IDcnt:0004 L:1 %
2018.07.01 20:34:47 0: HMLAN_Parse: HM R:R57201F66 stat:0002 t:00000000 d:FF r:7FFF     m:99 8112 999999 000000
2018.07.01 20:34:47 1: HMLAN_Parse: HM new condition ok
2018.07.01 20:34:50 0: HMLAN_Send:  HM S:S5720479F stat:  00 t:00000000 d:01 r:5720479F m:A5 A001 ABCDEF 2CBA68 010E
2018.07.01 20:34:50 3: DbLog MariaDB - Creating Push-Handle to database mysql:database=fhem;host=localhost;port=3306 with user fhemuser
2018.07.01 20:34:50 3: DbLog MariaDB - Push-Handle to db mysql:database=fhem;host=localhost;port=3306 created
Gigabyte GB-BACE-3150, 8GB RAM, 120GB SSD, Debian Stretch. xfce GUI + xvnc | Aktuelles FHEM mit ConfigDB+LogDB. MariaDB + phpmyadmin. | Zwave.me USB dongle, Jeelink, HM und HUE bridge.

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15220
  • s/fhem\.cfg/configDB/g
Antw:configDB
« Antwort #1 am: 01 Juli 2018, 21:17:02 »
Migriert hat sich das auch, Datenbank ist angelegt und hat sich befüllt. Den Restart hab ich auch ausgeführt.

Wie hast Du den restart gemacht? Ein "shutdown restart" reicht auf jeden Fall nicht aus. Du musst FHEM komplett beenden, dann ggf. das Startskript anpassen (hast Du wohl schon gemacht) und danach FHEM neu starten.

Wenn Dein FHEM allerdings über systemd gestartet wird, musst Du vermutlich das fhem.service file anpassen und nicht /etc/init.d/fhem

-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline Firefield

  • New Member
  • *
  • Beiträge: 25
Antw:configDB
« Antwort #2 am: 01 Juli 2018, 23:32:46 »
hatte mit stop gestoppt:
bloß: wie schnell man diverse sachen doch vergisst -_- ...ja fhem läuft als service, muss ja starten ohne dass sich wer einloggt. nun startets mit configdb - danke dass war der entsprechende hinweis.

Nun ist aber noch was anderes aufgetreten. der zwave.me dongle behauptet er ist permanent beschäftigt.
2018.07.01 22:18:45 3: Opening ZWAVE1 device /dev/ttyACM0
2018.07.01 22:18:45 1: ZWAVE1: Can't open /dev/ttyACM0: Device or resource busy
grund war, das /dev/ttyACM0 nun der gruppe dialout gehört. muss vorher irgendwie anders gewesen sein. hab dann fhem noch in die usergruppe geadded und nun gehts wieder.
ob das was mit der umstellung auf configdb zu tun hat?
(btw: mit reiner konsole über ssh würd mich das am sonntagabend überfordern..)
« Letzte Änderung: 01 Juli 2018, 23:39:02 von Firefield »
Gigabyte GB-BACE-3150, 8GB RAM, 120GB SSD, Debian Stretch. xfce GUI + xvnc | Aktuelles FHEM mit ConfigDB+LogDB. MariaDB + phpmyadmin. | Zwave.me USB dongle, Jeelink, HM und HUE bridge.

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15220
  • s/fhem\.cfg/configDB/g
Antw:configDB
« Antwort #3 am: 02 Juli 2018, 10:34:20 »
ob das was mit der umstellung auf configdb zu tun hat?

Mit Sicherheit nicht. Wohl eher was mit Deinem nach dem Crash neu aufgesetzten FHEM :)

nach meinem RPi crash
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline Firefield

  • New Member
  • *
  • Beiträge: 25
Antw:configDB
« Antwort #4 am: 02 Juli 2018, 17:40:29 »
hm, nach dem umstieg aufn nuc hatte ich schon ein paar mal neu gestartet, aus verschiedenen gründen. in der letzten woche jedoch nicht. der letzte kampf mit /dev/ war an ttyusb0. muss da wohl was umgestellt haben, dass sich zurückgesetzt hat. strange... seis drum geht ja jetzt  und thx nochma   :D
Gigabyte GB-BACE-3150, 8GB RAM, 120GB SSD, Debian Stretch. xfce GUI + xvnc | Aktuelles FHEM mit ConfigDB+LogDB. MariaDB + phpmyadmin. | Zwave.me USB dongle, Jeelink, HM und HUE bridge.

Offline betateilchen

  • Developer
  • Hero Member
  • ****
  • Beiträge: 15220
  • s/fhem\.cfg/configDB/g
Antw:configDB
« Antwort #5 am: 11 Juli 2018, 22:41:41 »
kann es sein, dass der vorige Beitrag in einem völlig falschen Thread gelandet ist?
-----------------------
Unaufgeforderte Anfragen per email werden von mir nicht beantwortet. Dafür ist das Forum da.
-----------------------
Nächster Hamburg-Stammtisch: 14.12.2018 - 18:30 Uhr

Offline laserrichi

  • Jr. Member
  • **
  • Beiträge: 92
Antw:configDB
« Antwort #6 am: 11 Juli 2018, 22:50:16 »
aaaaargl... stimmt... dachte mir gerade das mein post verschwunden ist....
habs gelöscht... sorry

sollte hier rein: https://forum.fhem.de/index.php/topic,87812.30.html

 

decade-submarginal