Autor Thema: Sonos beendet sich nach ca. 5 Minuten (Version 9.0)  (Gelesen 533 mal)

Offline juemuc

  • Full Member
  • ***
  • Beiträge: 252
Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« am: 01 Juli 2018, 22:38:18 »
Hallo,

seit ich die Version 9.0 von Sonos (Sonos-Version) installiert habe, wird der Sonos-Prozess in Fhem nach ca. 5 Minuten beendet. Log (Verbose 5) liegt vor.

Hat jemand ähnliche Probleme? Zusätzlich habe ich auch das aktuelle SSCAM-Modul installiert. Ich hoffe, das es hier keinen Zusammenhang gibt. Wer kann helfen. Hier die letzten Zeilen aus dem LOG.
2018.07.01 22:26:43 4: SONOS3: SONOS_Client_Data_Retreive(RINCON_B8E937643B6201400_MR, reading, location, ) -> http://192.168.70.16:1400/xml/device_description.xml
2018.07.01 22:26:43 5: SONOS3: Location: http://192.168.70.16:1400/xml/device_description.xml
2018.07.01 22:26:43 5: SONOS3: PingType: tcp
2018.07.01 22:26:43 4: SONOS3: 192.168.70.16 is alive
2018.07.01 22:26:43 5: SW: DoWork:undef:refreshProcessAnswer:

2018.07.01 22:26:43 5: SONOS0: Received: 'DoWork:undef:refreshProcessAnswer:'
2018.07.01 22:26:43 2: SONOS0: LastProcessAnswer way too old (Lastanswer: 1530476683.43255 ~ 2018-07-01 22:24:43)... try to restart the process and connection...
2018.07.01 22:26:43 4: SONOS0: ReadingsBeginUpdate from Module for "Sonos"
2018.07.01 22:26:43 4: SONOS0: Supress ReadingsEndUpdate from Module due to running BulkUpdate from SubProcess for "Sonos"
2018.07.01 22:26:44 5: SW: shutdown

2018.07.01 22:26:44 5: SONOS0: Received: 'shutdown'
2018.07.01 22:26:44 3: SONOS0: Disconnecting client and shutdown server...
2018.07.01 22:26:44 3: SONOS0: Trying to kill Sonos_Thread...
2018.07.01 22:26:44 3: SONOS0: Trying to kill LongJobs_Thread...
2018.07.01 22:26:44 3: SONOS0: Trying to kill IsAlive_Thread...
2018.07.01 22:26:44 3: SONOS0: Trying to kill PlayerRestore_Thread...
2018.07.01 22:26:44 0: SONOS0: Das Lauschen auf der Schnittstelle wurde beendet. Prozess endet nun auch...
2018.07.01 22:26:44 4: SONOS0: ReadingsBeginUpdate from Module for "Sonos_Bad"

Viele Grüße

Jürgen
3x Sonos Play 1, 1x Sonos Playbar + Sub, 1 Sonos-One
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und HM Funkmodul HM-MOD-RPI-PCB
Amazon Echo Dot

Raspi3 mit 32GB und akt. Raspberry

Offline Nobby1805

  • Sr. Member
  • ****
  • Beiträge: 521
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #1 am: 02 Juli 2018, 11:37:25 »
Ist denn die 9.0 schon offiziell verfügbar?
FHEM: 5.8 auf Windows Server 2003 mit Strawberry Perl 5.26.1.1-32bit
TabletUI: 2.7.2
IO: 2xHMLAN(0.965)|HMUSB2(0.967)

Offline juemuc

  • Full Member
  • ***
  • Beiträge: 252
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #2 am: 02 Juli 2018, 12:07:45 »
Ich befürchte NEIN  :-\

Viele Grüße
Jürgen
3x Sonos Play 1, 1x Sonos Playbar + Sub, 1 Sonos-One
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und HM Funkmodul HM-MOD-RPI-PCB
Amazon Echo Dot

Raspi3 mit 32GB und akt. Raspberry

Offline choenig

  • Full Member
  • ***
  • Beiträge: 112
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #3 am: 02 Juli 2018, 22:47:58 »
Hi,

ich habe zur Zeit ähnliche Probleme mit meinem SONOS System.

Ich habe auch immer mal wieder ein
2018.07.01 22:26:44 5: SONOS0: Received: 'shutdown'

aus heiterem Himmel. Ohne dass ich es beendet habe.

Ich habe jedoch
Version: 8.6
LG
Christian

Offline XXL-Wing

  • New Member
  • *
  • Beiträge: 18
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #4 am: 10 Juli 2018, 18:29:07 »
Ich hab auch massive Sonos Probleme :-(
Die Player werden einfach nicht online....

Logauszug:
2018.07.10 18:24:51 1: SONOS0: ./FHEM/00_SONOS.pm is listening to Port 4711
2018.07.10 18:24:59 3: SONOS0: Connection accepted from localhost:56830
2018.07.10 18:24:59 1: localhost:4711 reappeared (Sonos)
2018.07.10 18:25:27 1: PERL WARNING: Use of uninitialized value $statusPage in pattern match (m//) at ./FHEM/21_SONOSPLAYER.pm line 526.
2018.07.10 18:25:27 1: Perfmon: possible freeze starting at 18:25:24, delay is 3.599
2018.07.10 18:25:52 1: SONOS1: UPnP-Thread gestartet.
2018.07.10 18:25:52 1: SONOS2: LongJobs-Thread gestartet. Prüfe auf LongJobs...
2018.07.10 18:25:52 1: SONOS3: IsAlive-Thread gestartet. Warte 120 Sekunden und pruefe dann alle 30 Sekunden...
2018.07.10 18:25:52 1: SONOS4: Restore-Thread gestartet. Warte auf Arbeit...
2018.07.10 18:25:52 3: SONOS1: ProxyObject does not exists
2018.07.10 18:26:39 3: SONOS1: ProxyObject does not exists
2018.07.10 18:26:39 3: SONOS1: ProxyObject does not exists
2018.07.10 18:26:39 3: SONOS1: ProxyObject does not exists


Kennt das jemand? Ab und zu hatte es früher funktioniert aber da hat sich das Sonos Subsystem auch immer wieder verabschiedet...

Für jeden Tip dankbar,
LG
Mike

Offline juemuc

  • Full Member
  • ***
  • Beiträge: 252
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #5 am: 11 Juli 2018, 21:44:45 »
Sonos 9.0 ist nun verfügbar  ;D
3x Sonos Play 1, 1x Sonos Playbar + Sub, 1 Sonos-One
Fritzbox 7490 mit 4x Dect 200 und 3 Dect-ULE-Thermostate, HM Klingelsensor HM-Sen-DB-PCB, HM Fensterkontakte und HM Funkmodul HM-MOD-RPI-PCB
Amazon Echo Dot

Raspi3 mit 32GB und akt. Raspberry

Offline RalfP

  • New Member
  • *
  • Beiträge: 27
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #6 am: 12 Juli 2018, 06:13:51 »
Hallo,

leider auch bei mir das selbe Problem, seit dem neuesten Sonos Update auf 9.0

Gruß
Ralf

Offline Nobby1805

  • Sr. Member
  • ****
  • Beiträge: 521
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #7 am: 12 Juli 2018, 17:10:45 »
Bei mir funktioniert es auch mit der Version 9.0
FHEM: 5.8 auf Windows Server 2003 mit Strawberry Perl 5.26.1.1-32bit
TabletUI: 2.7.2
IO: 2xHMLAN(0.965)|HMUSB2(0.967)

Offline RalfP

  • New Member
  • *
  • Beiträge: 27
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #8 am: 12 Juli 2018, 18:25:44 »
Hallo,

nach einigen Stunden nichts anfassen und einem weiteren Neustart von Fhem, läuft es wieder, nach einem etwas holprigen Erkennen der Gruppen  ::)

mmmh

Gruß
Ralf

Offline inoma

  • Full Member
  • ***
  • Beiträge: 404
Antw:Sonos beendet sich nach ca. 5 Minuten (Version 9.0)
« Antwort #9 am: 12 Juli 2018, 22:59:32 »
Bei mir bisher alles problemlos mit 9.0. Absolut keine Probleme. Nur eine neue Meldung im Log seit dem update auf 9.0: Use of uninitialized value $updateItem in pattern match (m//) at ./FHEM/00_SONOS.pm line 5995, <$client> line 11.
« Letzte Änderung: 12 Juli 2018, 23:01:36 von inoma »
Raspberry Pi 3 B+ / Stretch: FHEM-Server 5.8, DbLog,Homematic, Homematic-IP über HMCCU, RESIDENTS, SONOS Play1, EnerGenie EG-PM2-LAN, FRITZBOX, GCALVIEW, GEOFANCY, HMCCU, HMUARTLGW, HM-MOD-UART, HUEBridge, Phillips HUE, FritzDECT, TRAFFIC, Xiaomi Robot Vacuum, alexa-fhem + Amazon Echo