Autor Thema: MapleCUx flash problem  (Gelesen 307 mal)

Offline fuppking

  • Jr. Member
  • **
  • Beiträge: 94
MapleCUx flash problem
« am: 08 Juli 2018, 19:12:31 »
Hallo,

hoffe ihr könnt mir helfen. Ich versuche gerade die a-culfw auf den MapleCun zu bringen. komme aber nicht wirklich weiter.
Ich habe nun folgende Fragen.:

a)  ich hab den Bootloader auf den STM32 gebrocht. Nun verhalt sich der Maple     
     folgender maßen
     -   keine LED blinkt
     -   im Geräte-Manger wird es als Serielles USB-Gerät (COM3) angezeigt
     -   Wenn ich auf den Reset Knopf drücke blinkt er schnell für ca 2 Sek dann
     -   ist wieder alles "Stumm" (Led ist aus"

b)   falls das alles so O.K ist dann brauch ich hilfe wie ich din a-culfw draufspiele.
      Bei den Arduinos spielte ich es immer mit XLoader drauf. Da es eine BIN datei
      datei ist geht es mit XLoader nicht. Mit den Programm dfu-util hab ich meine   
      Probleme. (Ich starte es (WIN10) und nix passiert.

Währe nett wenn mich jemand irgendwie unterstützt.


Vielen dank

   
« Letzte Änderung: 08 Juli 2018, 19:25:08 von fuppking »

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4211
Antw:MapleCUx flash problem
« Antwort #1 am: 09 Juli 2018, 17:40:48 »
Wäre nett wenn mich jemand irgendwie unterstützt.
Hast Du hier https://github.com/heliflieger/a-culfw/blob/master/culfw/Devices/MapleCUN/README.md schonmal geschaut?

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline fuppking

  • Jr. Member
  • **
  • Beiträge: 94
Antw:MapleCUx flash problem
« Antwort #2 am: 09 Juli 2018, 17:53:50 »
Nach dieser Anleitung hab ich gearbeitet. den Bootloader hab ich aufspielen können.
zumindest denke ich mir das (siehe oben.)
Probleme hab ich mit dem aufspielen der Bin Datei und dfu-util

es steht in der Anleitung das man innerhalb des schnellblinkens nach dem Reset
das dfu-util starten soll. Das teil blinkt aber auch nur 2 Sek. Also muss das ne schnelle sache sein. Genau das blaub ich irgendwie nicht sor richtig.

Ich nutze Win10 und weiss nicht so richtig wie ich dfu-util starten soll. Wenn ich es so starte dann offnet sich weder ein Fenster noch tut sich da was.

Also jede Hilfe ist mir wichtig damit ich mal zum Ziel komme

Danke

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4211
Antw:MapleCUx flash problem
« Antwort #3 am: 09 Juli 2018, 20:52:02 »
Hallo,

ich gebe die Befehlszeile ein, drücke dann quasi gleichzeitig Enter bzw. die Reset Taste, siehe Bild.
Klappt meistens. Die 97 % sind wohl irgendwie normal.

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1722
  • Es begann alles so klein ;-)
Antw:MapleCUx flash problem
« Antwort #4 am: 09 Juli 2018, 21:10:48 »
Hi,
ich habe heute mal das Linux Subsystem unter Win10 mit Debian aus dem Windows APP Store versehen.
Was soll ich sagen: Jetzt gehen die shell Skripte von Ranseyer auch auf der Windows Büchse ;-)

COM6 wird zu /dev/ttyS6

Gruß Arnd



Gesendet von iPhone mit Tapatalk
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...