Autor Thema: [Gelöst]Alexa findet keine neuen Geräte mehr  (Gelesen 1421 mal)

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
[Gelöst]Alexa findet keine neuen Geräte mehr
« am: 11 Juli 2018, 22:37:56 »
Hi,
ich kann über die Alexa alles definierte bis jetzt problemlos steuern, jetzt habe ich 3 neue ITR-1500 Intertechno Steckdosen in Fhem angelegt, die ich über Fhem auch steuern kann. Allerdings werden mir diese 3 Dosen nicht in der Alexa App angezeigt, was könnte ich da falsch gemacht haben? Meine anderen Intertechno Steckdosen lassen sich alle über Alexa steuern

Die Dose sieht so aus
Internals:
   CFGFN     
   Cul433_MSGCNT 1
   Cul433_RAWMSG i6965a65555a59955
   Cul433_RSSI -85
   Cul433_TIME 2018-06-30 13:51:05
   DEF        01100100110100000000110010 1 0000
   IODev      Cul433
   LASTInputDev Cul433
   MSGCNT     1
   NAME       Licht
   NR         724
   STATE      off
   TYPE       IT
   XMIT       0110010011010000000011001010000
   XMITdimdown 00
   XMITdimup  00
   XMIToff    0
   XMITon     1
   CODE:
     1          0110010011010000000011001010000
   Helper:
     DBLOG:
       state:
         myDbLog:
           TIME       1530360103.61678
           VALUE      off
   READINGS:
     2018-06-30 13:50:17   group           1
     2018-06-30 13:50:17   protocol        V3
     2018-06-30 14:01:43   state           off
     2018-06-30 13:50:17   unit            0000
Attributes:
   IODev      Cul433
   alexaName  Licht
   group      Steckdosen
   room       Alexa,Außen
   
   
Wenn ich in der APP nach neuen Geräten suche, bekomme ich in der Konsole folgende Ausgabe
https://pastebin.com/PHexNazN

Danach sieht doch aus als ob etwas gefunden wurde!?
"endpointId":"IT_01100100110100000000110010_1_0000","manufacturerName":"FHEMIT","modelName":"FHEM<unknown>","version":"<unknown>","friendlyName":"licht","description":"n: Licht, r: alexa,außen","actions":[],"capabilities":[{"type":"AlexaInterface","interface":"Alexa.PowerController","version":"3","properties":{"supported":[{"name":"powerState"}],"proactivelyReported":false,"retrievable":true}}],"displayCategories":["SWITCH"],"cookie":{"device":"Licht"}}
im Alexa Log steht folgendes
https://paste.ubuntu.com/p/NNKK6Wbm6B/

Ich hatte auch hier https://forum.fhem.de/index.php/topic,60452.2295.html schonmal etwas dazu gepostet, allerdings haben alle ideen dort nichts gebracht.

Hat noch jemand eine idee? Verzweifel langsam

Danke
« Letzte Änderung: 21 Oktober 2018, 19:34:19 von Tommy82 »
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline jojo61

  • New Member
  • *
  • Beiträge: 13
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #1 am: 12 Juli 2018, 11:14:54 »
Fehlt da nicht der alexaRoom in den Attributen ?

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #2 am: 12 Juli 2018, 13:56:32 »
Fehlt da nicht der alexaRoom in den Attributen ?
Seit wann muss der angegeben werden? Habe immer noch den „Alexa“ Room zugeordnet, bei allen Devices


Gesendet von iPhone mit Tapatalk
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 4381
  • NIVEAu ist keine Creme...
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #3 am: 13 Juli 2018, 00:26:04 »
alexaRoom ist nur für den Custom Skill relevant!
Und hat (somit) nichts mit der Gerätesuche im SmartHome Skill zu tun...

Hast du schon Rückmeldung von justme1968?

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #4 am: 13 Juli 2018, 06:50:32 »
alexaRoom ist nur für den Custom Skill relevant!
Und hat (somit) nichts mit der Gerätesuche im SmartHome Skill zu tun...

Hast du schon Rückmeldung von justme1968?

Gruß, Joachim

Hi, nein leider nicht
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline retikulum

  • Jr. Member
  • **
  • Beiträge: 81
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #5 am: 13 Juli 2018, 13:00:47 »
Poste mal deine cfg-Einträge.

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #6 am: 13 Juli 2018, 13:46:18 »
Poste mal deine cfg-Einträge.
Welche meinst du? Die json?


Gesendet von iPhone mit Tapatalk
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #7 am: 15 Juli 2018, 19:42:18 »
Poste mal deine cfg-Einträge.

Also wenn du die config.json meinst, die sieht so aus

{
    "alexa": {
        "port": 3000,
        "name": "Alexa TEST",
        "keyFile": "./key.pem",
        "certFile": "./cert.pem",
        "nat-pmp": "",
        "nat-upnp": false,
        "applicationId": "amzn1.ask.skill.f16610d1-327b-4d7a-9881-ce8e6250b5cb",
        "oauthClientID": "amzn1.application-oa2-client.aa28829efdaa4bbabdd0bc5271434917"
    },
   
    "connections": [
        {
            "name": "FHEM",
            "server": "127.0.0.1",
            "port": "8085",
            "filter": "room=Alexa"
        }
    ]
}
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #8 am: 19 Juli 2018, 07:16:13 »
Keiner mehr eine idee?
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #9 am: 22 Juli 2018, 19:51:24 »
Hab jetzt mal alexa-fhem geupdatet, in der Hoffnung das es dann wieder funktioniert, bekomme dann diese Meldung, kann die etwas mit meinem Problem zu tun haben? und was kann ich dagegen machen?

npm install
npm notice created a lockfile as package-lock.json. You should commit this file.
added 63 packages from 78 contributors and audited 136 packages in 37.298s
found 1 low severity vulnerability
  run `npm audit fix` to fix them, or `npm audit` for details
fhem@cubietruck:/opt/fhem/alexa-fhem$ npm audit fix
up to date in 6.55s
fixed 0 of 1 vulnerability in 136 scanned packages
  1 vulnerability required manual review and could not be updated
fhem@cubietruck:/opt/fhem/alexa-fhem$ npm audit`
>
> ^C
fhem@cubietruck:/opt/fhem/alexa-fhem$ npm audit
^C^X^C

^X^C
fhem@cubietruck:/opt/fhem/alexa-fhem$ npm audit

                       === npm audit security report ===

┌──────────────────────────────────────────────────────────────────────────────┐
│                                Manual Review                                 │
│            Some vulnerabilities require your attention to resolve            │
│                                                                              │
│         Visit https://go.npm.me/audit-guide for additional guidance          │
└──────────────────────────────────────────────────────────────────────────────┘
┌───────────────┬──────────────────────────────────────────────────────────────┐
│ Low           │ Regular Expression Denial of Service                         │
├───────────────┼──────────────────────────────────────────────────────────────┤
│ Package       │ debug                                                        │
├───────────────┼──────────────────────────────────────────────────────────────┤
│ Patched in    │ >= 2.6.9 < 3.0.0 || >= 3.1.0                                 │
├───────────────┼──────────────────────────────────────────────────────────────┤
│ Dependency of │ nat-pmp                                                      │
├───────────────┼──────────────────────────────────────────────────────────────┤
│ Path          │ nat-pmp > debug                                              │
├───────────────┼──────────────────────────────────────────────────────────────┤
│ More info     │ https://nodesecurity.io/advisories/534                       │
└───────────────┴──────────────────────────────────────────────────────────────┘
found 1 low severity vulnerability in 136 scanned packages
  1 vulnerability requires manual review. See the full report for details.
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 4381
  • NIVEAu ist keine Creme...
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #10 am: 23 Juli 2018, 06:10:30 »
Hatte ich auch...
Ist "nur" ein Hinweis auf eine (mögliche) Sicherheitslücke eines Pakets...

Funktioniert bei mir weiterhin problemlos...

Ich fürchte solang niemand (justme1968) die Ausgabe bzw. den Unterschied/das Problem in den Ausgaben etc. (siehe anderer Thread) findet wird es schwer...

Weil prinzipiell (scheint es ja) funktioniert es...
Gerätesuche prinzipiell ja auch...

Also Lambda, Trigger, Port scheint dann ja zu gehen...

Bin leider (weiterhin) ratlos...

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #11 am: 23 Juli 2018, 21:25:19 »
Also alle vorhanden Geräte funktionieren ohne Probleme, laut Log https://pastebin.com/0Max3rgK  werden ja auch die neuen gefunden, aber in der Alexa App werden mir diese dann nicht angezeigt..........
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #12 am: 13 August 2018, 07:45:26 »
Hab grade gesehen das andere Geräte welche ich irgendwann man den Alexa room zugewiesen habe (aber nie in Alexa bis jetzt genutzt habe) auch nicht in der App gefunden werden. Da ja leider keiner eine Idee hat, hab ich nur die Idee alles was Alexa und Fhem angeht zu deinstallieren, und neu zu machen. Wie deinstalliere ich das am einfachsten und saubersten?

Danke


Gesendet von iPhone mit Tapatalk
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

Offline Esjay

  • Sr. Member
  • ****
  • Beiträge: 818
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #13 am: 13 August 2018, 09:03:09 »
Hast du mal ein "setList on off" sowie "genericDeviceType switch" als Attribut hinzugefügt? Anschließend alexa-fhem neustarten, bzw. Server neustarten.

Grüße

Offline Tommy82

  • Hero Member
  • *****
  • Beiträge: 2310
Antw:Alexa findet keine neuen Geräte mehr
« Antwort #14 am: 14 August 2018, 20:55:54 »
Hast du mal ein "setList on off" sowie "genericDeviceType switch" als Attribut hinzugefügt? Anschließend alexa-fhem neustarten, bzw. Server neustarten.

Grüße

Hi, da es sich um eine Intertechno Steckdose handelt, gibt es kein setList, hab das aber auch mit einem Dummy erfolglos versucht.
genericDeviceType switch bringt leider auch keine besserung
Fhem Cubitruck Armbian Stretch 4.18.8-sunxi
HM-CC_RT-DN, HM-Sec-RHS,HM-Sec-SD, HM-Sec-SCo,IT1500,1xIT GRR-3500 Fritz!Dect200,Powerline546E,Enigma2 Modul mit 3 Vu+,Wol Modul für WinServer2016 und WinServer 2012,FB6590
Hanspreed 13,3 Zoll Wandtablett mit FTUI

 

decade-submarginal