Autor Thema: Login problem - Invalid get token response  (Gelesen 793 mal)

Offline yamaha1983

  • New Member
  • *
  • Beiträge: 20
Login problem - Invalid get token response
« am: 12 Juli 2018, 08:30:25 »
Hallo zusammen,

ich habe zuhause 3 Homeconnect Geräte im Einsatz (Spülmaschine, Ofen und Trockner).
Ich versuche es schon seit vielen Monaten immer wieder das FHEM Modul HomeConnectConnection ans laufen zu bekommen, schaffe es nicht und verwerfe das dann wieder für einen Monat.

Ich habe einen Developeraccount, der auch den "Advanced Account" Status besitzt.
Weiter habe ich meinen Benutzer yamaha1983 (so wie hier Benutzername auch im FHEM Forum) von euch freischalten lassen.

Im nächsten Schritt habe ich unter "My Applications" eine neue Applikation angelegt.
Application name: FHEM Betatester
Redirect URL(s): http://192.168.0.11:8083/fhem?cmd.Test=set%20hcconn%20auth%20&fwcsrf=secToken312
Application description: Homeconnect for FHEM

Die Homeconnectseite generiert einem dann einen "Client secret" und "API key". Soweit so gut.

Nun in meiner FHEM Instanz definiere ich nun ein Device vom Typen HomConnectConnection
-> define hcconn HomeConnectConnection [API Key von Homeconnect] http://192.168.0.11:8083/fhem?cmd.Test=set%20hcconn%20auth%20&fwcsrf=secToken312

Gerät wird dann angelegt und ist im state Login necessary. Wenn ich nun die Redirect URL aufrufe bekomme ich den Fehler: "Invalid get token response".

Ich habe auch so ziemlich alles versucht. Auch anstatt mit der eth0 adresse localhost versucht, dann aber vom rasperry lokal aus (sonst erreicht man localhost ja nicht). Ich habe localhost auch versucht, weil ich dort eine eigene WEBinstanz ohne secret Token habe. Dabei immer darauf geachtet, dass die Redirect URL von Homeconnect und FHEM syncron sind. Aber kommt letztendlich alles zum gleichen Ergebnis.

Nun habe ich nochmal verbose auf 5 gesetzt und im Logfile das hier gefunden:
2018.07.12 08:13:04 3: hcconn refreshing token
2018.07.12 08:13:14 1: PERL WARNING: Use of uninitialized value $tokens in concatenation (.) or string at ./FHEM/48_HomeConnectConnection.pm line 160.
2018.07.12 08:13:14 1: PERL WARNING: Use of uninitialized value $tokens in pattern match (m//) at ./FHEM/48_HomeConnectConnection.pm line 161.
2018.07.12 08:13:14 1: PERL WARNING: Use of uninitialized value $code in concatenation (.) or string at ./FHEM/48_HomeConnectConnection.pm line 165.
2018.07.12 08:13:14 1: PERL WARNING: Use of uninitialized value $_ in substitution (s///) at FHEM/HttpUtils.pm line 50.
2018.07.12 08:13:14 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at FHEM/HttpUtils.pm line 521.
2018.07.12 08:13:14 2: hcconn AuthTokenResponse <html>
<head><title>500 Internal Server Error</title></head>
<body bgcolor="white">
<center><h1>500 Internal Server Error</h1></center>
<hr><center>openresty/1.13.6.1</center>
</body>
</html>

2018.07.12 08:13:14 2: hcconn invalid json detected: >><html>
<head><title>500 Internal Server Error</title></head>
<body bgcolor="white">
<center><h1>500 Internal Server Error</h1></center>
<hr><center>openresty/1.13.6.1</center>
</body>
</html>
<<

Was mache ich nun falsch? Ich habe auch die Version von HomeConnect und HomeConnectConnection überprüft. Hier bin ich aktuell.

Wenn einer einen Rat weiß, dann wäre ich um jeden Tipp dankbar.

Grüße,
Tim

Offline Pf@nne

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 919
    • tech_LogBuch
Antw:Login problem - Invalid get token response
« Antwort #1 am: 13 Juli 2018, 05:32:04 »
Zitat
Gerät wird dann angelegt und ist im state Login necessary. Wenn ich nun die Redirect URL aufrufe bekomme ich den Fehler: "Invalid get token response".

Moin Tim,

hast du denn das Login vollzogen?
Also in der FHEM-Übersicht (nicht in den Device hinein gehen) den Button neben hcconn mal gedrückt?
Damit gelangst du zu HomeConnect und musst dich anmelden, danach wechselt der State auf "connected".

MfG
Pf@nne
FHEM auf: DS415+ (Master), Raspberry Pi 2

Offline yamaha1983

  • New Member
  • *
  • Beiträge: 20
Antw:Login problem - Invalid get token response
« Antwort #2 am: 13 Juli 2018, 08:09:39 »
Wow, es ist immer wieder schön wie ich mich selbst austrickse :D.
Nachdem ich hcconn angelegt hatte, bin ich immer mit -> "list hcconn" und dann per klick auf das Ergebnis in das Device gegangen. So habe ich nie den Login Button gesehen.
Dachte immer, dass der Login dann über die Redirect URL funktioniert.

Danke @ Pf@anne. Manchmal sind die kleinsten Dinge die größten Hürden. :D

Vielleicht baut ihr in eurer Doku noch einen kleinen Hinweis mit dem Login bei der Geräteübersicht ein. Dann erschließt sich für den Leser auch, wie ein Developeraccount und ein Normalaccount zusammenlaufen.

Damit kann der Thread wohl geschlossen werden.

Danke!

Offline Pf@nne

  • Moderator
  • Sr. Member
  • ***
  • Beiträge: 919
    • tech_LogBuch
Antw:Login problem - Invalid get token response
« Antwort #3 am: 14 Juli 2018, 22:19:23 »
Naja, genaugenommen.....

Zitat
Danach findet Ihr in dem neuen Device hcconn einen Link namens Home Connect Login. Diesen klicken und die Anmeldung wird durchgeführt. Danach im hcconn-Device noch scanDevices ausführen und Ihr solltet eine stattliche Anzahl Hausgeräte finden.

 8)
FHEM auf: DS415+ (Master), Raspberry Pi 2

Offline Hubertus

  • New Member
  • *
  • Beiträge: 3
Antw:Login problem - Invalid get token response
« Antwort #4 am: 04 Oktober 2018, 13:31:58 »
Hallo zusammen,

Homeconnect hat bei mir bisher bis August funktioniert. Nun meldet FHEM:
Zitat
2018.10.04 13:04:14 2: hcconn AuthTokenResponse {
  "error": "invalid_client",
  "error_description": "client secret validation failed"
}

Im DeveloperAccount war die Application "HCCON" nicht mehr freigeschaltet - habe die Freischaltung wieder beantragt- Diese wurde aber mit dem Hinweis: "Hello, For usage along with FHEM you don't need to publish application. Just user need to create and log in into Home Connect account. Because of that we are denying publication request. Your Home Connect Developer Team." zurückgewiesen.

Wie bekomme ich denn nun eine Verbindung hin? Danke für jeden Tipp

Gruß
Hubertus

Offline Hubertus

  • New Member
  • *
  • Beiträge: 3
Antw:Login problem - Invalid get token response
« Antwort #5 am: 04 Oktober 2018, 13:41:39 »
Sorry - habe im Forum noch weiter gestöbert und den Beitrag: https://forum.fhem.de/index.php/topic,89896.msg829235.html#msg829235
gefunden - nun klappt's auch mit dem Geschirrspüler.

 

decade-submarginal