Autor Thema: Temperatursensor TFA 33.3133  (Gelesen 974 mal)

Guest

  • Gast
Temperatursensor TFA 33.3133
« am: 23 November 2012, 22:33:48 »
Originally posted by: <email address deleted>

Hallo zusammen,

ich habe diese Woche meine ersten Schritte mit FHEM unternommen und
scheitere gerade an einem Temperatursensor.

Ich habe 2 Sensoren TFA 33.3133.
Einer (Kanal 2) wurde durch autocreate als TX3 angelegt:

2012.11.21 23:58:50 0: Server started (version Fhem 5.3 (DEVELOPMENT), $Id: fhem.pl 1996 2012-10-20 07:11:56Z rudolfkoenig $, pid 1269)
> 2012.11.22 00:10:52 3: TRX_WEATHER: Unknown device TX3, please define it
> 2012.11.22 00:10:52 0: TRX_ELSE: hex=085005005500004c59
> 2012.11.22 00:12:40 3: TRX_WEATHER: Unknown device TX3, please define it
> 2012.11.22 00:12:40 2: autocreate: define TX3 TRX_WEATHER TX3
> 2012.11.22 00:12:40 2: autocreate: define FileLog_TX3 FileLog ./log/TX3-%Y.log TX3
>
>
Der zweite (Kanal 1) bringt mir nur eine Fehlermeldung im Log:

2012.11.23 22:17:12 5: TRX_Parse1 '08500ad76702005669'
> 2012.11.23 22:17:12 5: TRX_0 dispatch 08500ad76702005669
> 2012.11.23 22:17:12 5: TRX_WEATHER: decoding delay=209 hex=08500ad76702005669
> 2012.11.23 22:17:12 1: RFX_WEATHER: common_temp error undefined subtype=0a
> 2012.11.23 22:17:12 4: TRX_WEATHER: error device_name undefined
>
> 2012.11.23 22:18:23 5: TRX_Parse1 '08500ad86702005769'
> 2012.11.23 22:18:23 5: TRX_0 dispatch 08500ad86702005769
> 2012.11.23 22:18:23 5: TRX_WEATHER: decoding delay=71 hex=08500ad86702005769
> 2012.11.23 22:18:23 1: RFX_WEATHER: common_temp error undefined subtype=0a
> 2012.11.23 22:18:23 4: TRX_WEATHER: error device_name undefined
>
>
Wie kann ich den Sensor in FHEM einbinden?
Kann mir dabei jemand behilflich sein?

Mein Setup:
Raspberry Pi mit RFXTRX433 und aktueller Development FHEM Version.

Danke, Markus

P.S.: Hat irgendjemand sonst noch X10 MS13E Bewegungsmelder im Einsatz?
 

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Guest

  • Gast
Re: Temperatursensor TFA 33.3133
« Antwort #1 am: 24 November 2012, 08:07:33 »
Originally posted by: <email address deleted>

Hallo Markus,

na dann schauen wir mal ;-)

Am Freitag, 23. November 2012 22:33:48 UTC+1 schrieb Markus M.:

> 2012.11.22 00:10:52 3: TRX_WEATHER: Unknown device TX3, please define it
>> 2012.11.22 00:10:52 0: TRX_ELSE: hex=085005005500004c59
>> 2012.11.22 00:12:40 3: TRX_WEATHER: Unknown device TX3, please define it
>> 2012.11.22 00:12:40 2: autocreate: define TX3 TRX_WEATHER TX3
>> 2012.11.22 00:12:40 2: autocreate: define FileLog_TX3 FileLog ./log/TX3-%Y.log TX3
>>
>>
>
Das ist ein La Crosse TX3-Sensor, der erkannt wurde. Ich vermute mal, dass
dies ein Sensor Deines Nachbarn ist.
Wenn Du den empfangen willst: Freuen und dem Nachbarn danken.

Wenn Du den nicht empfangen willst, kannst Du diesen mit dem Attribut
ignore ingorieren. Dann belästigt er Dich nicht mehr.

Evtl. ist es aber auch einer Deiner alter Wettersensoren, z.B. von Aldi.
 

> Der zweite (Kanal 1) bringt mir nur eine Fehlermeldung im Log:
>
> 2012.11.23 22:17:12 5: TRX_Parse1 '08500ad76702005669'
>> 2012.11.23 22:17:12 5: TRX_0 dispatch 08500ad76702005669
>> 2012.11.23 22:17:12 5: TRX_WEATHER: decoding delay=209 hex=08500ad76702005669
>> 2012.11.23 22:17:12 1: RFX_WEATHER: common_temp error undefined subtype=0a
>> 2012.11.23 22:17:12 4: TRX_WEATHER: error device_name undefined
>>
>> 2012.11.23 22:18:23 5: TRX_Parse1 '08500ad86702005769'
>> 2012.11.23 22:18:23 5: TRX_0 dispatch 08500ad86702005769
>> 2012.11.23 22:18:23 5: TRX_WEATHER: decoding delay=71 hex=08500ad86702005769
>> 2012.11.23 22:18:23 1: RFX_WEATHER: common_temp error undefined subtype=0a
>> 2012.11.23 22:18:23 4: TRX_WEATHER: error device_name undefined
>>
>>
>
Hier melden sich zwei TFA 30.3133-Sensoren, einer mit ID 0xd767 und einer
mit ID 0xd867.
Da das lowbyte der Sensoren gleich ist (67), musst Du um beide erkennen zu
können longids verwenden:

attr RFXCOMUSB longids TFA_303133

Wobei statt RFXCOMUSB hier der Name Deines RFXtrx443-Devicenamen ist.

 

> Wie kann ich den Sensor in FHEM einbinden?
> Kann mir dabei jemand behilflich sein?
>
> Mein Setup:
> Raspberry Pi mit RFXTRX433 und aktueller Development FHEM Version.
>
>
Gemäß fhem.pl hast Du eine alte FHEM-Version:
"2012.11.21 23:58:50 0: Server started (version Fhem 5.3 (DEVELOPMENT),
$Id: fhem.pl 1996 2012-10-20 07:11:56Z rudolfkoenig $, pid 1269)
"
also vom 20.10.2012.

Die TFX-Sensoren habe ich am 7.11.2012 hinzugefügt. Du brauchst also eine
FHEM-Version mit mindestens diesem diesem Datum.

Sagt mir bitte mal den Inhalt der ID-Zeile in 46_TRY_WEATHER. Diese sieht
beispielsweise wie folgt aus:
"
# $Id: 46_TRX_WEATHER.pm 2127 2012-11-16 20:11:15Z wherzig $
"
 
Mach ein update.

Danke, Markus
>
> P.S.: Hat irgendjemand sonst noch X10 MS13E Bewegungsmelder im Einsatz?
>  
>

Marmitek-X10-Sensoren habe ich nicht im Einsatz. Die waren mir zu teuer.

Ich habe aber zwei EAGLE EYE MS14A im Einsatz, die ich auf 433 Mhz umgebaut
habe.
(Siehe: http://www.domotica.famschenk.eu/MS14A_OP_433.92.html Google-Translate
hilft ;-) )

Gemäß meinem Verständnis müssten meine MS14A nach dem Umbau funktionell
baugleich mit dem Marmitek MS13E sein. Sehen auch genauso aus ;-)

Warum fragst Du?

Grüße

Willi

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Guest

  • Gast
Re: Temperatursensor TFA 33.3133
« Antwort #2 am: 24 November 2012, 15:18:09 »
Originally posted by: <email address deleted>

Hallo Willi

>
> Das ist ein La Crosse TX3-Sensor, der erkannt wurde. Ich vermute mal, dass
> dies ein Sensor Deines Nachbarn ist.
> Wenn Du den empfangen willst: Freuen und dem Nachbarn danken.
>


Da ich bisher immer nur abends getestet hatte und mein Sensor im
Kühlschrank hängt, hab ich das wohl verwechselt.
Scheint aber irgendwo draussen in der Sonne zu hängen


Hier melden sich zwei TFA 30.3133-Sensoren, einer mit ID 0xd767 und einer
> mit ID 0xd867.
>

Gibt es weitergehende Informationen wie man sowas entschlüsselt?
Gibt es eigentlich auch die Möglichkeit, eine Art RAW Mitschnitt vom RFXTRX
zu bekommen, d.h. auch nicht unterstützte Geräte?
 

> Da das lowbyte der Sensoren gleich ist (67), musst Du um beide erkennen zu
> können longids verwenden:
> attr RFXCOMUSB longids TFA_303133
> Wobei statt RFXCOMUSB hier der Name Deines RFXtrx443-Devicenamen ist.
>

Ich hab das mal gemacht obwohl es anscheinend nicht mehr nötig war (s.u.)
 

> Gemäß fhem.pl hast Du eine alte FHEM-Version:
> "2012.11.21 23:58:50 0: Server started (version Fhem 5.3 (DEVELOPMENT),
> $Id: fhem.pl 1996 2012-10-20 07:11:56Z rudolfkoenig $, pid 1269)"
> also vom 20.10.2012.
>
> Die TFX-Sensoren habe ich am 7.11.2012 hinzugefügt. Du brauchst also eine
> FHEM-Version mit mindestens diesem diesem Datum.
> Sagt mir bitte mal den Inhalt der ID-Zeile in 46_TRY_WEATHER. Diese sieht
> beispielsweise wie folgt aus:
> "# $Id: 46_TRX_WEATHER.pm 2127 2012-11-16 20:11:15Z wherzig $"
>

Das Update hatte ich am Mittwoch gemacht - sehr seltsam...

2012.11.23 00:06:01 5: update remote controls_fhem.txt: UPD 2012-11-17_07:45:14 30164 FHEM/46_TRX_WEATHER.pm

 Trotzdem tat sich noch nichts - komisch...
 

> Mach ein update.
>

Das war's dann letztendlich was endlich mal geholfen hat :)
Danke!
 

>
>> P.S.: Hat irgendjemand sonst noch X10 MS13E Bewegungsmelder im Einsatz?
>>  
>>
>
> Marmitek-X10-Sensoren habe ich nicht im Einsatz. Die waren mir zu teuer.
>
> Ich habe aber zwei EAGLE EYE MS14A im Einsatz, die ich auf 433 Mhz
> umgebaut habe.
> (Siehe: http://www.domotica.famschenk.eu/MS14A_OP_433.92.html Google-Translate
> hilft ;-) )
>

Die Seite kenne ich, billiger als 30 Euro bekomme ich die US Version incl.
Versand/Zoll und Umbau aber irgendwie auch nicht...
Kennst du eine günstigere Bezugsquelle?
Ich hatte noch einen UK Versand gefunden der aber nur auf der Insel liefert
(deshalb keinen Link mehr)
 

Gemäß meinem Verständnis müssten meine MS14A nach dem Umbau funktionell
> baugleich mit dem Marmitek MS13E sein. Sehen auch genauso aus ;-)
>
 

> Warum fragst Du?
>

Ich hab mir mal einen zum Testen geholt, werde damit wohl demnächst mal die
Wohnung aufrüsten.
Mein System ist noch im Aufbau, ich hab das Gefühl dass ich hier noch öfter
schreiben werde...

Demnächst sind die Jalousien dran, dafür werde ich mir aber wohl einen CUL
holen müssen, da in der 433MHz Welt etwas wie der FS20 SM8 fehlt.
Die Heizkörper sollen folgen, ich möchte aber ein System mit vollwertigen
Thermostatköpfen die ich manuell übersteuern kann.
Mal sehen wie sich die direkte Ansteuerung der MAX! Teile bis dahin
entwickelt.

Viele Grüße,
Markus

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com