Autor Thema: Fehlerhafte CC1101 Module  (Gelesen 40767 mal)

Offline tndx

  • Sr. Member
  • ****
  • Beiträge: 603
Antw:Fehlerhafte CC1101 Module
« Antwort #90 am: 18 Dezember 2018, 21:22:09 »
Guten Abend,

Gestern kam eine neue Lieferung von TENSTAR bei mir an.
Hab ein Modul fix ausgepackt und getestet - Anlernen klappte auf Anhieb.

Hier mal meine Aufzeichnungen bzgl. der Sendefrequenzen verschiedener Module:
ModulTX Freq. MHZ
CC1101 neueste Lieferung (i.O.)868.21
CC1101 ältere Lieferung (i.O.)868.26
Original eQ-3 TRX868.24
HM-MOD-UART868.25

Das CC1101 aus der neuen Lieferung liegt ca. 30-40kHz neben der Frequenz, auf der das originale HomeMatic Zeugs funkt.
Bei 300kHz Bandbreite liegt es noch im Bereich von "funktioniert".

wie bestimmt Ihr die exakte Sendefrequenz? Pi mal Daumen die Mitte des Signal-"Streifens", oder gibt es eine exaktere Methode?

Mitschnitt meiner Tenstar-Module s. Anhang, so arg verschoben scheint es ja nicht zu sein, oder? Meine Analyse ergab ja, dass HM-MOD-RPI-PCB (FHEM/piVCCU) durchaus in der Lage sind, die Module zu empfangen, aber die wiederum beantworten nicht deren Anfragen.

Offline noansi

  • Sr. Member
  • ****
  • Beiträge: 971
Antw:Fehlerhafte CC1101 Module
« Antwort #91 am: 19 Dezember 2018, 01:08:22 »
Hallo tndx,

nur der Vergleich mit HM-devices macht wirklich Sinn.

angehängt mal ein getConfig Beispiel.
Zuerst sendet mein CUL, dann das Device, usw. .

Im Vergeich liegen die beiden etwa 5kHz auseinander.

Gengenüber meinem DVB-T Stick sendet CUL etwa 13kHz verschoben.

Und den DVB-T Stick habe ich gegen einen gut zu empfangenen DVB-T Sender mit hoher Frequenz anhand seiner recht scharfen Bandkanten "abgeglichen". Nachdem ich den gut habe warm laufen lassen.
Und da endet auch meine Genauigkeitsinformation bei +/-?.

Gruß, Ansgar.
« Letzte Änderung: 19 Dezember 2018, 01:11:37 von noansi »

Offline plombe

  • New Member
  • *
  • Beiträge: 24
Antw:Fehlerhafte CC1101 Module
« Antwort #92 am: 19 Dezember 2018, 21:02:21 »
Zitat
author=Klaus0815 link=topic=91740.msg873357#msg873357 date=1545122497]
Hast Du beim NanoCul auch die Frequenz verändert, oder alles auf Standart gelassen? Wäre hilfreich um den Fehler weiter einzugrenzen

nanoCUL Version: culfw-1.67
in clib/rf_asksin.c die Adresse geändert:  0x65 -> 0x66, 0x6A -> 0x75
in der Konsole eingeben:
X21
Ar

                                       
Alle Telegramme werden einwandfrei empfangen.
Befehl zum Ein/Ausschalten einer Leuchte:

As0EF4A011F100135523110201C80000
As0EF4A011F100135523110201000000

Das funktioniert bei allen 10 Modulen.
Ich habe soeben hm_cc_rt_dn_update mit solch einem nanoCUL erfolgreich durchgeführt.

AskSin++ V3.0.2
Die CC1101_Register nach dem Init mehrfach ausgelesen und verglichen - alles in Ordnung.
Nur wenige Telegramme werden richtig empfangen.


« Letzte Änderung: 19 Dezember 2018, 21:15:46 von plombe »

Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #93 am: 20 Dezember 2018, 11:40:16 »
@plombe: Bedeutet dies, dass ich einfach die Änderung wie von dir beschrieben in "rf_asksin.c" vornehme und dann die Firmware kompiliere und es sollte damit laufen?

Dann probiert ich das gleich morgen mal aus.  8)
Ist es evtl. möglich die nanoCUL-FW so umzuschreiben, dass man die abweichenden Werte direkt in FHEM per "set" korrigieren kann?
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy

Offline plombe

  • New Member
  • *
  • Beiträge: 24
Antw:Fehlerhafte CC1101 Module
« Antwort #94 am: 20 Dezember 2018, 13:51:22 »
@thgorjup

Das gilt nur für die Verwendung des nanoCUL für HomeMatic.
Für andere Anwendungen kann man die Adressänderungen von FHEM aus vornehmen.
Schon einige Wochen läuft ein SIGNALDuino mit solch einem Modul problemlos.

H-G


Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #95 am: 20 Dezember 2018, 14:00:01 »
Ja, für mich ist es auch nur für Homematic wichtig. Danke für deine Antwort.
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy

Offline plombe

  • New Member
  • *
  • Beiträge: 24
Antw:Fehlerhafte CC1101 Module
« Antwort #96 am: 20 Dezember 2018, 19:03:53 »
So, richtige Frequenz gefunden!

CC1101_FREQ2 0x21
CC1101_FREQ1 0x66
CC1101_FREQ0 0x5F

Damit funktionieren alle Module.
Ich habe in der Hex Datei die Frequenz in Schritten verringert, ausgehend von der im SDR gemessenen. Dann die Software geflasht. So ging es schneller.
Ob das bei euren Modulen die gleiche Frequenz ist?

H-G

Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #97 am: 20 Dezember 2018, 22:23:09 »
CC1101_FREQ2 0x21
CC1101_FREQ1 0x66
CC1101_FREQ0 0x5F

@plombe: Wo ist denn das in der rf_asksin.c zu ändern?
Die Änderung 0x65 -> 0x66, 0x6A -> 0x75 bewirkt bei mir, dass nichts mehr geht.
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy

Offline plombe

  • New Member
  • *
  • Beiträge: 24
Antw:Fehlerhafte CC1101 Module
« Antwort #98 am: 20 Dezember 2018, 22:31:26 »
const uint8_t PROGMEM ASKSIN_CFG[] = {
     0x00, 0x07,
     0x02, 0x2e,
     0x03, 0x0d,
     0x04, 0xE9,
     0x05, 0xCA,
     0x07, 0x0C,
     0x0B, 0x06,
     0x0D, 0x21,
     0x0E, 0x66, //0x65,
     0x0F, 0x75, //0x6A,
     0x10, 0xC8,
     0x11, 0x93,
     0x12, 0x03,
     0x15, 0x34,
     0x17, 0x33, // go into RX after TX, CCA; EQ3 uses 0x03
     0x18, 0x18,
     0x19, 0x16,
     0x1B, 0x43,
     0x21, 0x56,
     0x25, 0x00,
     0x26, 0x11,
     0x29, 0x59,
     0x2c, 0x81,
     0x2D, 0x35,
     0x3e, 0xc3
};

Offline Klaus0815

  • Sr. Member
  • ****
  • Beiträge: 581
Antw:Fehlerhafte CC1101 Module
« Antwort #99 am: 20 Dezember 2018, 22:34:54 »
So, richtige Frequenz gefunden!

CC1101_FREQ2 0x21
CC1101_FREQ1 0x66
CC1101_FREQ0 0x5F

Damit funktionieren alle Module.
Ich habe in der Hex Datei die Frequenz in Schritten verringert, ausgehend von der im SDR gemessenen. Dann die Software geflasht. So ging es schneller.
Ob das bei euren Modulen die gleiche Frequenz ist?

H-G

Ich verstehe es zugegeben noch nicht wirklich
Funktionieren die fehlerhaften CC1101-Module mit dem NanoCul ohne jegliche Änderung? Oder muss auch dort an der Frequenz etwas angepasst werden?

Wir sollten versuchen, einzugrenzen ob es definitiv ein Hardware-Problem ist, oder ob vielleicht doch etwas an den AskSin-Libraries nicht passt


Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #100 am: 20 Dezember 2018, 22:46:35 »
Also ich habe gerade nochmal getestet. Mit dieser Einstellung in der rf_asksin.c  bewegt sich mein HM_Rolladen rein garnicht.
Ohne Änderung (Original HEX File) kann ich senden aber nicht empfangen. Die Änderung von plombe passt wohl nicht zu meinem Modul.

Hab heute meinen DVBT-Stick bekommen aber muss jetzt erstmal rausfinden wie ich die Messung mache.
Gibt es irgendwo ein Toturial für HDSDR mit dem DVB-T Stick? Oder kann hier jemand ein Quick-ToDo posten?
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy

Offline plombe

  • New Member
  • *
  • Beiträge: 24
Antw:Fehlerhafte CC1101 Module
« Antwort #101 am: 20 Dezember 2018, 22:50:34 »
@ thgorjup

Kannst Du den Wert von 0x75 mal auf 0x5F ändern?


Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #102 am: 20 Dezember 2018, 22:56:55 »
Geht leider auch nicht.  :-\
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy

Offline Klaus0815

  • Sr. Member
  • ****
  • Beiträge: 581
Antw:Fehlerhafte CC1101 Module
« Antwort #103 am: 20 Dezember 2018, 22:59:36 »

Gibt es irgendwo ein Toturial für HDSDR mit dem DVB-T Stick? Oder kann hier jemand ein Quick-ToDo posten?

https://homematic-forum.de/forum/viewtopic.php?t=11087&start=24

Offline thgorjup

  • Full Member
  • ***
  • Beiträge: 354
Antw:Fehlerhafte CC1101 Module
« Antwort #104 am: 20 Dezember 2018, 23:31:22 »
Hmm, dasToturial ist unvollständig. Es fehlen Dateien.
Ich habe das hier gefunden und so durchgeführt: http://hdsdr.de/RTLSDR_with_HDSDR.pdf
Jetzt läuft HDSDR mit dem Stick aber was muss ich wo einstellen?
FHEM auf Ubuntu 18.04LTS, 2x nanoCUL, JeeLink, nanoPIR, MQTT, ESP-Easy, HUE.
Sensoren+Aktoren: HM, IT, Lacrosse, Multitrade-PIR, VU+, Somfy