Autor Thema: Fehlerhafte CC1101 Module  (Gelesen 40755 mal)

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 4179
Antw:Fehlerhafte CC1101 Module
« Antwort #195 am: 04 Juni 2019, 20:47:29 »
Ich habe solche Pins bereits zuhause und auch einen Adapter gerade gedruckt. Leider ist es relativ schwierig genau 1mm große Löcher zu drucken.
0,5 drucken und aufbohren?

Gesendet von meinem Doogee S60 mit Tapatalk


Offline gloob

  • Hero Member
  • *****
  • Beiträge: 3129
Antw:Fehlerhafte CC1101 Module
« Antwort #196 am: 04 Juni 2019, 20:52:30 »
Hab keinen 1mm Bohrer :)
Ich probiere mal mit Einkleben.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline frank

  • Hero Member
  • *****
  • Beiträge: 9266
Antw:Fehlerhafte CC1101 Module
« Antwort #197 am: 04 Juni 2019, 21:01:06 »
statt aufbohren heiss einpressen.
FHEM: 6.0(SVN) => Pi3(stretch)
IO: CUL433|CUL868|HMLAN|HMUSB2|HMUART
CUL_HM: CC-TC|CC-VD|SEC-SD|SEC-SC|SEC-RHS|Sw1PBU-FM|Sw1-FM|Dim1TPBU-FM|Dim1T-FM|ES-PMSw1-Pl
IT: ITZ500|ITT1500|ITR1500|GRR3500
WebUI [hm.js]: https://forum.fhem.de/index.php/topic,106959.0.html
Informativ Informativ x 1 Liste anzeigen

Online Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 4179
Antw:Fehlerhafte CC1101 Module
« Antwort #198 am: 04 Juni 2019, 21:30:38 »
Hab keinen 1mm Bohrer :)
Ich probiere mal mit Einkleben.
Soll ich dir einen schicken? [emoji6]

Gesendet von meinem Doogee S60 mit Tapatalk


Offline gloob

  • Hero Member
  • *****
  • Beiträge: 3129
Antw:Fehlerhafte CC1101 Module
« Antwort #199 am: 04 Juni 2019, 21:31:50 »
Soll ich dir einen schicken? [emoji6]

Gesendet von meinem Doogee S60 mit Tapatalk

Kein Stress. Ich guck erstmal wie die Klebeversion hält. Spricht ja auch nicht gerade fürs Design im Moment.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline Tom Major

  • Sr. Member
  • ****
  • Beiträge: 565
    • TomMajor@github
Antw:Fehlerhafte CC1101 Module
« Antwort #200 am: 04 Juni 2019, 23:27:43 »
einfach nach pogo pins suchen.
https://de.aliexpress.com/wholesale?catId=0&initiative_id=AS_20190604100146&SearchText=test+probes+pogo+pins

Die Idee, sowas zu verwenden finde ich super!

lg,
Sabine

Danke für den link, sehen gut aus, werde mal welche bestellen, auch wenn der Frühling bald vorbei ist  ;)
Früher: FHEM 5.x
Jetzt: RaspberryMatic / ioBroker

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1791
    • Homepage
Antw:Fehlerhafte CC1101 Module
« Antwort #201 am: 05 Juni 2019, 09:11:04 »
Möchte eigentlich jemand eine Hand voll Stamps mit dem "868MHz"-Aufdruck (ohne Leerzeichen) geschenkt haben ?
FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!

Offline gloob

  • Hero Member
  • *****
  • Beiträge: 3129
Antw:Fehlerhafte CC1101 Module
« Antwort #202 am: 05 Juni 2019, 09:13:30 »
Möchte eigentlich jemand eine Hand voll Stamps mit dem "868MHz"-Aufdruck (ohne Leerzeichen) geschenkt haben ?

Bevor du sie weg wirfst würde ich mich mal dran versuchen.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline papa

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1852
Antw:Fehlerhafte CC1101 Module
« Antwort #203 am: 05 Juni 2019, 09:54:20 »
Möchte eigentlich jemand eine Hand voll Stamps mit dem "868MHz"-Aufdruck (ohne Leerzeichen) geschenkt haben ?
Nehme ich - habe noch Quarze da. Schicke auch gern die Hälfte zurück, wenn sie ordentlich funktionieren.
BananaPi + CUL868 + CUL433 + HM-UART + 1Wire

Offline CatWeazle

  • Full Member
  • ***
  • Beiträge: 266
Antw:Fehlerhafte CC1101 Module
« Antwort #204 am: 10 Juni 2019, 20:17:12 »
Hi Leutz,

ich habe hier gelesen, dass man die seltsamen Module mit dem FreqTest.ino Sketch testen kann.

Okay, ich habe einen fertig aufgebauten HB-UNI-SENS-BATT mit einem Pro-Mini 3V 8Mhz und einem dieser Module, die die Widerstände unter dem Chip Quer angeordnet haben.

In diesen ProMini habe ich den FreqTest.ino Sketch geladen.
So sollte es sein ... ... oder?

Dann sehe ich in dem Beitrag von papa:
Zitat
AskSin++ V3.1.7 (Jan 29 2019 21:23:22)
CC init1
CC Version: 14
 - ready
Start searching ...
Freq 0x21656A:   0/0
Freq 0x2165BA:   0/0
Freq 0x21651A:   0/0
Freq 0x21660A: 996699.  1/88
Search for upper bound
Freq 0x21661A: 996699.  1/88
 
usw.


Wie liest man diese Daten?
Über die serielle Schnittstelle des ProMini kommen keine vernünftigen Daten, egal wie schnell ich sie einstelle ?!?!?
 
Wat nu ?



EDIT 20:41!

okay, mein Fehler, die Einstellung in der Aruino IDE war falsch, ProMini 5V :(
Aber was soll ich sagen, kaum macht man es richtig, schon funktioniert es bei 57600 Baud
Die Frequenz des Moduls wurde auch angepasst und schon in FHEM eingebunden :)
« Letzte Änderung: 10 Juni 2019, 20:40:49 von CatWeazle »
Grüße, Mike

*****************************************
********  Wird Zeit für besser Wetter !  ********
*****************************************

Offline DirkS

  • New Member
  • *
  • Beiträge: 34
Antw:Fehlerhafte CC1101 Module
« Antwort #205 am: 13 Juni 2019, 08:02:20 »
Leider muss ich wohl auch solche fehlerhaften Module erwischt haben. Der erste Versuch ein HM-WDS40-TH-I-BME280 nach zubauen schlug fehl. Ich hatte dann noch ein älteres CC1101 in der Schublade gefunden, welches mal für ein CUL gedacht war. Dies wurde dann zu einem HM-LC-Sw2-FM zusammen gebaut und funktioniert auf Anhieb. Da diese beiden aktuell meine einzigen Homematic Komponenten sind, habe ich also die beiden Module und die CCU2 nebeneinander gelegt und getestet. (Vielleicht auch ein Fehler?)
Ohne ActivePing und nur die CCU2 im Anlernmodus passiert beim HM-WDS40-TH-I-BME280, welches das Frequenz Sketch laufen hat, keine Ausgabe. Wenn ich dann über die CCU oder am HM-LC-Sw2-FM den Anlernknopf drücke empfängt das HM-WDS40-TH-I-BME280 ein paar Telegramme und stellt auch eine Frequenz ein. Wobei die hintere Zahl vom HM-LC-Sw2-FM immer größer ist, wie die von der CCU2. Wenn dann wieder das richtige Sketch geflasht wird scheint die CCU2 wohl manchmal den Anlernversuch zu erkennen, denn es erscheint im Log die Seriennummer aber dann wird vom HM-WDS40-TH-I-BME280 wohl die Bestätigung nicht korrekt gesendet oder die Antwort von der Basis nicht erkannt.
Ist die hintere Zahl der Ausgabe aus dem Frequenztest Skript die Signalstärke?
Kann ein falsch konfiguierter BME280 den Funkverkehr beeinflussen? Denn als Meßwerte kommen ~250C und 0% raus. Hatte mich aber darum noch nicht weiter gekümmert.
Logs liefere ich heute Abend noch nach. Musste nur mal meinen Frust loswerden. Hoffe es ist nicht zu konfus.
[Nachtrag]
Ich habe wohl meine Platine mit 5V gegrillt. Der USB/Serial Adaoter hat einen 3V/5V Schalter. Aber dies scheint wohl nur die Signalpegel zu betreffen. Als Vcc kommt immer 5V raus... :-(
« Letzte Änderung: 13 Juni 2019, 19:27:30 von DirkS »

Offline berniie

  • Jr. Member
  • **
  • Beiträge: 51
Antw:Fehlerhafte CC1101 Module
« Antwort #206 am: 20 Juni 2019, 17:43:24 »
Hallo,
ich bekomme folgende Werte mit dem Test Sketch.

Done: 0x2164EA - 0x2165DA
Calculated Freq: 0x216562
Store into config area: 6562

Gibt es eine Formel mit der man daraus berechnen kann, um wieviel khz mein C1101 daneben liegt?

Gruß,
Jörg

Offline Tom Major

  • Sr. Member
  • ****
  • Beiträge: 565
    • TomMajor@github
Antw:Fehlerhafte CC1101 Module
« Antwort #207 am: 20 Juni 2019, 18:08:43 »
hatte gerade heute dazu was in einem anderen thread gepostet:
https://forum.fhem.de/index.php/topic,101568.msg950636.html#msg950636

in deinem Fall sind das 868,2967 MHz, nur 3kHz Abweichung zum Originalwert 868.299866 MHz.
Früher: FHEM 5.x
Jetzt: RaspberryMatic / ioBroker

Offline berniie

  • Jr. Member
  • **
  • Beiträge: 51
Antw:Fehlerhafte CC1101 Module
« Antwort #208 am: 20 Juni 2019, 19:16:29 »
Danke für die Info. Hatte auch den Eindruck, dass meine im Februar bestellten Module ganz ok sind.

Offline Tom Major

  • Sr. Member
  • ****
  • Beiträge: 565
    • TomMajor@github
Antw:Fehlerhafte CC1101 Module
« Antwort #209 am: 16 Oktober 2019, 01:09:10 »
Bedeutet eigentlich bei der RSSI Ausgabe hinten z.B. die 76 hier
req 0x21655A 868.294 MHz: 583E8D.  1/76
ein hoher Wert eine bessere Empfangsstärke?

In radio.h wird das so berechnet:
        uint8_t rsshex = spi.readReg(CC1101_RXFIFO, CC1101_CONFIG);         // read RSSI
        rss = -1 * ((((int16_t)rsshex-((int16_t)rsshex >= 128 ? 256 : 0))/2)-74);

Habe Module die durchgängig 70..80 RSSI haben und andere die um die 50 liegen.
Frage mich ob die 50er irgendwie schlechter sind.
Früher: FHEM 5.x
Jetzt: RaspberryMatic / ioBroker

 

decade-submarginal