Autor Thema: War pah: Fast neue Perl Bibliothek für libusb  (Gelesen 296 mal)

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1257
War pah: Fast neue Perl Bibliothek für libusb
« am: 10 Oktober 2018, 13:28:16 »
Ich nehme mal Bezug auf den Beitrag in Ankündigungen, wo ja keine Antwort möglich ist.
https://forum.fhem.de/index.php/topic,86364.0.html

z.B. 38_CO20.pm benutzt libusb, allerdings über Device::USB (https://metacpan.org/pod/Device::USB). Eigentlich stabil und ziemlich vollständig, wurde aber 2017 auf DEPRECATED gesetzt, da der Maintainer die Pflege aufgegeben hat und sich wohl kein Nachfolger gefunden hat.
RPi3+ FHEM5.9,HM-MOD-RPI-PCB+HM-USB-CFG2+hmland
HomeMatic: diverse, HUE: diverse,
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FB7590 v7.10, Echo Dot, Logi Circle 2

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6589
Antw:War pah: Fast neue Perl Bibliothek für libusb
« Antwort #1 am: 12 Oktober 2018, 13:02:12 »
Tja. Ich habe im Moment auch mehr Baustellen, als ich vertragen kann.

Steht im Moment ziemlich weit unten auf der Prioliste.

LG

pah

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1257
Antw:War pah: Fast neue Perl Bibliothek für libusb
« Antwort #2 am: 12 Oktober 2018, 13:10:18 »
Solange durch neue Perl-Versionen keine Inkompatibilitäten entstehen, auch da unkritisch. Funktioniert ja. Erstes mögliches Problem ab V5.27 gemeldet.


Gesendet von iPhone mit Tapatalk
RPi3+ FHEM5.9,HM-MOD-RPI-PCB+HM-USB-CFG2+hmland
HomeMatic: diverse, HUE: diverse,
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FB7590 v7.10, Echo Dot, Logi Circle 2