Autor Thema: Fresh Install - Error!  (Gelesen 365 mal)

Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Fresh Install - Error!
« am: 14 Oktober 2018, 02:08:06 »
Hi,

ich habe ein debian stretch auf einem raspberry installiert, dann apt-get update && apt-get dist-upgrade, dann
apt-get install libdevice-serialport-perl libwww-perl libio-socket-ssl-perl libcgi-pm-perl libjson-perl sqlite3 libdbd-sqlite3-perl libtext-diff-perl
dann
 wget http://fhem.de/fhem-5.9.deb
dann dpkg -i fhem-5.9.deb
dann webgui aufrufen
und dann kriege ich folgenden fehler:

fhem line 1:
Uncaught SyntaxError: Invalid or unexpected token

Fresh Install - nicht irgendwas eingerichtet. Was mache ich falsch?

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3915
  • NIVEAu ist keine Creme...
Antw:Fresh Install - Error!
« Antwort #1 am: 14 Oktober 2018, 10:16:17 »
Warum nicht den "simplen weg"!?

Hab ich gestern problemlos durchgeführt (musste, die SD vom PI war/ist wohl hinüber)

Edit: allerdings habe ich "nur" upgrade und nicht distupgrade durchgeführt...

EDIT2: und bevor ich dann weiteres installiere gehe ich erdt mal ins raspy-config und stelle ein was ich so will/brauche: Ländereinstellungen, timezone, expand, memory-aufteilung, ...

Gruß, Joachim
« Letzte Änderung: 14 Oktober 2018, 10:19:42 von MadMax-FHEM »
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Antw:Fresh Install - Error!
« Antwort #2 am: 14 Oktober 2018, 21:18:32 »
Auch mit dem simplen weg - gleiches ergebnis. Auch den pi nochmal neu installiert. In einer vm mit debian probiert, gleiches ergebnis.
Wenn ich das logfile anzeige bekomme ich das...

FileLog_logWrapper?dev=Logfile&type=text&file=fhem-2018-10.log line 1:
Uncaught SyntaxError: Invalid or unexpected token


Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 3915
  • NIVEAu ist keine Creme...
Antw:Fresh Install - Error!
« Antwort #3 am: 14 Oktober 2018, 21:57:59 »
Mit PI auf einem Raspbian Stretch lite!?

Nur "upgrade" und dann den "simplen Weg"!?

Wie geschrieben ging gestern bei mir problemlos...

Daher zur Fehlermeldung leider keine Idee...

Wenn aber in einer VM ähnliches/gleiches Problem, dann ist eine defekte SD Karte (wäre eine Idee bei nur PI-Installation gewesen) auch kein Grund.

Gruß, Joachim
FHEM 5.8 PI3: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 3x EnOcean, DashButtons, CO2, ESP-Multisensor, FireTV, NanoLeaf, ...
FHEM 5.8 PI2: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM 5.8 PI3 (Test): HM-MOD-PCB, Alexa (alexa-fhem), Google Home

Offline amenomade

  • Hero Member
  • *****
  • Beiträge: 2579
Antw:Fresh Install - Error!
« Antwort #4 am: 15 Oktober 2018, 12:17:13 »
Was sagen perl -v und instmodsh mit command l ?
FHEM 5.8 Pi 3, EchoDot, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, und HM Komponenten

F:"Schatz? Mach aus bitte"
M: "Alexa? Licht aus"-"Ich bin mir leider nicht sicher"  M:"Alexa? aus Licht"-"Das weiss ich leider nicht" M:"Alexa? Schalte...
F: "Drück mal auf den blöden Knopf!

Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Antw:Fresh Install - Error!
« Antwort #5 am: 15 Oktober 2018, 22:40:33 »
Perl -V

root@fhem:~# perl -v

This is perl 5, version 24, subversion 1 (v5.24.1) built for arm-linux-gnueabihf-thread-multi-64int
(with 81 registered patches, see perl -V for more detail)

Copyright 1987-2017, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.


instmodsh

root@fhem:~# instmodsh
Available commands are:
   l            - List all installed modules
   m <module>   - Select a module
   q            - Quit the program
cmd? l
Installed modules are:
   Perl
cmd? q

Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Antw:Fresh Install - Error!
« Antwort #6 am: 15 Oktober 2018, 22:41:28 »
Mit PI auf einem Raspbian Stretch lite!?

Nur "upgrade" und dann den "simplen Weg"!?

Wie geschrieben ging gestern bei mir problemlos...

Daher zur Fehlermeldung leider keine Idee...

Wenn aber in einer VM ähnliches/gleiches Problem, dann ist eine defekte SD Karte (wäre eine Idee bei nur PI-Installation gewesen) auch kein Grund.

Gruß, Joachim

Jupp - stretch lite, easy setup "The easy way: Use apt-get to install FHEM and all dependencies"


Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Antw:Fresh Install - Error!
« Antwort #7 am: 15 Oktober 2018, 22:54:33 »
Ich habe immer nur mit chrome probiert, mit dem IE taucht der Fehler nicht auf

Offline dirk@laurenz.ws

  • New Member
  • *
  • Beiträge: 6
Antw:Fresh Install - Error!
« Antwort #8 am: 16 Oktober 2018, 10:53:15 »
Ich habe immer nur mit chrome probiert, mit dem IE taucht der Fehler nicht auf

Chromeversion: Google Chrome ist auf dem neuesten Stand.
Version 69.0.3497.100 (Offizieller Build) (64-Bit)

 

decade-submarginal