Autor Thema: HCS Fehlermeldung  (Gelesen 649 mal)

Offline The-Holgi

  • Sr. Member
  • ****
  • Beiträge: 583
HCS Fehlermeldung
« am: 02 November 2018, 11:35:38 »
Hallo, (jetzt nochmal im richtigen Forum)
seit dem ich gestern ein update gemacht habe taucht folgender Fehler im log auf:
PERL WARNING: Argument "n/a" isn't numeric in subtraction (-) at ./FHEM/59_HCS.pm line 646.
stacktrace:
2018.11.01 20:34:57 1:     main::__ANON__                      called by ./FHEM/59_HCS.pm (646)
2018.11.01 20:34:57 1:     main::HCS_getValues                 called by ./FHEM/59_HCS.pm (190)
2018.11.01 20:34:57 1:     main::HCS_DoInit                    called by ./FHEM/59_HCS.pm (154)
2018.11.01 20:34:57 1:     main::HCS_Notify                    called by fhem.pl (3599)
2018.11.01 20:34:57 1:     main::CallFn                        called by fhem.pl (3519)
2018.11.01 20:34:57 1:     main::DoTrigger                     called by fhem.pl (631)

Was kann ich tun?
Gruß Holger
HP T610 Thin Client; Docker Fhem 5.9; 2X CUL V3 868mhz; Max Heizungssteuerung; FS20kse; FS20UWS; FS20S8-3; 2 FS20DI; HM-CFG-LAN,HM-LC-SW1-PL,HM-SEC-SD, HM-SE1PBU-FM;
Harmony Hub;Hue-Bridge mit Iris, E27 Bulb & FLS-PP

Offline bernd_zwo

  • New Member
  • *
  • Beiträge: 14
Antw:HCS Fehlermeldung
« Antwort #1 am: 06 November 2018, 22:57:03 »
Hallo Holger,
kannst Du mal schauen, welche Version vom HCS bei Dir läuft und eine Ausgabe von list <DeinHCSDevice> posten?

Gruß,
Bernd
Meine Installation: fhem 5.8, Raspi 2 / Raspbian, Busware CUL 868, HM-MOD-UART, HM-CFG-USB-2 (aCulfw V 1.26.04 a-culfw Build: 306), JeeLink V3, fht8v, TX29DTH-IT, HM- (diverse)

Offline The-Holgi

  • Sr. Member
  • ****
  • Beiträge: 583
Antw:HCS Fehlermeldung
« Antwort #2 am: 12 November 2018, 04:03:50 »
Hallo Bernd,
mittlerweile tritt der Fehler nicht mehr auf.
Autocreate hat wohl ein HT vom Nachbarn angelegt, welches natürlich nicht gepairt war.
Das muß dann zu dem Fehler geführt haben, nach löschen des „fremden“ Ht‘s war der Fehler weg.
War wohl Zufall, das mir das genau nach einem update aufgefallen ist.
Die Version von HCS sollte die aktuelle sein.
Hier trotzdem noch das list:
Internals:
   CHANGED   
   DEF        Therme
   DEVICE     Therme
   NAME       HCS_System
   NEXTCHECK  04:02:51
   NOTIFYDEV  global
   NR         223
   NTFY_ORDER 50-HCS_System
   STATE      idle
   TYPE       HCS
   READINGS:
     2015-01-30 11:22:50   0adecd          ignored
     2018-11-02 12:51:09   MAX_08320b      idle
     2018-11-12 03:57:51   bd_Thermostat   idle
     2018-11-11 22:07:50   devicestate     off
     2018-11-12 03:57:51   eco             off
     2018-11-12 03:57:51   fl_Thermostat   idle
     2018-11-12 03:57:51   ki_Thermostat   excluded
     2018-11-12 03:57:51   ku_Thermostat   idle
     2018-11-12 03:57:51   locked          00:00:00
     2018-11-12 03:57:51   overdrive       off
     2018-11-12 03:57:51   sensor          11.0
     2018-11-12 03:57:51   state           idle
     2018-11-12 03:57:51   sz_heizung      excluded
     2018-11-12 03:57:51   wz_Thermostat   idle
   helper:
     lastSentDeviceCmdOn 1541935968
     device:
       bd_Thermostat:
         actuator   0
         demand     0
         excluded   0
         ignored    0
         tempDesired 16.0
         tempMeasured 21.8
         type       MAX
       fl_Thermostat:
         actuator   0
         demand     0
         excluded   0
         ignored    0
         tempDesired 10.0
         tempMeasured 18.5
         type       MAX
       ki_Thermostat:
         actuator   0
         demand     0
         excluded   1
         ignored    0
         tempDesired 12.0
         tempMeasured 20.8
         type       MAX
       ku_Thermostat:
         actuator   0
         demand     0
         excluded   0
         ignored    0
         tempDesired 16.0
         tempMeasured 21.8
         type       MAX
       sz_heizung:
         actuator   0
         demand     0
         excluded   1
         ignored    0
         tempDesired 12.0
         tempMeasured 17.2
         type       MAX
       wz_Thermostat:
         actuator   0
         demand     0
         excluded   0
         ignored    0
         tempDesired 16.0
         tempMeasured 21.8
         type       MAX
Attributes:
   deviceCmdOff off
   deviceCmdOn on
   event-on-change-reading state,devicestate,eco,overdrive
   exclude    sz_heizung, ki_Thermostat
   fm_type    state
   idleperiod 10
   interval   5
   mode       valve
   room       Heizung
   sensor     Aussen_Sensor
   sensorReading temperature
   sensorThresholdOff 18
   sensorThresholdOn -1
   thermostatThresholdOff 0.5
   thermostatThresholdOn 0.5
   valveThresholdOff 10
   valveThresholdOn 40
   verbose    2

Gruß Holger
HP T610 Thin Client; Docker Fhem 5.9; 2X CUL V3 868mhz; Max Heizungssteuerung; FS20kse; FS20UWS; FS20S8-3; 2 FS20DI; HM-CFG-LAN,HM-LC-SW1-PL,HM-SEC-SD, HM-SE1PBU-FM;
Harmony Hub;Hue-Bridge mit Iris, E27 Bulb & FLS-PP

Offline bernd_zwo

  • New Member
  • *
  • Beiträge: 14
Antw:HCS Fehlermeldung
« Antwort #3 am: 20 November 2018, 00:08:27 »
Hallo zusammen,

ich habe in Abstimmung mit dem Maintainer das Logging, das wahrscheinlich zu dem o.a. Fehler führte, angepasst.
Zusätzlich werden jetzt noch PID20-Regler vom HCS berücksichtigt.

Gruß, Bernd
Meine Installation: fhem 5.8, Raspi 2 / Raspbian, Busware CUL 868, HM-MOD-UART, HM-CFG-USB-2 (aCulfw V 1.26.04 a-culfw Build: 306), JeeLink V3, fht8v, TX29DTH-IT, HM- (diverse)

Offline nebukadnezza

  • New Member
  • *
  • Beiträge: 13
Antw:HCS Fehlermeldung
« Antwort #4 am: 29 November 2018, 22:21:36 »
Hallo,

kann es sein, dass beim Anpassen etwas mit dem Logging schief gegangen ist?

Habe folgende Einträge im fhem log:
Zitat
2018.11.29 22:16:40 3: HCS kg.k2.cc.hcs Found 12 Device(s): 0 FHT, 12 HM-CC-TC, 0 MAX, 0 ZWave, demand: 0, idle: 0, ignored: 6, excluded: 0, unknown: 6, eco: no overdrive: no

Allerdings sollten es 6 idle und 6 excluded sein. Scheint, als wären die Werte um eine "Spalte" verrutscht.

list kg.k2.cc.hcs liefert das korrekt, nur das log scheint nicht zu passen.

Danke!

Offline The-Holgi

  • Sr. Member
  • ****
  • Beiträge: 583
Antw:HCS Fehlermeldung
« Antwort #5 am: 02 Dezember 2018, 15:47:21 »
Hallo,
bei mir taucht nun nach einem shutdown restart folgende Meldung im log auf:
PERL WARNING: Redundant argument in sprintf at ./FHEM/59_HCS.pm line 725Jemand eine Idee dazu?

Gruß Holger
HP T610 Thin Client; Docker Fhem 5.9; 2X CUL V3 868mhz; Max Heizungssteuerung; FS20kse; FS20UWS; FS20S8-3; 2 FS20DI; HM-CFG-LAN,HM-LC-SW1-PL,HM-SEC-SD, HM-SE1PBU-FM;
Harmony Hub;Hue-Bridge mit Iris, E27 Bulb & FLS-PP

Offline bernd_zwo

  • New Member
  • *
  • Beiträge: 14
Antw:HCS Fehlermeldung
« Antwort #6 am: 04 Dezember 2018, 17:33:52 »
Da hatte ich noch eine Stelle übersehen, ich habe eine neue Version eingecheckt: 17894
Die Reihenfolge im Log passt jetzt auch wieder.

Gruß, Bernd
« Letzte Änderung: 04 Dezember 2018, 21:31:19 von bernd_zwo »
Meine Installation: fhem 5.8, Raspi 2 / Raspbian, Busware CUL 868, HM-MOD-UART, HM-CFG-USB-2 (aCulfw V 1.26.04 a-culfw Build: 306), JeeLink V3, fht8v, TX29DTH-IT, HM- (diverse)

Offline The-Holgi

  • Sr. Member
  • ****
  • Beiträge: 583
Antw:HCS Fehlermeldung
« Antwort #7 am: 05 Dezember 2018, 08:38:08 »
Besten Dank,
die Meldung taucht nicht mehr auf.

Gruß Holger
HP T610 Thin Client; Docker Fhem 5.9; 2X CUL V3 868mhz; Max Heizungssteuerung; FS20kse; FS20UWS; FS20S8-3; 2 FS20DI; HM-CFG-LAN,HM-LC-SW1-PL,HM-SEC-SD, HM-SE1PBU-FM;
Harmony Hub;Hue-Bridge mit Iris, E27 Bulb & FLS-PP

Offline Beetle2003

  • New Member
  • *
  • Beiträge: 33
Antw:HCS Fehlermeldung
« Antwort #8 am: 08 Januar 2019, 22:34:06 »
Hallo,

hat jemand eine Lösung gefunden?
Ich erhalte die Meldung:
2018.03.17 17:25:52 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at ./FHEM/59_HCS.pm line 679.
2018.03.17 17:25:52 1: Excl/Ignored .
2018.03.17 17:25:52 1: Excl/Ignored .
2018.03.17 17:25:52 1: Excl/Ignored .
Ich habe festgestellt das sie Meldung immer dann kommt wenn der ECO Mode aktiviert ist.  Diese Meldungen werden im Abstand von 5 Minuten in das Log geschrieben.

 

decade-submarginal