Autor Thema: 433MHz Handsender  (Gelesen 223 mal)

Offline Snocksman

  • Jr. Member
  • **
  • Beiträge: 62
433MHz Handsender
« am: 04 November 2018, 13:22:46 »
Hallo zusammen,

ich habe mir ein paar günstige 433-MHz Handsender bestellt... Leider habe ich feststellen müssen, dass die Version der Handsender die ich da bestellt habe, einen festen 433MHz-Code haben und dieser nicht geändert werden kann... Wäre ja nicht so schlimm, wenn ich die Dinger trotzdem mit FHEM nutzen könnte; FHEM empfängt auch was von den Handsendern, kann damit aber scheinbar nichts anfangen...
Hier mal der Log-Auschnitt:
2018.11.04 13:05:02 4: CUL_Parse: nanoCUL i7BCFE85B -28.5
2018.11.04 13:05:02 4: nanoCUL IT: message "i7bcfe8" (7)
2018.11.04 13:05:02 4: nanoCUL IT: msgcode "" (0) bin = 011110111100111111101000
2018.11.04 13:05:02 4: nanoCUL IT: 1527x7bcfe not defined (Switch code: 1000)
Kann ich die Handsender trotzdem irgendwie in FHEM als Device anlegen, oder wenigstens irgendwie auf das empfangene Signal reagieren ?
(Zum Empfang nutze ich übrigens einen nanoCUL mit "V 1.26.04 a-culfw Build: 306")

Wäre schön wenn mir hier jemand auf die Sprünge helfen könnte...

Offline RaspiLED

  • Hero Member
  • *****
  • Beiträge: 1859
  • Es begann alles so klein ;-)
433MHz Handsender
« Antwort #1 am: 04 November 2018, 13:35:34 »
Ja, schau mal im Signalduino Wiki unter
„Es wird ein Protokoll erkannt, Autocreate legt aber kein device an“ hier:
https://wiki.fhem.de/wiki/SIGNALduino

Aber eigentlich sieht es doch gut aus. Die Tasten zweimal innerhalb von 1er Minute drücken sollte doch per Autocreate ein IT_Device im Raum IT anlegen. Oder ist Dein Autocreate aus?
https://wiki.fhem.de/wiki/Autocreate

Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
« Letzte Änderung: 04 November 2018, 13:38:20 von RaspiLED »
Raspberry Pi mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, WifiLight2, Bravia, ...

Offline Snocksman

  • Jr. Member
  • **
  • Beiträge: 62
Antw:433MHz Handsender
« Antwort #2 am: 04 November 2018, 15:00:35 »
Danke !!!

Der entscheidende Hinweis war: "Die Tasten zweimal innerhalb von 1er Minute drücken". Ich habe vor Uhrzeiten (>5 Jahre) das letzte IT-Device per Autocreate hinzugefügt... War das schon immer so, dass man die Knöpfe zwei mal für ein Autocreate drücken musste ?!  ??? Ich meine nämlich, dass ich für die IT-Fernbedienung damals jeden Knopf nur ein mal gedrückt hatte...

Aber jetzt hat ers angelegt und alles läuft wie es soll.

Falls noch jemand mit der gleichen Frage drüber stolpern sollte... So sieht das ganze dann in der Config aus. Ich habe den Handsender mit 4 Knöpfen dann auf zwei Devices mit on / off aufgeteilt:
define IT_1527x7bcfe_1 IT 1527x7bcfe 0010 1000
attr IT_1527x7bcfe_1 IODev nanoCUL
attr IT_1527x7bcfe_1 room IT
define FileLog_IT_1527x7bcfe_1 FileLog ./log/IT_1527x7bcfe_1-%Y.log IT_1527x7bcfe_1
attr FileLog_IT_1527x7bcfe_1 logtype text
attr FileLog_IT_1527x7bcfe_1 room IT

define IT_1527x7bcfe_2 IT 1527x7bcfe 0001 0100
attr IT_1527x7bcfe_2 IODev nanoCUL
attr IT_1527x7bcfe_2 room IT
define FileLog_IT_1527x7bcfe_2 FileLog ./log/IT_1527x7bcfe_2-%Y.log IT_1527x7bcfe_2
attr FileLog_IT_1527x7bcfe_2 logtype text
attr FileLog_IT_1527x7bcfe_2 room IT
« Letzte Änderung: 04 November 2018, 15:13:51 von Snocksman »

 

decade-submarginal