Autor Thema: Dewpoint-Problem, keine Anzeige in Readings  (Gelesen 144 mal)

Offline Electron

  • New Member
  • *
  • Beiträge: 8
Dewpoint-Problem, keine Anzeige in Readings
« am: 04 November 2018, 13:58:24 »
Hallo Zusammen,

Also entweder habe ich nen absoluten Denkfehler oder das Dewpoint-Modul macht wieder Ärger (, glaub ich aber nicht  ;))

Mein Device, an das ich den Dewpoint gehangen habe:

Internals
DEF                          MODULE 70:ee:50:2a:e0:fa 02:00:00:2b:0e:12
Device 70:ee:50:2a:e0:fa
IODev Wetter
LAST_POLL 2018-11-04 13:19:50
Module 02:00:00:2b:0e:12
NAME netatmo_M02_00_00_2b_0e_12
NOTIFYDEV global
NR 22
NTFY_ORDER 50-netatmo_M02_00_00_2b_0e_12
STATE T: 11.1 H: 90
SUBTYPE MODULE
TYPE         netatmo
dataTypes         Temperature,Humidity
firmware         46
last_message         2018-11-04 13:09:36
last_seen         2018-11-04 13:09:11
last_setup         2018-04-17 12:41:19
model NAModule1
moduleName Outdoor
openRequests         0
rf_status         67
status ok

Readings
active ok 2018-11-04 13:19:50
batteryPercent         84 2018-11-04 13:19:42
batteryState         ok 2018-11-04 13:19:42
batteryVoltage         5.622 2018-11-04 13:19:42
humidity         90 2018-11-04 13:19:26
temp_max         12.3         2018-11-04 10:57:35
temp_min         7.8 2018-11-04 03:58:53
temp_trend stable 2018-11-04 13:09:11
temperature 11.1         2018-11-04 13:19:26

Attributes
IODev Wetter
alias         Outdoor
devStateIcon         .*:no-icon
room         netatmo
stateFormat T: temperature H: humidity
verbose 5

...und die Dewpoint-Definition dazu:
Internals
CMD_TYPE dewpoint
DEF dewpoint netatmo_M02_00_00_2b_0e_12 temperature humidity dewpoint
DEV_REGEXP netatmo_M02_00_00_2b_0e_12
HUM_NAME humidity
NAME taupunkt
NEW_NAME dewpoint
NOTIFYDEV netatmo_M02_00_00_2b_0e_12
NR 36
NTFY_ORDER 10-taupunkt
STATE active
TEMP_NAME temperature
TYPE dewpoint
 
Attributes
absoluteHumidity 1
verbose 5

Das Problem ist jetzt, das in dem Device kein Dewpoint- oder absoluteHumidity-Reading gibt.

Hier noch ein Logauszug:
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='temperature: 11.4'
2018.11.04 14:00:49 5: dewpoint_notify: evName='temperature:' val=11.4'
2018.11.04 14:00:49 5: dewpoint_notify temperature! dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, temp=11.4
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, reference humidity=88 (690), temp=11.4
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='humidity: 88'
2018.11.04 14:00:49 5: dewpoint_notify: evName='humidity:' val=88'
2018.11.04 14:00:49 5: dewpoint_notify humidity! dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, hum=88
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, reference temperature=11.4 (381), hum=88
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='temperature: 11.4'
2018.11.04 14:00:49 5: dewpoint_notify: evName='temperature:' val=11.4'
2018.11.04 14:00:49 5: dewpoint_notify temperature! dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, temp=11.4
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, reference humidity=88 (381), temp=11.4
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='humidity: 87'
2018.11.04 14:00:49 5: dewpoint_notify: evName='humidity:' val=87'
2018.11.04 14:00:49 5: dewpoint_notify humidity! dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, hum=87
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, reference temperature=11.4 (73), hum=87
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='active: ok'
2018.11.04 14:00:49 5: dewpoint_notify: evName='active:' val=ok'
2018.11.04 14:00:49 5: dewpoint max_timediff=1

Geloggt wird also auch nichts...

Kann jemand meinen Fehler erkennen?
« Letzte Änderung: 04 November 2018, 14:18:46 von Electron »

Offline Heinz1973

  • New Member
  • *
  • Beiträge: 17
Antw:Dewpoint-Problem, keine Anzeige in Readings
« Antwort #1 am: 04 November 2018, 21:32:14 »
Ich habe auch ein Problem mit dem Modul erkannt:
seit der Umstellung von absFeuchte auf absoluteHumidity habe ich ein absFeuchte Reading mehr, sondern ein Reading „1“ mit dem richtigen Wert drin.

Ich vermute dass die 1 vom Attribut selber kommt:

define TaupunktMySensorsHumidity1 dewpoint dewpoint MYSENSOR_Humidity1 Temperature Humidity Dewpoint
attr TaupunktMySensorsHumidity1 absoluteHumidity 1





Offline Frank_Huber

  • Hero Member
  • *****
  • Beiträge: 2391
Antw:Dewpoint-Problem, keine Anzeige in Readings
« Antwort #2 am: 04 November 2018, 21:34:28 »
Hallo Zusammen,

Also entweder habe ich nen absoluten Denkfehler oder das Dewpoint-Modul macht wieder Ärger (, glaub ich aber nicht  ;))

Mein Device, an das ich den Dewpoint gehangen habe:

Internals
DEF                          MODULE 70:ee:50:2a:e0:fa 02:00:00:2b:0e:12
Device 70:ee:50:2a:e0:fa
IODev Wetter
LAST_POLL 2018-11-04 13:19:50
Module 02:00:00:2b:0e:12
NAME netatmo_M02_00_00_2b_0e_12
NOTIFYDEV global
NR 22
NTFY_ORDER 50-netatmo_M02_00_00_2b_0e_12
STATE T: 11.1 H: 90
SUBTYPE MODULE
TYPE         netatmo
dataTypes         Temperature,Humidity
firmware         46
last_message         2018-11-04 13:09:36
last_seen         2018-11-04 13:09:11
last_setup         2018-04-17 12:41:19
model NAModule1
moduleName Outdoor
openRequests         0
rf_status         67
status ok

Readings
active ok 2018-11-04 13:19:50
batteryPercent         84 2018-11-04 13:19:42
batteryState         ok 2018-11-04 13:19:42
batteryVoltage         5.622 2018-11-04 13:19:42
humidity         90 2018-11-04 13:19:26
temp_max         12.3         2018-11-04 10:57:35
temp_min         7.8 2018-11-04 03:58:53
temp_trend stable 2018-11-04 13:09:11
temperature 11.1         2018-11-04 13:19:26

Attributes
IODev Wetter
alias         Outdoor
devStateIcon         .*:no-icon
room         netatmo
stateFormat T: temperature H: humidity
verbose 5

...und die Dewpoint-Definition dazu:
Internals
CMD_TYPE dewpoint
DEF dewpoint netatmo_M02_00_00_2b_0e_12 temperature humidity dewpoint
DEV_REGEXP netatmo_M02_00_00_2b_0e_12
HUM_NAME humidity
NAME taupunkt
NEW_NAME dewpoint
NOTIFYDEV netatmo_M02_00_00_2b_0e_12
NR 36
NTFY_ORDER 10-taupunkt
STATE active
TEMP_NAME temperature
TYPE dewpoint
 
Attributes
absoluteHumidity 1
verbose 5

Das Problem ist jetzt, das in dem Device kein Dewpoint- oder absoluteHumidity-Reading gibt.

Hier noch ein Logauszug:
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='temperature: 11.4'
2018.11.04 14:00:49 5: dewpoint_notify: evName='temperature:' val=11.4'
2018.11.04 14:00:49 5: dewpoint_notify temperature! dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, temp=11.4
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, reference humidity=88 (690), temp=11.4
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='humidity: 88'
2018.11.04 14:00:49 5: dewpoint_notify: evName='humidity:' val=88'
2018.11.04 14:00:49 5: dewpoint_notify humidity! dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, hum=88
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, reference temperature=11.4 (381), hum=88
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='temperature: 11.4'
2018.11.04 14:00:49 5: dewpoint_notify: evName='temperature:' val=11.4'
2018.11.04 14:00:49 5: dewpoint_notify temperature! dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, temp=11.4
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, reference humidity=88 (381), temp=11.4
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='humidity: 87'
2018.11.04 14:00:49 5: dewpoint_notify: evName='humidity:' val=87'
2018.11.04 14:00:49 5: dewpoint_notify humidity! dev=netatmo_M02_00_00_2b_0e_12, hum_name=humidity, hum=87
2018.11.04 14:00:49 5: dewpoint max_timediff=1
2018.11.04 14:00:49 5: >dev=netatmo_M02_00_00_2b_0e_12, temp_name=temperature, reference temperature=11.4 (73), hum=87
2018.11.04 14:00:49 4: dewpoint_notify: cmd_type=dewpoint devname=netatmo_M02_00_00_2b_0e_12 dewname=taupunkt, dev=netatmo_M02_00_00_2b_0e_12, dev_regex=netatmo_M02_00_00_2b_0e_12 temp_name=temperature hum_name=humidity
2018.11.04 14:00:49 5: dewpoint_notify: s='active: ok'
2018.11.04 14:00:49 5: dewpoint_notify: evName='active:' val=ok'
2018.11.04 14:00:49 5: dewpoint max_timediff=1

Geloggt wird also auch nichts...

Kann jemand meinen Fehler erkennen?
Ich vermute es ist der Name. Nimm mal die Doppelpunkte raus.

Gesendet von meinem Doogee S60 mit Tapatalk


 

decade-submarginal