Autor Thema: fhem bleibt hängen, wenn OW Server nicht antwortet  (Gelesen 144 mal)

Offline maci

  • Full Member
  • ***
  • Beiträge: 371
  • ... und sie leben doch!
fhem bleibt hängen, wenn OW Server nicht antwortet
« am: 05 November 2018, 08:11:02 »
Mein Fhem Server bleibt hängen weil er keine Antwort vom OWServer bekommt.
Der OWServer ist auf einem anderen Raspberry. Dieser war gestern nicht erreichbar.
Weder per ssh, aber einige Ports waren offen, aber ohne Funktion . Er ist also im Dillirium :o

Mein Fhem Hauptserver bleibt nun hängen weil der OW-Server nicht antwortete.
Der 4304 port ist geschlossen lt. Portscan.

Im Log steht:
2018.11.05 08:01:36 3: Heizungstemperaturen: Opening connection to OWServer 10.0.0.8:4304...
2018.11.05 08:01:36 3: Heizungstemperaturen: Successfully connected to 10.0.0.8:4304.

Bei dieser Meldung blieb Fhem hängen und machte nicht weiter.
Weil Fhem nicht antwortete, habe ich den Server neu gestartet und da blieb er hängen machte nichts mehr.

Frage mich, warum es hier kein TimeOut gibt. Oder muss ich die Konfiguration anpassen?

Internals:
   DEF        10.0.0.8:4304
   LAST_READ_FAILED 0
   NAME       Heizungstemperaturen
   NOTIFYDEV  global
   NR         85
   NTFY_ORDER 50a-Heizungstemperaturen
   OWNET_VERSION 3.1p5
   STATE      Initialized
   TYPE       OWServer
   READINGS:
     2018-11-05 17:23:28   /settings/timeout/directory           60
     2018-11-05 17:23:28   /settings/timeout/ftp          900
     2018-11-05 17:23:28   /settings/timeout/ha7           60
     2018-11-05 17:23:28   /settings/timeout/network            1
     2018-11-05 17:23:28   /settings/timeout/presence          120
     2018-11-05 17:23:28   /settings/timeout/serial            5
     2018-11-05 17:23:28   /settings/timeout/server           10
     2018-11-05 17:23:28   /settings/timeout/stable          300
     2018-11-05 17:23:28   /settings/timeout/uncached 0
     2018-11-05 17:23:28   /settings/timeout/usb            5
     2018-11-05 17:23:28   /settings/timeout/volatile           15
     2018-11-05 17:23:28   /settings/timeout/w1           30
     2018-11-05 17:23:28   /settings/units/pressure_scale mbar
     2018-11-05 17:23:28   /settings/units/temperature_scale C
     2018-11-05 17:23:28   state           Initialized
   fhem:
     protocol   10.0.0.8:4304
Attributes:
   DbLogExclude .*
   group      Verbindung Heizung
   room       9.09_Systemkonfiguration

Es steht zwar etwas von Timeout drinnen, aber das reagierte gestern irgendwie nicht.
Die Uhrzeit ist daher weil ich um diese Zeit der OW Server wieder an laufen brachte und dann den Fhem server neu gestartet habe.
« Letzte Änderung: 06 November 2018, 07:31:59 von maci »
Raspberry Pi3, UniPi Vers. 1.1 mit Raspberry Pi2, Netatmo Wetterstation + Regenmesser, Netatmo Thermostat, 2x ESP8266 1wire WLAN Bridge, HMLan, Homematic