Autor Thema: Can't locate Switch.pm in @INC (you may need to install the Switch module)  (Gelesen 295 mal)

Offline riker1

  • Sr. Member
  • ****
  • Beiträge: 597
Hi

wollte ein Modul integrieren.

hatte ich bekommen von :

https://forum.fhem.de/index.php/topic,93220.msg858408.html#msg858408


aber:  Can't locate Switch.pm in @INC (you may need to install the Switch module)

wie installieren ich den Switch.pm für fhem?

Danke  für die Hilfe
FHEM 5.8 Ubuntu, FHEM 5.8 RPI 3 , Actoren: IT ,
MAX CUBE, MAX HT, MAX WT, Selbstbau nanoCULs, FS 20, Homematic, FTK, SW. DIM, Smoke,KODI,Squeezebox

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 22368
apt-get install libswitch-perl

Warum man aber ausgerechnet ein zusätzliches Modul installieren will nur für eine einzige Anweisung mit switch case ist mir ein Rätsel.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer

Offline riker1

  • Sr. Member
  • ****
  • Beiträge: 597
Hi Cooltux,

danke,

verstehe nicht, was du meinst.

wie kann ich es denn anderst machen?

eher über myUtils?

oder was meinst du?

Das mit dem Switch sagt halt die Fehlermeldung ??

Danke
FHEM 5.8 Ubuntu, FHEM 5.8 RPI 3 , Actoren: IT ,
MAX CUBE, MAX HT, MAX WT, Selbstbau nanoCULs, FS 20, Homematic, FTK, SW. DIM, Smoke,KODI,Squeezebox

Offline CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 22368
Das war nicht auf dich bezogen sondern auf denjenigen der den Codeteil geschrieben hat. Musst halt Switch installieren.
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer