Autor Thema: Modul für Netgear Arlo-Kameras  (Gelesen 35094 mal)

Offline ojb

  • Full Member
  • ***
  • Beiträge: 128
Antw:Modul für Netgear Arlo-Kameras
« Antwort #255 am: 19 Februar 2020, 12:44:22 »
Hi mi.ke,

super. Das haut hin. Danke.

Liebe Grüße
Oli
FHEM unter Lubuntu auf Asus EEBox: KNX (Wetterstation, Rollläden, Beleuchtung), CUNO (Temperatur und Feuchte über 1-Wire, Intertechno-Funksteckdosen), Dreambox, Viessmann Wärmepumpe, 1-Wire (Temperatur, Feuchte, Stromverbrauch), ...

Offline supernova1963

  • Full Member
  • ***
  • Beiträge: 434
Antw:Modul für Netgear Arlo-Kameras
« Antwort #256 am: 20 Februar 2020, 05:25:26 »
Hallo mi.ke,

danke ...,

Gernot

Offline mi.ke

  • Sr. Member
  • ****
  • Beiträge: 675
  • JASPER (powered by FHEM)
    • J.A.S.P.E.R. --> Just A Smart Perl Engineered Roomie
Antw:Modul für Netgear Arlo-Kameras
« Antwort #257 am: 20 Februar 2020, 11:48:26 »
@maluk

Ich habe ein Verständnisproblem mit der im Oktober eingeführten Änderung des connect-Verhaltens des Subtype ACCOUNT "aktiv|inaktiv", die seit Oktober2019 zusätzlich eingebaut wurde.

Quelle:"Device specific help"
expiryTime
Subtype ACCOUNT: Wenn alle Basisstation auf "disarmed" stehen, wird die Verbindung zur Cloud nach der hier angegebenen Zeit beendet. Bei einer Aktion mit einem Arlo-Gerät wird eine neue Verbindung aufgebaut. Angabe in Sekunden, Standard ist 600 (10 Minuten). Durch Angabe von 0 kann die Verbindung dauerhaft bestehen bleiben.
"

a.)
Ich habe mehrere Basisstationen am laufen, von denen 99% der Zeit mind. eine auf "armed" steht. Die Dritte meist auf "offline"
Trotzdem schaltet der "Subtype ACCOUNT" nach 10 Minuten auf "inaktiv".  Dies dürfte ja nach der Beschreibung nicht der Fall sein.


b.)
Das funktioniert meist.
Aber nicht belastbar. Der Status bleibt dann, trotz trigger, auf "inaktiv".

c.)
auch wenn "expiryTime" auf 0 steht, wechselt das device auf "inaktiv"

Kann es sein, dass das Verhalten an den mehrfach vorhandenen Basisstationen liegt?
Ich muss getehen, dass ich die in der Oktober-Version eingebauten Änderungen bis dato nicht getestet hatte, da die für mich stabilste Version die Rev.20219 vom 21.09.2019 war.

Oder lieg ich völlig falsch?

Danke und Grüße
cheers
mi.ke
FHEM 5.9 | Cubietruck + 8 x RPi(Z) + FB7590 + FB 6842 LTE via LAN und WAN (VPN) verbunden.
2 x CUL868 + 3 x RFXTRX(e) + 4 x HMwLanGW + Ardunio433 + 3 x LGW + IRBlast + CO2 +++
FS20, FHT, FMS, Elro(mod)AB440/R/S/D, OWL-CM160, Revolt, LGTV, STV, AVR, withings, HM-sec-*, HM-CC-RT-DN, AMAD, PCA301, arlo

Offline mi.ke

  • Sr. Member
  • ****
  • Beiträge: 675
  • JASPER (powered by FHEM)
    • J.A.S.P.E.R. --> Just A Smart Perl Engineered Roomie
Antw:Modul für Netgear Arlo-Kameras
« Antwort #258 am: 21 Februar 2020, 18:51:07 »
PS.
Ich muss getehen, dass ich die in der Oktober-Version eingebauten Änderungen bis dato nicht getestet hatte, da die für mich stabilste Version die Rev.20219 vom 21.09.2019 war.
@maluk
Ich habe jetzt erstmal zur Überbrückung die letzte Änderung zur Anmeldung in die Version Rev.20219 vom 21.09.2019 eingebaut, da leider das Device mit der neusten Version immer wiedermal auf inaktiv geblieben ist und so Bewegungen, die die APP gemeldet hat, nicht von FHEM erkannt wurden.
Seit dem wieder einwandfreier und störungsloser Betrieb.

Vielleicht könntest Du ja noch mal schauen?
Wenn Du LOGs oder irgendwas brauchst, sag einfach Bescheid.

cheers
mi.ke
FHEM 5.9 | Cubietruck + 8 x RPi(Z) + FB7590 + FB 6842 LTE via LAN und WAN (VPN) verbunden.
2 x CUL868 + 3 x RFXTRX(e) + 4 x HMwLanGW + Ardunio433 + 3 x LGW + IRBlast + CO2 +++
FS20, FHT, FMS, Elro(mod)AB440/R/S/D, OWL-CM160, Revolt, LGTV, STV, AVR, withings, HM-sec-*, HM-CC-RT-DN, AMAD, PCA301, arlo

Offline m0urs

  • Full Member
  • ***
  • Beiträge: 175
    • Urs-o-Log
Antw:Modul für Netgear Arlo-Kameras
« Antwort #259 am: 10 März 2020, 18:56:38 »
Gibt es schon eine Idee, wie man mit der ab Anfang kommenden Jahres wohl verpflichtenden 2FA umgehen kann? Ich denke, wir sollten Arlo wissen lassen, dass man das entweder weiterhin optional machen muss oder wenigstens eine Art Application Password einführt...

https://community.arlo.com/t5/Arlo/Mandatory-Two-Step-Authentication-Verification-a-Bad-Idea/m-p/1760890#M4454
« Letzte Änderung: 10 März 2020, 21:54:01 von m0urs »

Offline maluk

  • Full Member
  • ***
  • Beiträge: 167
Antw:Modul für Netgear Arlo-Kameras
« Antwort #260 am: 22 März 2020, 10:57:31 »
Ich habe mir über die verpflichtende 2FA mal Gedanken gemacht: vermutlich kann man protestieren, so viel man möchte. Arlo wird es trotzdem einführen.

Was mir momentan als mögliche Lösung einfällt: es gibt unter Linux den Gammu SMSD, mit dem man SMS empfangen kann. Dazu benötigt man einen Surf-Stick und eine SIM-Karte. Mit einem Prepaid-Tarif sollten da auch keine großen Kosten anfallen, da ja nichts versendet, sondern nur empfangen wird. Ich werde das bei Gelegenheit mal ausprobieren. Wenn man SMS empfangen kann, kann ich das Arlo-Modul so umstellen, dass es mit 2FA zurechtkommt.

Theoretisch gibt es auch virtuelle SMS-Dienste, aber ich habe auf die Schnelle keinen günstigen gefunden, der für den Zweck verwendbar wäre. Falls irgendjemand eine Idee hat, wie man zuverlässig kostenlos SMS auf dem Raspberry empfangen kann, gerne hier Vorschläge machen  :)

Offline m0urs

  • Full Member
  • ***
  • Beiträge: 175
    • Urs-o-Log
Antw:Modul für Netgear Arlo-Kameras
« Antwort #261 am: 22 März 2020, 11:41:21 »
Ich experimentiere gerade damit ein wenig rum. Allerdings nutze ich ja nicht mehr das FHEM Modul sondern ein eigenes Python-Script basierend auf https://github.com/jeffreydwalter/arlo. M.E. bringt das ganze aber nur sinnvoll etwas, wenn wir es schaffen, dass man nicht andaurnd eine SMS benötigt sondern ein Device als TRUSTED kennzeichnen kann und damit nach einmaliger Authentifizierung keine weitere 2FA Abfrage mehr bekommt. Angeblich soll das so ja mit der iPhone-App z.B. funktionieren (hab ich aber noch nicht getestet).

Meine Experimente sind aber auch noch seh am Anfang. Erschwerend kommt hinzu, dass ich kein Programmierer bin, sondern das mit Try & Error machen muss ;-)

Das FHEM-Modul nutze ich übrigens deswegen nicht mehr, weil es ja bei mir mit einer Basis-Station und 2 Bridges mit mehreren Arlo Lights nie zufriedenstellend funktioniert hatte.

Offline m0urs

  • Full Member
  • ***
  • Beiträge: 175
    • Urs-o-Log
Antw:Modul für Netgear Arlo-Kameras
« Antwort #262 am: 22 März 2020, 13:15:55 »
Vielleicht rudert Arlo doch wieder zurück. Aus diesem Chat-Ausschnitt mit dem Arlo-Support kann man ablesen, dass es doch eine Wahlfreiheit bleibt. Man kann nur hoffen.

https://community.arlo.com/t5/Arlo/Mandatory-Two-Step-Authentication-Verification-a-Bad-Idea/m-p/1762753#M74989

Offline m0urs

  • Full Member
  • ***
  • Beiträge: 175
    • Urs-o-Log
Antw:Modul für Netgear Arlo-Kameras
« Antwort #263 am: 23 März 2020, 18:54:11 »
Bad news, Arlo scheint genauso beratungsresistent zu sein, wie sonst auch. Der Kundenservice ist echt unterirdisch bei denen :-(

Zitat

As part of our efforts to continually evolve and further strengthen our privacy and security practices, Arlo announced it will now require all users to use two-factor authentication when logging into their Arlo account. The new security mandate will go into effect for new users in Q2 of 2020, and will require existing Arlo users to enable the feature on their current Arlo accounts by end of year. While Arlo has strongly encouraged its users to enable two-factor authentication since its introduction, Arlo believes requiring this added layer of security is yet another measure we can take to help our users safeguard their accounts and their data.

 

Arlo Team

 

decade-submarginal