Autor Thema: Fehlende readings mit CUNO MAX CUBe und Max Scanner  (Gelesen 230 mal)

Offline andy_lox

  • New Member
  • *
  • Beiträge: 25
Fehlende readings mit CUNO MAX CUBe und Max Scanner
« am: 10 Dezember 2018, 22:58:37 »
Hallo zusammen, ich bin schon sehr lange stiller Mitleser und meistens hat mir das Forum auch immer geholfen. Jetzt komme ich mal an die Grenzen und brauche eure Hilfe.

Zur Ausgangssituation, ich habe ein Mx Cube mit 6 HT die ich über FHEM in meine restliche Heimsteuerung eingebunden habe. Das funktioniert so ganz ok, aber ich hatte immer mal wieder Probleme mit den Credits, weil die Temperatur eben aus der Heimsteuerung kommt und nicht aus dem Wochenprogramm.

Also hab ich mich dazu entschlossen doch den MaxCube zum CUNO umzuflashen, hier schon mal die Daten die aktuell drauf sind, extra eine Version ohne Creditlimit:
Internals:
   CMDS       BbCFiAZNEkGMKLUYRTVWXOefhltxz
   CUBe_MSGCNT 1
   CUBe_TIME  2018-12-10 22:07:47
   Clients    :CUL_MAX:HMS:CUL_IR:STACKABLE_CC:TSSTACKED:STACKABLE:
   DEF        192.168.178.71:2323 0000
   DeviceName 192.168.178.71:2323
   FD         6
   FHTID      0000
   NAME       CUBe
   NR         6
   NR_CMD_LAST_H 3
   PARTIAL   
   RAWMSG     Z0E030202069A8C1234560001190524FC
   RSSI       -76
   STATE      Initialized
   TYPE       CUL
   VERSION    V 1.26.04_nocredits a-culfw Build: private build (unknown) CUBe (F-Band: 868MHz)
   initString X21
Zr
Za123456
Zw111111
   MatchList:
     1:CUL_MAX  ^Z........................
     8:HMS      ^810e04....(1|5|9).a001
     D:CUL_IR   ^I............
     H:STACKABLE_CC ^\*
     M:TSSTACKED ^\*
     N:STACKABLE ^\*
   READINGS:
     2018-12-10 22:07:11   cmds             B b C F i A Z N E k G M K L U Y R T V W X O e f h l t x z
     2018-12-10 22:07:46   credit10ms      3600
     2018-12-10 22:07:47   state           Initialized
   XMIT_TIME:
     1544476035.58493
     1544476035.88547
     1544476066.19953
Attributes:
   model      CUNO
   rfmode     MAX

Ich habe den CUNO weiterhin im Netzwerk wie vorher und Strom aus der Fritzbox, allerdings nur Strom ohne Daten, hatte gehört, das könnte Fehler machen.

Beim pairen der HT die vorher auf factory reset gesetzt wurden, hatte ich schon einige Probleme, dass es nicht immer direkt geklappt hat. Ich muss den FHEM dienst oft neustarten damit es dann schließlich ging.

Jetzt habe ich den CUNO so eingebunden:
define CUBe CUL 192.168.178.71:2323 0000
attr CUBe model CUNO
attr CUBe rfmode MAX
define cm CUL_MAX 123456
attr cm IODev CUBe

Hier ein Beispiel HT aus dem Bad:
define MAX_0645b0 MAX HeatingThermostat 0645b0
attr MAX_0645b0 userattr scnProcessByDesiChange:0,1 scnShutterList scnModeHandling:NOCHANGE,AUTO,MANUAL
attr MAX_0645b0 IODev cm
attr MAX_0645b0 alias Bad
attr MAX_0645b0 room MAX
attr MAX_0645b0 scanTemp 1
attr MAX_0645b0 scnProcessByDesiChange 1

Desweiteren hab ich den maxScanner am laufen:
define Scanner MaxScanner
attr Scanner room MAX

Jetzt kann ich die desiredtemperature auslesen und setzen, allerdings fehlen mit einige Readings von den HT in der Anzeige und der MaxScanner meckert das auch an:
MaxScanner MAX_0645b0 Work.729 !! READING:temperature is not defined !!
So sieht das HT aus:
Internals:
   DEF        HeatingThermostat 0645b0
   IODev      cm
   NAME       MAX_0645b0
   NR         134
   STATE      18.0 °C
   TYPE       MAX
   addr       0645b0
   type       HeatingThermostat
   READINGS:
     2018-12-10 22:01:47   RSSI            -54
     2018-12-10 20:05:12   TimeInformationHour 0
     2018-12-10 22:01:47   battery         ok
     2018-12-10 22:01:47   batteryState    ok
     2018-12-10 21:57:30   comfortTemperature 21
     2018-12-10 22:01:47   desiredTemperature 18.0
     2018-12-10 21:57:30   ecoTemperature  17
     2018-12-10 20:10:48   groupid         0
     2018-12-10 21:57:30   maximumTemperature on
     2018-12-10 21:58:30   measurementOffset 0.0
     2018-12-10 21:57:30   minimumTemperature off
     2018-12-10 22:01:47   mode            manual
     2018-12-10 22:01:41   msgcnt          4
     2018-12-10 22:01:47   state           18.0 °C
     2018-12-10 22:01:47   valveposition   0
     2018-12-10 21:57:30   windowOpenDuration 15
     2018-12-10 21:57:30   windowOpenTemperature 12
   helper:
     NextScan   1544476056
   internals:
     interfaces thermostat;battery;temperature
Attributes:
   IODev      cm
   alias      Bad
   room       MAX
   scanTemp   1
   scnProcessByDesiChange 1
   userattr   scnProcessByDesiChange:0,1 scnShutterList scnModeHandling:NOCHANGE,AUTO,MANUAL

Ich hoffe ich habe an alles gedacht und hoffe ihr könnt mir helfen woran es liegen kann. Vielen Dank vorab!

 

decade-submarginal