Autor Thema: 433Mhz Signalduino manax / mumbi Steckdose Problem  (Gelesen 4694 mal)

Offline peterboeckmann

  • Jr. Member
  • **
  • Beiträge: 81
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #90 am: 22 August 2019, 17:55:50 »
Hallo Marco, hallo Sidey,

so funktioniert es, wie es (zumindest aus meiner Sicht) soll.

 8)

Ich gebe 5 Daumen hoch!

Vielen Dank und viele Grüße,
Peter

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2343
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #91 am: 22 August 2019, 19:46:27 »
Hi HomeAutoUser,

Es sollte auch ohne Zusätzliches DoTrigger gehen.
Insbesondere der Wert State im Event.
Was soll der auslösen?

Tauchen Events im Eventmonitor auf, wenn readingsSingleUpdate aufgerufen wird?

ReadingsSingleUpdate kann durch verschiedene Attribute beeinflusst werden, ob ein Event generiert wird.
Sind da eventuell welche gesetzt?

Grüße Sidey

Gesendet von meinem Moto Z (2) mit Tapatalk

Signalduino, HMLan, Raspberry Pi, Mysensors, ESPEasy, HABridge für Echo

Offline HomeAuto_User

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 574
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #92 am: 22 August 2019, 21:04:23 »
Hallo Sidey,

ich habe nun nochmal nachgesehen und getestet.

Im Code die Zeile
readingsSingleUpdate($defs{"RC_10_" . $deviceCode ."_A"}, "state" , $state , 1) if (defined $defs{"RC_10_" . $deviceCode ."_A"});erzeugt kein Event. Der Monitor lässt nichts von dem Device sehen. --> deswegen keine sichtbare Aktualisierung des Zustandes, sondern nur mit Reload Browser sichtbar

Aber laut Doku, sollte doch die 1 am ende ein Event auslösen.
Flag, ob evtl. ein Event für das Reading getriggert werden soll (Wert: 1, Event ist abhängig von den Attributen: event-on-change-reading, event-on-update-reading, event-min-interval, ...). Wenn dieses Flag den Wert 0 oder undef besitzt, wird kein Event erzeugt.
Attribute in dem Device sind nicht gesetzt.
Internals:
   DEF        RC_10 7869_A
   FUUID      5d5c15bc-f33f-2293-d673-d9f6263cd9656873
   IODev      sduino_dummy
   NAME       RC_10_7869_A
   NR         689
   STATE      on
   TYPE       SD_UT
   bitMSG     no data
   lastMSG    no data
   CHANGED:
     on
     on
     on
   CHANGEDWITHSTATE:
   READINGS:
     2019-08-22 20:53:12   LastAction      send
     2019-08-20 18:06:49   deviceCode      0111100001101001
     2019-08-22 20:54:01   state           on
     2019-08-20 18:06:49   x_n4            0000
     2019-08-20 18:06:47   x_n5-8_off      1110001001000
     2019-08-20 18:06:49   x_n5-8_on       1111001001010
Attributes:
   IODev      sduino_dummy
   model      RC_10
   room       SD_UT

Global habe ich auch keine Einschränkungen vorgenommen oder welche anderen "versteckten" Dinge wirken darauf ein?

Der DoTrigger Weg war als Workaround, wo das  Reading state halt nochmal getriggert werden sollte. (Vielleicht fasse ich die Funktion falsch auf aber somit wird das Reading mit dem vorhanden Wert nochmal aktualisiert)
- FHEM v5.9 | Rasberry PI 3
- radino CC1101 433Mhz (SIGNALduino)| - radino CC1101 868Mhz (CUL) | nano 433Mhz (SIGNALduino) - Sensoren: 3x FHT 80b | 5x FHT 80 TF-2 | 2x S300TH | 1x WS7000-20 | 5x "Hideki" | THR128 und andere ;-)

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2343
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #93 am: 22 August 2019, 21:11:06 »

Global habe ich auch keine Einschränkungen vorgenommen oder welche anderen "versteckten" Dinge wirken darauf ein?

Der DoTrigger Weg war als Workaround, wo das  Reading state halt nochmal getriggert werden sollte. (Vielleicht fasse ich die Funktion falsch auf aber somit wird das Reading mit dem vorhanden Wert nochmal aktualisiert)

DoTrigger aktualisiert keinerlei Readings, es werden damit nur Events generiert.
Ich schau mir das mal an. Es gibt eine Einschränkung, dass Aufrufe der NotifyFN kein neues Event auslösen können.
Vermutlich um Endlosschleifen zu umgehen.
Ich war jetzt aber nicht unbedingt der Auffassung, dass ein Aufruf einer NotifyFN dazu führt, dass die Parse Funktion aufgerufen wird.

Grüße Sidey
Signalduino, HMLan, Raspberry Pi, Mysensors, ESPEasy, HABridge für Echo

Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 94
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #94 am: 22 August 2019, 21:15:31 »
Hallo Marco,

Zitat
Bitte mal die 4 readingsSingleUpdate Zeilen ersetzen und testen.
war erst etwas irreführend aber nachdem ich die 4 Zeilen nicht ersetzt,
sondern den neuen Code zusätzlich hinten ran hinzugefügt habe funktioniert alles wie es soll.
Von meiner Seite aus könnten wir das so lassen...

Danke Dir
MfG Uwe
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2343
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #95 am: 22 August 2019, 21:56:42 »
Hi,

ich bräuchte mal die Raw MSGs für _ALL und einen der Kanäle... Dann könnte ich das nähere Analysieren.

Grüße Sidey
Signalduino, HMLan, Raspberry Pi, Mysensors, ESPEasy, HABridge für Echo

Offline peterboeckmann

  • Jr. Member
  • **
  • Beiträge: 81
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #96 am: 22 August 2019, 23:59:39 »
Hallo Sidey,

ich habe die RAWMSGs mal rausgesucht:


KnopfRAWMSG
A onMS;P1=781;P3=-372;P4=251;P5=-903;P6=-10342;D=46451313131345454545131345134545134545454513131313454513454513451345;CP=4;SP=6;O;m1;E;
A offMS;P1=790;P2=-363;P3=257;P4=-896;P5=-10283;D=35341212121234343434121234123434123434343412121234343412343412343434;CP=3;SP=5;O;m2;C;C;
B onMS;P0=-367;P2=-892;P3=265;P4=-10335;P5=787;D=34325050505032323232505032503232503232323250503250323250323250503232;CP=3;SP=4;O;m2;2;P;
B offMS;P0=264;P1=-367;P2=791;P4=-887;P6=-10335;D=06042121212104040404212104210404210404040421210404040421040421212104;CP=0;SP=6;O;m2;
C onMS;P0=-887;P1=790;P2=-361;P3=265;P5=-10342;D=35301212121230303030121230123030123030303012301212303012303030301230;CP=3;SP=5;O;m2;0;0;
C offMS;P0=794;P1=-364;P2=265;P3=-885;P4=-10325;D=24230101010123232323010123012323012323232301230123232301232323232323;CP=2;SP=4;O;m1;
D onMS;P0=-884;P1=790;P2=-365;P3=272;P4=-10323;D=34301212121230303030121230123030123030303030121212303012301230301230;CP=3;SP=4;O;m1;0;
D offMS;P1=-364;P2=264;P3=-892;P4=787;P5=-10331;D=25234141414123232323414123412323412323232323414123232341234123232323;CP=2;SP=5;O;m2;A;
All onMS;P1=-361;P2=267;P3=-884;P4=792;P5=-10342;D=25234141414123232323414123412323412323232323412323232341234123414123;CP=2;SP=5;O;m2;A;
All offMS;P1=-363;P2=789;P3=267;P4=-887;P5=-10332;D=35342121212134343434212134213434213434343421343434343421343434212134;CP=3;SP=5;O;m2;4;

Viele Grüße,
Peter

Offline Sidey

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2343
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #97 am: 23 August 2019, 00:26:12 »
Danke.

Ich habe die Ursache des Problems zwischenzeitlich auch ausfindig machen können.

Zwecks Umgehung habe ich die Anpassung von HomeAuto_User noch ein wenig angepasst und an zwei Stellen den Code optimiert und hoffentlich keine Fehler dabei eingebaut.

Wer die Anpassung mal testen möchte:

update force https://raw.githubusercontent.com/RFD-FHEM/RFFHEM/dev_r34_RC10_allfix/controls_signalduino.txt
Bei mir klappt das mit dem _ALL Button jetzt so wie es soll.


Grüße Sidey
Signalduino, HMLan, Raspberry Pi, Mysensors, ESPEasy, HABridge für Echo

Offline peterboeckmann

  • Jr. Member
  • **
  • Beiträge: 81
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #98 am: 23 August 2019, 08:41:09 »
Hallo Sidey, hallo Marco,

es funktioniert noch wie ich es mir gewünscht habe.

Vielen Dank!

Gruß,
Peter

Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 94
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #99 am: 23 August 2019, 10:36:42 »
Hallo ihr beiden,

auch von mir vielen Dank,
mit der geänderten Fassung funktioniert es jetzt ebenso.

Gruß Uwe
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

Offline HomeAuto_User

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 574
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #100 am: 23 August 2019, 13:35:01 »
Hallöchen,
Danke für die Rückmeldung. Eine Frage noch zur Klarstellung, hattet ihr es via Update Force von Sidey eingespielt? Das ist ja die Fassung welche für alle freigegeben werden soll.

Liebe Grüße


Gesendet von iPhone mit Tapatalk Pro
- FHEM v5.9 | Rasberry PI 3
- radino CC1101 433Mhz (SIGNALduino)| - radino CC1101 868Mhz (CUL) | nano 433Mhz (SIGNALduino) - Sensoren: 3x FHT 80b | 5x FHT 80 TF-2 | 2x S300TH | 1x WS7000-20 | 5x "Hideki" | THR128 und andere ;-)

Offline peterboeckmann

  • Jr. Member
  • **
  • Beiträge: 81
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #101 am: 23 August 2019, 13:41:35 »
Hallo,

Ja, ich hatte den Update-Befehl von Sidey verwendet. Die Datei wurde zu dem Zeitpunkt auch aktualisiert.

Viele Grüße,
Peter

Gesendet von meinem SM-G975F mit Tapatalk


Offline my-engel

  • Jr. Member
  • **
  • Beiträge: 94
Antw:433Mhz Signalduino manax / mumbi Steckdose Problem
« Antwort #102 am: 23 August 2019, 16:18:26 »
Hallo,

Ja, ich auch über den Update-Befehl und die Datei wurde auch aktualisiert.
Wenn ich sie dann mit dem Editor öffne, hat diese einen ältere/andere Versionsnummer in der ersten Zeile als die vorherige von Dir ...

Viele Grüße,
Uwe
FHEM: => FB7490(OS 06.30-freetz-devel-13932M)
           => RPi3
IO:       HMLAN / HMUSB2 / HMUARTLGW / nanoCUL433

 

decade-submarginal