Autor Thema: fakelog: keine set Befehle mehr  (Gelesen 204 mal)

Offline Schlimbo

  • Sr. Member
  • ****
  • Beiträge: 580
fakelog: keine set Befehle mehr
« am: 11 Januar 2019, 17:35:48 »
Hallo zusammen,

mit dem Update vom 05. Januar wurden die "set" Befehle für fakelog Devices entfernt:
https://forum.fhem.de/index.php/topic,95351

Ich fand es gerade beim debuggen mit Verbose 5 sehr hilfreich in FHEM eine einfache Möglichkeit zu haben vor und nach dem debuggen das Logfile mit "clear" zu löschen, das funktioniert jetzt leider nicht mehr. Spricht etwas dagegen das "clear" wenigstens über die Befehlszeile wieder zu erlauben?
Zustimmung Zustimmung x 2 Liste anzeigen

Offline inoma

  • Sr. Member
  • ****
  • Beiträge: 507
Antw:fakelog: keine set Befehle mehr
« Antwort #1 am: 11 Januar 2019, 20:33:34 »
Hatte ich auch. Einfach in der def “fakelog” durch irgendwas anderes ersetzen, z.B. “myFhemlog”, dann gehts wieder, also :defmod Logfile FileLog ./log/fhem.log myFhemlog
« Letzte Änderung: 11 Januar 2019, 20:35:10 von inoma »
Raspberry Pi 3 B+ / Stretch, DbLog,Homematic, Homematic-IP über HMCCU, RESIDENTS, SONOS, FRITZBOX, GCALVIEW, GEOFANCY, HMUARTLGW, HM-MOD-UART, HUEBridge, TRAFFIC, alexa-fhem + Amazon Echo
Zustimmung Zustimmung x 1 Liste anzeigen

Offline eisman

  • Full Member
  • ***
  • Beiträge: 236
Antw:fakelog: keine set Befehle mehr
« Antwort #2 am: 12 Januar 2019, 09:12:09 »
Hallo zusammen,

mit dem Update vom 05. Januar wurden die "set" Befehle für fakelog Devices entfernt:
https://forum.fhem.de/index.php/topic,95351

Ich fand es gerade beim debuggen mit Verbose 5 sehr hilfreich in FHEM eine einfache Möglichkeit zu haben vor und nach dem debuggen das Logfile mit "clear" zu löschen, das funktioniert jetzt leider nicht mehr. Spricht etwas dagegen das "clear" wenigstens über die Befehlszeile wieder zu erlauben?

bin ich auch der Meinung, wenn man durch Modulefehler, das logfile zumüllt, sollte man es auch löschen können, was jetzt nur über den Umweg mit einem externen Editor geht, ich schaue regelmäßig in loc und lösche es dann.

mfg
1x FHEM Debian, Homematic / 1x FHEM Debian, FS20 / 1X FHEM Raspberry ,i2c,onewire,gpio
1x MQTT auf Windows 2012 Hyper-V-Server / 5x ESP8266(ESPeasy,ESPlink) mit 7"HMI
1x FHEM Windows / 1x Arduino Mega mit Configurable Firmata 2.06V

Offline Schlimbo

  • Sr. Member
  • ****
  • Beiträge: 580
Antw:fakelog: keine set Befehle mehr
« Antwort #3 am: 12 Januar 2019, 09:13:05 »
Hallo Ina,
Danke für deine Antwort, jetzt leuchtet es mit ein, der Eintrag "fakelog" ist ja nur der regexp Teil und für das globale Logfile muss hier nur etwas verwendet werden, das auf kein Gerät matched.
define <name> FileLog <filename> <regexp> [readonly]
Ich hatte das Wiki so verstanden, dass für das globale Logfile zwingend "fakelog" verwendet werden muss:
https://wiki.fhem.de/wiki/FileLog


Offline inoma

  • Sr. Member
  • ****
  • Beiträge: 507
Antw:fakelog: keine set Befehle mehr
« Antwort #4 am: 12 Januar 2019, 11:17:04 »
Nein. ich hatte im changelig vom update gesehen, das Rudi im Januar update das controlset disabled hat, falls der name ‘fakelog’ ist, deswegen einfach der andere Name.
Raspberry Pi 3 B+ / Stretch, DbLog,Homematic, Homematic-IP über HMCCU, RESIDENTS, SONOS, FRITZBOX, GCALVIEW, GEOFANCY, HMUARTLGW, HM-MOD-UART, HUEBridge, TRAFFIC, alexa-fhem + Amazon Echo

Offline Benni

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1889
  • FHEMinist
FHEM (FL 9.9) (configDB+DbLog) auf Debian Wheezy.
Jede Menge HM mit 2x HMUART (WeMos+esp-link) über VCCU.
UniRoll an CUL868. Sebury F2-2 RFID über ESPEasy
Module: 98_rssFeed und 98_QRCode

Online KernSani

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2484
Antw:fakelog: keine set Befehle mehr
« Antwort #6 am: 12 Januar 2019, 14:23:36 »
https://wiki.fhem.de/wiki/Cmdalias bietet eine schöne Möglichkeit das Log zu löschen


Kurz, weil mobil
RasPi: RFXTRX, HM, mySensors, JeeLink, miLight, squeezbox, Alexa, Siri, ...