Autor Thema: Funksteckdosen (DIP-Code) über nanoCUL klappt nicht obwohl Signal erkannt wird  (Gelesen 217 mal)

Offline seneca

  • New Member
  • *
  • Beiträge: 4
Hallo,

ich habe über einen selbstgebauten nanoCUL ein älteres Set Funksteckdosen (nicht selbstlernend, sondern mit DIP) aus dem Baumarkt (Toom) laufen, die auch recht zuverlässig funktionieren:

define SchaltdoseA IT 000000FFFF FF F0
attr SchaltdoseA IODev CUL_433
attr SchaltdoseA model itswitch

Nun habe ich letztes Jahr ein weiteres Set gekauft. Auch dieses wird mittels DIP Schaltern eingestellt. Es sieht etwas moderner aus (wenn Bilder gezeigt werden sollen, hole ich das heute Abend nach).
Die Steckdosen hab ich genauso definiert, wie die ersten. Leider bringt das keinerlei Erfolg.

define Schaltdose1B IT F0000F0FFF 0F F0
attr Schaltdose1B IODev aCUL_433
attr Schaltdose1B model itswitch

Jetzt zu dem, was ich mir so garnicht erklären kann:
Wenn ich die definierte Dose per Fernbedienung schalte, wird das Signal ja über den nanoCUL aufgefangen und ausgewertet. Unbekanntes wird über autocreate angelegt (dann bekomme ich einen Raum IT-irgenwas angelegt) - aber die bereits definierte Funksteckdose wird direkt anhand des Signals erkannt:

Eventconsole:
=============
2019-02-07 19:10:07 IT IT_F0000FF0FF on
2019-02-07 19:10:09 IT IT_F0000FFF0F on
2019-02-07 19:10:10 IT IT_F0000FF0FF off
2019-02-07 19:10:10 IT IT_F0000FFF0F off
2019-02-07 19:10:11 IT Schaltdose1B off
2019-02-07 19:10:14 IT Schaltdose1B on


Logauszug:
==========
2019.02.07 19:10:07 4: CUL_Parse: CUL_433 i40145115 -63.5
2019.02.07 19:10:07 5: CUL_433: dispatch i401451
2019.02.07 19:10:09 3: aCUL_433 IT: IT_F0000FFF0F ???->on
2019.02.07 19:10:09 3: aCUL_433 IT: IT_F0000FFF0F on->on
2019.02.07 19:10:09 5: CUL/RAW: /i40151114

2019.02.07 19:10:09 4: CUL_Parse: CUL_433 i40151114 -64
2019.02.07 19:10:09 5: CUL_433: dispatch i401511
2019.02.07 19:10:10 3: aCUL_433 IT: IT_F0000FFF0F on->off
2019.02.07 19:10:10 3: aCUL_433 IT: IT_F0000FF0FF on->off
2019.02.07 19:10:11 5: CUL/RAW: /i40145411

2019.02.07 19:10:11 4: CUL_Parse: CUL_433 i40145411 -65.5
2019.02.07 19:10:11 5: CUL_433: dispatch i401454
2019.02.07 19:10:11 3: aCUL_433 IT: Schaltdose1B on->off
2019.02.07 19:10:12 5: CUL/RAW: /i4011540E

2019.02.07 19:10:12 4: CUL_Parse: CUL_433 i4011540E -67
2019.02.07 19:10:12 5: CUL_433: dispatch i401154
2019.02.07 19:10:14 3: aCUL_433 IT: Schaltdose1B off->on

Also muss doch die Fernbedienung grundsätzlich den gleichen Code senden, wie FHEM via CUL - oder?
Jetzt zu meiner Frage: Wo ist mein (denk)Fehler?
Ich dachte schon, es liegt vieleicht am CUL und habe einen zweiten gebaut mit der a-Culfw - ebenfalls erfolglos.

Viele Grüße!
Tobias
« Letzte Änderung: 08 Februar 2019, 08:51:14 von seneca »

Online gloob

  • Hero Member
  • *****
  • Beiträge: 2902
Was passiert denn, wenn du die DIP Switches von Schaltdose1B genauso einstellst wie bei SchaltdoseA.

Dann müssten ja zumindest beide Dosen schalten wenn du SchaltDoseA schaltest.
« Letzte Änderung: 08 Februar 2019, 09:08:48 von gloob »
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline seneca

  • New Member
  • *
  • Beiträge: 4
Ich meine das schonmal getestet zu haben (bin mir grad nicht sicher und mach das heute Abend nochmal) - es ist als würde die Steckdose noch was erwarten, dass die FB sendet, FHEM aber nicht.

Aber da melde ich mich lieber nach nem Test nochmal....

Offline seneca

  • New Member
  • *
  • Beiträge: 4
Hallo,

das macht leider keinen Unterschied - dann reagiert die bisherige B Dose, aber die neue, gleich konfigurierte, nicht (hab natürlich auch die DIP Schalter gleich eingestellt).
Interessant ist auch, dass die über autocreate angelegten Devices keine Regung zeigen, wenn ich versuche sie über FHEM anzusteuern.

Hier noch ein paar Bilder (das 3. Bild ist die Serie die tadellos funktioniert):


Offline marcg

  • New Member
  • *
  • Beiträge: 9
Hi,

mit was hast Du denn den CUL gebaut ? Mit dem CC1101 Modul oder den anderen günstigen Modulen ?

Ich hab so einige Firmwares/Versionen mit meinen selbstgebauten CUL mit Arduino Nano & CC1101 für meine alten Elro-Steckdosen mit DIP-Schalter ausprobiert und ich kann sagen, die "kompatibleren" Funksignale hat die a-culfw https://forum.fhem.de/index.php/topic,35064.0.html generiert.

Das weiß ich deswegen so genau, weil ich auf einem Raspberry noch mein alten PILIGHT System am laufen habe. Mit der SignalDuino Firmware z.B. hat PILIGHT irgendwas erkannt, aber keine Intertechno/Elro Signale. Und die Steckdose wollte auch nur manchmal schalten. Mit der a-culfw wurde dann alles korrekt erkannt. Gut..ob jetzt PILIGHT genauer an der IT Protokoll Spec dran ist wie der Signalduino weiß ich natürlich nicht... ich habs nur gemerkt...

Marc


Offline seneca

  • New Member
  • *
  • Beiträge: 4
Der nanoCUL ist ein Arduino Nano V3 und ein 433 MHZ CC1101 (mir Aufschraubantenne). Wie gesagt - die "alten" eckigen Steckdosen schaltet der CUL (mit beiden Firmware-Versionen) problemlos. Und es wird auch erkannt, dass die im FHEM konfigurierte Dose auf der Fernbedienung angesteuert wird (FHEM erkennt anhand des aufgefangenen Signals ja sogar das Device).