Autor Thema: Neues Modul für die WS980WiFi Wetterstation  (Gelesen 49258 mal)

Offline Romoker

  • Full Member
  • ***
  • Beiträge: 171
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #255 am: 28 Juli 2021, 14:49:32 »
Zitat
D.h. ich lass das so oder steckt in dem Text ein change request? :-)

Kein Change Request. So lassen bitte.

Viele Grüße
BeagleBoneBlack & Raspberry Pi 4; FB7490; div. Homematic Komponenten; CUL433: CUL_TX, Conbee II, SOMFY, 1-Wire, Z-Wave, Zigbee, SmartPlugs von Sonoff und Shelly mit MQTT
Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline choenig

  • Developer
  • Full Member
  • ****
  • Beiträge: 404
  • Module: MieleAtHome, WS980, [ALP600]
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #256 am: 30 Juli 2021, 07:48:02 »
Guten Morgen,

Leider gar nicht :-(

Mh, da habe ich leider keine konkrete Idee.

Hast du das Device mit oder ohne IP definiert? Wenn Du es ohne definierst, versucht er, die WS980 im Netzwerk zu finden. Funktioniert das?

Hast du gleichzeitig noch einen anderen Client verbunden? Das gibt nämlich auch Probleme (das merke ich immer, wenn ich neue Versionen in meiner fhem-dev Umgebung teste).

LG
Christian

Offline aruttkamp

  • New Member
  • *
  • Beiträge: 16
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #257 am: 03 August 2021, 20:45:50 »
Vielen Dank , Christian !
Nachdem ich nun alles von vorne bis hinten geprüft habe die erschreckende Wahrheit ...
Die IP war falsch. Also mein Fehler ..
DANKE !

Gefällt mir Gefällt mir x 1 Liste anzeigen

Offline dancatt

  • Sr. Member
  • ****
  • Beiträge: 539
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #258 am: 04 August 2021, 11:27:59 »
Moin,

mein Log ist die ersten 3 August-Tage voll mit folgenden Meldungen:
2021.08.03 09:52:27.732 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
[0 67 127 255 0 0 68 127 255 0 0 70 60 2 52 71 255 0 0 72 38 168 9 52 73 38 168 9 52 ]
[00 43 7f ff 00 00 44 7f ff 00 00 46 3c 02 34 47 ff 00 00 48 26 a8 09 34 49 26 a8 09 34 ]
2021.08.03 09:52:27.857 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
[0 67 127 255 0 0 69 127 255 0 0 70 62 0 0 71 255 0 0 72 38 188 0 3 73 38 188 0 3 75 255 255 0 0 76 255 255 0 0 78 0 0 0 0 0 0 85 0 255 255 255 0 0 86 255 255 0 0 87 255 0 0 ]
[00 43 7f ff 00 00 45 7f ff 00 00 46 3e 00 00 47 ff 00 00 48 26 bc 00 03 49 26 bc 00 03 4b ff ff 00 00 4c ff ff 00 00 4e 00 00 00 00 00 00 55 00 ff ff ff 00 00 56 ff ff 00 00 57 ff 00 00 ]
2021.08.03 09:53:32.151 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
[9 52 ]
[09 34 ]
2021.08.03 09:54:34.566 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
[9 52 ]
[09 34 ]

Ist das schon bekannt?

Vielen Dank.

Gruß Daniel
Cubietruck: FHEM-Server 6.0

Homematic: HM-USB-CFG2, HM-CFG-LAN, HM-LC-SW1-FM, HM-LC-Sw1-Pl-DN-R1, HM-CC-RT-DN, HM-TC-IT-WM-W-EU, HM-SEC-SC-2, HM-SEC-SD, HM-PB-6-WM55

Offline choenig

  • Developer
  • Full Member
  • ****
  • Beiträge: 404
  • Module: MieleAtHome, WS980, [ALP600]
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #259 am: 04 August 2021, 21:13:02 »
Wow, das ist mich nicht bekannt,

ich weiss auch noch gar nicht, wo das herkommt.

Ich melde mich wieder, aber vor dem Wochenende habe ich vermutlich wenig Zeit :(

LG
Christian

Offline Romoker

  • Full Member
  • ***
  • Beiträge: 171
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #260 am: 05 August 2021, 09:48:10 »
@dancat
Zitat
Ist das schon bekannt?
Du hast wahrscheinlich das neue Attribut "invalidValues skipAndLog" in Deinem WS989WIFI-Objekt aktiviert. Siehe https://forum.fhem.de/index.php/topic,97441.msg1167591.html#msg1167591

Viele Grüße
BeagleBoneBlack & Raspberry Pi 4; FB7490; div. Homematic Komponenten; CUL433: CUL_TX, Conbee II, SOMFY, 1-Wire, Z-Wave, Zigbee, SmartPlugs von Sonoff und Shelly mit MQTT

Offline dancatt

  • Sr. Member
  • ****
  • Beiträge: 539
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #261 am: 02 September 2021, 07:02:24 »
Moin,

mein Log ist immer noch voll von folgenden Meldungen:
2021.09.02 00:01:54.330 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
[0 67 127 255 0 0 69 127 255 0 0 70 62 0 0 71 255 0 0 72 39 41 0 0 73 39 41 0 0 75 255 255 0 0 76 255 255 0 0 78 0 0 0 0 0 0 85 0 255 255 255 0 0 86 255 255 0 0 87 255 0 0 ]
[00 43 7f ff 00 00 45 7f ff 00 00 46 3e 00 00 47 ff 00 00 48 27 29 00 00 49 27 29 00 00 4b ff ff 00 00 4c ff ff 00 00 4e 00 00 00 00 00 00 55 00 ff ff ff 00 00 56 ff ff 00 00 57 ff 00 00 ]
2021.09.02 00:01:54.461 1: ws980wifi (WS980::WS980_error:1369) ERROR: 0 not found
Unabhängig was im Attribut "invalidValues" steht.
Was sollte denn da stehen?

Zusätzlich dazu wurde das Reading brightness seit gestern um 20:17:48 nicht mehr aktualisiert. Passiert aktuell öfters.
Das hat zur Folge dass einige Lampen und die Rollläden nicht funktionieren.
Weiß jemand was hier das Problem sein könnte?

Vielen Dank.

Gruß Daniel
Cubietruck: FHEM-Server 6.0

Homematic: HM-USB-CFG2, HM-CFG-LAN, HM-LC-SW1-FM, HM-LC-Sw1-Pl-DN-R1, HM-CC-RT-DN, HM-TC-IT-WM-W-EU, HM-SEC-SC-2, HM-SEC-SD, HM-PB-6-WM55

Offline choenig

  • Developer
  • Full Member
  • ****
  • Beiträge: 404
  • Module: MieleAtHome, WS980, [ALP600]
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #262 am: 02 September 2021, 08:06:41 »
Guten Morgen,

könntest Du mal verbose auf 5 stellen und dann nochmal den 'not found' error posten inkl. vorangegangenem log ab "Sending new request for"?

Ich hab' das leider kein einziges mal in meinem Log.

LG
Christian
« Letzte Änderung: 02 September 2021, 08:10:37 von choenig »

Offline atze2010

  • New Member
  • *
  • Beiträge: 10
Antw:Neues Modul für die WS980WiFi Wetterstation
« Antwort #263 am: 23 November 2021, 07:31:11 »
Hallo,
erst mal vielen Dank für dieses gute Modul, was ich schon sehr lange problemlos im Einsatz habe!
Ich habe seit längerer Zeit im Log diese Einträge:
2021.11.23 01:53:01 1: WS980 (WS980::WS980_ReadFn:948) looks like the reply could not be decoded, skipping
2021.11.23 01:56:01 1: WS980 (WS980::WS980_ReadFn:948) looks like the reply could not be decoded, skipping
2021.11.23 02:02:01 1: WS980 (WS980::WS980_ReadFn:948) looks like the reply could not be decoded, skipping
Dabei fällt mir jetzt auf, dass dies immer nur auftritt, wenn die Sekunde der Abfragezeit auf "01" steht. Alle anderen Abfragen, die laut Intervall außerhalb dieser Zeit liegen, laufen ordnungsgemäß durch.
Es werden immer genau so lange diese Fehlerzeilen geschrieben, bis sich das Intervall wegen der internen Verzögerungen wieder auf eine andere Sekunde verschiebt.
Ist das nur bei mir so? (Habe zusätzlich zu FHEM noch ein anderes Anzeigemodul für die Wetterdaten laufen, welches die FHEM-WS980-Daten per Websocket abfragt, kann aber damit eigentlich nix zu tun haben).
Danke und viele Grüße Uwe

 

decade-submarginal