Autor Thema: Problem Zusammenspiel von MQTT2_Server mit Alexa Interface  (Gelesen 692 mal)

Offline Huehni

  • New Member
  • *
  • Beiträge: 29
Hallo zusammen,

ich habe folgendes Problem / Beobachtung im Zusammenspiel von MQTT2_Server / MQTT2_Device mit dem Alexa Interface auf meinem Raspi. Vielleicht weiß da jemand einen Rat oder ist es ein Bug?

Mein Setup: Ich habe eine Trafädi LED-Leuchte im Flur, die mittels eines CC2531 Stick, zigbee2mqtt sowie einen MQTT2_Server als MQTT2_Device erfolgreich in FHEM eingebunden habe.

Meine Beobachtung: Über FEHM kann ich die Leuchte normal an und ausschalten. Über die Alexa App geht das auch. Aber wenn ich die Leuchte mit der Alexa App ausschalte, denn wird der Status nach kurzer Zeit wieder als "eingeschaltet" angezeigt. Wenn ich aber die LED Leuchte im Flur über den Wandschalter "hart" ausschalte, dann bleibt der Status in der Alexa App auf "ausgeschaltet".

Kann mir hier jemand weiter helfen?

Gruß,
Hühni
RaPi B+; CUL V3 - FW 1.62.07_build_63; 6x ITR-1500; 2x ITT-1500; 1x CMR-1000; 1x YWT-8500; 3x Somfy RTS; GRR-3500; AVM DECT-200; FB 7490

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 16331
Antw: Problem Zusammenspiel von MQTT2_Server mit Alexa Interface
« Antwort #1 am: 19 März 2019, 10:01:40 »
Vielleicht zeigst du uns ein list von dem MQTT2_DEVICE?

(Ich würde darauf tippen, dass du auch was an der configuration-yaml geändert hast, so dass regelmäßig ein "online"-Signal kommt; das setzt dann den state auf "on", wenn die Bulb online ist, also am Stromnetz hängt. Sowas hatte ich mal - ohne Berücksichtigung weiterer Schaltmöglichkeiten von dritter Seite - mit einem userreading gemacht (?).)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn:MySensors, Weekday-&RandomTimer, Twilight,  AttrTemplate {u.a. mqtt2, mysensors, zwave}