FHEM - Hausautomations-Systeme > SlowRF

S300TH Warnung bei bestimmter LUftfeuchtigkeit

<< < (3/4) > >>

Martin Fischer:
versuch es doch mal über den von mir beschriebenen weg..

reacend:
Hi Markus,
also ich verstehe es nicht, auch wenn ich dein Modul in den FHEM ordner packe und nen shutfdown mache und fhem manuell neustarte geht die fb_mail funktion nicht in telnet... Ist eventuell grad ein BUG irgendwo?

Bitte helfen, will doch einfach nur mails versenden.

BG


--- Zitat von: Markus schrieb am So, 30 Dezember 2012 13:19 ---meine 99_emailUtils.pm


vieleicht hilft es dir ja, ich hab aber ein fritz box.



--- Code: ---##############################################
# $Id: 99_myUtils.pm $
package main;

use strict;
use warnings;
use POSIX;


sub
emailUtils_Initialize($$)
{
my ($hash) = @_;
}

sub fb_mail {
my $rcpt = $_[0];
my $subject = $_[1];
my $text = $_[2];
system("echo \"$text\" > fhem_nachricht.txt");
system("mailer send -i 'fhem_nachricht.txt' -s \"$subject\" -t \"$rcpt\"");
system("rm fhem_nachricht.txt");
}

1;
--- Ende Code ---


Gruß Markus
--- Ende Zitat ---

Puschel74:
Hallo,

Achtung! Markus setzt seine Mail-Routine auf seiner FritzBox ein.
Das kannst du nicht so ohne weiteres auf dein Ubuntu übertragen (vermute ich mal).

Was ist den mit dem, von Martin, beschriebenen Weg?
Er benennt in dem angegebenen Link explizit sendEmail für sein System.
Evtl. hast du ja damit mehr Glück.

Grüße

reacend:
Hi,
naja der weg gefällt mir nicht ich möchte nciht extra noch ein bash script einsetzten... Aber eventuell nutzte ich seine system("") Methode...

Ich warte aber erstmal ab eventuell ist ja ein BUG im FHEM und beim nächsten update ist er weg..


BG,
reacend

Puschel74:
Hallo,

naja. An einen Bug in FHEM glaube ich fast nicht da der Mailversand bei
mehreren einwandfrei funktioniert.
Egal ob über FB oder Linux (oder auch Win??).

Grüße

Navigation

[0] Themen-Index

[#] Nächste Seite

[*] Vorherige Sete

Zur normalen Ansicht wechseln