Autor Thema: Nach define von Intertechno verschwindet der CUL  (Gelesen 3227 mal)

KatalytischerKonverter

  • Gast
Nach define von Intertechno verschwindet der CUL
« am: 31 Dezember 2012, 12:22:17 »
Hallo Zusammen,

ich komme gerade bei meinen ersten Versuchen nicht so recht weiter.

Ich nutze FHEM 5.3 auf der Fritzbox mit CUL868. Die Config ist noch Standard bis auf:

define ELROA1 IT 000000000F 11 10
attr ELROA1 IODev CUL_0
attr ELROA1 model itswitch

(Ist eine Beispiel-Config von der Mailingliste)

Der CUL wird nach dem starten des Routers als CUL_0 erkannt. Sobald ich nun den oben genannten Teil in die Config einfüge verschwindet der CUL aus unsortet und everything.
Starte ich die Fritzbox nun neu, verschwindet "attr ELROA1 IODev CUL_0" aus der Config.

Stehe da gerade auf dem Schlauch....habe schon gesucht wie verrückt :(

Offline Fennek

  • Full Member
  • ***
  • Beiträge: 114
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #1 am: 31 Dezember 2012, 13:42:23 »
Hallo,

wie ist denn Dein CUL definiert sollte so aussehen


define CUL01 CUL /dev/ttyACM0@9600 xxxx
attr CUL01 rfmode SlowRF
FHEM Cubietruck mit 50GB SSD
HMLAN: TC,VD,DN,DIM,SW,SEC,TH
HUEBridge, HUEDevice:LCT,LLC
Sonos: 5xPL1,2xPB,2xSUB
iBeacon's

Offline Fennek

  • Full Member
  • ***
  • Beiträge: 114
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #2 am: 31 Dezember 2012, 13:47:01 »
ich habe noch vergessen

was sagt das log dazu?

FHEM Cubietruck mit 50GB SSD
HMLAN: TC,VD,DN,DIM,SW,SEC,TH
HUEBridge, HUEDevice:LCT,LLC
Sonos: 5xPL1,2xPB,2xSUB
iBeacon's

KatalytischerKonverter

  • Gast
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #3 am: 02 Januar 2013, 14:52:04 »
Hallo Andreas,

erstmal vielen Dank für deine Mühe!

Ich habe den CUL nun so definiert wie von dir geschrieben.
Hier meine Config:
attr global logfile ./log/fhem-%Y-%m.log
attr global modpath .                  # where our FHEM directory is
attr global statefile ./log/fhem.save  # where to save the state of the devices
attr global verbose 3                  # "normal" verbosity (min 1, max 5)

define telnetPort telnet 7072 global   # our TCP/IP port

define WEB FHEMWEB 8083 global

define WEBphone FHEMWEB 8084 global
attr WEBphone smallscreen

define WEBtablet FHEMWEB 8085 global
attr WEBtablet touchpad

# Fake FileLog entry, to access the fhem log from FHEMWEB
define Logfile FileLog ./log/fhem-%Y-%m.log fakelog

define autocreate autocreate
attr autocreate autosave
attr autocreate device_room %TYPE
attr autocreate filelog ./log/%NAME-%Y.log
attr autocreate weblink
attr autocreate weblink_room Plots

# Disable this to avoid looking for new USB devices on startup
define initialUsbCheck notify global:INITIALIZED usb create


# If the above notify did not helped, then you probably have to enable some of
# the following lines.  Verify first that /dev/xxx ist correct.

#define FHZ FHZ /dev/USB0
#define CUL CUL /dev/ttyACM0@9600 1234
#attr CUL rfmode HomeMatic

#define EUL TCM 310 /dev/ttyACM0@57600
#define BscBor TCM 120 /dev/ttyUSB0@9600
#define BscSmartConnect TCM 310 /dev/ttyUSB0@57600

#FB_checkPw does not for FB-OS > 5.22
#attr WEB basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr WEBphone basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr WEBtablet basicAuth {use FritzBoxUtils;;FB_checkPw("localhost","$password") }
#attr telnetPort globalpassword {use FritzBoxUtils;;FB_checkPw("localhost","$password") }

define CUL01 CUL /dev/ttyACM0@9600 0000
attr CUL01 rfmode SlowRF

define ELROA1 IT FFFFFF000F 11 10
attr ELROA1 IODev CUL01
attr ELROA1 model itswitch


Mein Log:
2013.01.02 14:44:11 1: Including fhem.cfg
2013.01.02 14:44:11 3: telnetPort: port 7072 opened
2013.01.02 14:44:11 3: WEB: port 8083 opened
2013.01.02 14:44:11 3: WEBphone: port 8084 opened
2013.01.02 14:44:11 3: WEBtablet: port 8085 opened
2013.01.02 14:44:11 3: Opening CUL01 device /dev/ttyACM0
2013.01.02 14:44:11 3: Setting CUL01 baudrate to 9600
2013.01.02 14:44:11 3: CUL01 device opened
2013.01.02 14:44:12 3: CUL01: Possible commands: BCFiAZEGMRTVWXefmltux
2013.01.02 14:44:12 3: No I/O device found for ELROA1
2013.01.02 14:44:12 1: Including ./log/fhem.save
2013.01.02 14:44:44 1: Including fhem.cfg
2013.01.02 14:44:45 3: telnetPort: port 7072 opened
2013.01.02 14:44:45 3: WEB: port 8083 opened
2013.01.02 14:44:45 3: WEBphone: port 8084 opened
2013.01.02 14:44:45 3: WEBtablet: port 8085 opened
2013.01.02 14:44:45 3: Opening CUL01 device /dev/ttyACM0
2013.01.02 14:44:45 3: Setting CUL01 baudrate to 9600
2013.01.02 14:44:45 3: CUL01 device opened
2013.01.02 14:44:45 3: CUL01: Possible commands: BCFiAZEGMRTVWXefmltux
2013.01.02 14:44:45 3: No I/O device found for ELROA1
2013.01.02 14:44:45 1: Including ./log/fhem.save
2013.01.02 14:50:16 2: IT set ELROA1 on
2013.01.02 14:50:18 2: IT set ELROA1 off
2013.01.02 14:50:21 2: IT set ELROA1 on


Hast du eine Idee wieso "No I/O Device found" gemeldet wird?

Offline Fennek

  • Full Member
  • ***
  • Beiträge: 114
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #4 am: 02 Januar 2013, 16:25:53 »
Hallo,

schön das ich Dir helfen konnte.

Der log Eintrag erscheint bei mir auch trotz definierten IO device.

Scheint normal zu sein.

Noch ein Hinweis zum CUL868

Du kannst Ihn auch so konfigurieren

define CUL01 CUL /dev/ttyACM0@9600 1234
attr CUL01 rfmode HomeMatic

somit hast Du den Vorteil das er als Standard HomeMatic (868Mhz)Devices schaltet aber bei
Bedarf temporär in den IT SlowRF Modus wechselt um Deine ELRO's zu schalten und wieder zurück.

Wenn Du darüber mehr Infos brauchts scheue nicht einen Blick in:  http://culfw.de/culfw.html

:-)
FHEM Cubietruck mit 50GB SSD
HMLAN: TC,VD,DN,DIM,SW,SEC,TH
HUEBridge, HUEDevice:LCT,LLC
Sonos: 5xPL1,2xPB,2xSUB
iBeacon's

Offline broadway

  • Full Member
  • ***
  • Beiträge: 218
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #5 am: 02 Januar 2013, 18:28:25 »
Zitat von: KatalytischerKonverter schrieb am Mi, 02 Januar 2013 14:52

Hast du eine Idee wieso "No I/O Device found" gemeldet wird?


Du hast ja keinen Intertechno I/O device! Der CUL kann diese ja nur "nebenbei" steuern. Ist aber normal, kommt bei mir auch.
Linksys NSLU2 debian + CUL | FHT80B, FS20, Elro

KatalytischerKonverter

  • Gast
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #6 am: 02 Januar 2013, 21:24:18 »
Habe ich nun gemacht....puh...ich hatte allerdings nicht damit gerechnet, dass die Steckdose so unzuverlässig schalten!
Zum testen reicht es erstmal....

Nun mal schauen wie ich es schaffe meinen Raspberry automatisch zu pingen und bei fehlender Antwort zu resetten :)


Online MarkusN

  • Full Member
  • ***
  • Beiträge: 245
    • Markus´ Blog
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #7 am: 02 Januar 2013, 21:38:28 »
Hallo,

was bedeutet für dich denn unzuverlässig? Wie viel Prozent der Schaltbefehle werden nicht umgesetzt? Welche Entfernung/Bebauung hast du zwischen CUL und den Steckdosen, und welche Antenne hast du am CUL? Ich möchte mir demnächst einen CUNO kaufen und damit u.A. auch Elros/ITs schalten, wenn das aber tatsächlich derart unzuverlässig ist werde ich mir das wohl noch mal überlegen müssen.

Grüße,

Markus

Offline Fennek

  • Full Member
  • ***
  • Beiträge: 114
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #8 am: 02 Januar 2013, 21:40:22 »
ja ist so,

ich habe auch keine guten Erfahrungen mit Elro und Ablegern davon.

Ist sehr Funkfeld und Entfernungsabhängig.

FHEM Cubietruck mit 50GB SSD
HMLAN: TC,VD,DN,DIM,SW,SEC,TH
HUEBridge, HUEDevice:LCT,LLC
Sonos: 5xPL1,2xPB,2xSUB
iBeacon's

KatalytischerKonverter

  • Gast
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #9 am: 02 Januar 2013, 21:42:58 »
Also da ich die Steckdose gerade erst teste solltest du eigentlich besser die fragen die diese schon länger einsetzen....

Beim testen waren 2 Meter dazwischen....allerdings haben wir hier sehr sehr viele WLANs etc.

Nachdem ich die Steckdose nun mal vom Netz genommen habe, hat sie alle Schaltbefehle ausgeführt.
Kann dir aber gern noch mal eine Rückmeldung geben wenn ich sie im richtigen Betrieb habe.

Offline Fennek

  • Full Member
  • ***
  • Beiträge: 114
Aw: Nach define von Intertechno verschwindet der CUL
« Antwort #10 am: 02 Januar 2013, 22:08:17 »
Hi Markus,

hier mal meine Installation :

1 x FB 7390 im Obergeschoss mit fhem und CUL868 im SlowRF Modus für 4 ELRO AB440
            Abstand der ELRO's vom CUL zwischen 3 und 5 m
            Schalterfolg ca 70%
1 x FB 7390 im Untergeschoss mit HMLAN-CFG zur Steuerung von einigen HM-TC,DIM und Switchen
            auf beiden Etagen
            Schalterfolg 98%

es gibt noch eine Alternative FS20.
FHEM Cubietruck mit 50GB SSD
HMLAN: TC,VD,DN,DIM,SW,SEC,TH
HUEBridge, HUEDevice:LCT,LLC
Sonos: 5xPL1,2xPB,2xSUB
iBeacon's