Autor Thema: [Gelöst] MQTT für WLED, rgb reading mit # klappt nicht  (Gelesen 5723 mal)

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Hi,

ich versuche gerade WLED per MQTT anzusprechen (https://github.com/Aircoookie/WLED/wiki/MQTT).
Das funktioniert auch soweit ich in rgb #hexwert gebe.
Geliefert wird von WLED auch wieder #hexwert.

Nun wollte ich gern den Colorpicker verwenden. Der schein nur hexwert zu liefern.
Ich habe mich in den mqtt2.templates umgesehen und da bin ich bei zigbee auch fündig geworden und habe etwas in dieser Art gefunden:
  hex:colorpicker,HEX,0,15,255 BASE_TOPIC/DEV_ID/set {"color":{"$EVTPART0":"#$EVTPART1"}}
Das habe ich versucht für mein Device in
  rgb:colorpicker,HEX  wled/TestLED/col {"#$EVTPART1"}
anzupassen. Leider funktioniert das nicht.

Kann mir jemand bitte auf die Sprünge helfen?

Das List meines MQTT Devices, funktionsfähig ohne Colorpicker sieht so aus:
Internals:
   CID        a020a621c6c3
   DEF        a020a621c6c3
   DEVICETOPIC MQTT2_a020a621c6c3
   FHEM_MQTT2_MSGCNT 16
   FHEM_MQTT2_TIME 2019-03-22 21:13:47
   FUUID      5c93e232-f33f-0c45-f528-70f8b16469d9e705
   IODev      FHEM_MQTT2
   LASTInputDev FHEM_MQTT2
   MSGCNT     16
   NAME       MQTT2_a020a621c6c3
   NR         1213
   STATE      rgb
   TYPE       MQTT2_DEVICE
   OLDREADINGS:
   READINGS:
     2019-03-22 21:13:47   pct             127
     2019-03-22 21:13:47   rgb             #FF9F99
     2019-03-22 21:13:47   state           rgb
Attributes:
   IODev      FHEM_MQTT2
   devStateIcon {Color::devStateIcon( $name, "rgb" );}
   readingList a020a621c6c3:wled/TestLED/g:.* pct
a020a621c6c3:wled/TestLED/c:.* rgb
   room       MQTT2_DEVICE
   setList    rgb wled/TestLED/col
pct wled/TestLED

Gruß und Danke,
Stefan

« Letzte Änderung: 22 März 2019, 23:51:49 von stefanru »

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #1 am: 22 März 2019, 22:28:49 »
Versuch's mal mit
rgb:colorpicker,HEX  wled/TestLED/col #$EVTPART1
Erläuterung: zigbee&Co wollen die Anweisungen als JSON verpackt. Das scheint bei dir nicht erforderlich zu sein. Das ist aber ausdrücklich eine Annahme und kann auch falsch sein. Solltest du dann noch was brauchen, wäre es hilfreich, wenn du eine komplette Sendeanweisung liefern könntest.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #2 am: 22 März 2019, 23:51:32 »
Hi Beta-User,
super das wars!

Vielen Dank für die Erklärung.

Gruß,
Stefan

Offline f-zappa

  • Full Member
  • ***
  • Beiträge: 105
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #3 am: 28 März 2019, 13:18:55 »
Ich habe auch ein WLED-Objekt (ein umgebauter Leuchtspiegel aus den 60ern, sieht schweinegeil aus). Eine FHEM-Anbindung habe ich dafür noch nicht gebaut, weil mir "There is no support for authentication/encryption at this time" nicht wirklich behagt.
Inzwischen hat WLED aber auch eine JSON-API, die man bestimmt gut via HTTPMOD ansprechen kann (wenn man nicht gleich ein eigenes Modul bauen möchte).
Hat da vielleicht schon jemand etwas fertig?

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #4 am: 28 März 2019, 13:23:45 »
@f-zappa:
Was spricht dagegen, das mit MQTT anzusprechen? Wenn ich das richtig deute, funktioniert das im Prinzip problemlos bei stefanru...

Wären genau 2 Devices: Ein MQTT2_SERVER (auch für anderes zu nutzen) und ein MQTT2_DEVICE.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline f-zappa

  • Full Member
  • ***
  • Beiträge: 105
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #5 am: 28 März 2019, 13:36:11 »
Was spricht dagegen, das mit MQTT anzusprechen? Wenn ich das richtig deute, funktioniert das im Prinzip problemlos bei stefanru...
Noch mal das Zitat: "There is no support for authentication/encryption at this time"
Ich muss meinen MQTT-Server dann für unauthentifizierte Zugriffe öffnen. Jeder darf dran, ohne Credentials angeben zu müssen. Das widerstrebt mir.

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #6 am: 28 März 2019, 13:41:09 »
Ah ok, irgendwie hatte ich den Link zwischen dem MQTT2_SERVER und diesem Text noch nicht...

Könntest du diesem speziellen Client ein eigenes allowed gönnen?
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #7 am: 12 April 2019, 22:38:42 »
Hi,

hätte noch eine kleine Frage:
Das mit RGB senden geht nun super.
Leider ist es so das WLED in einem Topic die RGB Farbe liefert und in einem anderen kann ich sie setzen.

Also mit    
rgb:colorpicker,HEX wled/a020a621c6c3/col #$EVTPART1
setze ich zur Zeit die RGB Farbe.

Ändere ich sie nun an der Lampe direkt bekomme ich das über
a020a621c6c3:wled/a020a621c6c3/c:.* rgb
mitgeteilt.

Hier wird der Wert auch wieder mit # gesendet.
Leider kann damit der colorpicker wieder nix anfangen.
Kann man das # am Anfang beim Empfangen auch irgendwie wegschneiden?

Gruß und Danke,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #8 am: 13 April 2019, 10:37:33 »
Das Wegschneiden sollte gehen, du brauchst aber "hinten" dann Perl:

Würde mal folgendes testen:
a020a621c6c3:wled/a020a621c6c3/c:.* {{"rgb"=>substr($EVENT,1,6)}} Kann aber sein, dass du den substr erst in eine Variable packen mußt usw..

Bei der Gelegenheit:
Scheint ein Device zu sein, für den es noch kein attrTemplate gibt. Vielleicht magst du was beisteuern? Wenn du Hilfe benötigst, würde mich neben ein paar Infos zum Gerät selbst eine RAW-Definition hier weiterbringen, optimalerweise mit den unveränderten default-Topic-Strukturen.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #9 am: 13 April 2019, 14:37:40 »
Hi Beta-User,

super hat geklappt.
Natürlich, sehr gerne steuer ich ein attrTemplate bei.

Muss das aber erstmal zum laufen bringen. An / Aus fehlt mir noch.
Sollte gehen in dem man on/off an das main topic sendet.

Ich melde mich bei fragen oder wenn ich es soweit zusammen habe.

Ansteuern tue ich einen ESP8622 auf dem WLED läuft:
https://github.com/Aircoookie/WLED/wiki/MQTT

WLED ist ziemlich gut für RGB Stripes WS2812.

Gruß,
Stefan


Offline Sharky69

  • Newbie
  • Beiträge: 2
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #10 am: 23 Oktober 2019, 17:03:54 »
Hallo Stefan,

ich habe auch eine WS218B-LED-Streifen mit der WLED-Software ausgestattet. Läuft sehr gut über das Webinterface. Allerdings habe ich es bisher noch nicht in FHEM integriert. Deswegen wäre ich sehr dankbar für Deine Unterstützung. Kannst Du vielleicht Dein Template mit einer kurzen Anleitung posten, auch wenn es noch nicht ganz perfekt ist?
Da wäre ich Dir sehr dankbar!

LG

Michael

Offline projectsun

  • Jr. Member
  • **
  • Beiträge: 52
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #11 am: 13 November 2019, 00:50:42 »
Hallo,

ich würde mich auch über ein template freuen. Helligkeit setzen klappt, on/off senden bewirkt nur einen toggle und RGB macht mir nur schwarz, also aus
Zentrale Ubuntu, Rpi B+ mit Busware 868 CUL ser2net, Rpi 2 an Aquarium mit DS18B20, und S0Counter, Rpi 3 mit nanoCUL 433 und 868 ser2net, 7x Revolt NC-5462, 1x miniCUL WLAN, 3x IT-1000, 6x ELRO AB440, KS300, EM1000-HSM, EM1000-WZ, FHT80B, 5x FHT8v2, 20x Nodemcu mit Sensoren, 6x Echo, Sonos

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #12 am: 15 November 2019, 07:25:57 »
Wenn jemand ein list (bitte nur mit dem, was funktioniert bzw. Hinweisen, was ggf. nicht) beitragen könnte, wäre das schon mal hilfreich. Die Kommandos an sich scheinen (bis auf den col-Teil) recht einfach zu sein.

Allerdings steht da auf der Seite "MQTT-Interface wird grade überarbeitetet (breaking change)". Das hat demnach eher vorläufigen Charakter...
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #13 am: 21 November 2019, 18:49:20 »
Hi,

sorry ich war eine Zeitlang nicht mehr hier.
Habe jetzt erst gesehen dass hier Interesse besteht.

Ich bin sehr zufrieden mit der MQTT implementierung, mittlerweile läuft es super stabil.

Ich weiß leider nicht wie ich so ein attrTemplate aus meinen Daten erstellen kann.

Hier erstmal ein List in dem alles drinsteht. Bei Gelegenheit schaue ich mal wie ich ein attrTemplate erzeugen kann.
Internals:
   CID        a020a621c6c3
   DEF        a020a621c6c3
   DEVICETOPIC KuechenLicht
   FUUID      5cd1d0d2-f33f-0c45-e918-02b2175584076a07
   IODev      myMQTT2Client
   LASTInputDev myMQTT2Client
   MSGCNT     1286
   NAME       KuechenLicht
   NR         1231
   STATE      brightness
   TYPE       MQTT2_DEVICE
   myMQTT2Client_MSGCNT 1286
   myMQTT2Client_TIME 2019-11-21 08:08:22
   READINGS:
     2019-11-21 08:08:22   api             <?xml version="1.0" ?><vs><ac>0</ac><cl>255</cl><cl>191</cl><cl>0</cl><cs>0</cs><cs>0</cs><cs>0</cs><ns>0</ns><nr>1</nr><nl>0</nl><nf>1</nf><nd>60</nd><nt>0</nt><fx>0</fx><sx>75</sx><ix>128</ix><fp>0</fp><wv>-1</wv><ws>0</ws><md>1</md><cy>0</cy><ds>Kuechenlicht</ds></vs>
     2019-08-31 21:00:06   bewegung        0
     2019-11-21 08:08:22   brightness      0
     2019-11-21 08:08:22   rgb             FFBF00
     2019-11-13 01:14:50   state           brightness
Attributes:
   IODev      myMQTT2Client
   devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" );}
   group      Licht
   icon       hue_filled_iris
   readingList myMQTT2Client:wled/kuechenlicht/g:.* brightness
myMQTT2Client:wled/kuechenlicht/c:.* {{"rgb"=>substr("$EVENT",1,6)}}
myMQTT2Client:wled/kuechenlicht/v:.* api
   room       EG,MQTT2_DEVICE
   setList    rgb:colorpicker,RGB wled/kuechenlicht/col #$EVTPART1
brightness:colorpicker,BRI,0,1,255 wled/kuechenlicht
status:on,off,t wled/kuechenlicht
   webCmd     rgb:brightness
   widgetOverride rgb:colorpicker,HSV

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #14 am: 23 November 2019, 12:34:30 »
Danke für das list (für attrTemplate-Erstellung ist RAW tendenziell einfacher, hätte ich deutlicher sagen sollen...).

Würde das mal "auf Verdacht" so einchecken, aber wenn es jemand testen würde und kurzfristig Rückmeldung geben, wenn was verbessert werden kann: Danke...

Versuchsweise Änderungen gg. das list:
- Das widgetOverride sollte jetzt direkt  in der readingList stecken
- getrennte on/off/toggle (?)-setter

#source post: https://forum.fhem.de/index.php/topic,98880.msg995308.html#msg995308
name:wled_controller
filter:TYPE=MQTT2_DEVICE
desc:To control a WLED device, see https://github.com/Aircoookie/WLED/wiki for details).
order:W_01
par:BASE_ID;BASE_ID typically is wled;{ AttrVal("DEVICE","readingList","") =~ m,([^:]+)[/][^/]+[/].*:, ? $1 : undef }
par:DEVNAME;Device name as configured;{ AttrVal("DEVICE","readingList","") =~ m,([^:]+)[/]([^/]+)[/].*:, ? $1 : undef }
par:ICON;ICON as set, defaults to hue_filled_iris;{ AttrVal("DEVICE","icon","hue_filled_iris") }
attr DEVICE icon ICON
attr DEVICE setList\
  on:noArg BASE_ID/DEVNAME status on\
  off:noArg BASE_ID/DEVNAME status on\
  toggle:noArg BASE_ID/DEVNAME status t\
  rgb:colorpicker,HSV BASE_ID/DEVNAME/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 BASE_ID/DEVNAME
attr DEVICE readingList \
  BASE_ID/DEVNAME/g:.* brightness\
  BASE_ID/DEVNAME/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  BASE_ID/DEVNAME/v:.* api
deletereading -q DEVICE (?!associatedWith).*
attr DEVICE devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
attr DEVICE webCmd rgb:brightness
attr DEVICE model wled_controller
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #15 am: 23 November 2019, 21:02:40 »
Hi Beta-User,

ich teste das sehr gerne.
Habe gerade ein Update gemacht aber noch kein Template gefunden.

Gib mal bescheid wenn du es fertig hast dann teste ich es mit meinen WLEDs.
Habe gerade alle auf die neueste Version gehoben.

P.S.: Hier ist die MQTT beschreibung von Wled. Ist aber mittlerweile etwas outdated. Es geht mittlerweile auch mit secure connection.

Gruß und Danke,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #16 am: 24 November 2019, 09:03:09 »
Hi Stefan,

die Frage war eigentlich, ob es getestet werden kann vor der Verteilung via update ;D .

Zum Testen findest du unter https://wiki.fhem.de/wiki/AttrTemplate#Eigene_Templates_entwickeln eine kurze Anleitung mit weiteren Links.

Sollte in deinem letzten Post eigentlich ein Link sein?
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #17 am: 24 November 2019, 11:21:02 »
Hi Beta-User,

:-) jetzt verstehe ich erst. Dein Post ist das attrTemplate. Da war ich ja voll auf dem schlauch gestanden.
Klar ich teste es und melde mich.

Ja ich wollte einen link mit rein hängen:
https://github.com/Aircoookie/WLED/wiki/MQTT
Wie gesagt leider zur Zeit nicht ganz aktuell.

Gruß,
Stefan


Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #18 am: 24 November 2019, 13:09:45 »
Ok habs ausprobiert.

Hast noch nen kleinen bug drin bei off steht am ende on, da muss auch off hin.
Ansonsten tut es, gefällt mir gut.

Hast du noch eine Idee wegen des colorpickers?
Im Device Overview tut es wie gewünscht. Aber wenn man RGB bei set auswählt und dort etwas einstellt kommt folgende Meldung:
fhemweb_colorpicker.js line 85:
Uncaught TypeError: cmd is not a function

Gruß,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #19 am: 24 November 2019, 13:24:33 »
Sorry wg. dem off, das korrigiere ich direkt...

Was den Colorpicker angeht: Funktioniert das, wenn man das via widgetOverride einstellt wie in deinem List?
(Wenn auch da ein Bug ist, sollte sich das Rudi (?) mal ansehen (=> gesonderte Meldung bei FHEMWEB). MMn. sollte es keinen Unterschied machen, an welcher Stelle das widget definiert wird; wenn doch, wäre das ggf. was, was hier als "feature" von MQTT2_DEVICE beschrieben werden sollte...)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #20 am: 24 November 2019, 13:40:26 »
Hi Beta-User,
nein das tut auch bei mir nicht. Gleicher Fehler.

Das Thema wird hier schon diskutiert, die Diskussion ist aber alt. Rudi war da auch schon kurz dabei.
https://forum.fhem.de/index.php?topic=90589.0

Irgendwie fehlen wohl parameter, mir ist aber nicht klar welche.

Danke und Gruß,
Stefan

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21666
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #21 am: 24 November 2019, 22:53:02 »
Ich bin eigentlich nicht zustaendig, da colorpicker nicht meine Baustelle ist.
Wenn ich https://wiki.fhem.de/wiki/Color und die verlinkte Firmware-Seite anschaue, dann sollte setList die Zeile
rgb:colorpicker,RGB BASE_ID/DEVNAME/col #$EVTPART1
enthalten. Ohne Gewähr, da ich kein Geraet zum Testen habe.

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #22 am: 24 November 2019, 23:13:29 »
Hi Rudi,

ja das funktioniert.
Ist dann halt ein reiner RGB Colorpicker, und nicht der mit den 3 Schiebern von HSV.
Aber ich denke das passt auch besser das Gerät hat ja nur ein RGB reading.

Hier der angepasste Code Beta-User:
#source post: https://forum.fhem.de/index.php/topic,98880.msg995308.html#msg995308
name:wled_controller
filter:TYPE=MQTT2_DEVICE
desc:To control a WLED device, see https://github.com/Aircoookie/WLED/wiki for details).
order:W_01
par:BASE_ID;BASE_ID typically is wled;{ AttrVal("DEVICE","readingList","") =~ m,([^:]+)[/][^/]+[/].*:, ? $1 : undef }
par:DEVNAME;Device name as configured;{ AttrVal("DEVICE","readingList","") =~ m,([^:]+)[/]([^/]+)[/].*:, ? $1 : undef }
par:ICON;ICON as set, defaults to hue_filled_iris;{ AttrVal("DEVICE","icon","hue_filled_iris") }
attr DEVICE icon ICON
attr DEVICE setList\
  on:noArg BASE_ID/DEVNAME status on\
  off:noArg BASE_ID/DEVNAME status off\
  toggle:noArg BASE_ID/DEVNAME status t\
  rgb:colorpicker,RGB BASE_ID/DEVNAME/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 BASE_ID/DEVNAME
attr DEVICE readingList \
  BASE_ID/DEVNAME/g:.* brightness\
  BASE_ID/DEVNAME/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  BASE_ID/DEVNAME/v:.* api
deletereading -q DEVICE (?!associatedWith).*
attr DEVICE devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
attr DEVICE webCmd rgb:brightness
attr DEVICE model wled_controller

Den sollte man so einchecken können.
Richtig cool. Danke euch für eure Hilfe.

Gruß,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #23 am: 25 November 2019, 09:44:22 »
Danke für die Rückmeldung, ist eingecheckt (=>via update ab morgen kurz vor 8:00 Uhr verfügbar).

@Rudi: Sorry, hatte irgendwie nicht auf dem Schirm, dass das (ggf. indirekt) zu Color.pm gehört...

Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21666
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #24 am: 25 November 2019, 10:36:07 »
Soweit ich es sehe, implementiert Color.pm "nur" eine Menge von Funktionen, die von einem Farbschema ins Andere konvertieren.
Das hier referenzierte Widget ist in fhemweb_colorpicker.js implementiert, und bei FHEMWEB dokumentiert (https://fhem.de/commandref_modular.html#widgetOverride)
Ich gehe davon aus, dass die HSV Variante ohne Parameter nicht fuer widgetOverride vorbereitet ist, auf die Schnelle konnte ich aber nicht die Ursache finden.

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #25 am: 25 November 2019, 11:00:31 »
Hmm, wie auch immer, evtl. sollte man den alten Thread reaktivieren oder was neues dazu starten.

(Das betrifft mich aber wenn überhaupt, dann nur indirekt, daher bleibe ich dazu schlicht still, auch wenn ich grundsätzlich die HUE-Slider-Lösung angenehmer zu bedienen finde wie den RGB-Picker. Von daher wäre das nicht schlecht, wenn man (wer auch immer) sowas (ohne die beiden anderen Slider) irgendwie auch für "klassische" RGB-Geräte bereitstellen könnte.
 (Das ist aber nur aus der Erinnerung rekonstruiert, kann sein, dass ich dabei was übersehen hatte; das stammt aus der Zeit, als ich die templates für milight entwickelt habe, und da gab es dann den einfachen Ausweg nach hue und auch meine Kenntnisse in FHEMWEB-Design waren da noch andere...).)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #26 am: 25 November 2019, 14:08:22 »
ein widgetOverride mit <cmd>:colorpicker,HSV sollte problemlos funktionieren. gerade mit einem HUEDevice und dark style getestet.

was genau geht denn nicht? kannst du ein minimal beispiel mit einem dummy bauen bei dem das problem
zu sehen ist?
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21666
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #27 am: 25 November 2019, 15:00:13 »
Mitattr global logfile -
attr global modpath .
define w FHEMWEB 8083 global
define d dummy
attr d setList rgb:colorpicker,HSV
bekommt man die Fehlermeldung:
Zitat
fhemweb_colorpicker.js line 85:
Uncaught TypeError: cmd is not a function
falls man mit einem der Regler herumspielt.

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #28 am: 25 November 2019, 15:09:55 »
dto., wenn man dasselbe via widgetOverride macht (das ist optisch dasselbe wie das MQTT2_DEVICE, um das es hier eigentlich geht, daher die weiteren Readings usw.):
defmod Test_rgb dummy
attr Test_rgb readingList brightness\
  rgb\
  api
attr Test_rgb setList on:noArg\
  off:noArg\
  toggle:noArg\
  rgb:colorpicker,RGB\
  brightness:colorpicker,BRI,0,1,255
attr Test_rgb widgetOverride rgb:colorpicker,HSV
Das Testsystem läuft auf einem strawberry-Perl@Win7
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #29 am: 25 November 2019, 15:11:28 »
ok. ich das ganze bisher immer nur als webcmd verwendet. da geht es.

nicht als set in der detail ansicht.

fix kommt nachher.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #30 am: 25 November 2019, 15:16:03 »
sollte im svn repariert sein.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #31 am: 25 November 2019, 16:01:35 »
Danke für's fixen  :) .

@stefanru:
Soll dann in das template jetzt die HSV-Variante rein?

@justme1968:
Gäbe es die Option, sich noch einen reinen RGB-Slider zu wünschen? Wäre vermutlich zukünftig noch für  ein paar Geräte interessant, die RGB und PCT/brightness getrennt verwalten und in FHEMWEB dann für beides slider-widgets vertragen würden. (Das hier ist für MQTT-Gerät m.E. nicht ungewöhnlich)  (Oder übersehe ich mal wieder was?)
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #32 am: 25 November 2019, 16:11:53 »
naja... ein rgb wert der nicht die helligkeit beeinflusst gibt es erst mal nicht. die helligkeit ist hier implizit immer mit drin.

rgb über einen einzigen slider geht nicht.

das wäre dann hue.

aber zusätzlich zum colorpicker für die farbe noch einen slider für die helligkeit anzuzeigen geht doch jetzt schon.

oder verstehe ich etwas falsch?
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #33 am: 25 November 2019, 16:22:40 »
Das mit der Helligkeit ist richtig ??? , Kopfkratz .

Worum es geht: In der Regel will man für farbige Leuchten zwei bzw. drei slider haben; zwei, wenn man Farbe und Helligkeit einstellen kann hat, drei, wenn man zusätzlich eine ct-Option hat.

Hier hat man einen separaten Slider für die Helligkeit, was demnach benötigt würde, wäre einer, der (auf derselben Helligkeitsstufe, die grade gilt) einen RGB-Wert liefert. Der HUE-Slider macht ja einen Zahlenwert, oder liege ich da falsch? Daher kann man den für diejenigen Geräte nicht verwenden, die den HUE-Wert nicht "verstehen".
(Für sowas wäre dann nur die Frage, wo der Slider den aktuellen Helligkeitswert hernimmt, und welche Skalierung für den gilt (100% oder 0-255); könnte man durch weitere Argumente lösen? EDIT: Oder den vorherigen RGB-Wert auswerten?)
Die Alternative wäre, den HUE-Slider anzubieten, und eine der Funktionen aus Color zu nutzen, um den Wert vor dem Senden zu beeinflussen; dann wird aber der Informationsfluss rückwärts gestört, weil was anderes zurückkommt, als gesendet wurde.
« Letzte Änderung: 25 November 2019, 16:24:23 von Beta-User »
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #34 am: 25 November 2019, 18:16:27 »
wenn das device ein set kommando nur für die helligkeit hat -> einfach den hier: https://wiki.fhem.de/wiki/Color#Helligkeit verwenden.

wenn das device keinen eigenes set kommando hat und nur rgb kann -> den colorpicker im rgb oder hsv mode nutzen. da gibt es jeweils einen slider der nur die helligkeitsstufe komponente ändert.

wenn du noch etwas anderes meinst -> bitte noch mal beschrieben :(.


der dritte slider im rgb mode ist nicht für die farbtemperatur sonder für die sättigung. schau mal hier: https://wiki.fhem.de/wiki/Hue#Grundlagen_-_Farbmodelle. das mischen von komponenten aus unterschiedlichen farbmodellen ist normalerweise nicht sinnvoll.


der slider für die farbtemperatur ist noch mal etwas anderes: https://wiki.fhem.de/wiki/Color#Farbtemperatur.

es gibt devices die automatisch den weiss anteil mit steuern wenn man eine farbe setzt und die automatisch in einen nur weiss modus wechseln wenn man die farbtemperatur explizit setzt (fast alle zigbee devices mit ausnahme der de geräte mit neurer firmware). hier kann man im frontend den colorpicker und den ct slider anzeigen aber beide beeinflussen sich automatisch gegenseitig durch die rückmeldung vom device.

und es gibt devices bei denen beides völlig getrennt ist. hier kann man beides anzeigen und getrennt voneinander bedienen.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #35 am: 25 November 2019, 21:27:12 »
Na ja, was stefanru gerne haben wollte, ist nach meinem Verständnis ein Device, das in etwa so aussieht bzw. sich so steuern läßt:

defmod dummy_test dummy
attr dummy_test readingList brightness rgb
attr dummy_test setList brightness:colorpicker,BRI,0,15,255 rgb:colorpicker,HUE,0,1,359
attr dummy_test webCmd brightness:rgb
Aber der HUE-Slider liefert leider eben Zahlenwerte, die man nicht sinnvoll an das konkrete Device via MQTT versenden kann, denn das mag ausschließlich RGB-Werte im RRGGBB-Format. Das sollte der Slider liefern...

Dass es andere Widgets gibt, die das hergeben, ist klar, aber der Mechanismus mit dem Aufklappen vom RGB-Widget ist nicht sooo schön, wenn man daneben sowieso einen Slider für die Helligkeit hat.

Sorry für die Ungenauigkeit, was die anderen Optionen/Begrifflichkeiten betr. Farbe usw. angeht. Es geht einfach nur darum, (genau nur) das anzuzeigen, was dann auch das (Ziel-) Device versteht/verarbeiten kann. Hier ist das eben nur brightness und rgb.

Hoffe, das ist nun etwas klarer?
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #36 am: 25 November 2019, 22:28:36 »
wenn du den colorpicker im HSV mode verendest klappt nichts auf. die drei regler sind immer sichtbar.

das problem ist: ein oder zwei regler sind nicht genug um eine farbe im rgb oder hsv raum zu bestimmen. es sind drei komponenten nötig. d.h. um rgb einzustellen reicht ein regler nicht.

#FF0000 und #FFFFFF und #FF9999 sind auf hue ebene alles die gleiche farbe. reines rot. und haben alle 100% helligkeit. sie unterscheiden sich nur in der sättigung die du als dritten regler unterschlagen hast.

auch wenn das device nur rgb und helligkeit kann brauchst du im gui alle drei regler um alle möglichen farben einzustellen. genau dafür ist der HSV mode vom colorpicker da.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #37 am: 25 November 2019, 23:03:04 »
Hi Beta-User,

ich denke den Hue Slider hätte ich dann lieber.

@justme:
Sieh dir mal den Anhang an.
So sieht so ein Device dann in der Übersicht aus.

Die vorne sind die HUE, der hinten ist das Brightness-Reading des Devices, wobei Brightness von 0 - 255 geht.
Irgendwie ist die Helligkeit doch jetzt 2 mal vorhanden.
Einmal im Hue von 0 - 100 und einmal im Brightness-Reading von 0 - 255.

Nochmal vielen Dank für eure Hilfe.

Gruß,
Stefan

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #38 am: 25 November 2019, 23:09:54 »
wenn du nur eins von beiden willst darfst du in deinem webCmd auch nur eins von beiden einbauen.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #39 am: 26 November 2019, 07:51:06 »
@justme1968: Danke nochmal für die Infos.

@stefanru:
Läßt sich das Device denn über den HSV (? nicht HUE, oder?) -Slider auch Helligkeitsmäßig gut bedienen? Der mittlere slider sollte auch irgendwelche Auswirkungen auf das Device haben? Dann würde ich (nur) den in webCmd anbieten, doppeln macht keinen Sinn.

Wenn einer der slider funktionslos sein sollte, dann bleiben wir beim aktuellen Stand.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #40 am: 26 November 2019, 20:50:40 »
Hi,

ich glaub ich hab das nicht so gut ausgedrückt.
Der vordere ist HSV und alles funktioniert, der hintere ist Brightness, auch diese funktioniert.

Ist Brightness 0, kann ich an HSV drehen wie ich will es tut sich nichts.
Hat Brightness einen Wert größer 0 kann ich HSV benutzen.
Auch den unteren der drei Slider von HSV der ja auch von Schwarz bis volle Farbe geht.
Ich kann also mit dem unteren vom HSV Slider die Helligkeit von 0 bis 100 einstellen, wobei 100 maximal die Helligkeit von Brightness haben kann.

Bsp: Brightness 50.
Unterer HSV Slider ist bei 0 aus und bei 100 hat die Lampe eine Brightness von 50.

Ein Problem hat der HSV Slider aber.
Slide ich den unteren Slider wirklich auf 0 wird RGB 000000.
Das heißt alle Slider in HSV gehen auf Anfangsposition.
Farbe und Sättigung ändern sich also plötzlich.
Bin mir nicht sicher woran das liegt.
Ich denke aber dass der HSV Slider wenn der untere Slider auf 0 steht alles auf 0 setzt.
Somit geht die Farbe und Sättigung verloren.

Ich würde den HSV Slider gern behalten.
Ist irgendwie besser zu bedienen als die RGB Auswahl.
Außerdem hat RGB ja das selbe. Man kann von oben nach unten auch immer dunkler werden.
Extremfall also eine schwarze Farbe und die LED ist aus obwohl Brightness auf 255 steht.

Ich denke wir sollten HSV nehmen.
Das einzige Problem ist wenn man den unteren HSV Slider auf 0 stellt.
Vielleicht kann justme was dazu sagen?

Gruß,
Stefan

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 19999
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #41 am: 26 November 2019, 21:04:39 »
jedes farbmodell hat gewisse nachteile. bei hsv geht bei sättigung 0 oder helligkeit 0 die farbe ‘verloren‘. bei rgb kann man nicht einfach durch die farben scrollen.

wenn man die farmodelle auch noch kombinieren muss weil in einem die einstellung einfacher geht, dieses aber vom device nicht direkt unterstützt wird verstärken sie die probleme gegenseitig.

d.h. für hsv: wenn man die helligkeit auf 0 dreht gehen bei der hin- und rückrechnung über rgb die beiden anderen kanäle verloren weil sich aus rgb 000000 nichts mehr rekonstruieren lässt. ähnliches gilt für ffffff d.h. weiß.

bei einem device das direkt in hsv arbeitet würde das nicht passieren weil nicht hin und her gerechnet werden muss und im device bzw. reading die original werte erhalten bleiben.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #42 am: 26 November 2019, 21:22:45 »
Ah ok, danke für die Erklärung.

Hmm, dann fällt es mir schwer zu sagen ob HSV oder RGB für die WLED.
Sie hat nur ein RGB und ein Brightness reading.
Dann wäre wohl RGB das korrekte.

Gruß,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #43 am: 27 November 2019, 07:39:52 »
Dann lassen wir das im template wie es ist. Zumindest die Beschreibung verweist nach hierher, ggf. bzw. bei Gelegenheit nehme ich noch einen comment dazu auf, dass man es auch danach noch wiederfindet, wenn man sich intensiver mit seinem device beschäftigt.

Finde es besser, man hat eine etwas "umständliche" Bedienung (@justme1968: das ist ausdrücklich keine Kritik, die Hintergründe, warum das so sein muss, hast du ja nochmal ausführlich dargelegt) wie irritierende Verhaltensweisen bei einem "mißbrauchten" widget.

(@stefanru: Du kannst das bei dir ja trotzdem so lassen; du kennst ja die Einschränkungen, und wenn du ein paar "Farb-Buttons" dazupackst, die rgb liefern, ist das auch einfach zu überspielen...).
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #44 am: 27 November 2019, 20:53:44 »
Hi,

nein das passt. Ich denke ich nehme dann auch RGB. Ich benutze das FHEM WebUI eh fast nicht zum steuern.
Läuft alles automatisiert mit Bewegungsmelder usw.

Also alles super.

Vielen dank nochmal!

Gruß,
Stefan

Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #45 am: 17 Februar 2020, 20:50:19 »
Hallo
Wollte da auch mal testen da ich einige  WS2812 rumliegen hatte.
Nach flashen der firmware auf meinen esp8266 und mqtt Aktivierung
wird bei mir dieses Device per template angelegt
defmod MQTT2_WLED_vitrine MQTT2_DEVICE WLED_vitrine
attr MQTT2_WLED_vitrine DbLogExclude .*
attr MQTT2_WLED_vitrine IODev MQTTServer
attr MQTT2_WLED_vitrine comment For questions about the use of different widgets for color selection see discussion at https://forum.fhem.de/index.php/topic,98880.msg995308.html
attr MQTT2_WLED_vitrine devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
attr MQTT2_WLED_vitrine genericDeviceType light
attr MQTT2_WLED_vitrine homebridgeMapping Brightness=brightness::brightness,maxValue=100,factor=0.39216,delay=true
attr MQTT2_WLED_vitrine icon hue_filled_iris
attr MQTT2_WLED_vitrine model wled_controller
attr MQTT2_WLED_vitrine readingList wled/wled/g:.* brightness\
  wled/wled/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  wled/wled/v:.* api
attr MQTT2_WLED_vitrine room MQTT2_DEVICE
attr MQTT2_WLED_vitrine setList on:noArg wled/wled status on\
  off:noArg wled/wled status off\
  toggle:noArg wled/wled status t\
  rgb:colorpicker,RGB wled/wled/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 wled/wled
attr MQTT2_WLED_vitrine webCmd rgb:brightness
funktionierte aber nicht
colorpicker wollte selbst nach Anpassung der  Pfade
nicht funtionieren.
Firmware ist die letzte vom Dezember 2019

defmod MQTT2_WLED_vitrine MQTT2_DEVICE WLED_vitrine
attr MQTT2_WLED_vitrine DbLogExclude .*
attr MQTT2_WLED_vitrine IODev MQTTServer
attr MQTT2_WLED_vitrine comment For questions about the use of different widgets for color selection see discussion at https://forum.fhem.de/index.php/topic,98880.msg995308.html
attr MQTT2_WLED_vitrine devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
attr MQTT2_WLED_vitrine genericDeviceType light
attr MQTT2_WLED_vitrine homebridgeMapping Brightness=brightness::brightness,maxValue=100,factor=0.39216,delay=true
attr MQTT2_WLED_vitrine icon hue_filled_iris
attr MQTT2_WLED_vitrine model wled_controller
attr MQTT2_WLED_vitrine readingList wled/vitrine/g:.* brightness\
  wled/vitrine/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  wled/vitrine/v:.* api\
WLED_vitrine:wled/vitrine/g:.* g\
WLED_vitrine:wled/vitrine/c:.* c\
WLED_vitrine:wled/vitrine/status:.* status\
WLED_vitrine:wled/vitrine/v:.* v
attr MQTT2_WLED_vitrine room MQTT2_DEVICE
attr MQTT2_WLED_vitrine setList on:noArg wled/vitrine status on\
  off:noArg wled/vitrine status off\
  toggle:noArg wled/vitrine status t\
  rgb:colorpicker,RGB wled/vitrine/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 wled/vitrine
attr MQTT2_WLED_vitrine webCmd rgb:brightness
attr MQTT2_WLED_vitrine widgetOverride rgb:colorpicker,HSV

attr vitrinenlicht_wled webCmd rgb:brightness
attr vitrinenlicht_wled widgetOverride rgb:colorpicker,HSV


Was ich mir noch wünschen würde die Effekte irgenwie mit
einzubauen habe aber leider null Plan wie das anzustellen ist.
Mein  Plan wäre alle meine Milight durch diese zu ersetzen da die WS2811
gefühlt smoother laufen.

Andre


Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #46 am: 17 Februar 2020, 21:05:08 »
Hi Andre,

eigentlich sollte die ReadingsList so aussehen, hier für mein kuechenlicht:
readingList
wled/kuechenlicht/g:.* brightness
  wled/kuechenlicht/c:.* {{"rgb"=>substr("$EVENT",1,6)}}
  wled/kuechenlicht/v:.* api

Hast du den bei der Wled auf dem Web Ui unter Config -> MQTT angeschaltet und dort auch ein Device Topic Vergeben?
Für mein Beispiel wäre das wled/kuechenlicht

Kann dir da nur recht geben WLEd läuft super smooth und ist richtig cool.
Ja du kannst auch die Effekte über MQTT ansprechen und zwar über die API, dort kannst du alle Befehler der HTTP API übergeben.
Siehe:https://github.com/Aircoookie/WLED/wiki/MQTT

Z.b. für mein Küchenlicht:
set myMQTT2Client publish wled/kuechenlicht/api CL=#98F3F9&A=255&TT=1000

CL ist Farbe, A ist Helligkeit und TT ist die dauer des Übergangs.
Für eine Effekt würdest du noch &FX=10 setzen.
Das würde Effekt Nummer 10 laufen lassen.

Gruß,
Stefan



Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #47 am: 17 Februar 2020, 21:42:30 »
In der Web UI habe ich bei Device Topic: wled/vitrine eingetragen
Group Tropic steht auf wled/all
Client ID steht auf WLED-vitrine und Mqtt aktiviert
den rest habe ich erst mal nicht verändert.
Welche Firmware hast du drauf vielleicht liegt es ja daran das das falsch
angelegt wird.
set mqttserver publish wled/vitrine/api CL=#98F3F9&A=255&TT=1000 &FX=2
funtioniert wunderbar... :)
Andre

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #48 am: 17 Februar 2020, 21:47:37 »
Hab die neuste Firmware drauf.
Hatte aber auch die vorher drauf.
Benutze das schon ne Zeit lang.

Wo ist denn dein Problem genau?
Wenn das "set mqttserver publish wled/vitrine/api CL=#98F3F9&A=255&TT=1000 &FX=2" geht sollte doch auch der rest gehen.

Hast du in deiner ReadingsList:
wled/vitrine/g:.* brightness
  wled/vitrine/c:.* {{"rgb"=>substr("$EVENT",1,6)}}
  wled/vitrine/v:.* api

Gruß,
Stefan

Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #49 am: 18 Februar 2020, 10:40:35 »
Problem eigentlich nicht nach anpaasung der Pfade läuft es ja erst mal
es wird nur falsch vom template angelegt vieleicht liegt es nur an meiner
Konfiguration das das so passiert.
defmod MQTTServer MQTT2_SERVER 1884 global
attr MQTTServer DbLogExclude .*
attr MQTTServer autocreate simple
attr MQTTServer icon mqtt
attr MQTTServer rawEvents 1
attr MQTTServer room MQTT2_DEVICE,Mqtt

Internals:
   .FhemMetaInternals 1
   CID        WLED_vitrine
   DEF        WLED_vitrine
   DEVICETOPIC MQTT2_WLED_vitrine
   FUUID      5e4ae9f3-f33f-0b03-84fc-e1c0e1eb40de45a0
   FVERSION   10_MQTT2_DEVICE.pm:0.211680/2020-02-10
   IODev      MQTTServer
   LASTInputDev MQTTServer
   MQTTServer_MSGCNT 16
   MQTTServer_TIME 2020-02-17 21:43:03
   MSGCNT     16
   NAME       MQTT2_WLED_vitrine
   NR         766
   STATE      toggle
   TYPE       MQTT2_DEVICE
   .attraggr:
   .attrminint:
   READINGS:
     2020-02-17 21:43:02   api             <?xml version="1.0" ?><vs><ac>0</ac><cl>152</cl><cl>243</cl><cl>249</cl><cs>0</cs><cs>0</cs><cs>0</cs><ns>1</ns><nr>1</nr><nl>0</nl><nf>1</nf><nd>60</nd><nt>132</nt><fx>2</fx><sx>128</sx><ix>128</ix><fp>0</fp><wv>-1</wv><ws>0</ws><cy>0</cy><ds>WLED</ds><ss>0</ss></vs>
     2020-02-17 21:43:02   brightness      0
     2020-02-17 21:43:02   c               #98F3F9
     2020-02-17 21:43:02   g               0
     2020-02-17 21:43:02   rgb             98F3F9
     2020-02-17 21:43:02   state           toggle
     2020-02-17 21:43:02   status          online
     2020-02-17 21:43:02   v               <?xml version="1.0" ?><vs><ac>0</ac><cl>152</cl><cl>243</cl><cl>249</cl><cs>0</cs><cs>0</cs><cs>0</cs><ns>1</ns><nr>1</nr><nl>0</nl><nf>1</nf><nd>60</nd><nt>132</nt><fx>2</fx><sx>128</sx><ix>128</ix><fp>0</fp><wv>-1</wv><ws>0</ws><cy>0</cy><ds>WLED</ds><ss>0</ss></vs>
   helper:
     bm:
       MQTT2_DEVICE_Get:
         cnt        14
         dmx        -1000
         dtot       0
         dtotcnt    0
         mTS        18.02. 10:39:46
         max        7.20024108886719e-05
         tot        0.000534772872924805
         mAr:
           HASH(0x564100625a48)
           MQTT2_WLED_vitrine
           brightness
       MQTT2_DEVICE_Set:
         cnt        30
         dmx        -1000
         dtot       0
         dtotcnt    0
         mTS        17.02. 21:43:02
         max        0.0286839008331299
         tot        0.0400433540344238
         mAr:
           HASH(0x564100625a48)
           MQTT2_WLED_vitrine
           toggle
Attributes:
   DbLogExclude .*
   IODev      MQTTServer
   comment    For questions about the use of different widgets for color selection see discussion at https://forum.fhem.de/index.php/topic,98880.msg995308.html
   devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
   genericDeviceType light
   homebridgeMapping Brightness=brightness::brightness,maxValue=100,factor=0.39216,delay=true
   icon       hue_filled_iris
   model      wled_controller
   readingList wled/vitrine/g:.* brightness
  wled/vitrine/c:.* {{"rgb"=>substr("$EVENT",1,6)}}
  wled/vitrine/v:.* api
WLED_vitrine:wled/vitrine/g:.* g
WLED_vitrine:wled/vitrine/c:.* c
WLED_vitrine:wled/vitrine/status:.* status
WLED_vitrine:wled/vitrine/v:.* v
   room       MQTT2_DEVICE
   setList    on:noArg wled/vitrine status on
  off:noArg wled/vitrine status off
  toggle:noArg wled/vitrine status t
  rgb:colorpicker,RGB wled/vitrine/col #$EVTPART1
  brightness:colorpicker,BRI,0,1,255 wled/vitrine
   webCmd     rgb:brightness
   widgetOverride rgb:colorpicker,HSV

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #50 am: 18 Februar 2020, 11:22:24 »
Erklär mir mal was falsch angelegt wird.
Bei mir ist das passt alles wenn ich ein Device neu anlege.
Was musstest du denn aus welchem Grund anpassen?

Gruß,
Stefan

Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #51 am: Gestern um 12:18:57 »
Hallo
Sorry das ich mich erst jetzt melde.
defmod MQTT2_WLED_vitrine MQTT2_DEVICE WLED_vitrine
attr MQTT2_WLED_vitrine DbLogExclude .*
attr MQTT2_WLED_vitrine IODev MQTTServer
attr MQTT2_WLED_vitrine comment For questions about the use of different widgets for color selection see discussion at https://forum.fhem.de/index.php/topic,98880.msg995308.html
attr MQTT2_WLED_vitrine devStateIcon {Color::devStateIcon( $name, "rgb", "rgb", "brightness", "state" )}
attr MQTT2_WLED_vitrine genericDeviceType light
attr MQTT2_WLED_vitrine homebridgeMapping Brightness=brightness::brightness,maxValue=100,factor=0.39216,delay=true
attr MQTT2_WLED_vitrine icon hue_filled_iris
attr MQTT2_WLED_vitrine model wled_controller
attr MQTT2_WLED_vitrine readingList wled/vitrine/wled/vitrine/g:.* brightness\
  wled/vitrine/wled/vitrine/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  wled/vitrine/wled/vitrine/v:.* api
attr MQTT2_WLED_vitrine room MQTT2_DEVICE
attr MQTT2_WLED_vitrine setList on:noArg wled/vitrine/wled/vitrine status on\
  off:noArg wled/vitrine/wled/vitrine status off\
  toggle:noArg wled/vitrine/wled/vitrine status t\
  rgb:colorpicker,RGB wled/vitrine/wled/vitrine/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 wled/vitrine/wled/vitrine
attr MQTT2_WLED_vitrine webCmd rgb:brightness

Und so habe ich es dann abgeändert.
defmod MQTT2_WLED_vitrine MQTT2_DEVICE WLED_vitrine
attr MQTT2_WLED_vitrine DbLogExclude .*
attr MQTT2_WLED_vitrine IODev MQTTServer
attr MQTT2_WLED_vitrine comment For questions about the use of different widgets for color selection see discussion at https://forum.fhem.de/index.php/topic,98880.msg995308.html
attr MQTT2_WLED_vitrine devStateIcon {Color::devStateIcon( $name, "rgb","rgb", "brightness", "state" )}
attr MQTT2_WLED_vitrine genericDeviceType light
attr MQTT2_WLED_vitrine homebridgeMapping Brightness=brightness::brightness,maxValue=100,factor=0.39216,delay=true
attr MQTT2_WLED_vitrine icon hue_filled_iris
attr MQTT2_WLED_vitrine model wled_controller
attr MQTT2_WLED_vitrine readingList wled/vitrine/g:.* brightness\
  wled/vitrine/c:.* {{"rgb"=>substr("$EVENT",1,6)}}\
  wled/vitrine/v:.* api\
WLED_vitrine:wled/vitrine/g:.* g\
WLED_vitrine:wled/vitrine/c:.* c\
WLED_vitrine:wled/vitrine/status:.* status\
WLED_vitrine:wled/vitrine/v:.* v
attr MQTT2_WLED_vitrine room MQTT2_DEVICE
attr MQTT2_WLED_vitrine setList on:noArg wled/vitrine status on\
  off:noArg wled/vitrine status off\
  toggle:noArg wled/vitrine status t\
  rgb:colorpicker,RGB wled/vitrine/col #$EVTPART1\
  brightness:colorpicker,BRI,0,1,255 wled/vitrine
attr MQTT2_WLED_vitrine webCmd rgb:brightness
attr MQTT2_WLED_vitrine widgetOverride rgb:colorpicker,HSV
Wie du  siehst legt er die Pfade wled/vitrine doppelt an.
Auch der Colorpicker funktioniert bei mir so nicht
Andre

Offline stefanru

  • Sr. Member
  • ****
  • Beiträge: 620
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #52 am: Gestern um 13:09:52 »
Hi Andre,

ah ok.
Das sieht ja seltsam aus. Ich probiere das heute mal.
Als ich meine Device angelegt hatte war nichts doppelt.

Gruß,
Stefan

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #53 am: Gestern um 13:31:32 »
Hm, das ist zwar einerseits klar, dass das attrTemplate kaputt war (Korrektur ist seit eben im svn), aber diesen Effekt hätte der bug nicht haben sollen...

(Wenn testen, bitte mit der version aus dem svn bzw. mit der kleinen Änderung von eben).
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #54 am: Gestern um 14:24:37 »
Habs eben getestet funktioniert
Diese Meldung kommt aber beim anlegen....
Unknown command WLED_vitrine:wled, try help.
Unknown command WLED_vitrine:wled, try help.
Unknown command WLED_vitrine:wled, try help.
Unknown command WLED_vitrine:wled/col, try help.
Unknown command WLED_vitrine:wled, try help.
Unknown command WLED_vitrine:wled/g:.*, try help.
Unknown command WLED_vitrine:wled/c:.*, try help.
Unknown command WLED_vitrine:wled/v:.*, try help.
Colorpicker arbeitet auch wieder ohne Änderung

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #55 am: Gestern um 14:34:21 »
Hmm, bin grade etwas am Rätseln, wo das herkommen könnte.

Wichtig ist erst mal, dass die Parameter sauber aufgelöst werden. Das scheint der Fall zu sein?

Alles andere _könnte_ auch von irgendeiner "Altlast" her kommen. Von daher würde es mich interessieren, ob diese Meldungen auch kommen, wenn man ein "neues" Device hat, wie autocreate es erstellt hatte?
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline andre07

  • Full Member
  • ***
  • Beiträge: 117
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #56 am: Gestern um 22:07:06 »
Ich habe ein zweites neues Device angelegt selbige Fehlermeldung erscheint

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 9279
  • eigentlich eher "user" wie "developer"
Antw:[Gelöst] MQTT für WLED, rgb reading mit # klappt nicht
« Antwort #57 am: Heute um 09:21:19 »
Hmm, aus dieser Beschreibung alleine werde ich leider nicht schlau. Ich vermute (?), diese Fehlermeldungen "unknown command.." erscheinen, wenn du das attrTemplate anwendest?

Bitte (sofern ich dem auf den Grund gehen soll, muß ich das bei Gelegenheit 1:1 nachvollziehen...): Ein (vollst.) RAW von dem, was autocreate erstellt, dann eine genaue Angabe, wie du welches attrTemplate anwendest.
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | BT@OpenMQTTGateway
svn:MySensors, WeekdayTimer, RandomTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

 

decade-submarginal