Autor Thema: [gelöst] Meldung bei define: "Cannot load module HomeConnectConnection"  (Gelesen 7056 mal)

Offline hoppel118

  • Sr. Member
  • ****
  • Beiträge: 968
Moin Leute,

ich habe mittlerweile eine Kühl-Gefrie-Kombination von Bosch. Ich kann das Gerät über die Home Connect App bereits bedienen. Nun möchte ich das Gerät in FHEM einbinden. Dafür halte ich mich an das Wiki. Ich bin mir nicht sicher, ob das da alles noch aktuell ist, kann mich aber auch täuschen. Hier meine Fragen:

1. Brauche ich wirklich einen Advanced Account? Wenn ja wo kann ich das einstellen? Bei "Additional Information" kann ich unter "Account Type" --> "Corporate", "(Open Source) Community" oder "Individual" auswählen, siehe Screenshot. Ich habe mich jetzt mal für "(Open Source) Community" entschieden, oder soll ich "Corporate" verwenden?
2. Wen trage ich unter "Community Contact" ein? Habe mich erstmal selbst hinterlegt.
3. Anschließend habe ich mir dann eine App registriert, siehe zweiten Screenshot. Ist die "Client ID" der API-KEY, den ich für die Definition in FHEM benötige?

Wenn ich nun versuche hcconn in FHEM zu definieren, erhalte ich die Meldung "Cannot load module HomeConnectConnection". Im Logfile sehe dann folgende Einträge:

2019.10.24 12:58:13 1: reload: Error:Modul 48_HomeConnectConnection deactivated:
 Can't locate Switch.pm in @INC (you may need to install the Switch module) (@INC contains: fhem.p/lib fhem.p/FHEM/lib ./FHEM/lib ./lib ./FHEM ./ /usr/local/FHEM/share/fhem/FHEM/lib . /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/x86_64-linux-gnu/perl5/5.24 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at ./FHEM/48_HomeConnectConnection.pm line 26.
BEGIN failed--compilation aborted at ./FHEM/48_HomeConnectConnection.pm line 26.

Was genau mache ich falsch?

Danke euch und Gruß Hoppel
« Letzte Änderung: 26 Oktober 2019, 21:59:55 von hoppel118 »
Server: Openmediavault, XEON E3-1240L-v5, Supermicro X11SSH-CTF, 64GB ECC RAM, SSD, RAID-Z2
Homebridge | Alexa | Yowsup
Homematic: VCCU 2xHMUSB, 1xWLGW | HomeConnect | Philips Hue | Sonos: Beam, Sub, One, Symfonisk | Unifi: USG, USW, AC-AP-Pro | Xiaomi: S50, Smart Fan | vbus: Vitosolic 200SD4

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 7588
  • NIVEAu ist keine Creme...
Bzgl. Anmeldung kann ich leider nicht helfen...

Modul-Ladefehler, mal hier schauen: https://forum.fhem.de/index.php?topic=93355.0

Gruß, Joachim
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, KODI, alexa-fhem, ...
FHEM PI2 Stretch: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 Stretch (Test)

Offline hoppel118

  • Sr. Member
  • ****
  • Beiträge: 968
Hallo Joachim,

danke, ja, das hat das Problem gelöst. Ich konnte mich erfolgreich einloggen. An dem Device "hcconn" sehe ich nun den Status "Connected".

Sehr gut, danke dir. Ich werde diesbezüglich die Fehlermeldung im Wiki ergänzen und den Hinweis zu dem Paket verschieben. Tatsächlich steht im Wiki, dass man bei Fehlern dieses Paket installieren soll. Das habe ich allerdings gekonnt überlesen, weil es im Kapitel "Modul-Installation" aufgeführt wird und nicht bei der "Basisdefinition", wo der Fehler dann auftritt.  ???

Viele Grüße Hoppel
« Letzte Änderung: 24 Oktober 2019, 15:14:17 von hoppel118 »
Server: Openmediavault, XEON E3-1240L-v5, Supermicro X11SSH-CTF, 64GB ECC RAM, SSD, RAID-Z2
Homebridge | Alexa | Yowsup
Homematic: VCCU 2xHMUSB, 1xWLGW | HomeConnect | Philips Hue | Sonos: Beam, Sub, One, Symfonisk | Unifi: USG, USW, AC-AP-Pro | Xiaomi: S50, Smart Fan | vbus: Vitosolic 200SD4

Offline hoppel118

  • Sr. Member
  • ****
  • Beiträge: 968
Meine Kühl-Gefrier-Kombination wurde mittlerweile erkannt. Es hat ein wenig gedauert. Bei dem automatisch ergänzten Device standen zunächst 3 Fragezeichen im state. Das sieht nun besser aus. Nachdem ich dann "requestSettings" gesetzt habe, sehe ich mehr Readings und kann einiges konfigurieren. Hier ein list des Devices:

Internals:
   DEF        hcconn BOSCH-KGN36HI33-68A40E026CA7
   FUUID      5db19a18-f33f-5dcf-550b-cab968ae2b23a95a
   NAME       KGN36HI33
   NR         494
   STATE      Idle
   TYPE       HomeConnect
   aliasname  Kühlschrank
   brand      Bosch
   commandPrefix
   eventChannelTimeout 1571926396.5396
   haId       BOSCH-KGN36HI33-68A40E026CA7
   hcconn     hcconn
   programs   
   retrycounter 0
   type       FridgeFreezer
   vib        KGN36HI33
   READINGS:
     2019-10-24 16:09:34   BSH.Common.Setting.PowerState BSH.Common.EnumType.PowerState.On
     2019-10-24 15:47:37   BSH.Common.Status.DoorState BSH.Common.EnumType.DoorState.Closed
     2019-10-24 16:12:46   Refrigeration.FridgeFreezer.Setting.SetpointTemperatureFreezer -18 °C
     2019-10-24 16:13:16   Refrigeration.FridgeFreezer.Setting.SetpointTemperatureRefrigerator 6 °C
     2019-10-24 16:09:34   Refrigeration.FridgeFreezer.Setting.SuperModeFreezer 0
     2019-10-24 16:09:34   Refrigeration.FridgeFreezer.Setting.SuperModeRefrigerator 0
     2019-10-24 15:47:37   state           Idle
Attributes:
   alias      Kühlschrank
   icon       scene_wine_cellar

Ich sehe also den Power- und den Doorstate. Außerdem kann ich die Temperatur in der Kühl- und in der Gefriereinheit getrennt von einander einstellen und die beiden Funktionen "SuperKühlen" und "SuperGefrieren" über FHEM schalten. Gerade getestet, das funktioniert alles. SUPER!!!  8)

Anscheinend lag ich mit meinen Vermutungen zur Konfiguration des Developer Accounts und der Application richtig, so dass nun quasi alle Fragen meines Eingangsposts beantwortet sind. 

Danke für das tolle Modul!

Viele Grüße Hoppel
« Letzte Änderung: 26 Oktober 2019, 14:29:28 von hoppel118 »
Server: Openmediavault, XEON E3-1240L-v5, Supermicro X11SSH-CTF, 64GB ECC RAM, SSD, RAID-Z2
Homebridge | Alexa | Yowsup
Homematic: VCCU 2xHMUSB, 1xWLGW | HomeConnect | Philips Hue | Sonos: Beam, Sub, One, Symfonisk | Unifi: USG, USW, AC-AP-Pro | Xiaomi: S50, Smart Fan | vbus: Vitosolic 200SD4

Online MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 7588
  • NIVEAu ist keine Creme...
Bzgl. der Fehler/Warnings und der Zusatzfragen würde ich einen neuen Thread aufmachen...

Dann bleibt der hier für andere mit DIESEM Problem...
...und du findest (neue) Helfer für die ANDEREN Dinge...
(ich kann dir da leider nicht [mehr] weiter helfen)

Bei diesen hier dann halt [gelöst] davor...

Gruß, Joachim
FHEM PI3B+ Buster: HM-CFG-USB, 40x HM, ZWave-USB, 6x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, KODI, alexa-fhem, ...
FHEM PI2 Stretch: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, KODI, ha-bridge, ...
FHEM PI3 Buster (Test)
FHEM PI3 Stretch (Test)

Offline hoppel118

  • Sr. Member
  • ****
  • Beiträge: 968
Ok, habe meine Themen in insgesamt 4 Threads verteilt. ;)

Danke dir, bye
Server: Openmediavault, XEON E3-1240L-v5, Supermicro X11SSH-CTF, 64GB ECC RAM, SSD, RAID-Z2
Homebridge | Alexa | Yowsup
Homematic: VCCU 2xHMUSB, 1xWLGW | HomeConnect | Philips Hue | Sonos: Beam, Sub, One, Symfonisk | Unifi: USG, USW, AC-AP-Pro | Xiaomi: S50, Smart Fan | vbus: Vitosolic 200SD4