Autor Thema: [Gelöst] Abhängigkeitsprobleme Bein Installieren von Deconz  (Gelesen 454 mal)

Offline SamNitro

  • Sr. Member
  • ****
  • Beiträge: 707
  • Kölner Wimpelbeauftragter
Hey, habe auf meinem Produktivsystem ein problem beim Installieren von Deconz,
komme da nicht wirklich weiter hoffe jemand kann helfen


pi@FHEM:~ $ sudo apt install deconz
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 deconz : Hängt ab von: libqt5widgets5 soll aber nicht installiert werden
          Hängt ab von: libqt5gui5 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
pi@FHEM:~ $ sudo apt install libqt5widgets5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libqt5widgets5 : Hängt ab von: libgles2-mesa (>= 7.8.1) soll aber nicht installiert werden oder
                                 libgles2
                  Hängt ab von: libqt5gui5 (>= 5.7.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
pi@FHEM:~ $ sudo apt install libqt5gui5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libqt5gui5 : Hängt ab von: libgles2-mesa (>= 7.8.1) soll aber nicht installiert werden oder
                             libgles2
              Empfiehlt: libqt5svg5 soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
pi@FHEM:~ $ sudo apt install libqt5svg5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libqt5svg5 : Hängt ab von: libqt5gui5 (>= 5.7.1~20161021+dfsg~) soll aber nicht installiert werden
              Hängt ab von: libqt5widgets5 (>= 5.7.1~20161021+dfsg~) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
pi@FHEM:~ $

LG Patrick
« Letzte Änderung: 17 April 2019, 15:30:31 von SamNitro »
(Rpi 3, Stretch) (EnOcean) (MAX!) (CUL868) (CUL433) (Zigbee) (FS20) (ESP8266) (Echo)

Offline Otto123

  • Hero Member
  • *****
  • Beiträge: 13268
  • schon mal restore trainiert?
    • Otto's Technik Blog
Antw:Abhängigkeitsprobleme Bein Installieren von Deconz
« Antwort #1 am: 16 April 2019, 17:53:40 »
Hi,

du kannst versuchen, das zu reparieren:
sudo apt-get install -f
Hattest Du vorher mal einsudo apt-get update
sudo apt-get upgrade
gemacht?

Was ist das für ein System?
Was steht in der sources.list?cat /etc/apt/sources.listHast Du zusätzliche Sources?ls -lha /etc/apt/sources.list.d
Gruß Otto
« Letzte Änderung: 16 April 2019, 17:58:04 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7490+7412,WRT1900ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266

Offline SamNitro

  • Sr. Member
  • ****
  • Beiträge: 707
  • Kölner Wimpelbeauftragter
Antw:Abhängigkeitsprobleme Bein Installieren von Deconz
« Antwort #2 am: 16 April 2019, 18:12:19 »
Zitat
sudo apt-get install -f
Habe ich schon gemacht
sudo apt-get install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Zitat
cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
#deb http://raspbian.raspberrypi.org/raspbian/ jessie main contrib non-free r$
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

wie man an der liste erkennt bin ich auf Raspbian Stretch war mal jessie

pi@FHEM:~ $ ls -lha /etc/apt/sources.list.d
insgesamt 12K
drwxr-xr-x 2 root root 4,0K Apr 16 14:59 .
drwxr-xr-x 6 root root 4,0K Apr 16 16:31 ..
-rw-r--r-- 1 root root   58 Apr 16 14:59 deconz.list
Nur die deconz die ich versuche zu installieren

Habe eine Anleitung gefunden zu "Defekte Pakete unter Ubuntu/Debian auflisten und löschen"
pi@FHEM:~ $ dpkg --list | grep ^rc
rc  javascript-common                  11                                all          Base support for JavaScript library packages
rc  liblzo2-2:armhf                    2.08-1.2                          armhf        data compression library
rc  libssl1.0.0:armhf                  1.0.1t-1+deb8u8                   armhf        Secure Sockets Layer toolkit - shared libraries
rc  libwebsockets3:armhf               1.2.2-1                           armhf        lightweight C websockets library
rc  npm                                1.4.21+ds-2                       all          package manager for Node.js
rc  vim-runtime                        2:8.0.0197-4+deb9u1               all          Vi IMproved - Runtime files
(Rpi 3, Stretch) (EnOcean) (MAX!) (CUL868) (CUL433) (Zigbee) (FS20) (ESP8266) (Echo)

Offline SamNitro

  • Sr. Member
  • ****
  • Beiträge: 707
  • Kölner Wimpelbeauftragter
Antw:Abhängigkeitsprobleme Bein Installieren von Deconz
« Antwort #3 am: 16 April 2019, 19:35:53 »
Die Anleitung hat aber auch nix gebracht.


Mobil unterwegs!
(Rpi 3, Stretch) (EnOcean) (MAX!) (CUL868) (CUL433) (Zigbee) (FS20) (ESP8266) (Echo)

Offline SamNitro

  • Sr. Member
  • ****
  • Beiträge: 707
  • Kölner Wimpelbeauftragter
Antw:Abhängigkeitsprobleme Bein Installieren von Deconz
« Antwort #4 am: 17 April 2019, 15:30:02 »
sudo aptitude install deconz
hat das problem gelöst indem es mir was vorgeschlagen hat:

Downgrade der folgenden Pakete:

libglapi-mesa [18.3.6-1 (now) -> 13.0.6-1 (stable)]

keine Ahnung warum die version so hoch war  :o
(Rpi 3, Stretch) (EnOcean) (MAX!) (CUL868) (CUL433) (Zigbee) (FS20) (ESP8266) (Echo)