Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
Hard- und Firmware / Antw:nanoCUL 868 Problem HomeMatic
« Letzter Beitrag von RaspiLED am Heute um 06:29:15 »
Hi, mich interessiert eher die Frage nach der Hardware?
Meine Glaskugel sagt der Test Pin am FTDI ist nicht auf Ground!
Also hast Du einen nanoCUL mit FTDI?
ls -la /dev/serial/by-id/*
Dann starte den Pi mal neu ohne ihn vom Strom zu nehmen und schaue ob der CUL auf initialized geht, normalerweise bleibt der nur open, bis man den USB trennt und wieder reinsteckt.
Falls es das ist:
https://ketturi.kapsi.fi/2014/04/how-to-fix-moody-arduino-nano/
Gruß Arnd



Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
2
TabletUI / Antw:Probleme mit Pagebutton
« Letzter Beitrag von sash.sc am Heute um 06:22:39 »
habe mir Deinen Code nochmal angeschaut.

Zuerst ist mir aufgefallen, dass folgender Fehler drin ist:
data-active-pattern=".*#wz.html"statt
data-active-pattern=".*#wz1.html"
Dann: hast Du noch eine index.html?
Oder warum "index1.html"?
Wo sind sonst die ganzen Elemente, die in die index.html reingehören?

Versuch außerdem mal folgendes für die wz1.html
</head>
<body>
  <div class="page" id="wz1">
    <div class="gridster">
    <ul>

<li data-row="1" data-col="1" data-sizex="1" data-sizey="1">
<header>Wohnzimmer</header>
<div class="cell">
    <div data-type="label"
data-device="ts01"
data-get="temperature"
data-limits='[1,15,28]'
data-colors='["#6699FF","#e8a945","#bb6242"]'
data-unit=" °C"
class="large bold"></div>
    <div>Temperatur</div>
    </div>

<div class="cell">
<div data-type="label"
data-device="ts01"
data-fix="0"
data-part="4"
data-limits='[0,20,80]'
data-colors='["#e8e406","green","#8e8eed"]'
data-unit=" %"
class="large bold"></div>
    <div>Luftfeuchte</div>
    </div>
</li>
   
    </ul>
    </div>
  </div>
</body>
</html>
Habe alles nochmal neu aufgebaut. Jetzt funktioniert alles, wie es soll.

Letztendlich waren es Positionierungsfehler von ein paar Definitionen gewesen.

Habe jetzt nur das Problem, dass nach dem Aufbau einer Seite ein reconnect in 10s kommt.

Gruß Sascha

Gesendet von meinem E6653 mit Tapatalk

3
Marktplatz - Güter / Antw:Suche 433mhz WLAN Gateway
« Letzter Beitrag von RaspiLED am Heute um 06:19:39 »
Hi,
Dann nimm doch einen SignalESP oder einen CUL auf ESP8266 Basis.
Gruß Arnd


Raspi2 mit FHEM, CUL, Signalduino, MySensors, HomeBridge, Presence, Bravia, ...
4
Anfängerfragen / Antw:get/set im Sekundentakt
« Letzter Beitrag von crispyduck am Heute um 06:16:37 »
Danke, alles klar. Einfach nur gut wenn man weiß was man machen kann und was man nicht machen sollte.  ;)

Beispiel:

define di_test DOIF ([+2]) (setreading $SELF add {([test:state]+[test1:state])})
attr di_test do always

Wenn man die selbe Berechnung aber auch schon in der Bedingung braucht muss sie zumindest zwei mal berechnet werden, oder kann man das auch schon irgendwie in der Bedingung in eine Variable schreiben?
Folgendes z.B., immer wieder die gleiche (vereinfachte) Berechnung [test:state]+[test1:state]
define di_test DOIF ([+2] and ([test:state]+[test1:state]) > 5) (set test {([test:state]+[test1:state])}) DOELSEIF (([test:state]+[test1:state]) < 0) (set test {([test:state]+[test1:state])-5)})......
attr di_test do always
5
Anfängerfragen / Antw:Wetterstation
« Letzter Beitrag von igami am Heute um 05:41:11 »
Es gibt auf luftdaten.info eine Anleitung wie man mit einem NodeMCU einen Feinstaubsensor baut.
Für den gibt es hier eine alternative Firmware, damit er mehr Sensoren unterstützt.
Du kannst dann also einfach einen NodeMCU mit BME280 und VEML6070 nehmen und hast alles was du brauchst.
6
Mobile Devices / Antw:Messenger / XMPP-Jabber ?
« Letzter Beitrag von igami am Heute um 05:35:56 »
Du könntest dann auch der erste Nutzer sein, der msgDialog mit Jabber verwendet. Bisher wird das Modul soweit ich weiß ausschließlich mit TelegramBot verwendet.
7
Server - Linux / Antw:Erfahrungsbericht hp ThinClient als FHEM-Server
« Letzter Beitrag von g-dave am Heute um 05:14:28 »
Zu den Performance-Themen hatte ich irgendwo auch schon mal was geschrieben, aber richtig messen ist schwierig.

Klar ist: im reinen Rechenbetrieb ist der Unterschied nicht riesig, da schlägt vielleicht der etwas höhere Takt leicht durch. Der "normale Seitenaufbau" ist sehr flüssig, die kurzen Gedenksekunden, die der Pi2 einem abverlangt, sind weg. (Das kann man vielleicht vergleichen mit dem S905x-Quad-Core, der in der TV-Box und z.B. den Odroiden seinen Dienst tut).

Seine Vorteile richtig ausspielen kann der T5740 dann, wenn es um Datenträgerzugriffe geht. Das ist an sich architekturbedingt deutlich schneller: beim Pi geht eben auch die ganze andere Peripherie über dem USB-Flaschenhals (Netzwerknutzung + USB-Geräte). Ergo sind Plots viel schneller aufgebaut (vom Eindruck her vielleicht sogar schneller wie auf der TV-Box, die plotfork nutzen konnte).

Aber klar: das ist auf dem Pi auch schon kein Weltuntergang ;) .

Was "Gefrickel" angeht: Es sind für eine T5740 genau zwei Teile (90°-Winkel und ein Kabel, zusammen ca. 5 Euro in China), die man außer einer regulären SSD braucht, und das Basteln beschränkt sich auf's Abschneiden von etwas Kunststoff und der Kapselung der SSD... So tragisch finde ich das nicht - es brauchte halt erst mal etwas Aufwand und Tests, um rauszufinden, was wirklich notwendig ist.

Ob sich das lohnt?
Wie geschrieben, ging es mir vorrangig darum, die SD-Karte loszuwerden, die mir anfällig vorkam. Der leichte Performance-Gewinn ist ein netter Nebeneffekt, FHEM läuft (mit meinen Anforderungen) flüssig, mehr brauche ich nicht.
Dann habe ich den USB-Hub eliminiert, auch gut ::) .

Ob ein NUC&Co die bessere Wahl wäre?
Gerechnet auf die Lebensdauer fällt der Mehrpreis für eine kleine Variante nicht so in's Gewicht, das lasse ich mal außen vor.
Aber er hätte zu wenig USB-Ports gehabt.
Neuere Hardware ist unter Linux auch nicht immer die bessere Wahl, manchmal sind da Komponenten verbaut, die - in der Regel nur eine gewisse Zeit, aber eben solange ggf. - "speziell" sind. Ob das auf den NUC etc. auch zutrifft: keine Ahnung.
Die verfügbare Mehrperformance brauche ich nicht, und wenn, würde mich das ggf. nur dazu verführen, auf dem NUC auch noch andere Dinge machen zu wollen wie ihn nur als FHEM-Server zu nutzen - das ist bei meinem Spieltrieb kontraproduktiv (ich habe auch nicht die Neigung, in näherer Zukunft Kenntnisse in Virtualisierungstechniken zu erwerben, also bitte: Keine Kommentare, dass sich die Risiken darüber minimieren lassen, das ist eine andere Spielwiese...). Und für zusätzliche Nutzungen wäre dann vermutlich wieder zu wenig Raum für eine weitere Festplatte, dann bräuchte man eigentlich schon wieder was anderes...

Zusammengefaßt: Ich bin bis dahin zufrieden, mal schauen, wie sich das Teil längerfristig schlägt. (Da fällt mir ein, ich wollte noch lmsensors wieder installieren, ist einfach herrlich, wenn da Temperaturen knapp über Zimmertemperatur gemeldet werden ;) ).

Schön jedenfalls, dass man die Wahl hat, und

@Gasmast3r: Danke auch für die Rückmeldung, dass die Anleitung hilfreich war!

Gruß, Beta-User
Wow vielen Dank für die ausführliche Antwort :). Jetzt fühle ich mich ja regelrecht verpflichtet es wenigstens zu testen ;-p.
8
Wie sagte Odoaker zu seinen Mannen im Film "Die letzte Legion":
Zitat
Falsche Antwort. Bring ihn weg und schneid ihm die Kehle durch.

Es ist nicht der Lesebefehl, der nicht funktioniert - sondern offenbar geht der Schreibbefehl in die Hose. Mit
configDB fileshow YAAHMFilekann man sich auch ohne "FileRead" die Datei anzeigen lassen. Mit
configDB infokann man sehen, wie groß die eigene configdb ist, und
configDBalleine zeigt noch ein paar weitere Möglichkeiten.

Ersetz doch bitte mal die Schreibroutine YAAHM_save durch die oben gepostete Version, und setz bei dem YAAHM-Device verbose auf 5. Ich tippe auf irgendein Problem mit der JSON-Erzeugung aus dem Datenhash.

LG

pah
9
Hard- und Firmware / nanoCUL 868 Problem HomeMatic
« Letzter Beitrag von ufo-hans am Heute um 02:17:27 »
Hi Leute!

Seit ein paar Jahren verwende ich nun FHEM (total begeistert!!!) und habe laut Log 708 "defined entities"... ;)

Der HomeMatic Teil war bis heute über ein HM-USB-CFG in Betrieb. Da es dieses aber nicht mehr gibt und man ja in die Zukunft schauen will, habe ich die letzten Tage alles auf einen neuen Raspi und ein nanoCUL umgebaut. So weit, so gut... AN SICH funktioniert alles wie gewünscht!

Das Problem ergab sich nach ein paar Stunden Betrieb (im Log von FHEM ist natürlich nichts zu sehen...):

die "L" LED am nanoCUL begann relativ flott (schneller als 1Hz) zu blinken und keinerlei Befehle wurden mehr abgesetzt bzw. keine Statusmeldungen empfangen. Da sich das Verhalten provozieren hat lassen, indem man ein "set CUL raw B00" absendet, dachte ich mir ganz oberschlau, dass ich den Befehl aus der Firmware mal rausnehme, damit da nicht versehentlich in den Bootloader gehüpft wird... Das Entfernen des Befehls klappte - aber nach ein paar weiteren Stunden war das gleiche "L-Geblinke" und Totenstarre wieder vorhanden.

Hat jemand eine Idee, was da schief laufen könnte?

Lg, Hans.

Tante Edit: vergessen zu schreiben: neueste Version am nanoCUL: V 1.67 nanoCUL868
10
FRITZ!Box / FB7490 mit FRITZ!OS: 6.98-48254 neue PERL WARNING
« Letzter Beitrag von inoma am Heute um 01:12:52 »
Ich habe seit dem Wochenende die neue BETA mit FRITZ!OS: 6.98-48254 auf meiner FB7490 installiert, seitdem bekomme ich sehr oft, etwa alle 5 bis 20 Minuten die folgende Warnung im LOG. Leider habe ich nicht rausfinden können, woran das liegt, kann evtl jemand helfen?
Mit der alten 6.92 Firmware trat die Warnung nicht auf. Stört nicht, ist halt nur nervig.

PERL WARNING: Argument "" isn't numeric in numeric eq (==) at ./FHEM/72_FRITZBOX.pm line 1542.das ist die folgende Zeile im Abschnitt "# Create a reading if a landevice is connected" if ($_->{ethernet} == 0 && $_->{wlan} == 1) {
Seiten: [1] 2 3 ... 10
decade-submarginal