Neues Modul - 74_Unifi - Für den Ubiquiti Networks (UBNT) - Unifi Controller

Begonnen von rapster, 23 August 2015, 02:12:04

Vorheriges Thema - Nächstes Thema

Wolle02

Das Problem ist wahrscheinlich der Umstand, dass irgendein Firmwareupdate deines Switches in der Vergangenheit Änderungen eingeführt hat mit denen das Modul hier nicht umgehen kann; und deswegen funktioniert es halt nicht.

Leider ist das Modul hier offensichtlich verwaist. Der Modulmaintainer war das letzte Mal am 05.11.2023 online.

hanswerner1

Hallo,
ich habe eine Dream Maschine von Unifi gekauft. Vorher hatte ich den Unifi Controller als Docker Container laufen und Fhem konnte sich problemlos damit verbinden. Nun läuft der Controller auf der UDM und die Verbindung funktioniert nicht mehr.

List vom Modul:
Internals:
   DEF        192.168.0.1 443 crypt:755b5455 crypt:5b5c4148031016085000010652
   FUUID      650db580-f33f-8133-e92f-ac15372b6efb3d41
   NAME       Unifi
   NOTIFYDEV  global
   NR         1126
   NTFY_ORDER 50-Unifi
   STATE      disconnected
   TYPE       Unifi
   UC_VERSION unknown
   VERSION    3.5.3
   eventCount 33
   READINGS:
     2024-03-10 13:00:47   state           disconnected
   accespoints:
   alerts_unarchived:
   clients:
   events:
   helper:
     password   crypt:5b5c4148031016085000010652
     username   crypt:755b5455
   hotspot:
     vouchers:
   httpParams:
     header    
     ignoreredirects 1
     loglevel   5
     method     POST
     noshutdown 0
     timeout    5
     hash:
     sslargs:
       SSL_verify_mode 0
   unifi:
     CONNECTED  disconnected
     eventPeriod 24
     interval   30
     ucurl      https://192.168.0.1/api/s/default/
     udmurl     https://192.168.0.1/proxy/network/api/s/default/
     url        https://192.168.0.1/api/s/default/
     customClientReadings:
       attr_value .:^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime
       parts:
         0000000_part:
           ReadingRegEx ^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime
           nameRegEx  .
   updateDispatch:
   wlans:
Attributes:
   alias      Unifi
   group      Present
   icon       it_wifi
   isUDM      1
   room       90_System

Die Version der UDM ist: UniFi OS 3.2.12 / Netzwerk 8.0.28

Weis jemand Rat ?

Viele Grüße
HW1 

Ralli

Gruß,
Ralli

Proxmox 8.2 Cluster mit HP ED800G2i7, Intel NUC11TNHi7+NUC7i5BNH, virtualisiertes fhem 6.3 dev, virtualisierte RaspberryMatic (3.75.7.20240420) mit HB-RF-ETH 1.3.0 / RPI-RF-MOD, HM-LAN-GW (1.1.5) und HMW-GW, FRITZBOX 7490 (07.57), FBDECT, Siri und Alexa

hanswerner1

Zitat von: Ralli am 10 März 2024, 14:46:23https://forum.fhem.de/index.php?msg=1297760

Danke für die schnelle Antwort, die Version hab ich auch schon erfolglos ausprobiert.
Folgendes ist im Log:


2024.03.10 16:03:36 5: Unifi (Unifi_Login_Send) - executed.
2024.03.10 16:03:36 5: Unifi (Unifi_Login_Receive) - executed.
2024.03.10 16:03:36 5: Unifi (Unifi_Login_Receive) - Failed because no data was received!
2024.03.10 16:03:36 5: Unifi (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2024.03.10 16:04:04 5: Unifi: Defined with url:https://192.168.0.1/api/s/default/, interval:30
2024.03.10 16:04:05 5: Unifi (Unifi_Notify) - executed.
2024.03.10 16:04:05 5: Unifi (Unifi_Notify) - checking 1 state
2024.03.10 16:04:05 5: Unifi (Unifi_Notify) - executed. - Remove all Timers & Call DoUpdate...
2024.03.10 16:04:05 5: Unifi (Unifi_DoUpdate) - executed.
2024.03.10 16:04:05 5: Unifi (Unifi_Login_Send) - executed.
2024.03.10 16:04:05 5: Unifi (Unifi_initCustomClientReadings) - parsed part: .  ->  ^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime
2024.03.10 16:04:05 5: Unifi (Unifi_initCustomClientReadings) - parsed Attribute customClientReadings: {"parts":{"0000000_part":{"ReadingRegEx":"^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime","nameRegEx":"."}},"attr_value":".:^accesspoint|^essid|^hostname|^last_seen|^snr|^uptime"}.
2024.03.10 16:04:05 5: Unifi (Unifi_Login_Receive) - executed.
2024.03.10 16:04:05 5: Unifi (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2024.03.10 16:04:05 5: Unifi (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2024.03.10 16:04:09 5: Unifi: get called with ?.
2024.03.10 16:04:28 5: Unifi (Unifi_Notify) - executed.
2024.03.10 16:04:28 5: Unifi: get called with ?.
2024.03.10 16:04:30 5: Unifi: get called with ?.
2024.03.10 16:04:35 5: Unifi (Unifi_Login_Send) - executed.
2024.03.10 16:04:36 5: Unifi (Unifi_Login_Receive) - executed.
2024.03.10 16:04:36 5: Unifi (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2024.03.10 16:04:36 5: Unifi (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2024.03.10 16:04:39 5: Unifi: set called with update
2024.03.10 16:04:39 4: Unifi: set update
2024.03.10 16:04:39 5: Unifi (Unifi_DoUpdate) - executed.
2024.03.10 16:04:39 5: Unifi (Unifi_Login_Send) - executed.
2024.03.10 16:04:39 5: Unifi: get called with ?.
2024.03.10 16:04:41 5: Unifi (Unifi_Login_Receive) - executed.
2024.03.10 16:04:41 5: Unifi (Unifi_Login_Receive) - Login Failed (without msg)! - state:''
2024.03.10 16:04:41 5: Unifi (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
2024.03.10 16:04:47 5: Unifi: get called with ?.

Ralli

Es kommt erst gar nicht zu einem erfolgreichen Login. User/Passwort neu setzen.
Gruß,
Ralli

Proxmox 8.2 Cluster mit HP ED800G2i7, Intel NUC11TNHi7+NUC7i5BNH, virtualisiertes fhem 6.3 dev, virtualisierte RaspberryMatic (3.75.7.20240420) mit HB-RF-ETH 1.3.0 / RPI-RF-MOD, HM-LAN-GW (1.1.5) und HMW-GW, FRITZBOX 7490 (07.57), FBDECT, Siri und Alexa

hanswerner1

Hab ich versucht, klappt nicht. Hab auch mal einen extra User in der Unifi Console für Fhem angelegt, wird aber auch nicht verbunden.

Hab dann mal mit den gleichen User/Password über ioBroker eine Unifi Instanz angelegt, da war die Verbindung direkt da.
 

Neeein

Zitat von: Wolle02 am 08 März 2024, 14:21:12Das Problem ist wahrscheinlich der Umstand, dass irgendein Firmwareupdate deines Switches in der Vergangenheit Änderungen eingeführt hat mit denen das Modul hier nicht umgehen kann; und deswegen funktioniert es halt nicht.

Leider ist das Modul hier offensichtlich verwaist. Der Modulmaintainer war das letzte Mal am 05.11.2023 online.

Das muss es wohl sein...

marvin78

Zitat von: Neeein am 10 März 2024, 20:42:05
Zitat von: Wolle02 am 08 März 2024, 14:21:12Das Problem ist wahrscheinlich der Umstand, dass irgendein Firmwareupdate deines Switches in der Vergangenheit Änderungen eingeführt hat mit denen das Modul hier nicht umgehen kann; und deswegen funktioniert es halt nicht.

Leider ist das Modul hier offensichtlich verwaist. Der Modulmaintainer war das letzte Mal am 05.11.2023 online.

Das muss es wohl sein...

Die API hat sich an der Stelle schon vor einigen Jahren geändert.

rolizer

Hi,
nur falls sich mal jemand 2 Wochen mit Fehlermeldungen wie dieser rumschlägt und die Ursache im Bereich "unsichere SSL Verbindungen akzeptieren" sucht:
2024.03.13 14:09:17 5: unifi_pi: get called with ?.
2024.03.13 14:09:32 5: unifi_pi (Unifi_Login_Send) - executed.
2024.03.13 14:09:33 5: unifi_pi (Unifi_Login_Receive) - executed.
2024.03.13 14:09:33 5: unifi_pi (Unifi_Login_Receive) - Failed with HTTP Code 500!
2024.03.13 14:09:33 5: unifi_pi (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...
Merke: verwende NIEMALS Anführungszeichen "" in Passwörtern!
 >:(

hanswerner1

Zitat von: hanswerner1 am 10 März 2024, 19:27:47Hab ich versucht, klappt nicht. Hab auch mal einen extra User in der Unifi Console für Fhem angelegt, wird aber auch nicht verbunden.
Hab dann mal mit den gleichen User/Password über ioBroker eine Unifi Instanz angelegt, da war die Verbindung direkt da.

Da ich über das Unifi Modul die Anwesenheitsabfrage (Handys in Wlan eingebucht) mache muss ich erstmal mit einen Workaround leben. Ich habe nur zu diesem Zweck iobroker installiert und mach dort die Abfrage und leite das Ergebnis an Fhem weiter.




chazz

Seit kurzem bietet Unifi die 2 Faktor Authentifizierung an.
Schaltet man diese ein, so kann sich FHEM nicht mehr verbinden.

Unify (Unifi_Login_Receive) - Login Failed! - state:'error' - msg:'api.err.Ubic2faTokenRequired'
FHEM - KNX - HomeMatic - HUE - Fritz! - TabletUI - .....

PatrickR

Zitat von: chazz am 16 April 2024, 20:04:17Seit kurzem bietet Unifi die 2 Faktor Authentifizierung an.
Schaltet man diese ein, so kann sich FHEM nicht mehr verbinden.

Unify (Unifi_Login_Receive) - Login Failed! - state:'error' - msg:'api.err.Ubic2faTokenRequired'
Kann das sein, dass Du irgendein Cloud-Geraffel für die Anmeldung am Controller aktiviert hast? Ich melde mich mit einem lokalen Account an und es funktioniert trotz der Aktivierung der 2FA im Ubnt-Account.

Patrick
lepresenced - Tracking von Bluetooth-LE-Tags (Gigaset G-Tag) mittels PRESENCE

"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to produce bigger and better idiots. So far, the universe is winning." - Rich Cook

flummy1978

Hallo zusammen,

ich habe mir vor kurzem das UCG Ultra (nettes Teil btw) zugelegt, das mein altes USG ablösen sollte und es auch geschafft hat. In diesem Fall ist aber auch der Controller umgezogen. Seitdem leider keine Chance sich mit dem Controller zu verbinden. Hat es jemand von Euch schon mal geschafft? Eine idee wie man vorgehen könnte?
Ich würde da gern beim herausfinden der Möglichkeit behilflich sein, allerdings ist mein Wissen über die FHEM Module doch relativ im Keller  :-\

Im Log ist lediglich folgendes zu finden:
2024.05.26 13:43:56.645 5: Unifi_Controller (Unifi_Login_Receive) - executed.
2024.05.26 13:43:56.646 5: Unifi_Controller (Unifi_Login_Receive) - Failed because no data was received!
2024.05.26 13:43:56.646 5: Unifi_Controller (Unifi_Login_Receive) - Connect/Login to Unifi-Controller failed. Will try again after interval...

Was entsprechend auf den falschen Aufruf hinweist, aber sonst auch leider nichts. Ich habe sämtliche Ports, SiteNamen usw schon probiert, mit dem entsprechendem User kann ich mich Problemlos einloggen.

Würde mich sehr freuen, wenn mir da jemnand weiter helfen könnte
Viele Grüße
Andreas

MadMax-FHEM

Ich hab auch das neue USG Ultra? laufen und bin verbunden...

Attribut isUDM oder so gesetzt?

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

flummy1978

Hallo Joachim, vielen Dank für die schnelle Antwort

Zitat von: MadMax-FHEM am 26 Mai 2024, 13:52:53Ich hab auch das neue USG Ultra? laufen und bin verbunden...

Attribut isUDM oder so gesetzt?

Gruß, Joachim

UUhhh das macht mich da mal schön neugierig.... Du hast keine besondere Version, weil das Modul ja schon länger nicht bearbeitet wurde) Wie hast Du die Verbindung genaut definiert? Mit der angepassten IP Adresse, vom alten Controller:

192.168.0.1 8443 crypt:... crypt:... 120gehts nämlich leider nicht.

Ich habe neben "is UDM" auch noch alle anderen Varianten probiert mit und ohne Site und alle Ports jeweils mit und ohne UDM setzen ;(

Hoffnungsvoll (weil scheinbar bei jemandem funktionierend)
Viele Grüße
Andreas