Neues Frontend: FhemNative Updates

Begonnen von Syrex-o, 16 Juli 2019, 14:50:24

Vorheriges Thema - Nächstes Thema

ToM_ToM

#45
ZitatSteht etwas in deinen fhem Log?

Mit Verbose 5 nur folgendes:

2019.07.25 13:03:06 3: wsPort: port 8080 opened
2019.07.25 13:03:06 5: websocket subscribeOpen CODE(0x7e3a290)
2019.07.25 13:03:06 5: websocket subscribeClose CODE(0x7dde830)


Anbei auch nochmal ein Screenshot von den Einstellungen in der App.

VG, Thomas
Hardware: BananaPi, Busmaster CUL, SanDisk 16GB Ultra SD, 16 GB USB-Stick | Software: Armbian, FHEM 5.8

Syrex-o

Sieht alles eigentlich gut aus soweit.
Ist dein Port 8080 schon von einem anderen Gerät belegt ?

Alle cpan Pakete sind installiert?
Einen fhem restart gemacht ?

Grüße

ToM_ToM

ZitatIst dein Port 8080 schon von einem anderen Gerät belegt ?
Nein

ZitatAlle cpan Pakete sind installiert?
Wenn du die folgenden aus deiner Doku meinst, ja. Es sei denn, ich habe irgendwelche Pakete übersehen.

sudo cpan App::cpanminus
sudo cpanm Protocol::WebSocket
sudo cpanm JSON


ZitatEinen fhem restart gemacht ?
Ja natürlich.

Habe auch nochmal ein FHEM update durchgeführt.

VG, Thomas
Hardware: BananaPi, Busmaster CUL, SanDisk 16GB Ultra SD, 16 GB USB-Stick | Software: Armbian, FHEM 5.8

Syrex-o

Hast du schon beide websockets ausprobiert ?
Welche Version von FhemNative hast du installiert ?

ToM_ToM

Ich habe es mit deinem und mit FhemWeb auf Port 8083 ausprobiert.

Die App-Versionen habe ich die 0.9.4 und die 0.9.5 getestet. Bei beiden finder er die Geräte nicht.
Liefert die App irgendwelche Logs die weiterhelfen können?
Hardware: BananaPi, Busmaster CUL, SanDisk 16GB Ultra SD, 16 GB USB-Stick | Software: Armbian, FHEM 5.8

Syrex-o

Probier es Mal mit Version 0.9.3.

Die Version unterstützt noch kein Fhemweb. Das schränkt die Fehler vielleicht etwas ein.
Und vorher einmal deinstallieren und Daten löschen.

Nein, die App schreibt kein Log.
Hast du irgendwelche Sicherheitseinstellungen, die die Kommunikation verhindern ?

ToM_ToM

#51
ZitatProbier es Mal mit Version 0.9.3.
Auch damit leider das gleiche Problem.

ZitatHast du irgendwelche Sicherheitseinstellungen, die die Kommunikation verhindern ?
Ich habe zwar eine Security Software drauf, aber die hat nichts geblockt.

Habe es eben auch nochmal auf meinem Tablet mit der 0.9.3 probiert, auf dem keinerlei Security-Software läuft.
Auch hier habe ich das gleiche Verhalten.

Edit: Was aber mit der 0.9.3 funktioniert hat, ist das "Räume kreieren" in den Einstellungen. Also muss ja eine Verbindung an sich existieren.

VG, Thomas
Hardware: BananaPi, Busmaster CUL, SanDisk 16GB Ultra SD, 16 GB USB-Stick | Software: Armbian, FHEM 5.8

Syrex-o

Ich vermute, dass irgendwas die Kommunikation blockiert und keine Antworten gesendet werden.

Ich werde Mal einen Debugging Modus einbauen, damit man dem Problem auf den Grund gehen kann.

Grüße

Syrex-o

Update:
Habe einen Logger mit eingebaut, der dir eine JSON Datei aus Fehlern schreibt. Zu finden in Einstellungen ab Version 1.0

Die Box Komponente hat zusätzliche Funktionen bekommen.
Das Label beim Circle Slider ist gefixt.

Im Github Repo unter Development befindet sich jetzt immer die aktuelle Version als Code.
Wer selber eine neue Komponente schreiben möchte, kann sich an den noch folgenden Developer Guide halten.

Grüße

ToM_ToM

ZitatHabe einen Logger mit eingebaut, der dir eine JSON Datei aus Fehlern schreibt. Zu finden in Einstellungen ab Version 1.0

Hast du noch irgendwas geändert? Denn mit der neuen Version läuft es bei mir.  8)
Hardware: BananaPi, Busmaster CUL, SanDisk 16GB Ultra SD, 16 GB USB-Stick | Software: Armbian, FHEM 5.8

Syrex-o

Na umso besser  ;)

An der websocket nichts weiter.

Habe nur ein paar security Probleme behoben.

rabehd

Ich habe Websocket von ntruchsess installiert.
Die App in Version 1.0 installiert.
Die Daten meines Servers eingetragen.

Die Verbindung steht: connect in grün.
Aber keine Räume vorhanden. Wobei bei "Räume kreieren" die Meldung kommt, dass alle Räume vorhanden sind.

Was mache ich falsch?
Auch funktionierende Lösungen kann man hinterfragen.

Syrex-o

So,
Bitte poste Mal deine FhemNative Konfiguration + die Definition der Websocket in fhem.

Alle Logos die du findest.
Kann es sonst nur schwer nachvollziehen.

Grüße

rabehd

#58
Hier meine Device:
Internals:
   FUUID      5d3b0520-f33f-9fab-f6d4-1bc76a519e7e6453
   IODev      websocketPort
   NAME       wsPort_json
   NOTIFYDEV 
   NR         774
   NTFY_ORDER 50-wsPort_json
   STATE      ???
   TYPE       websocket_json
   resource   /
   typeSubscriptions:
   websockets:
Attributes:
   IODev      websocketPort
   room       Zugang

Darf das STATE auf ??? stehen?

Internals:
   DEF        8080 global
   FUUID      5d3b0546-f33f-9fab-46a1-e66d527d0bbdf23b
   NAME       wsPort
   NOTIFYDEV  global
   NR         776
   NTFY_ORDER 50-wsPort
   SERVERSOCKET
   STATE      Initialized
   TYPE       websocket
   global     global
   port       8080
   READINGS:
     2019-07-27 12:42:10   state           Initialized
   onclose:
   onopen:
Attributes:
   room       Zugang


Im Log habe ich nichts gefunden.
Auch kein Log auf dem Handy (...\Phone\Android\data\de.FhemNative.FhemNative) obwohl ich Log eingeschalten habe.
Beim json habe ich die IP-Adresse verändert.

Ich hoffe das hilft meinen Fehler zu benennen.


Auch funktionierende Lösungen kann man hinterfragen.

Syrex-o

Deine Devices sehen gut aus.

Das Log von FhemNative wird wie folgt erstellt:
1. Logging aktivieren.
2. Fehler verursachen.
3. Logging ausschalten.

Dann wird dir angezeigt, wo sich das Log Files befindet.

Du hast mir die den settings Export geschickt.

Überprüfe bitte, ob du alle cpan Pakete installiert hast.

Grüße