Hauptmenü

Neues Frontend: FhemNative Updates

Begonnen von Syrex-o, 16 Juli 2019, 14:50:24

Vorheriges Thema - Nächstes Thema

stebar_

Hallo Syrex-o,

vielen Dank für die Plattformunabhängige Visualisierungen! Echt ein tolles Projekt  :)

Ich benutze im Augenblick die Version 4.3.1 (iOS und Android) und habe nachfolgendes Problem:

Ich habe in einem Raum mehrere ,,Button" definiert, wenn ich diese betätige aktualisieren sich diese teilweise nicht selbstständig, erst wenn der Raum erneut aufgerufen wird, stimmt der Status. Parallel habe ich zur Kontrolle FHEM Web geöffnet, hier passt alles. Das Problem tritt in beiden Apps (iOS und Android) auf.

Verbunden sind die Apps über fhemweb, in den Attributes der Websitzung habe ich longpoll auf websocket gesetzt.

Vielleicht ist das Problem behebbar.

Vielen Danke!

claudio

Zitat von: Syrex-o am 05 Oktober 2023, 10:40:45
Zitat von: claudio am 04 Oktober 2023, 22:10:55
Zitat von: Syrex-o am 04 Oktober 2023, 16:02:53Update: FhemNative 4.3.4

Version 4.3.4 ist im GitHub für Desktop Geräte verfügbar.
Die mobilen Versionen sind eingereicht und warten auf Bestätigung.

Changes:
  • Neu: Thermostat Alias für Device / automatische Textgröße
  • Neu: readingProxy support
  • Neu: Popup/Picker Implementierung
  • Neu: Aktualisierter Komponenten-Creator, um Raumgröße nicht zu beeinflussen
  • Neu: BackBtn Android Support, um App zu beenden
  • Neu: Wetter Komponente mit unterschiedlichen Styles
  • Fixed: Popups und Picker überlappen nicht mehr mit anderen Komponenten
  • Fixed: Color-Picker Favoriten überlappen nicht mehr auf iOS
  • Fixed: Gleichzeitige Events aus FHEM
  • Fixed: Max/Min size für Popup/Picker
  • Fixed: Popup/Picker Raum-Header ist wieder erreichbar
  • Fixed: Scroll-Position nach Komponenten-Auswahl
  • Fixed: Filterung in Select Komponenten
  • Fixed: Popup/Picker automatisch schließen bei Raum/Edit-Container-Wechsel
  • Fixed: Viele Kleinigkeiten ;)

Link zum Release: https://github.com/Syrex-o/FhemNative/releases/tag/v4.3.4

VG

thanks !
Where can I download the apk (I have no playstore access) for android ?

Apk files are no longer supported from my side.
If you do not have access to the playstore, please build the apk on your own (no problem for me).

What's the reason ?
I dont' know how to build it, with what tools ?

I guess I'll have to stay with old 2.6.3 version then

GatuRatz

Hallos,

ich habe eine (vermutlich doofe) Frage:
Ich konnte auf meinem Linux-PC mit dem Befehl "npm run serve:web:desktop" tatsächlich die neueste Version kompilieren, und ich kann im Abschluss mit dem Browser unter http://localhost:4200 dann auch tatsächlich das Programm bedienen.

Aber welche Files muss ich dann auch einen Webserver kopieren, damit es von dort funktioniert? Ein Verzeichnis "www" gibt es nicht.

Alternativ: wie kann ich das erzeugte PWA auf meinem PC starten? Momentan läuft es nur im Anschluss an die Kompilation.

Am liebsten wäre mir natürlich ein natives Programm unter Linux, aber die Option, das für Linux zu komplieren, gibt es nicht mehr, oder?

LG
GatuRatz

Syrex-o

Zitat von: GatuRatz am 29 Oktober 2023, 16:21:39Hallos,

ich habe eine (vermutlich doofe) Frage:
Ich konnte auf meinem Linux-PC mit dem Befehl "npm run serve:web:desktop" tatsächlich die neueste Version kompilieren, und ich kann im Abschluss mit dem Browser unter http://localhost:4200 dann auch tatsächlich das Programm bedienen.

Aber welche Files muss ich dann auch einen Webserver kopieren, damit es von dort funktioniert? Ein Verzeichnis "www" gibt es nicht.

Alternativ: wie kann ich das erzeugte PWA auf meinem PC starten? Momentan läuft es nur im Anschluss an die Kompilation.

Am liebsten wäre mir natürlich ein natives Programm unter Linux, aber die Option, das für Linux zu komplieren, gibt es nicht mehr, oder?

LG
GatuRatz
Hey,

Definitiv keine doofe Frage.
Möchtest du eine Linux version erzeugen? Das geht mit dem Befehl: npm run build:app:desktopDas erstellt dir wie auf Windows oder Mac eine Version für das aktuelle Betriebssystem.
Ich habe den Support für Linux eingestellt, aber jeder kann gern selbst einen Build herstellen.

VG

Syrex-o

Zitat von: stebar_ am 08 Oktober 2023, 17:21:12Hallo Syrex-o,

vielen Dank für die Plattformunabhängige Visualisierungen! Echt ein tolles Projekt  :)

Ich benutze im Augenblick die Version 4.3.1 (iOS und Android) und habe nachfolgendes Problem:

Ich habe in einem Raum mehrere ,,Button" definiert, wenn ich diese betätige aktualisieren sich diese teilweise nicht selbstständig, erst wenn der Raum erneut aufgerufen wird, stimmt der Status. Parallel habe ich zur Kontrolle FHEM Web geöffnet, hier passt alles. Das Problem tritt in beiden Apps (iOS und Android) auf.

Verbunden sind die Apps über fhemweb, in den Attributes der Websitzung habe ich longpoll auf websocket gesetzt.

Vielleicht ist das Problem behebbar.

Vielen Danke!
Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG

Syrex-o

Zitat von: Guzzi-Charlie am 06 Oktober 2023, 16:34:55
Zitat von: Syrex-o am 06 Oktober 2023, 12:20:36Man kann Farbcodes doch direkt eingeben. Als Beispiel: Einfach "#000" im Suchfeld eingeben und per"hinzufügen" auswählen. Dann wird die Farbe auch für zukünftige Auswahloptionen gespeichert und direkt angeboten.
Oh Mann, da muß man auch erst mal drauf kommen, Danke.

Wenn Du mir jetzt noch verrätst welchen Farbcode der Hintergrund des Dark-Themes hat wäre ich schon zufrieden.
Ups, ganz vergessen zu antworten:
Die Farbcodes vom dark/bright theme sind alle hier zu finden: https://github.com/Syrex-o/FhemNative/blob/main/libs/services/src/lib/theme/themes.ts

VG

GatuRatz

Zitat von: Syrex-o am 30 Oktober 2023, 10:49:46
Zitat von: GatuRatz am 29 Oktober 2023, 16:21:39Hallos,

ich habe eine (vermutlich doofe) Frage:
Ich konnte auf meinem Linux-PC mit dem Befehl "npm run serve:web:desktop" tatsächlich die neueste Version kompilieren, und ich kann im Abschluss mit dem Browser unter http://localhost:4200 dann auch tatsächlich das Programm bedienen.

Aber welche Files muss ich dann auch einen Webserver kopieren, damit es von dort funktioniert? Ein Verzeichnis "www" gibt es nicht.

Alternativ: wie kann ich das erzeugte PWA auf meinem PC starten? Momentan läuft es nur im Anschluss an die Kompilation.

Am liebsten wäre mir natürlich ein natives Programm unter Linux, aber die Option, das für Linux zu komplieren, gibt es nicht mehr, oder?

LG
GatuRatz
Hey,

Definitiv keine doofe Frage.
Möchtest du eine Linux version erzeugen? Das geht mit dem Befehl:
npm run build:app:desktopDas erstellt dir wie auf Windows oder Mac eine Version für das aktuelle Betriebssystem.
Ich habe den Support für Linux eingestellt, aber jeder kann gern selbst einen Build herstellen.

VG

Der Linux-Build läuft leider nicht durch, und ich kenne mich zu wenig aus, um zu erkennen, woran es liegt.

Aber die PWA mit npm run serve:web:desktop funktioniert offensichtlich, im Anschluss an den Kompliervorgang wird ja ein lokaler Webserver gestartet und das Ding läuft.

Wie kann ich die PWA laufen lassen, ohne sie jedesmal vorher zu komplieren?

LG
GatuRatz

Haecksler

ZitatZitat von: stebar_ am 08 Oktober 2023, 17:21:12
Hallo Syrex-o,

vielen Dank für die Plattformunabhängige Visualisierungen! Echt ein tolles Projekt  :)

Ich benutze im Augenblick die Version 4.3.1 (iOS und Android) und habe nachfolgendes Problem:

Ich habe in einem Raum mehrere ,,Button" definiert, wenn ich diese betätige aktualisieren sich diese teilweise nicht selbstständig, erst wenn der Raum erneut aufgerufen wird, stimmt der Status. Parallel habe ich zur Kontrolle FHEM Web geöffnet, hier passt alles. Das Problem tritt in beiden Apps (iOS und Android) auf.

Verbunden sind die Apps über fhemweb, in den Attributes der Websitzung habe ich longpoll auf websocket gesetzt.

Vielleicht ist das Problem behebbar.

Vielen Danke!
Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG

Das Problem hatte ich auch ist aber bei mir seit 4.3.4 behoben.

stebar_

Zitat von: Syrex-o am 30 Oktober 2023, 15:49:55Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG
Kann es gern bei bedarf zusammenstellen, nun habe ich nachfolgende Mitteilung gesehen:
Zitat von: Haecksler am 01 November 2023, 09:00:21Das Problem hatte ich auch ist aber bei mir seit 4.3.4 behoben.
Ich wollte nun die V 4.3.4 unter iOS installieren, das Update ist hier nicht sichtbar oder wurde es noch nicht veröffentlicht? Gibt es die Möglichkeit die Android Installationsdatei unter https://github.com/Syrex-o/FhemNative/releases bereitzustellen?

Syrex-o

Zitat von: stebar_ am 12 November 2023, 19:12:04
Zitat von: Syrex-o am 30 Oktober 2023, 15:49:55Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG
Kann es gern bei bedarf zusammenstellen, nun habe ich nachfolgende Mitteilung gesehen:
Zitat von: Haecksler am 01 November 2023, 09:00:21Das Problem hatte ich auch ist aber bei mir seit 4.3.4 behoben.
Ich wollte nun die V 4.3.4 unter iOS installieren, das Update ist hier nicht sichtbar oder wurde es noch nicht veröffentlicht? Gibt es die Möglichkeit die Android Installationsdatei unter https://github.com/Syrex-o/FhemNative/releases bereitzustellen?

Leider kann ich die Android Version nicht als Release zur Verfügung stellen. Die mobilen Versionen wird es nur noch über die Stores geben. V4.3.4 ist bei iOS noch nicht durch. Da gab es einige Probleme bei bestimmten Komponenten. Wird aber spätestens Ende nächster Woche verfügbar sein.

VG

stebar_

Zitat von: Syrex-o am 12 November 2023, 22:46:00
Zitat von: stebar_ am 12 November 2023, 19:12:04
Zitat von: Syrex-o am 30 Oktober 2023, 15:49:55Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG
Kann es gern bei bedarf zusammenstellen, nun habe ich nachfolgende Mitteilung gesehen:
Zitat von: Haecksler am 01 November 2023, 09:00:21Das Problem hatte ich auch ist aber bei mir seit 4.3.4 behoben.
Ich wollte nun die V 4.3.4 unter iOS installieren, das Update ist hier nicht sichtbar oder wurde es noch nicht veröffentlicht? Gibt es die Möglichkeit die Android Installationsdatei unter https://github.com/Syrex-o/FhemNative/releases bereitzustellen?

Leider kann ich die Android Version nicht als Release zur Verfügung stellen. Die mobilen Versionen wird es nur noch über die Stores geben. V4.3.4 ist bei iOS noch nicht durch. Da gab es einige Probleme bei bestimmten Komponenten. Wird aber spätestens Ende nächster Woche verfügbar sein.

VG

Danke für die Info, ich würde mal schauen, ob sich das Problem damit erledigt hat.

Syrex-o

#791
Kurzes Update,

Ich habe es leider nicht geschafft das Update für iOS fertig zu stellen. Ich hänge mich in den nächsten Tagen dran.

Edit:
Nach kleinen Problemen mit dem AppStore ist version 4.3.4 jetzt auch bei Apfel verfügbar  :)

VG

stebar_

Zitat von: stebar_ am 13 November 2023, 18:32:13
Zitat von: Syrex-o am 12 November 2023, 22:46:00
Zitat von: stebar_ am 12 November 2023, 19:12:04
Zitat von: Syrex-o am 30 Oktober 2023, 15:49:55Könntest du ein paar mehr Details geben?
- Welche Komponenten sind konkret im Raum?
- Welche Fhem devices/readings?
- Lässt sich das Problem auf Devices/Readings oder Komponenten eingrenzen?

VG
Kann es gern bei bedarf zusammenstellen, nun habe ich nachfolgende Mitteilung gesehen:
Zitat von: Haecksler am 01 November 2023, 09:00:21Das Problem hatte ich auch ist aber bei mir seit 4.3.4 behoben.
Ich wollte nun die V 4.3.4 unter iOS installieren, das Update ist hier nicht sichtbar oder wurde es noch nicht veröffentlicht? Gibt es die Möglichkeit die Android Installationsdatei unter https://github.com/Syrex-o/FhemNative/releases bereitzustellen?

Leider kann ich die Android Version nicht als Release zur Verfügung stellen. Die mobilen Versionen wird es nur noch über die Stores geben. V4.3.4 ist bei iOS noch nicht durch. Da gab es einige Probleme bei bestimmten Komponenten. Wird aber spätestens Ende nächster Woche verfügbar sein.

VG

Danke für die Info, ich würde mal schauen, ob sich das Problem damit erledigt hat.

Hat sich unter iOS mit 4.3.4 erledigt, danke!

egmontr

#793
Hallo,

bei mir klappt die Verbindung zu Fhem gar nicht.
Habe alles deaktiviert und es funktioniert trotzdem nicht.

Hier ist die Konfiguration aus Fhem:
define WEB FHEMWEB 8083 global
# attr WEB basicAuth xxxxxxxxxxxxxxxxxxxxx
attr WEB editConfig 1
attr WEB hiddenroom DashboardRoom
# für fhemNative
attr WEB longpoll websocket


Und anbei ein Screenshot des Verbindungs-Profil: 1 im Anhang.

Im Browser kann ich "http://192.168.1.153:8083/fhem" ohne Probleme aufrufen.

Was mache ich falsch?

LG Egmont

RPI B+ mit FHEM und CUL V3 868MHZ

frober

Ist dein Fhem wirklich schon so alt?

basicAuth steht normalerweise im allowed Device.
Hast du ein allowed Device?

Fhemconfig editieren ist auch nicht empfehlenswert.
Raspi 3b mit Raspbian Buster und relativ aktuellem Fhem,  FS20, LGW, PCA301, Zigbee, MQTT, MySensors mit RS485(CAN-Receiver) und RFM69, etc.,
einiges umgesetzt, vieles in Planung, smile

********************************************
...man wächst mit der Herausforderung...