Hauptmenü

Neues Frontend: FhemNative Updates

Begonnen von Syrex-o, 16 Juli 2019, 14:50:24

Vorheriges Thema - Nächstes Thema

Syrex-o

Zitat von: frober am 10 Juli 2021, 19:59:14
Ich habe noch ein Problem, wenn ich Fhemnativ öffne wird die Bluetooth-Verbindung zu meinem Lautsprecher abgebrochen.

Die Verbindung sollte nicht beendet werden
Ein bekanntes Problem ist, dass NativeAudio die aktuell laufenden Musik pausiert. Ist das der Fall ?

frober

Zitat von: Syrex-o am 11 Juli 2021, 19:56:01
Die Verbindung sollte nicht beendet werden
Ein bekanntes Problem ist, dass NativeAudio die aktuell laufenden Musik pausiert. Ist das der Fall ?

Das wäre möglich, zumindest hört die Musik direkt beim Start der App auf.
Habe es gerade ohne Bluetooth, direkt mit der Handylautsprecher getestet, Musik wird pausiert.
Raspi 3b mit Raspbian Buster und relativ aktuellem Fhem,  FS20, LGW, PCA301, Zigbee, MQTT, MySensors mit RS485(CAN-Receiver) und RFM69, etc.,
einiges umgesetzt, vieles in Planung, smile

********************************************
...man wächst mit der Herausforderung...

Syrex-o

Zitat von: frober am 11 Juli 2021, 20:17:52
Das wäre möglich, zumindest hört die Musik direkt beim Start der App auf.
Habe es gerade ohne Bluetooth, direkt mit der Handylautsprecher getestet, Musik wird pausiert.
Ich teste Mal ein bisschen Rum. Sodass alle, die das Audio Feature nicht nutzen, das Problem nicht haben

MiniBlister

Hallo,

vielen Dank für die tolle Arbeit. Ich versuche gerade mein FTUI3 nachzustellen. Geht ziemlich gut.
Leider schaffe ich es nicht, vernüftig ein Hintergrund Bild einzubinden.

Kann man das irgendwo konfigurieren? Ich habe es bereist mit einer Image Komponenten versucht, die cached aber nicht sauber sondern muss jedesmal geladen werden.

Grüße
MiniBlister

Syrex-o

Zitat von: MiniBlister am 11 Juli 2021, 21:12:04
Hallo,

vielen Dank für die tolle Arbeit. Ich versuche gerade mein FTUI3 nachzustellen. Geht ziemlich gut.
Leider schaffe ich es nicht, vernüftig ein Hintergrund Bild einzubinden.

Kann man das irgendwo konfigurieren? Ich habe es bereist mit einer Image Komponenten versucht, die cached aber nicht sauber sondern muss jedesmal geladen werden.

Grüße
MiniBlister
Nabend,
Die Image Komponente hat einen konfigurierbaren Cache. Musst einfach Mal damit spielen. Funktioniert halt nur, wenn man auf einer Oberfläche bleibt.
Oder eben direkt ein Bild vom Gerät auswählen (kann die Komponente auch). Wenn dich dein Bild nicht ändert, eignet sich das am besten.

australien

Zitat von: Syrex-o am 02 Juli 2021, 19:40:42
Bug ist schon im Arbeit. Ich hoffe morgen Abend Release Candidate 2 (RC.2) auf GitHub zu stellen.

Gibt es sonst noch Auffälligkeiten?

Hallo Syrex-o

gibt es da schon was neues? Oder kann ich es nur nicht finden?

danke
raspberry pi3
signalduino, Shelly1, Shelly2, Sonos, Unifi
Amazon Fire Tablet 7 | Noname Android Tablet 10"

Syrex-o

Zitat von: australien am 07 September 2021, 18:55:21
Hallo Syrex-o

gibt es da schon was neues? Oder kann ich es nur nicht finden?

danke

Morgen kommt der nächste RC. Die Firma ist diese Woche angemeldet worden. Also zum Store dauert es noch ca. 8 Wochen (deutsche Verwaltung).

Syrex-o

Update FhemNative 3.0.0 RC.3

Bitte beachtet die Hinweise aus diesem Post!

Dieses Update beinhaltet wieder ein paar Fixes und neue Sachen:

  • Der Websocket Handler wurde neu aufgesetzt. Das sollte das Verbindungsmanagement deutlich stabilisieren
  • Selbst signierte Zertifikate werden jetzt unterstützt (Danke an @frober für die tatkräftige Unterstützung)
  • Neues Side-Menu (das vorherige hat häufig gezickt)
  • Fixes im Switch
  • Picker close animation fix
  • App aus "Recent" laden sollte deutlich besser funktionieren

Link zum Release

Beste Grüße
Syrex-o

Tueftler1983

sorry wenn ich frage aber stehe mit githup auf dem kriegsfuß, wo finde ich die 3.0.0 apk zum download??

Syrex-o

Zitat von: Tueftler1983 am 16 September 2021, 09:08:45
sorry wenn ich frage aber stehe mit githup auf dem kriegsfuß, wo finde ich die 3.0.0 apk zum download??

Verstehe ich das richtig, dass du nichts von GitHub laden willst, oder es nicht findest?
Falls du es nicht findest, hier ist das letzte Release: FhemNative 3.0.0 RC.3

Beste Grüße

Tueftler1983

Doch wollen schon, mit dem finden haperte es, habe immer nur die .ZIP zum Download gefunden wo aber keine apk Datei drin war. Erst nach langen stöbern habe ich eben dann die Datei gefunden.

Ich habe mein Fhem web mit Password und selbst signierten Zertifikat geschützt. Diese Kombi würde ich gerne auch für die websocket Connection nutzen um auch von unterwegs ohne VPN Zugriff zu haben.

Geht das und wenn ja was muss ich wie und wo einstellen?

frober

Zur  Info:

Syrex-o hat das SSL-Thema in einen neuen Thread verschoben.

Weiter geht es hier:
https://forum.fhem.de/index.php/topic,122994.0.html
Raspi 3b mit Raspbian Buster und relativ aktuellem Fhem,  FS20, LGW, PCA301, Zigbee, MQTT, MySensors mit RS485(CAN-Receiver) und RFM69, etc.,
einiges umgesetzt, vieles in Planung, smile

********************************************
...man wächst mit der Herausforderung...

witschi87

Da die neue fhemnative.de Seite scheinbar nicht (mehr) funktioniert, frage ich mal hier: Gibt es auch eine Lösung für das deployment auf iOS-Geräten?

Syrex-o

Zitat von: witschi87 am 17 Dezember 2021, 22:58:54
Da die neue fhemnative.de Seite scheinbar nicht (mehr) funktioniert, frage ich mal hier: Gibt es auch eine Lösung für das deployment auf iOS-Geräten?

Sorry für die späte Antwort. fhemnative.de ging noch nie live. Ich arbeite dran.
Für iOS musst du aktuell leider noch selbst eine App über testflight laufen lassen. Ändert sich aber auch bald.

Sobald ich die Zeit finde, zieht FhemNative einmal komplett in eine neue Projektstruktur um. Dann habe ich auch endlich keine Probleme mit der Website mehr.
Dann folgen iOS und Android Apps über die Stores.

Grüße

Vize

Hallo,

bin heute auf FhemNAtive aufmerksam geworden und wollte mal testen, wie es sich so anlässt.

Leider bekomme ich das Ganze nicht so recht ans Laufen.

Ich habe Option 2 mit Fhemweb Websocket auf einer Windows (10) Maschine ausprobiert.
Nachdem ich die Verbindungs- und Logindaten passend eingetragen habe, wurde unten links im Fenster auch "mit FHEM verbunden" angezeigt.
Dann habe ich einen Raum angelegt. Als ich dann dort mit einem Lichtschalter beginnen wollte, bekam ich immer die Fehlermeldung  "Fhem Gerät nicht gefunden". Ich habe es mehrfach kontrolliert, sowohl Name des Devices und Reading sind korrekt eingetragen, IP des FHEM Servers passt, Portnummer auch, Anmeldedaten für sichere Verbindung auch. Mit anderen Devices aus meinem Setup funktioniert es auch nicht.
Hier komme ich nicht weiter.

Habe ich etwas übersehen oder falsch gemacht? Muss noch irgendwas installiert oder vorbereitet werden?
Welche Infos werden noch gebraucht, um dem Problem auf die Spur zu kommen?

Eine Sache ist mir noch aufgefallen. Auch wenn ich FhemNativ wieder vom PC entfernt hatte - sprich gesamtes Verzeichnis gelöscht, wurde beim nächsten Start (nach erneutem Entpacken der Zip-Datei) der von mir zuvor angelegte Raum angezeigt, ohne dass ich diesen nochmal anlegen musste.
Speichert FhemNative noch irgendwelche (Konfig)Daten woanders ab? Wenn ja, wo?

Vielen Dank schonmal für jegliche Tipps und Hilfe!

VG
Andreas