INSTA Funkbus (Gira, Berker, Jung)

Begonnen von Michi, 20 Januar 2014, 14:44:29

Vorheriges Thema - Nächstes Thema


Zitat von: steini1984 am 01 Oktober 2022, 23:44:54
I just bought a second CUL device from here:

The manual says that i should find the device under /dev/serial/by-id/usb-SHK_NANO_CUL_868-if00-port0@38400 0000 but i comes up as:
Can anyone give me a hint on how I can flash the device.
You should do a reclamation also involving amazon, see for details why.

The seller ("smarty") is one of our "well-known customers" here causing trouble with not well designed products every now and then. Very unhappy to see, he is getting back to old behaviour...

See also here:,99871.msg1237474.html#msg1237474
Server: HP-elitedesk@Debian 12, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files


Thanks for this information. This is really disappointing and I can verify that I have a fake since the serial is A50285BI :(

I could actually flash the device by changing the baudrate:
avrdude -D -p atmega328p -P /dev/ttyUSB0 -b 115200 -c arduino -U flash:w:nanoCUL.hex


Hello again. I have both a CUL  from Busware (CC1101 - USB - Lite module - V3) and a nanoCUL which both work fine. I have been using them to sniff the bus traffic and sync the state of my Gira lights with Home assistant, but controlling the lights via an XS1 from Ezcontrol.

Now i have been playing with the CUL to control the lights, but I cannot figure out the dimming.

I can turn on/off and completely dim up or down, but have not figured out the stop command. My understanding is that I should send a command to dim (eg UL) and then a stop command (S0) to stop the dimming but all my permutations and timing has not worked.

Here is an example of a command I send to dim to 100% brightness:

That gives me the following sequence:

Then I have tried to stop the dimming (for example at 50%) with this commands, but none seem to work for me:

I see that there are some versions of the firmware and maybe dimming is not supported with all of them? I tried to flash a different version, but it got me nowhere. I´m currently on the firmware from reply #110: nanoCUL.hex (MD5 > fa69b2683822bc275f28e9c1e0228cb0)

Can someone point me in the right direction - thanks :)