FHEM Forum

FHEM - Hardware => Einplatinencomputer => Thema gestartet von: Ralf am 12 Februar 2013, 22:19:27

Titel: COC - LED leuchtet permanent
Beitrag von: Ralf am 12 Februar 2013, 22:19:27
Hallo,

wollte den anderen Thread nicht kapern, daher hier nochmal separat:
Bei meinem COC leuchtet die LED permanent, und ich kann darauf nicht zugreifen.

Es handelt sich um die "Komplett-Version", also mit OW etc.
Ich habe das Busware-Image genommen (18-09-2012).

Wenn ich versuche, den neu zu flashen (avrdude... COC.hex), dann kommt die Fehlermeldung

"Connecting to programmer; .avrdude: butterfly_recv(): programmer is not responding"

Jemand eine Idee, was ich machen kann?

\Ralf
Titel: Aw: COC - LED leuchtet permanent
Beitrag von: C. Zimmermann am 13 Februar 2013, 10:06:49
bist du dir sicher, dass du fhem vorher geschlossen hast? Habe glaub so einen Fehler auch mal gehabt, als ich das vergessen hatte.
Titel: Aw: COC - LED leuchtet permanent
Beitrag von: Ralf am 13 Februar 2013, 11:05:22
Zitat von: C. Zimmermann schrieb am Mi, 13 Februar 2013 10:06
bist du dir sicher, dass du fhem vorher geschlossen hast? Habe glaub so einen Fehler auch mal gehabt, als ich das vergessen hatte.

Ja, fhem lief nicht.

\Ralf
Titel: Aw: COC - LED leuchtet permanent
Beitrag von: dougie am 14 Februar 2013, 08:10:41

...hast du einen Monitor an deinem RPi? Dort kommt bei mir beim Systemstart eine Meldung "Starting RPi COC Extension".... hast du die auf dem Schirm?
Titel: Aw: COC - LED leuchtet permanent [gelöst]
Beitrag von: Ralf am 15 Februar 2013, 19:18:33
Ich konnte das Problem lösen, indem ich eine neue Firmware geflasht habe.

Falls es interessiert:

COC.hex runtergeladen

sudo su
/etc/init.d/fhem stop
echo 17 > /sys/class/gpio/export
echo 18 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio17/direction
echo out > /sys/class/gpio/gpio18/direction
echo 0 > /sys/class/gpio/gpio18/value
echo 0 > /sys/class/gpio/gpio17/value
echo 1 > /sys/class/gpio/gpio17/value
echo 1 > /sys/class/gpio/gpio18/value

avrdude -p atmega1284p -P /dev/ttyAMA0 -b 38400 -c avr109 -U flash:w:COC.hex


Danach fhem neu gestartet und alles ist gut...
Titel: Aw: COC - LED leuchtet permanent [gelöst]
Beitrag von: JoMe am 29 März 2013, 18:12:05
Hallo,

ich habe es so versucht, wie du es beschrieben hattest.....

aber ich bekomme immer noch die gleiche Fehlermeldung...

Kann es sein, daß das stopen von FHEM nicht reicht?

Hast du vor dem update noch was gemacht????

Danke,

gruß,

Joachim
Titel: Aw: COC - LED leuchtet permanent [gelöst]
Beitrag von: JoMe am 06 April 2013, 16:57:57
Hallo,

jetzt ging es....habe aber keine Ahnung warum und wieso.....

Gruß,

Joachim