FHEM Forum

FHEM - Anwendungen => Heizungssteuerung/Raumklima => Thema gestartet von: masl am 06 November 2020, 14:19:18

Titel: Vitoconnect / FHEM - Benachrichtigung bei Störung
Beitrag von: masl am 06 November 2020, 14:19:18
Hallo!
Ich habe meine Vitocal 242 übers Vitoconnect ins FHEM angebunden. Daten erhalte ich soweit.
Allerdings würde ich gerne benachrichtigt werden wenn die Anlage auf Störung geht.
Hat das jemand schon gemacht?
Das Reading Fehlereintraege_aktive bringt recht viele Einträge:
{"gone":[{"status":"coming","audiences":[],"timestamp":"2020-11-06T20:59:20.386Z","accessLevel":"customer","priority":"criticalError","errorCode":"a9","new":true,"acknowledged":false}],"new":[],"current":[]}
Titel: Antw:Vitoconnect / FHEM - Benachrichtigung bei Störung
Beitrag von: andreas13 am 26 November 2020, 12:25:27
Hallo,
das Reading ist im JSON Format. Die Meldungen in Struktur unterhalb von "gone" sind historisch. Neue und aktuelle Fehler stehen entsprechend unter "new" bzw. "current".  Wenn Du darauf reagieren willst, musst du wohl zu Perl greifen (userReadings, reguläre Ausdrücke oder sowas in der Art). Da bin ich aber mangels Perl-Kenntnisse raus :-(
VG
Andreas

Hallo!
Ich habe meine Vitocal 242 übers Vitoconnect ins FHEM angebunden. Daten erhalte ich soweit.
Allerdings würde ich gerne benachrichtigt werden wenn die Anlage auf Störung geht.
Hat das jemand schon gemacht?
Das Reading Fehlereintraege_aktive bringt recht viele Einträge:
{"gone":[{"status":"coming","audiences":[],"timestamp":"2020-11-06T20:59:20.386Z","accessLevel":"customer","priority":"criticalError","errorCode":"a9","new":true,"acknowledged":false}],"new":[],"current":[]}
Titel: Antw:Vitoconnect / FHEM - Benachrichtigung bei Störung
Beitrag von: BlackHawk133 am 01 April 2021, 16:22:56
Hallo,

bei meinem Modul ist heute aus irgendeinem Grund das gesamte FHEM gecrashed und hat in einer Endless Loop gestartet.
Nach 2 Stunden suchen habe ich das Vitoconnect Modul als schuldigen gefunden. Dort kam im Log immer die Meldung:

"Can't use string ("2021-04-01T13:42:42.285Z") as an ARRAY ref while "strict refs" in use at ./FHEM/98_vitoconnect.pm line 1724."

Ich habe das Modul im fhem.cfg auskommentiert und danach lief mein gesamtes FHEM wieder suaber....

Hat jemand eine Ahnung, was da schief geht?