FHEM Forum

FHEM => Frontends => fronthem / smartVISU => Thema gestartet von: Stromer17 am 12 März 2017, 20:47:50

Titel: Problem bei Smartvisu Installation
Beitrag von: Stromer17 am 12 März 2017, 20:47:50
Hallo ich wollte smartvisu installieren komme hier leider nicht weiter!
Beim Eintrag in FHEM:
update force https://raw.githubusercontent.com/herrmannj/fronthem/master/controls_fronthem.txt
gibt es keine Meldung, seite ist dann nicht erreichbar.
Vielleicht kann mir ja  jemand weiterhelfen. :)
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: Drewzu am 16 März 2017, 19:18:03
dito hab ich das selbe Problem

UPD FHEM/01_fronthem.pm
Got 21951 bytes for FHEM/01_fronthem.pm, expected 21949
aborting.
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: herrmannj am 16 März 2017, 19:34:34
Nach 2300 bitte nochmal probieren...

Vg
Jörg
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: herrmannj am 16 März 2017, 21:10:23
done
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: Cybers am 23 April 2021, 13:54:29
Aktuell wieder das gleiche Problem:

Downloading https://raw.githubusercontent.com/herrmannj/fronthem/master/controls_fronthem.txt
UPD FHEM/01_fronthem.pm
Got 21901 bytes for FHEM/01_fronthem.pm, expected 21951
aborting.

Gruß, Sascha
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: herrmannj am 23 April 2021, 13:59:43
damn ... ab heute Abend ok ...
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: Cybers am 23 April 2021, 14:02:15
Danke
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: herrmannj am 23 April 2021, 14:08:15
habs per hand geändert kann aber nicht testen. magst mal schauen bitte?
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: Cybers am 23 April 2021, 14:42:53
Update geht.

Habe jetzt aber noch ein weiteres Problem:
Irgendwie war jetzt plötzlich mein fronthem-Device weg. Es hat mehrere Jahre problemlos gelaufen. Bei Neudefinition mit define MyFronthem fronthem bekomme ich diesen Fehler: Cannot load module fronthem

Berechtigungen, Besitzer und Gruppe sind mit allen anderen Fhem-Dateien identisch. Daran habe ich auch niuchts geändert.

Im Log steht das:
BEGIN failed--compilation aborted at ./FHEM/01_fronthem.pm line 30.
Compilation failed in require at ./FHEM/01_fronthem.pm line 30.
2021.04.23 14:37:26 0: Attempt to reload fhwebsocket.pm aborted.

BEGIN failed--compilation aborted at ./FHEM/01_fronthem.pm line 30.
Compilation failed in require at ./FHEM/01_fronthem.pm line 30.
 Attempt to reload fhwebsocket.pm aborted.
2021.04.23 14:37:26 1: reload: Error:Modul 01_fronthem deactivated:

Was könnte das aufeinmal sein?
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: herrmannj am 23 April 2021, 15:01:56
#30 wird fhwebsocket geladen , der wurde seit 6 Jahren nicht geändert. Entweder der fehlt Dir oder Rechte, oder was auch immer. :)
Titel: Antw:Problem bei Smartvisu Installation
Beitrag von: Cybers am 20 Mai 2021, 12:31:51
Danke, das läuft jetzt wieder alles. Allerdings habe ich jetzt ein neues Problem. Bei der UZSU funktioniert die Experteneinstellung nicht. Wenn mann bei "Spätestens" was einträgt, wird es nicht in den WDT übernommen. Das geiche bei "Condition" und "DelayedExec". Da muß scheinbar was in der 99_fronthemUtils.pm geändert werden.

Edit: Das Problem hatte bereits jemand geposted: https://forum.fhem.de/index.php/topic,102229.msg958125.html#msg958125 (https://forum.fhem.de/index.php/topic,102229.msg958125.html#msg958125) -> aber auch damit läuft es nicht rund.

Gruß, Sascha