FHZ1300PC stalls FHEM

Begonnen von jeke, 21 Juni 2013, 14:13:51

Vorheriges Thema - Nächstes Thema


Yesterday, I have begun to experience problems with my FHZ 1300 PC bridge and this appears to stall FHEM occasionally.  The symptoms are as follows:

- The LED on the FHZ 1300 PC begins to flash rapidly as soon as I start FHEM.  The FHT instruction buffer is not full.  It does this even if I start FHEM with a config script that does not contain any devices and does not autocreate any.  Restarting the FHZ1300PC, reinitialising it, restarting the computer, changing the USB cable or locating the FHZ1300PC further away from other equipment does not alter its behaviour
- The FHZ 1300 PC interacts normally with FS20 devices.  On some, rare, occasions, a command needs to be repeated.
- The FHZ 1300 PC can find FHT devices, but does not seem to be able to send data to them or retrieve data from them.  When starting FHEM with a script that only initialises the FHZ 1300 PC, it will auto create all FHT devices.
- Attempting to set the temperature of an FHT device often causes FHEM to stall.
- I noticed the problem after installing an additional FS20 Piri and a new HUE light.  I had to extend the configuration file to cause the HUE light to switch on in response to a Piri even.  After restarting FHEM, I noticed FHEM had stalled.
- I have two versions of fhem (5.3 and 5.4) and a number of scripts.  The problem appears in every setup.

I have the following questions:
- What does the blinking LED on the FHZ 1300 PC indicate?
- What might cause this problem?
-- Could there be interference with a HUE Bridge?  I have a HUE Bridge, but it is located about 4 meters away from the FHZ?
-- I have 9 HUE light bulbs.  Could their communication with the HUE Bridge be interfering with the FHZ?
-- Could the FHZ1300PC be broken?
- Would it be worthwhile to switch to a CUL/CUN device?  Might a CUL be less prone to such problems?

Any advice would be much appreciated.


I have read the command reference and I have tried reinitialising the FHZ, unplugging it, etc.  but nothing I have tried really resolves the problem


Which version of fhem are you using or when did you execute the update command?

We fixed a problem with echo about 2 days ago, introduced about 3 weeks ago, which might result in the symptomps you described, if you are using the PRESENCE module.


Thank you for your prompt reply and advice.

I have updated FHEM just now, but problem you refer to did not cause this behaviour.  I did learn a little more about the problem in the process, however.

When running a shutdown restart, FHEM stalls after:
2013.06.21 14:02:35 3: FHZ opening FHZ device /dev/cu.usbserial-EL68LX2Q
2013.06.21 14:02:35 3: FHZ opened FHZ device /dev/cu.usbserial-EL68LX2Q

When I kill the process, FHEM keeps blocking at that point.  Only after I unplug and plug in the FHZ 1300 PC am I able to restart FHEM.  The LED on the FHZ1300 keeps blinking and the device keeps struggling to communicate with FHT devices.  For example, after instructing FHEM:

set studyTStat desired-temp 17

I get the following log:

2013.06.21 14:11:23 2: FHT set studyTStat desired-temp 17.0
2013.06.21 14:15:23 1: FHZ get   fhtbuf
2013.06.21 14:15:23 2: FHT set studyTStat desired-temp 17.0
2013.06.21 14:19:23 1: FHZ get   fhtbuf
2013.06.21 14:19:23 2: FHT set studyTStat desired-temp 17.0
2013.06.21 14:23:23 1: FHZ get   fhtbuf
2013.06.21 14:23:23 2: FHT set studyTStat desired-temp 17.0
2013.06.21 14:27:23 2: studyTStat set desired-temp 17.0: no confirmation after 4 tries, giving up

FHEM is receiving actuator data for all the FHT devices from the FHZ.  It does not appear to be receiving any measured-temp data.

FS20 devices work normally.

In a nutshell, I get some of the same symptoms as described at http://fhem.de/commandref.html#FHZ in that the FHZ does not appear to be able to communicate with FHT devices (even though they are recognised) but is able to communicate with FS20 devices.  However, I do not seem to get USB disconnects or "transmit limit exceeded" errors.  


This looks exactly like a missing pairing between FHEM and the FHT80b.


Absolutely right.  Re-pairing the FHZ and FHT80Bs did the trick.

Thank you very much for your help!