DBlog: Abhängiges CPAN Modul

Begonnen von Sidey, 06 März 2024, 17:30:04

Vorheriges Thema - Nächstes Thema

DS_Starter

#15
Hallo Sidey,

ich habe die Meta Daten angepasst und eingecheckt.
In meinem contrib liegt die gleiche Version. Du kannst es damit schonmal testen.

Edit: Es wird der Treiber mit DBD::mysql (<5)   suggested   unknown angezeigt. Vllt. ist es noch hinzubekommen dass die installierte Version verglichen und somit als "installed" angezeigt wird. Bei mir ist die 4.052 installiert und müsste eigentlich bei <5 als "installed" erkannt werden.

LG,
Heiko
ESXi@NUC+Debian+MariaDB, PV: SMA, Victron MPII+Pylontech+CerboGX
Maintainer: SSCam, SSChatBot, SSCal, SSFile, DbLog/DbRep, Log2Syslog, SolarForecast,Watches, Dashboard, PylonLowVoltage
Kaffeekasse: https://www.paypal.me/HMaaz
Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/DS_Starter

Sidey

Hi DS_Starter,

habe das Docker Image noch mal neu erstellt und jetzt wurde auch DBD::mysql mit version 4.052 installiert.
Dafür schon mal vielen Dank.



Ich habe dann auch über den Installer nachgeschaut und auch hier erscheint:
DBD::SQLite suggested installed

Ich vermute, Du nutzt kein Docker Image für deine Tests und Dir fehlt jetzt eine neue Abhängigkeit des Installers, wenn die nicht installiert ist, dann wird "unknown" ausgegeben, da nicht erkannt werden kann, ob man eine kompatible Version installiert hat.

CPAN::Meta::Requirements::Range (2.143)

Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa, Docker, AlexaFhem

Maintainer von: SIGNALduino, fhem-docker, alexa-fhem-docker, fhempy-docker

DS_Starter

Nein, Docker nutze ich nicht für FHEM.
Das ist jetzt auch nicht dramatisch. Ich habe auch DBD::SQLite installiert (im Prinzip alle Treiber die ich mit DbLog unterstütze) und wird auch als installed erkannt. Mysql mit der geänderten Meta nicht (mehr) als installiert.

Anbei ein Screenshot, dadurch wird es ersichtlicher.
Wie gesagt nicht dramatisch.
ESXi@NUC+Debian+MariaDB, PV: SMA, Victron MPII+Pylontech+CerboGX
Maintainer: SSCam, SSChatBot, SSCal, SSFile, DbLog/DbRep, Log2Syslog, SolarForecast,Watches, Dashboard, PylonLowVoltage
Kaffeekasse: https://www.paypal.me/HMaaz
Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/DS_Starter

Sidey

Zitat von: DS_Starter am 09 März 2024, 17:41:13Anbei ein Screenshot, dadurch wird es ersichtlicher.

Ich hab das genau so auch verstanden, wie im screenshot dargestellt.

Dir fehlt: "CPAN::Meta::Requirements::Range".   
Signalduino, Homematic, Raspberry Pi, Mysensors, MQTT, Alexa, Docker, AlexaFhem

Maintainer von: SIGNALduino, fhem-docker, alexa-fhem-docker, fhempy-docker

DS_Starter

Ah, jetzt hats klick gemacht.  :)
Habe das Modul nachinstalliert:

  sudo apt-get install libcpan-meta-requirements-perl

Jetzt klappts auch mit der Anzeige wie ich es mir vorstelle.

Danke für die Info,
LG
ESXi@NUC+Debian+MariaDB, PV: SMA, Victron MPII+Pylontech+CerboGX
Maintainer: SSCam, SSChatBot, SSCal, SSFile, DbLog/DbRep, Log2Syslog, SolarForecast,Watches, Dashboard, PylonLowVoltage
Kaffeekasse: https://www.paypal.me/HMaaz
Contrib: https://svn.fhem.de/trac/browser/trunk/fhem/contrib/DS_Starter