Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
Anfängerfragen / Antw:Flash von Sonoff-Bridge
« Letzter Beitrag von call_me_driver am Heute um 01:30:15 »
hey, ne leider keine änderung...
2
Vielen Dank für deine Antwort, Tom Major.

Probleme sehe ich eher in der Robustheit des Konzepts bei langen Leitungslängen. Die Prozessorpins werden dann ggf. über viele Meter ungeschützt verlängert. So was macht man "normalerweise" nicht, sondern setzt einen entsprechend robusten Bus, Transceiver etc. ein, z.B. CAN, 1-Wire, RS485 um mal einige zu nennen. Nachteil ist natürlich erhöhter Schaltungsaufwand.
Das Konzept mag so fürs erste funktionieren, aber es wird Störungen auf den langen Leitungen einfangen oder auch Überspannungen, z.B. bei nahem Gewitter, und diese direkt auf den Prozessor leiten. Das ist nicht gut..

Die Variante mit Bus klingt schon eher aufwändig und nach viel Zusatzhardware. Da würde ich dann vielleicht doch eher gleich zu sowas wie einem Loxone Miniserver tendieren. Oder dem Input-Server, der klingt auch interessant und der Bausatz koste 107 €. Die Eingänge sind dort immerhin galvanisch getrennt von der Steuerung.

Durch die Verdrillung der Adern hätte ich mir erhofft, dass Störungen vermieden werden. Und diese hätte ich dann wohl auch mit anderen Lösungen, ausser ich verlängere die Drähte nicht bis ins UG, sondern mache möglichst früh die "Überleitung" zu einem Bus. Was dann aber wieder umso mehr Hardware bedeuten würde, die ich dann auch noch irgendwie in die Deckendose reinstopfen muss.

Bei Überspannung durch Gewitter ist dann der Raspberry wohl futsch, aber wenn das der Worst-Case ist, kann ich mit dem Risiko leben.

Hat jemand einen Vorschlag für die Befestigung der Cat-Volldrähte am Raspberry?
Vielleicht sowas hier:
https://www.adafruit.com/product/2711
?

Das wäre dann zwar nicht kompatibel mit dem Pi Zero, aber habe mir eh noch überlegt, dass ich lieber einen Pi mit RJ45-Anschluss nehme, da ich den wohl eh gleich ziemlich in der Nähe des Switch befestigen werde. Hätte eigentlich auch noch einen alten Raspberry Pi Model B, aber der ist dann auch nicht kompatibel mit den o.g. Erweiterungen, da er nur 26 Pins hat :-\

Und bestünde dann evtl. sogar die Gefahr, dass bei einem Blitzeinschlag über die Ethernet-Verbindung noch mehr kaputt geht als nur der Raspberry (nämlich so ziemlich alles im Netzwerk, ausser was über WiFi läuft)? :o

Dann vielleicht doch lieber den Zero WH und ganz simpel mit WAGO-Klemmen und solchen Jumperkabeln arbeiten?
https://www.amazon.de/dp/B00MWMEIF2/

Zur Not dann abschneiden/abisolieren, falls die Pins zu wenig lang für die WAGO-Klemmen sind...
3
Homematic / Antw:Vorhandene HM Installation mit HM IP nachrüsten
« Letzter Beitrag von fhem-hm-knecht am Heute um 01:20:32 »
Bestelle es doch und berichte  ;D

HM-IP geht nur über HMCCU -->Fhem egal wie die ganzen Bausätze heißen und heißen werden

Manche stehen auf das HM-IP manche nicht, für mich ist HM-IP aktuell eine Krücke, das liegt aber in der Anwendung bei mir!
Soll nicht heißen, das es nicht genau das "Richtige" für dich ist.

4
Homematic / Vorhandene HM Installation mit HM IP nachrüsten
« Letzter Beitrag von errazzor am Heute um 01:03:46 »
Hallo,

ich habe viel gelesen über HM IP, möchte mich aber jetzt vor dem Komponentenkauf nochmal rückversichern und Meinungen dazu einholen.

Meine momentane Installation besteht derzeit ausschliesslich aus Homematic "Classic" Komponenten mit folgendem Aufbau:

- FHEM Hauptinstanz auf Raspi 3 B+ mit HM-MOD-RPI-PCB + JeeLink
- FHEM Zweitinstanz auf Raspi 3 B (nur für lepresenced)
- HMLAN zur Reichweitenerweiterung
- JeeLink Relay Stick
- ein CUL liegt derzeit unbenutzt herum (wurde durch das RPI-PCB ersetzt)

Homematic IP ist für mich derzeit ausschließlich aufgrund der Schalt-Mess-Aktoren (HmIP-BSM) intressant, da ich mit diesen am einfachsten meine Wechsel-/Kreuzschaltungen "smart" machen kann.

Jetzt stellt sich mir die Frage, was der beste Weg für die Intregration von HM IP in die bestehende Konfiguration ist.

Nach allem was ich bisher gelesen habe über CCU2/3, YAHM, Raspberrymatic, piVCCU etc. etc. ... bin ich zu dem Schluss gekommen, dass der Bausatz "Charly" von ELV wohl die eleganteste Lösung wäre.

Ursprünglich dachte ich, ich könnte auf der bestehenden FHEM-Hauptinstanz mit HM-MOD-RPI-PCB einfach YAHM dazuinstallieren und könnte dann sowohl HM als auch HM IP schalten.
Allerdings habe ich gelesen, dass wohl nur immer eine Instanz auf die Funkhardware zugreifen kann .. was bedeutet entweder oder. Ist das korrekt?

Wenn dem so ist dann stellt sich mir nur noch die Frage, was sind die Vor- und Nachteile zwischen:

Bausatz "Charly" vs. zusätzlichen Raspi3+HM-MOD-RPI-PCB+YAHM (oder andere Software) ?

(Das Charly die neue CCU3 ist und eine etwas bessere Funkreichweite als das RPI-PCB haben soll habe ich gelesen)
Ganz toll wäre natürlich, wenn ich auf dem Charly-Bausatz dann auch noch lepresenced laufen lassen könnte, damit einer der Raspis entfallen kann.

Wie würdet ihr es machen und warum?

Für Tipps und Antworten bedanke ich mich im Vorfeld.

5
FHEM Development / set Einträge pro definition individuell
« Letzter Beitrag von Sidey am Heute um 00:55:12 »
Hallo,

ich komme aktuell einfach nicht drauf, wie ich die Set Befehle in einer Definition individuell gestalten könnte.
Wenn ich $sets{key} = value setze, dann gilt das für alle Definitionen dieses Moduls.

Grüße Sidey
6
Multimedia / Antw:sonos playbase - wie TV "eingang" wählen?
« Letzter Beitrag von deppennase am Heute um 00:51:56 »
Ich hänge mich mal hier dran, ich habe nämlich ein vermutlich identisches Problem mit meiner Sonos Beam: wenn ich die Wiedergabe wie oben beschrieben starte wird nicht der TV Sound ausgegeben.

In der App wird wenn der Fernseher läuft auch SPDIF angezeigt (obwohl die Beam über HDMI angeschlossen ist), wenn ich die Wiedergabe über FHEM wie angegeben starte wird mir der Name der Sonos-Device mit dem Klinkenkabel-Symbol in der Sonos app angezeigt.

Vielen Dank im Voraus!
7
Bastelecke / Antw:SIGNALDuino Empfänger Firm- und Hardware
« Letzter Beitrag von stefanru am Heute um 00:39:57 »
Hm,

wirklich komisch.
Soll ich die Register auslesen wenn der Fehler wieder auftritt?
Meinst du ein get raw C99?
ccregAll:

ccreg 00: 0D 2E 2D 07 D3 91 3D 04 32 00 00 06 00 10 B0 71
ccreg 10: 37 00 30 23 B9 00 07 00 18 14 6C 07 00 91 87 6B
ccreg 20: 03 56 11 EF 2C 19 1F 41 00 59 7F 3F 88 31 0B

Gruß,
Stefan
8
Bastelecke / Antw:Atmega Fusebit Doctor
« Letzter Beitrag von PeMue am Gestern um 23:39:16 »
Hallo,

kann man eigentlich den IC für Atmega-DOC auch im Atmega Fusebit Doctor selbst programmieren?
Ich meine, wenn man den auf IC4 einsteckt und an SC3 den Programmer einsteckt, sollte das doch funktionieren, oder?
Entweder es geht nicht, oder ich habe bei mir eine kalte Lötstelle.
Naja, mit dem uralt Pollin Atmel Evaluationsboard (unter einer dicken Staubschicht  8)) konnte ich den Atmega8 programmieren, mal sehen ob's dann der IC im Atmega Fusbit Doctor funktioniert ...

Gruß PeMue

Edit:
Grundreflexe sind da:
Welcome
AVR Atmega fusebit doctor (HVPP+HVSP) version 2.11
http://diy.elektroda.eu/atmega-fusebit-doctor-hvpp
Usage in commercial/profit purposes not allowed
MANUAL HVPP MODE
Init programming...  DONE
Read signature...    1E 95 14
Searching chip...    no names in 8kB ver
Read fusebits...     L:FF H:DA E:FD
Should be...         L:62 H:D9 E:FF
Lockbits...          DISABLED (CF)
What to do?...
1 - write fusebits
2 - modify fusebits
3 - set lockbits
4 - chip erase
5 - end
9
Anfängerfragen / Antw:Fhem2fhem CPIO Signale übertragen
« Letzter Beitrag von Otto123 am Gestern um 23:34:16 »
Es geht natürlich auch ein regExp, also z.B in der Art.
NameDesRechnerImKeller:7072 LOG:Sensor(1|2)https://commandref.fhem.de/commandref_DE.html#FHEM2FHEM
Bitte den regExp Filter so scharf wie möglich  :D

Gruß Otto
10
Bastelecke / Antw:SIGNALDuino Empfänger Firm- und Hardware
« Letzter Beitrag von Sidey am Gestern um 23:32:19 »
Was mir aber aufgefallen ist, nach einiger Zeit liefert ein get ccconf komische Werte.
ccconf: freq:95.920MHz bWidth:464KHz rAmpl:42dB sens:8dB (DataRate:3173.83Baud)

Sowohl Frequenz wie auch Baudzahl sind total schräg. Er sendet aber nach wie vor einwandfrei.
Ist das ein Problem oder nur ein Fehler in der Rückgabe?



Das ist seltsam. Er funktioniert trotzdem einwandfrei? Kannst Du die Register einmal manuell auslesen?


Ich habe nun die RC7 seit 11 Tagen an meinem Testsystem am laufen. Bei mir stimmt die ccconf Ausgabe.
V 3.3.1-RC7 SIGNALduino cc1101 - compiled at May 11 2018 23:00:28

Grüße Sidey
Seiten: [1] 2 3 ... 10
decade-submarginal