Einbindung 1-Wire DS9490RAdapter klappt nicht

Begonnen von RitterSport, 14 April 2015, 12:36:42

Vorheriges Thema - Nächstes Thema

RitterSport

Hallo,

momentan läuft im Aufbau für mein 1-Wire-Netz der Adapter an meinem Raspi2 mit OWServer, das funktioniert.
Aber zum Testen möchte ich gerne OWX oder OWX_Asynchron nutzen, bekomme es aber nicht hin.

lsusb liefert:
ZitatBus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 04fa:2490 Dallas Semiconductor DS1490F 2-in-1 Fob, 1-Wire adapter
Bus 001 Device 007: ID 8564:1000
Bus 001 Device 005: ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project
Bus 001 Device 006: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

In Fhem sind folgende USB-Devices zugewiesen:
Zitatdefine COC CUL /dev/ttyAMA0@38400 1234
define myJeeLink JeeLink /dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller-if00-port0@57600
define CUL_0 CUL /dev/serial/by-id/usb-busware.de_CUL868-if00@9600 1034
Also ist USB0 schonmal nicht möglich?!
Ein USB-Stick ist auch am Raspi eingebunden als dev/sda

Das Problem ist, das define HausOWX OWX /dev/ttyUSBX ob mit 1,2,3, oder 4nicht funktioniert OWX wird nicht initialisiert.
Zusätzlich bekomme ich nicht die id des Adapert heraus, um ihn per serial dev/serial/by-id/ einzubinden.

Kann mir jemand Hinweise geben?

Danke

Prof. Dr. Peter Henning

Klar: etwas mehr die Suchfunktion bemühen.

http://www.fhemwiki.de/wiki/Interfaces_f%C3%BCr_1-Wire

DS2490 kann nur über libusb angesprochen werden, macht eben keinen /dev/ttyUSBX-Port auf. und ist bekanntermaßen mit OWX nicht verwendbar.

LG

pah

RitterSport

Danke pah.
Da habe ich vor Wald nix von den Bäumen gesehen. Und einfach die falschen Grundannahmen gemacht.