Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
Revision 16661: 01_FHEMWEB.pm: do not delete "state" from "set state". Show updates on ...

01_FHEMWEB.pm: do not delete "state" from "set state". Show updates on mobile views

Source: Revision 16661: 01_FHEMWEB.pm: do not delete "state" from "set state". Show updates on ...
2
FHEMWEB / Antw:Bug im Mobile Web UI
« Letzter Beitrag von rudolfkoenig am Heute um 21:59:19 »
Zitat
ich habe einen Bug im Mobile Web UI gefunden.
Die Sache ist deutlich komplizierter.

1. Das Reading state ist in FHEM was Spezielles: es gibt den Status des Geraetes aus Sicht des Modulautors wieder. Der Benutzer kann das aendern, aber das ist eine andere Geschichte. Normalerweise setzt der Benutzer diesen Status ohne "state". Bsp. aus FS20: um eine Lampe einzuschalten verwendet man "set Lamp on" statt "set Lamp state on", weil das meiner Ansicht nach "intuitiver" ist,  auch wenn das Weglassen von state an mancher Stelle zu Verwirrung fuehrt.
2. Falls auf der FHEMWEB Detailseite ein Reading mit dem gleichen Namen wie das set Argument gefunden wird, dann wird der set Befehl von JavaScript per XHR aufgerufen, falls nicht, dann wird eine neue HTML-Seite (per form submit, die "alte" HTML Methode) angefordert.
3. Auf der Mobilseite wurde das angezeigte Reading vom JavaScript nie "gefunden".
4. Die "form-submit" Methode hat bei einem set XX state YY" das Wort state entfernt (siehe Punkt 1), und das fuehrt zu der gezeigten Fehlermeldung. Die XHR-Variante macht das nicht, deswegen klappt es damit.

D.h. das Problem tritt auch auf der Desktop-Seite auf nach einem "deletereading XX state".

- ich habe jetzt auf der mobilen Seite das Auffinden eines Readings gefixt. Als Nebeneffekt werden da ab sofort die Reading-Aenderungen auch dynamisch angezeigt (wie auf dem Desktop).
- bei der "form-submit" Methode wird bei "set XX state YY" das Wort state ab sofort nicht mehr entfernt.

Ich finde inzwischen, dass die spezielle Behandlung von Geraeten mit kleinen Bildschirm bzw. Touchpad nicht in Perl/FHEMWEB gemacht werden sollte, sondern vom Style spezifischen JavaScript, wie ich das im f18 Style gezeigt habe. Damit kann die gleiche FHEMWEB-Instanz von allen Geraeten verwendet werden, und solche Probleme treten nicht mehr auf.
3
@Ulm32b
Danke für deinen Vorschlag. Aber das wird nicht gehen. Ich kann nur Icons in Abhängigkeit des Readings anzeigen lassen, keine Bilder.
Wirklich? data-hide geht doch auch bei image.
4
Bastelecke / Antw:Platine für Selbstbau NanoCUL
« Letzter Beitrag von PeMue am Heute um 21:56:04 »
Hat jemand die culfw_v1.67 Firmware geflasht auf einem 868 nano Eigenbau? PCB war glaub Version 1.2.
Ich habe einen 433 MHz nanoCUL, daher habe ich die aktuelle a-culfw geflasht. Die normale culfw v1.67 sollte aber auch problemlos gehen.

Gruß PeMue
5
Anfängerfragen / Antw:DOIF-Modul und Sunset()/Sunrise
« Letzter Beitrag von amenomade am Heute um 21:51:07 »
Probier mal ohne das rote:
Zitat
([{sunset(-1700,"16:00","21:00")}]-[{sunrise(+5000,"08:00","09:00")}])
6
Anfängerfragen / Antw:FHEM Absturz....mehrfach gestartet
« Letzter Beitrag von amenomade am Heute um 21:47:14 »
Hier am Ende
https://wiki.fhem.de/wiki/FHEM_startet_nicht_-_Tipps_zur_Fehlersuche

Dazu evtl. mit der cfg Datei fhem.cfg.demo.
7
Sonstige Systeme / Antw:Robonect (Automower G3): online
« Letzter Beitrag von curt am Heute um 21:42:22 »
Sehe ich nicht so...
...
Die Antwort steht in Health, nciht in Status...

Wir nutz(t)en die Vokabel "health" unterschiedlich. Ich dachte an diese Geschichte hier:

http://192.168.1.41/xml?user=curt&pass=PASSWORD&cmd=health
EInfach mal useHealth auf 1 stellen, bitte...

Oh, was es alles gibt. Aber so richtig klar ist mir immer noch nicht, ob wir aneinander vorbei reden. Oder ich eine andere Robonect.pm nehmen muss. Der Einfachheit halber zeige ich mal meine derzeitigen Readings - kannst Du bitte kurz prüfen?

2018-04-26 21:39:44   alarm-ueberspannung_batterie 0
2018-04-26 21:39:44   alarm-unterspannung_batterie 0
2018-04-26 21:39:44   alarm-zu_feucht 0
2018-04-26 21:39:44   alarm-zu_kalt   0
2018-04-26 21:39:44   alarm-zu_warm   0
2018-04-26 21:39:44   allgemein-batteriezustand 100
2018-04-26 21:39:44   allgemein-betriebsstunden 435
2018-04-26 21:39:44   allgemein-dauer 0
2018-04-26 21:39:44   allgemein-modus automatik
2018-04-26 21:39:44   allgemein-status schlafen
2018-04-26 21:39:44   fehler_aktuell  Unbekannter Fehlercode!
2018-04-26 21:39:44   spannung-batterie 27327
2018-04-26 21:39:44   state           schlafen
2018-04-26 21:39:44   timer-startdatum 2018-04-27
2018-04-26 21:39:44   timer-startzeit 08:10:00
2018-04-26 21:39:44   timer-status    standby
2017-10-07 04:15:57   winterschlaf    0
2018-04-26 21:39:44   wlan-signal     -96
2018-04-26 21:39:44   wlan-signal-prozent -1
8
TabletUI / multistatebutton sendet falschen set-Befehl
« Letzter Beitrag von Wuehler am Heute um 21:38:54 »
Hallo,

ich habe ein Problem mit den multistatebuttons in meiner Testumgebung nach dem Update heute. Leider weiß ich nicht, ob es schon länger existiert, da ich bei den letzten updates von fhem die ftui-Teile nicht in die Produktions-Umgebung übernommen habe.
Folgendes Beispiel

   <div data-type='multistatebutton'
        data-device='Sonos_WZ1'
        data-get='transportState'
        data-get-on='["STOPPED","PLAYING"]'
        data-set='["Play","Stop"]'
        data-set-default='Stop'
        data-icons='["fa-play","fa-stop"]'
        data-background-icon="fa-circle-o"
        data-background-colors='["#666666", "#666666"]'
        data-colors='["#ffffff", "#ffffff"]'
        class="small"></div>

sendet in der Entwicklerconsole  des Browsers folgendes ab
set Sonos_WZ1 Play,Stop STOPPED
Natürlich geht die Sonos dann nicht an. Habe ich da eine Änderung übersehen?

Danke schonmal,
Dirk
9
Bastelecke / Antw:HMRF-RTC-Board - Raspberry Pi Zero W als CCU
« Letzter Beitrag von rvideobaer am Heute um 21:36:03 »
Hallo,

heute ist die Platine angekommen, und ich habe sie gleich verbaut. da ich aber noch FHEM unter Raspian betreibe habe ich die RTC nach dieser Anleitung:
https://tutorials-raspberrypi.de/raspberry-pi-rtc-modul-i2c-echtzeituhr/ installiert.
Es scheint alles zu funktionieren.

Noch mal vielen Dank.

Gruß Rolf
10
Homematic / Antw:Homematic CCU3 und HMIP Wired
« Letzter Beitrag von schwatter am Heute um 21:33:59 »
Ich überlege auch, einige HM-IP Geräte anzuschaffen.

Könnte es mit dem RPI-RF-MOD funktionieren, HM-IP direkt aus Fhem anzusprechen? Oder auch hier, nur wieder
über Umweg?

https://www.elv.de/homematic-funk-modulplatine-fuer-raspberry-pi-3-rpi-rf-mod-komplettbausatz.html
Seiten: [1] 2 3 ... 10
decade-submarginal