Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
ESP8266 / Antw:Entwicklung: Sensor mit dem ESP8266 WLAN-Funkmodul
« Letzter Beitrag von locutus am Heute um 21:53:21 »
Sehe ich das richtig, dass ich beide Lötbrücken SJ1 und SJ2 von 1-2 auf 2-3 ändern muss, um RGBW zu nutzen?
Nur wenn der ESP8266 vorher mit passender RGBW-Firmware programmiert wurde. Ansonsten ist das Umsetzen der Lötbrücken sinnlos.
Siehe auch: https://github.com/arendst/Sonoff-Tasmota/wiki/Arilux-LC02
2
Zitat
Die Probleme sind erst in der letzten Zeit aufgetreten. Diese Konfiguration habe ich aber schon seit Jahren!

Dann doch mal bitte ein list von deinem DbLog-Device und einen Ausdruck von "get <name> configCheck".

3
MQTT / Antw:Milight via MQTT (war: Modul für Sidoh-Bridge, jetzt: MQTT2)
« Letzter Beitrag von krakel am Heute um 21:49:14 »
Wenn ich de MQTT2-Server wieder lösche und mosquitto starte, kann ich auch mit mosquitto_sub -d -v -t \# Daten vom MiLight-Hub empfangen:

Client mosqsub/22382-p2 received PUBLISH (d0, q0, r1, m0, 'milight/states/0x1/rgb_cct/1', ... (145 bytes))
milight/states/0x1/rgb_cct/1 {"state":"ON","status":"ON","hue":171,"saturation":100,"bulb_mode":"color","color":{"r":0,"g":255,"b":216},"device_id":1,"device_type":"rgb_cct"}
Client mosqsub/22382-p2 received PUBLISH (d0, q0, r0, m0, 'milight/updates/0x1/rgb_cct/1', ... (11 bytes))
milight/updates/0x1/rgb_cct/1 {"hue":216}
Client mosqsub/22382-p2 received PUBLISH (d0, q0, r0, m0, 'milight/states/0x1/rgb_cct/1', ... (130 bytes))
milight/states/0x1/rgb_cct/1 {"state":"ON","brightness":71,"level":28,"hue":216,"bulb_mode":"color","color":{"r":0,"g":102,"b":255},"device_id":1,"group_id":1}
Client mosqsub/22382-p2 sending PINGREQ
Client mosqsub/22382-p2 received PINGRESP

Es stimmt: Mit "list MQTT.*" kommt nichts außer dem Server.
Was meinst Du mit IP-Bereich freigegeben?
4
Die Namensgebung für die serielle Schnittstelle ist vom Betriebssystem abhängig …
/dev/ttyAMA0
/dev/serial0
/dev/ttyS0
und sollte deshalb im Skript angepasst werden.
5
Und noch etwas. Ich weiß nicht genau warum, aber ich kann den Wert H im plot nicht darstellen.

2018-10-21_21:26:25 xiaomi1 T: 14.9 H: 4.8 D: -25.0

Colum 4 liefert den Wert von T, Colum 8 den Wert von D, Colum 6 liefert keinen Wert im Graphen.

Woran kann das liegen? Handelt es sich eventuell umeinen String und keine Zahl?

Es gibt auch Fehlermeldungen im log.

Server started with 179 defined entities (fhem.pl:17528/2018-10-14 perl:5.024001 os:linux user:fhem pid:1949)
2018.10.21 21:18:49 1: PERL WARNING: Illegal hexadecimal digit ' ' ignored at ./FHEM/74_XiaomiBTLESens.pm line 865.
2018.10.21 21:18:49 3: eval: {XiaomiBTLESens::ExecGatttool_Done('xiaomi1|4c:65:a8:d8:ae:ef|ok|read|0x18|{"gtResult":"45 "}')}
2018.10.21 21:18:49 1: PERL WARNING: Illegal hexadecimal digit ' ' ignored at ./FHEM/74_XiaomiBTLESens.pm line 866.
2018.10.21 21:18:49 3: eval: {XiaomiBTLESens::ExecGatttool_Done('xiaomi1|4c:65:a8:d8:ae:ef|ok|read|0x18|{"gtResult":"45 "}')}
2018.10.21 21:18:49 0: HourCounter Gasverbrauch Run.598 first run done countsOverall:12162
2018.10.21 21:18:49 3: delete tmp_time_gas : Please define tmp_time_gas first
2018.10.21 21:18:51 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at (eval 193) line 1.
2018.10.21 21:18:51 3: eval: { "Xiaomi Humidity Min $data{min2}, Max $data{max2}, Last $data{currval2}, Taupunkt $data{currval3}" }
2018.10.21 21:19:02 1: PERL WARNING: Argument "5.0\0" isn't numeric in numeric le (<=) at ./FHEM/98_dewpoint.pm line 278.
2018.10.21 21:20:55 1: PERL WARNING: Use of uninitialized value in concatenation (.) or string at (eval 236) line 1.
2018.10.21 21:20:56 3: eval: { "Xiaomi Humidity Min $data{min2}, Max $data{max2}, Last $data{currval2}, Taupunkt $data{currval3}" }
2018.10.21 21:26:25 1: PERL WARNING: Argument "4.8\0" isn't numeric in numeric le (<=) at ./FHEM/98_dewpoint.pm line 278.
6
Die stehen im ASC Device selbst da sie "global" sind. Also das ein und aus schalten. Bei den Rolläden kann man nur Einzel Steuerungen per Attribut ein stellen.

Ich habe im ASC-Device nur die Readings xx_nextAstroTimeEvent und xx_lastPosValue.
Fehlen mir Readings? Übersehe ich etwas?

Internals:
   CHANGED   
   MID        da39a3ee5e6b4b0d3255bfef95601890afd80709
   NAME       Rolladensteuerung
   NOTIFYDEV  EG.ku.TK.FensterKU,GH.xx.LS.HelligkeitAussen,OG.sz.TK.FensterSZ,Rolladensteuerung,global,rgr_Home,rr_Sascha
   NR         217
   NTFY_ORDER 50-Rolladensteuerung
   NotifyOrderPrefix 51-
   STATE      active
   TYPE       AutoShuttersControl
   VERSION    0.1.80
   OLDREADINGS:
   READINGS:
     2018-10-21 19:07:25   EG.ku.RO.KURolladen_lastPosValue 100
     2018-10-21 19:07:25   EG.ku.RO.KURolladen_nextAstroTimeEvent 22.10.2018 - 07:00
     2018-10-21 19:08:17   EG.sp.RO.SPRolladen_lastPosValue 100
     2018-10-21 19:08:17   EG.sp.RO.SPRolladen_nextAstroTimeEvent 22.10.2018 - 07:38
     2018-10-21 19:07:20   EG.wz.RO.WZRolladen.1_lastPosValue 100
     2018-10-21 19:07:20   EG.wz.RO.WZRolladen.1_nextAstroTimeEvent 22.10.2018 - 07:38
     2018-10-21 19:07:20   EG.wz.RO.WZRolladen.2_lastPosValue 100
     2018-10-21 19:07:20   EG.wz.RO.WZRolladen.2_nextAstroTimeEvent 22.10.2018 - 07:38
     2018-10-21 19:07:49   OG.az.RO.AZRolladen_lastPosValue 100
     2018-10-21 19:07:49   OG.az.RO.AZRolladen_nextAstroTimeEvent 22.10.2018 - 07:39
     2018-10-21 19:07:31   OG.gz.RO.GZRolladen_lastPosValue 90
     2018-10-21 19:07:31   OG.gz.RO.GZRolladen_nextAstroTimeEvent 22.10.2018 - 09:30
     2018-10-21 20:24:59   OG.sz.RO.SZRolladen_lastPosValue 80
     2018-10-21 19:07:45   OG.sz.RO.SZRolladen_nextAstroTimeEvent 21.10.2018 - 22:30
     2018-09-30 11:23:06   lockOut         off
     2018-09-30 11:15:58   partyMode       off
     2018-10-20 14:02:59   room_Homekit_Rolladen EG.ku.RO.KURolladen,EG.sp.RO.SPRolladen,EG.wz.RO.WZRolladen.1,EG.wz.RO.WZRolladen.2,OG.az.RO.AZRolladen,OG.gz.RO.GZRolladen,OG.sz.RO.SZRolladen
     2018-10-20 14:14:41   selfDefense     on
     2018-10-20 14:02:59   state           active
     2018-10-06 10:12:13   sunriseTimeWeHoliday on
     2018-10-20 14:02:59   userAttrList    rolled out
   helper:
     shuttersList:
       EG.ku.RO.KURolladen
       EG.sp.RO.SPRolladen
       EG.wz.RO.WZRolladen.1
       EG.wz.RO.WZRolladen.2
       OG.az.RO.AZRolladen
       OG.gz.RO.GZRolladen
       OG.sz.RO.SZRolladen
   monitoredDevs:
     EG.ku.TK.FensterKU:
       EG.ku.RO.KURolladen ASC_WindowRec
     GH.xx.LS.HelligkeitAussen:
       EG.ku.RO.KURolladen ASC_Shading_Brightness_Sensor
       OG.sz.RO.SZRolladen ASC_Shading_Brightness_Sensor
     OG.sz.TK.FensterSZ:
       OG.sz.RO.SZRolladen ASC_WindowRec
     rgr_Home:
       Rolladensteuerung ASC_residentsDevice
     rr_Sascha:
       OG.sz.RO.SZRolladen ASC_Roommate_Device
Attributes:
   ASC_antifreezeTemp 3
   ASC_autoAstroModeEvening HORIZON
   ASC_autoAstroModeEveningHorizon -7
   ASC_autoAstroModeMorning HORIZON
   ASC_autoAstroModeMorningHorizon -5
   ASC_autoShuttersControlEvening on
   ASC_autoShuttersControlMorning on
   ASC_residentsDevice rgr_Home
   ASC_sunPosDevice Astro
   ASC_sunPosReading SunAz
   ASC_temperatureReading temperature
   ASC_temperatureSensor GV.xx.TF.Aussen
   DbLogExclude .*
   icon       fts_shutter_automatic
   room       Rolladen
7
Hallo,

nachdem mein System in letzter Zeit sehr träge reagiert hat bin ich auf die Suche gegangen. Eine extreme Sache, die mir aufgefallen ist, wenn der ElectricityCalculator  bei Änderungen in die Datenbank geschrieben wird!

Die Auswertung von apptime mit schreiben der Werte in die Datenbank deaktiviert!

 ElectricityCalculator                    ElectricityCalculator_Notify            17        1      17.32    17.32     0.00     0.00 21.10. 21:02:40 HASH(ElectricityCalculator); HASH(Stromzaehler)

Die Auswertung von apptime mit schreiben der Werte in die Datenbank aktiviert!

 ElectricityCalculator                    ElectricityCalculator_Notify         33201        1   33201.14 33201.14     0.00     0.00 21.10. 21:06:04 HASH(ElectricityCalculator); HASH(Stromzaehler)

Der Wert average ist deutlich der Hinweis auf das blockieren von FHEM. Ohne schreiben der Daten in die Datenbank kommt es zu keinem Blockieren!

Die Einstelluingen fürs loggen sind:

event-on-change-reading     .*
DbLogInclude         .*

Die Probleme sind erst in der letzten Zeit aufgetreten. Diese Konfiguration habe ich aber schon seit Jahren!

Hat jemand ein Tip für mich?

Danke
8
Multimedia / Antw:FHEM -> Samsung TV mit Tizen
« Letzter Beitrag von dora71 am Heute um 21:15:30 »
Hallo Markus, hallo Forum,

möchte mich auch gerne als Tester eines neuen Samsung TVs zur Verfügung stellen. Mein Modell ist der UE55NU8509.

Nach gefühltem x-ten Durchlesen des Wikis und diesem Thread sind mir einige Sachen noch nicht klar. Eventuell gibt es ja bei der N-Serie auch noch ganz andere Sachen zu beachten.

Das Einzige, was bisher funktioniert, ist die Verbindung zum TV über den Port 8001. Soweit, so gut (lt. Modul connected).

Mit dem Browseraufruf http://samsung.ip:8001/api/v2/ bekomme ich auch ein JSON-Feld mit den Informationen zurückgeliefert. Immerhin.

Die Fehlermeldung mit verbose 5 ist wie folgt:
2018.10.21 21:00:25 5: [STV] SamsungTVW3 command 2 parameter
2018.10.21 21:00:25 5: [STV] SamsungTVW3 send to TV: GET /api/v2/channels/samsung.remote.control?name=RkhFTVJlbW90ZQ== HTTP/1.1
Upgrade: websocket
Connection: Upgrade
Host: $dev:$wsport
Sec-WebSocket-Key: dGhlIHNhbXBsZSBub25jZQ==
Sec-WebSocket-Version: 13


2018.10.21 21:00:25 5: [STV] SamsungTVW3 first websocket response: HTTP/1.1 101 Switching Protocols
Upgrade: WebSocket
Connection: Upgrade
Sec-WebSocket-Accept: s3pPLMBiTxaQ9kYGzzhZRbK+xOo=


2018.10.21 21:00:25 5: [STV] SamsungTVW3 second websocket response: �${"event":"ms.channel.unauthorized"}

2018.10.21 21:00:25 5: [STV] SamsungTVW3 connected with websocket
2018.10.21 21:00:25 4: [STV] SamsungTVW3 sending 2
2018.10.21 21:00:25 5: [STV] SamsungTVW3 send payload: {"params":{"TypeOfRemote":"SendRemoteKey","Option":"false","Cmd":"Click","DataOfCmd":"KEY_2"},"method":"ms.remote.control"}


OK, unauthorized ... auf dem TV hatte ich 1x eine Meldung zum Zulassen. Das habe ich gemacht.
Das Perl-Script hatte ich geladen, die IP angepasst, aber nach dem Start fragt er nach der TV-Pin ?!? Wie komme ich denn zu der PIN? Auf dem Fernseher wird nichts angezeigt.

Sollten die offenen Ports benötigt werden (diese unterscheiden sich bis auf den 8001 von denen, die ich bisher gefunden habe), hier die Ausgabe von nmap:
8001/tcp  open  vcom-tunnel
8002/tcp  open  teradataordbms
8080/tcp  open  http-proxy
9080/tcp  open  glrpc
9110/tcp  open  unknown
9999/tcp  open  abyss
32768/tcp open  filenet-tms
32769/tcp open  filenet-rpc

50169/tcp open  unknown
51495/tcp open  unknown

Mache ich noch etwas falsch oder ist der Fernseher einfach "zu neu", so dass sich zu viel verändert hat? Oder habe ich noch etwas nicht gelesen?
Ich benutze die Modul-Version aus Post #386 vom 13.10.2018

Danke für die Hilfe.

Gruß Rainer
9
Marktplatz - Güter / [Verkaufe] WLAN LaCrosse Gateway
« Letzter Beitrag von gloob am Heute um 21:05:26 »
Hallo,

Ich habe noch zwei LaCrosse Gateway mit WLAN und USB abzugeben. Das Gateway besteht aus einem Wemos und einem RFM69HW Funkmodul mit 868MHz. Zur besseren Spannungsversorgung ist noch ein AMS1117 3.3V auf der Unterseite verbaut.
Das Gateway ist fertig mit der neuesten Firmware geflasht und kann direkt in FHEM eingebunden werden. Das Gateway kann per WiFi oder USB genutzt werden.

Ich hätte gerne 16€ für ein Gateway. Als Versand kann ich Luftpolsterumschlag für 2€ oder für 5€ als versichertes Paket anbieten. Beim Luftpolsterumschlag übernehme ich allerdings keine Garantie.


Für die Konfiguration sind folgende Schritte nötig:
Zitat
·         Mit dem LaCrosseGateway Access Point "LaCrosseGateway_xxxxxx" verbinden (siehe Beschreibung Funktionsweise)
·         Mithilfe eines Browsers die LaCrosseGateway "Setup"-Page öffnen
·         SSID und das Password eintragen. Man kann zwei SSID/Passwort-Kombinationen mit jeweils einem Timeout konfigurieren. 120 bedeutet z.B. dass das LGW 120 Sekunden lang versucht, die SSID zu erreichen. Falls die erste SSID nach "Timeout" Sekunden nicht erreicht wurde, wird Timeout Sekunden lang versucht, die zweite SSID zu connecten.
·         [Empfohlen] Das Frontend Passwort festlegen
·         [Optional] Falls kein DHCP-Server zur Verfügung steht bzw. keine Reservierung erwünscht ist, dann muss die IP-Adresse / Netmask (Optional auch Gateway) eingetragen werden
·         [Empfohlen] Hostnamen festlegen bzw. anpassen
·         Alle Angaben mit dem Button "save and restart" bestätigen. Dabei werden die vorgenommen Einstellungen im EEPROM gespeichert und ein Neustart des LaCrosseGateways initiiert.

Nach dem Neustart verbindet sich das LaCrosseGateway mit dem WLAN-Router.
Anschließend kann mit der Inbetriebnahme in FHEM fortgefahren werden.

Einbinden in FHEM ist auch einfach:
define myLaCrosseGateway LaCrosseGateway 192.168.1.12:81
Mehr Informationen gibt es im Wiki:
https://wiki.fhem.de/wiki/LaCrosseGateway_V1.x
10
Es gibt was ähnliches (nur "schöner") im Forum...
...eigentlich gedacht für Raspi Zero W...

https://forum.fhem.de/index.php/topic,86536.msg789583.html#msg789583

Sollte aber auch auf einen "normalen" PI passen...

Und wenn es das "normale" HM-PCB ist, sollte auch eine Nutzung in fhem kein Thema sein...

Gruß, Joachim
Seiten: [1] 2 3 ... 10
decade-submarginal